SOLIDWORKS Installation und Administration

Diese Anleitung beschreibt die Installation, Lizenzierung, Aktualisierung und Administration von SOLIDWORKS Produkten für Einzelinstallationen und Mehrfachinstallationen.

Einzelinstallationen | Aktivierung mehrerer Installationen
Installation Installation auf einem oder mehreren Computern. | Installation Erstellung eines Administrator-Installationsabbildes, das auf einer bestimmte Anzahl von Client-Computern angewendet wird.
Lizenzierung Rechneraktivierung, Online-Lizenzierung oder Netzwerklizenzierung. | Lizenzierung Rechneraktivierung, Online-Lizenzierung oder Netzwerklizenzierung.
Upgrades (Aktualisierungen) Einzel-Computer auf eine neue Version aktualisieren. | Upgrades (Aktualisierungen) Aktualisieren von mehreren Computern auf eine neue Version durch Aktualisierung des Administrator-Installationsabbildes, das auf allen diesen Computern zur Installation benutzt wird.
Verwaltung Modifizieren, Reparieren oder Entfernen von Installationen, Aktualisieren auf neue Versionen. | Verwaltung Aktualisieren von Administrator-Installationsabbildern und Clients und Verwalten von Netzwerklizenzen.

Der SOLIDWORKS Installations-Manager ermöglicht das Konfigurieren von Einstellungen für SOLIDWORKS Produktkomponenten einschließlich SOLIDWORKS, SOLIDWORKS Toolbox, PhotoView 360, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS PCB, SOLIDWORKS Visualize und SOLIDWORKS SolidNetWork License Manager.

Der SolidNetWork License Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.

Das SOLIDWORKS Admin Portal ist ein Cloud-basiertes Ressourcen- und Servicemanagement-System, mit dem Sie Online-Lizenzen zuweisen und verwalten können. Die Zuweisung von Lizenzen ist nur für die Online-Lizenzierung erforderlich. Für andere Lizenztypen ist die Lizenzzuweisung optional.

Inhaltsverzeichnis

  • Einzelinstallation oder Administrator-Installationsabbild

    Sollten Sie SOLIDWORKS Produkte auf jedem Computer separat installieren oder sollten Sie ein Administrator-Installationsabbild erstellen und die Installation allen Clients mit einem Befehl bereitstellen?

  • System- und Softwareanforderungen überprüfen

    Stellen Sie vor der Installation sicher, dass Ihr System die Anforderungen an Hardware, Betriebssystem und Microsoft-Produkte erfüllt. Beachten Sie, dass Zusatzanwendungen, wie z. B. SOLIDWORKS Electrical und SOLIDWORKS Visualize und eDrawings, zusätzliche Anforderungen haben.

  • SOLIDWORKS Installation wird initiiert

    Sie können die Installation von SOLIDWORKS durch Laden einer DVD in den lokalen Computer initiieren, durch Zugriff auf ein freigegebenes Installationsverzeichnis oder über einen Download von SOLIDWORKS.


Einzelinstallation oder Administrator-Installationsabbild

Sollten Sie SOLIDWORKS Produkte auf jedem Computer separat installieren oder sollten Sie ein Administrator-Installationsabbild erstellen und die Installation allen Clients mit einem Befehl bereitstellen?

Wenn Sie nur auf einem Computer installieren, oder wenn Sie für Dutzende oder Hunderte Computer zuständig sind, ist es offensichtlich, welche Option zu wählen ist. In Fällen, die dazwischen liegen, sollten Sie die folgenden Vergleiche beachten.

Einzelinstallation | Administrator-Installationsabbild
Anwender können Ihre eigene SOLIDWORKS Administration führen. | Der Systemadministrator kann mehrere Installationen mit dem Options-Editor anpassen, indem er Optionen wie die Erstellung einer neuen Installation oder die Aktualisierung einer bestehenden festlegt sowie die Ausführung der Installation als Administrator, die Ausführung externer Befehle vor oder nach der Installation, verschiedene Produktgruppierungen etc. festlegt.
Die Computer müssen für die Person, die die Installation ausführt, physisch zugreifbar sein. | Client-Computer können sich auch entfernt befinden, solange auf sie vom selben Netz zugegriffen werden kann.
Siee können verschiedene Versionen. Service Packs oder Produkte auf verschiedenen Computern mit separaten Einstellungen installieren. | Mit dem Options-Editor können Administrator-Installationsabbilder Konsistenz in Versionen, Service Packs, Produkten und Einstellungen gewährleisten.
Die Computer müssen Netzwerk- oder E-Mail-Zugang haben. Eine Netzwerk- oder E-Mail-Verbindung ist erforderlich, um SOLIDWORKS zu aktivieren und Dateien herunterzuladen. Netzwerkzugriff ist auch für den Bezug von Lizenzen von einem Netzwerk-Lizenzserver erforderlich.

Eine lokale Netzwerk-Verbindung ist für die Bereitstellung der Anwendung erforderlich. Medien-Laufwerke auf Client-Computern sind nicht erforderlich.

Clients können automatisch aktualisiert werden. Alle Clients, auf denen vom selben Administrator-Installationsabbild installiert wurde, haben dasselbe Service Pack. Um mehrere Versionen zu verwalten, können Sie mehrere Administrator-Installationsabbilder erstellen.

Die Lizenzaktivierung kann automatisiert werden.

Für ein Administrator-Installationsabbild ist Speicherplatz auf dem Server erforderlich; Clients benötigen denselben Platz wie Einzelinstallationen.

Übergeordnetes Thema SOLIDWORKS Installation und Administration
System- und Softwareanforderungen überprüfen
SOLIDWORKS Installation wird initiiert


System- und Softwareanforderungen überprüfen

Stellen Sie vor der Installation sicher, dass Ihr System die Anforderungen an Hardware, Betriebssystem und Microsoft-Produkte erfüllt. Beachten Sie, dass Zusatzanwendungen, wie z. B. SOLIDWORKS Electrical und SOLIDWORKS Visualize und eDrawings, zusätzliche Anforderungen haben.

Die aktuellen Systemanforderungen finden Sie unter http://solidworks.com/System_Requirements.

Übergeordnetes Thema SOLIDWORKS Installation und Administration
Einzelinstallation oder Administrator-Installationsabbild
SOLIDWORKS Installation wird initiiert


SOLIDWORKS Installation wird initiiert

Sie können die Installation von SOLIDWORKS durch Laden einer DVD in den lokalen Computer initiieren, durch Zugriff auf ein freigegebenes Installationsverzeichnis oder über einen Download von SOLIDWORKS.

Um die SOLIDWORKS Installation zu initiieren, führen Sie einen der folgenden Schritte aus:

  • Um auf einen lokalen Computer von einem Datenträger aus zu installieren, legen Sie den entsprechenden Datenträger in das Laufwerk ein.
  • Um von einem Download-Verzeichnis zu installieren, gehen Sie zum Verzeichnis, und doppelklicken Sie auf setup.exe.
  • SOLIDWORKS durch Download installieren:
    1. Rufen Sie die SOLIDWORKS Website auf.
    2. Melden Sie sich als Subskriptionsdienst-Kunde mit Ihrer E-Mail-Adresse und Ihrem Passwort oder Ihrer SOLIDWORKS Seriennummer an.
    3. Klicken Sie unter Self Service auf Download Software and Updates.
    4. Wählen Sie unter Software herunterladen (Windows, Mac, Linux) die SOLIDWORKS Version und das Service Pack zum Herunterladen aus.
Übergeordnetes Thema SOLIDWORKS Installation und Administration
Einzelinstallation oder Administrator-Installationsabbild
System- und Softwareanforderungen überprüfen


Einzelinstallationen

Inhaltsverzeichnis

  • Installation auf Einzel-Computern

    Sie können SOLIDWORKS mit mehreren Installationsmethoden auf einem Einzelcomputer installieren.

  • Verwaltung von Einzelplatzinstallationen

    Normalerweise besteht die Verwaltung von Einzelinstallationen aus der Modifizierung, Reparatur, dem Entfernen und Aktualisieren von Installationen.


Installation auf Einzel-Computern

Sie können SOLIDWORKS mit mehreren Installationsmethoden auf einem Einzelcomputer installieren.

Die Installation erfolgt über den SOLIDWORKS Installations-Manager, der die Installation auf die von Ihnen erworbenen Produkte anpasst. Bevor Sie mit der Installation beginnen:

  • Halten Sie Ihre SOLIDWORKS Seriennummer bereit.
  • Stellen Sie sicher, dass Sie über einen funktionierenden Internet-Anschluss verfügen. Die Verbindung ist zum Prüfen der Berechtigung erforderlich.

Der SOLIDWORKS Installations-Manager benötigt verschiedene Microsoft Komponenten wie zum Beispiel den Microsoft Windows Installer, Microsoft Visual Studio Tools for Applications, Visual Basic und .NET Framework. Wenn die korrekten Versionen aller von Windows vorausgesetzten Komponenten nicht auf dem Computer installiert sind, installiert der SOLIDWORKS Installations-Manager diese automatisch vor der Installation der SOLIDWORKS Produkte. Der Bonjour-Service für Windows ist ebenfalls eine erforderliche Komponente.

Installationsmethode | Übersicht über den Vorgang
Verwenden der SOLIDWORKS Installationsmedien | Legen Sie den DVD-Datenträger in das Laufwerk ein.
Ein Download-Verzeichnis auf einem Server verwenden Doppelklicken Sie im Download-Verzeichnis auf setup.exe.

Man muss von dem Computer, auf dem Sie SOLIDWORKS Produkte installieren, auf das Download-Verzeichnis zugreifen können. Er muss des Weiteren alle SOLIDWORKS Installationsdateien enthalten, bevor Sie mit der Installation beginnen können. Mit dem SOLIDWORKS Installations-Manager können Sie fehlende Dateien finden, wenn Sie Zugriff auf das Internet und Schreibrechte auf das Download-Verzeichnis haben.

Aktualisierung einer bestehenden SOLIDWORKS Installation mittels Nach Aktualisierungen suchen Wählen Sie eine der folgenden Optionen aus:
  • Klicken Sie in SOLIDWORKS auf Hilfe > Nach Aktualisierungen suchen.
  • Klicken Sie unter Windows auf Start > Alle Programme > SOLIDWORKS Installations-Manager > Nach Aktualisierungen suchen.
Sie müssen über eine funktionierende Internetverbindung und Administratorrechte auf dem Computer verfügen.
Herunterladen von der SOLIDWORKS Kunden-Website
  1. Rufen Sie die SOLIDWORKS Website auf.
  2. Melden Sie sich als Subskriptionsdienst-Kunde mit Ihrer E-Mail-Adresse und Ihrem Passwort oder Ihrer SOLIDWORKS Seriennummer an.
  3. Klicken Sie unter Self Service auf Download Software and Updates.
  4. Klicken Sie unter Download Software auf die SOLIDWORKS Version, die Sie installieren möchten.
Sie müssen über eine funktionierende Internetverbindung verfügen und Kunde der Subskriptionsdienste mit Anmeldeinformationen für den Zugriff auf das Kundenportal sein.

Wenn die Installation abgeschlossen ist, starten Sie die SOLIDWORKS Anwendung, und aktivieren Sie die Lizenz.

Um eine Auflistung der Produkte anzuzeigen, die auf Ihrem Rechner installiert sind, klicken Sie im SOLIDWORKS Hauptmenü auf Hilfe > Meine Produkte. Mit den Häkchen im Dialogfeld sind die Produkte gekennzeichnet, die Ihnen oder Ihrem Unternehmen basierend auf Ihren Aktivierungen und Netzwerklizenzen gehören. Sie können auch mehr über SOLIDWORKS Produkte erfahren, indem Sie auf den Link oben in jeder Produktkategorie klicken.

Um zu sehen, welche Lizenzen in Verwendung sind, klicken Sie in Windows auf Start > SOLIDWORKS <Version> > SOLIDWORKS Extras > SolidNetWork License Manager Client > Lizenzverwendung (Registerkarte).

Übergeordnetes Thema Einzelinstallationen
Verwaltung von Einzelplatzinstallationen


Verwaltung von Einzelplatzinstallationen

Normalerweise besteht die Verwaltung von Einzelinstallationen aus der Modifizierung, Reparatur, dem Entfernen und Aktualisieren von Installationen.

Inhaltsverzeichnis

  • Modifizieren einer Installation

    Sie können eine Installation modifizieren, um Produkte zu installieren, die noch nicht installiert wurden, oder um Produkte zu entfernen. Dafür muss die vorherige Installation mit einem vollständigen Satz von Installationsdateien abgeschlossen worden sein. Diese Option ist nicht verfügbar, wenn Sie die vorherige Installation mit einem Service Pack aktualisiert haben.

  • Reparieren einer Installation

    Wenn Sie Probleme mit einem installierten SOLIDWORKS Produkt haben, können Sie den SOLIDWORKS Installations-Manager für die Reparatur der Installation verwenden.

  • Einzelinstallation auf ein früheres Service Pack zurücksetzen

  • Entfernen einer Installation

    Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.

  • Auf neue Version aktualisieren

    Es gibt mehrere Methoden, wie Sie eine Einzelinstallation auf eine neue SOLIDWORKS Version aktualisieren können.

  • Produkt-Koexistenzregeln

    Die folgenden Produkt-Koexistenzregeln bestimmen, wie neue Produkte installiert und bestehende Produkte aktualisiert werden.

Übergeordnetes Thema Einzelinstallationen
Installation auf Einzel-Computern


Modifizieren einer Installation

Sie können eine Installation modifizieren, um Produkte zu installieren, die noch nicht installiert wurden, oder um Produkte zu entfernen. Dafür muss die vorherige Installation mit einem vollständigen Satz von Installationsdateien abgeschlossen worden sein. Diese Option ist nicht verfügbar, wenn Sie die vorherige Installation mit einem Service Pack aktualisiert haben.

Wenn Sie die SOLIDWORKS Anwendung installiert und eine Zusatzanwendung zu einem späteren Zeitpunkt erworben haben, können Sie die Installation ändern, um die neue Zusatzanwendung hinzuzufügen. Sie müssen die Zusatzanwendung auf jedem einzelnen Rechner installieren.

  1. Stellen Sie sicher, dass keine SOLIDWORKS Sitzung aktiv ist.
  2. Klicken Sie in Windows 7 oder höher auf Start > Systemsteuerung >Programme und Komponenten.
  3. Wählen Sie die installierte SOLIDWORKS Software aus, die Sie ändern möchten, und klicken Sie auf Ändern.
  4. Klicken Sie auf dem Bildschirm Willkommen beim SOLIDWORKS Installations-Manager auf Einzelinstallation (auf diesem Computer) ändern.
  5. Verifizieren Sie auf dem Bildschirm Seriennummer, dass die für Ihre Installation passenden Seriennummern angegeben sind.
  6. Wählen Sie auf dem Bildschirm Produktauswahl die zu installierenden oder entfernenden Produkte aus.
    Falls Sie eine Installation modifizieren:
    • Es werden standardmäßig keine Produkte installiert oder entfernt, auch wenn Sie eine neue Seriennummer festlegen. Sie müssen die Installationsaktion für jedes Produkt oder jede Feature-Komponente ändern.
    • Klicken Sie, um die projizierte Aktion für eine bestimmte Komponente zu sehen, auf den Namen der Komponente (aber nicht auf das Kontrollkästchen). Die gewünschte Installationsaktion erscheint im Informationsfeld unter der Produktauflistung.
    • Sie können auf das Kontrollkästchen neben der Produktkomponente klicken, um die Installationsaktion für diese Komponente zu ändern. (Beispiel: Wenn Sie Komponenten installieren oder entfernen, legt die Aktivierung des Kontrollkästchens fest, dass die Komponente zu installieren oder zu entfernen ist, und die Deaktivierung des Kontrollkästchens legt fest, dass die Komponente nicht zu installieren oder zu entfernen ist.)
    • Wenn Sie eine Komponenteninstallationsaktion aus der ursprünglichen Wahl ändern, erscheint in der Auflistung ein Sternchen (*) neben der Komponente.
    • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
    • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.
  7. Klicken Sie auf dem Bildschirm Zusammenfassung auf Jetzt modifizieren.
  8. Klicken Sie auf dem Bildschirm Installation vollständig auf Fertig stellen.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Reparieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Entfernen einer Installation
Auf neue Version aktualisieren
Produkt-Koexistenzregeln


Reparieren einer Installation

Wenn Sie Probleme mit einem installierten SOLIDWORKS Produkt haben, können Sie den SOLIDWORKS Installations-Manager für die Reparatur der Installation verwenden.

Zum Reparieren einer Installation muss Ihr Computer jedoch über alle Quelldateien aus der vorherigen Installation und über die angewendeten Service Packs verfügen, und zwar an jenem Speicherort, an dem sie ursprünglich installiert wurden.

Eine Einzelinstallation kann repariert werden. Ein Administrator-Installationsabbild kann nicht repariert werden; Sie müssen das Administrator-Installationsabbild deinstallieren und erneut installieren.
  1. Klicken Sie in Windows 7 oder höher auf Start > Systemsteuerung > Programme > Programme und Funktionen.
  2. Wählen Sie die SOLIDWORKS Version aus, die Sie reparieren möchten, und klicken Sie auf Ändern.
  3. Klicken Sie auf dem Bildschirm Willkommen beim SOLIDWORKS Installations-Manager auf Einzelinstallation reparieren (auf diesem Computer)..
  4. Wählen Sie auf dem Bildschirm Zu reparierende Produkte das zu reparierende Produkt.
  5. Deaktivieren Sie den Rest der Produkte auf dem Bildschirm.
  6. Klicken Sie auf Reparieren.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Übergeordnetes Thema Installationsfehler / Installation abgebrochen
Modifizieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Entfernen einer Installation
Auf neue Version aktualisieren
Produkt-Koexistenzregeln
Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation
Kontaktaufnahme mit dem SOLIDWORKS Fachhändler


Einzelinstallation auf ein früheres Service Pack zurücksetzen

Um eine Einzelinstallation auf ein früheres Service Packversion in der aktuellen Hauptversionsfamilie zurückzusetzen, die aktuell auf dem Computer installierte Service Pack-Version deinstallieren und die frühere Version installieren.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Modifizieren einer Installation
Reparieren einer Installation
Entfernen einer Installation
Auf neue Version aktualisieren
Produkt-Koexistenzregeln


Entfernen einer Installation

Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.

  1. Stellen Sie sicher, dass keine SOLIDWORKS Sitzung aktiv ist.
  2. Wenn Sie die SOLIDWORKS Lizenz auf einen anderen Computer übertragen möchten, tun Sie dies, bevor Sie die SOLIDWORKS Installation auf diesem Computer entfernen.
    Weitere Informationen finden Sie unter Übertragen einer Lizenz.
  3. Starten Sie in Windows 7 oder höher die Systemsteuerung > Programme und Funktionen.
  4. Wählen Sie die Produktkomponente aus, die entfernt werden sollen.
    In einigen Fällen könnten Sie mehrere SOLIDWORKS Service Pack-Komponenten für eine bestimmte Hauptversion vorfinden. Entfernen Sie, um eine Hauptversion von SOLIDWORKS zu entfernen, alle Service Pack-Elemente dieser Hauptversion.
  5. Auf dem Deinstallieren-Bildschirm:
    1. wählen Sie die Produkte aus, die entfernt werden sollen. Standardmäßig werden alle Produktkomponente selektiert.
    2. Deaktivieren Sie die Produkte, die nicht entfernt werden sollen.
    3. Wählen Sie, ob eine benutzerdefinierte oder vollständige Deinstallation durchgeführt werden soll. Der SOLIDWORKS Installations-Manager führt eine Standard-Deinstallation durch und entfernt Programmdateien und Ordner.
      1. Klicken Sie auf Ändern in Erweiterte Optionen.

        Der Bildschirm Erweiterte Optionen wird eingeblendet und die Programmdateien und Ordner-Option ist ausgewählt.

      2. Wählen Sie eine oder mehrere Optionen aus, um eine benutzerdefinierte Deinstallation auszuführen, oder wählen Sie alle Optionen, um eine vollständige Deinstallation durchzuführen.
      3. Klicken Sie auf Zurück zu Übersicht.
      4. Klappen Sie auf dem Bildschirm Übersicht die Option Erweiterte Optionen auf, um die Deinstallationsmethode und die Einträge anzuzeigen.
    4. Klicken Sie auf Elemente entfernen.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Übergeordnetes Thema Verwaltung von mehreren Installationen
Modifizieren einer Installation
Reparieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Auf neue Version aktualisieren
Produkt-Koexistenzregeln
Administrator-Installationsabbilder auf neue Version aktualisieren
Administration von Service Pack-Produktaktualisierungen
Übertragen einer Lizenz


Auf neue Version aktualisieren

Es gibt mehrere Methoden, wie Sie eine Einzelinstallation auf eine neue SOLIDWORKS Version aktualisieren können.

Sie können auf eine neue Version aktualisieren, wenn Sie:
  • Neue Installationsmedien erhalten
  • Nach dem Start von SOLIDWORKS über Upgrades benachrichtigt werden
  • Manuell nach Aktualisierungsergebnissen suchen
  • Eine neue Kopie des SOLIDWORKS Installations-Managers starten

Wenn Sie eine neue Version installieren, können Sie die aktuelle Installation aktualisieren oder die neue Version parallel installieren. Wenn Sie eine Service Pack-Version für eine aktuelle Hauptversion installieren, dann wird die Version automatisch aktualisiert.

Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Modifizieren einer Installation
Reparieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Entfernen einer Installation
Produkt-Koexistenzregeln

Manuell nach Aktualisierungen suchen

Wenn Sie über Administratorrechte auf dem Computer verfügen, können Sie mit einer der folgenden Methoden nach Aktualisierungen für eine bereits installierte SOLIDWORKS Version suchen.

  • Klicken Sie in SOLIDWORKS auf Hilfe > Nach Updates suchen.
  • Klicken Sie in Microsoft Windows auf Start > Alle Programme > SOLIDWORKS Installations-Manager > Nach Updates suchen.

Vorbehalte betreffend Aktualisierungen

Produkte, die mehrere Installationen mit verschiedenen Hauptversionen haben können, unterstützen nicht in jedem Fall Hauptaktualisierungen oder die Möglichkeit, von einer Hauptversionen auf die nächste in einer Einzeloperation zu aktualisieren.

In diesem Fall simuliert der SOLIDWORKS Installations-Manager die Aktualisierung, indem zunächst die neue Version installiert und dann die alte entfernt wird. Zurzeit unterstützen das SOLIDWORKS Kernprodukt und Hauptaktualisierungen, während dies auf andere Produkte nicht zutrifft.

Daraus ergeben sich folgende Konsequenzen:
  • Wenn Sie das SOLIDWORKS Kernprodukt von einer Hauptversion auf die nächste aktualisieren:
    • Die bestehenden installierten Speicherplätze ändern sich nicht.
    • Die Aktualisierung kann zurückgesetzt werden, wenn ein Fehler auftritt oder während der Aktualisierung abgebrochen wird.
  • Wenn andere Produkte von einer Hauptversion auf die nächste aktualisiert werden:
    • Jedes Produkt wird zunächst als neues Produkt an einem neuen Speicherplatz installiert. Danach wird die ursprüngliche Installation entfernt.
    • Sobald die Aktualisierung gestartet wurde, kann sie nicht mehr zurückgesetzt werden, wenn ein Fehler auftritt oder wenn der Aktualisierungsvorgang abgebrochen wird.


Produkt-Koexistenzregeln

Die folgenden Produkt-Koexistenzregeln bestimmen, wie neue Produkte installiert und bestehende Produkte aktualisiert werden.

Regel | Beispiele
Mehrere Hauptversionen des SOLIDWORKS Kernprodukts sind erlaubt, mit Ausnahme der unten aufgeführten Produkte. | SOLIDWORKS 2018 SP 3.0 und SOLIDWORKS 2019 SP 0.0 können auf demselben Computer installiert sein.
Mehrere Service Packs der gleichen Hauptversion sind nicht erlaubt. | SOLIDWORKS 2019 SP 0.0 und 2019 SP 1.0 können nicht gemeinsam auf demselben Computer installiert sein. Wenn Sie SOLIDWORKS 2019 SP 1.0 auf einem Computer installieren, auf dem SOLIDWORKS 2019 SP 0.0 bereits installiert ist, ersetzt der SOLIDWORKS Installations-Manager SP 0.0 durch SP 1.0.
Von den folgenden Produkten ist nur jeweils eine Version auf einem Computer erlaubt:
  • SolidNetWork License Manager
 Wenn SOLIDWORKS 2019 SP 0.0 installiert ist, wird SolidNetWork License Manager auf 2019 SP 0.0 aktualisiert, auch wenn eine frühere Hauptversion von SOLIDWORKS auf dem Computer installiert bleibt.
Von den folgenden Produkten ist nur jeweils eine Version auf einem Computer erlaubt:
  • SOLIDWORKS Electrical
 Wenn Sie eine neue Installation von SOLIDWORKS Electrical 2019 SP 1.0 erstellen, entfernt der SOLIDWORKS Installations-Manager automatisch frühere Versionen von SOLIDWORKS Electrical vom Computer. Sichern Sie Ihre SOLIDWORKS Electrical Umgebung vor dem Upgrade.
Von den folgenden Produkten ist nur jeweils eine Version auf einem Computer erlaubt:
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

Wenn Sie SOLIDWORKS 2019 SP 0.0 oder SP 1.0 installieren, sollten Sie auch auf SOLIDWORKS 2019 PDM Server und PDM Client aktualisieren.

Wenn Sie SOLIDWORKS 2019 PDM Server installieren, sollten Sie den PDM Server Installationsprozess für die Installation von SOLIDWORKS PDM Client verwenden. Installieren Sie den SOLIDWORKS PDM Client nicht separat mit dem Client-Installationsprozess.

Release-Version und Service Packs von SOLIDWORKS PDM Client müssen die gleichen wie SOLIDWORKS PDM Server auf dem gleichen Computer sein.

Unter dem Thema Installieren eines PDM Servers mit SLDIM finden Sie weitere Informationen.

Nur eine Version eines integrierten Produkts kann für eine SOLIDWORKS Hauptversion installiert werden. Versionen eingeschlossener Produkte aus verschiedenen Hauptversionen von SOLIDWORKS können jedoch koexistieren. | Wenn SOLIDWORKS 2019 SP 0.0 auf 2019 SP 1.0 aktualisiert wird, wird SOLIDWORKS Explorer 2019 SP 0.0 automatisch auf 2019 SP 1.0 aktualisiert. SOLIDWORKS Explorer 2018 SP 4.0 kann jedoch mit SOLIDWORKS Explorer 2019 SP 0.0 oder mit SOLIDWORKS Explorer 2019 SP 1.0 koexistieren.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Modifizieren einer Installation
Reparieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Entfernen einer Installation
Auf neue Version aktualisieren


Mehrere Installationen

Inhaltsverzeichnis

  • Bereitstellung für mehrere Clients

    Sie können das SOLIDWORKS Produkt auf mehreren Clients installieren, indem Sie ein Administrator-Installationsabbild erstellen und die Installation auf Clients anwenden.

  • Administrator-Installationsabbilder verwenden

    Ein Administrator-Installationsabbild gestattet die konfigurierbare Installation von SOLIDWORKS Produkten von einem einzigen Netzwerkbereich.

  • Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen

    Sobald Sie ein freigegebenes Administrator-Installationsabbild-Verzeichnis erstellt haben, können Sie Clients über E-Mail benachrichtigen.

  • Befehlszeilenbereitstellung

    Sie können mittels einer Eingabeaufforderung oder Stapeldatei (stille Installation) ein Administrator-Installationsabbild automatisch aktivieren.

  • Verwaltung von mehreren Installationen

    Für mehrere Installationen umfassen die Verwaltungsaufgaben die Aktualisierung der Administrator-Installationsabbilder auf die neuen Versionen, Anwendung der Service Pack Aktualisierungen und das Entfernen von Installationen.


Bereitstellung für mehrere Clients

Sie können das SOLIDWORKS Produkt auf mehreren Clients installieren, indem Sie ein Administrator-Installationsabbild erstellen und die Installation auf Clients anwenden.

Der Vorgang zur Anwendung auf mehreren Clients ist wie folgt:
  1. Administrator-Installationsabbild erstellen.
    • Administrator-Installationsabbild vom SOLIDWORKS Installations-Manager aus erstellen
  2. Administrator-Installationsabbild auf Clients anwenden.
    • Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen
    • Mit der Befehlszeile aus dem Administrator-Abbild installieren
  3. Implementieren Sie Lizenzierung.
    • Verwalten von Einzellizenzen
    • Lizenzen mit einem SolidNetWork License Manager verwalten
Übergeordnetes Thema Mehrere Installationen
Administrator-Installationsabbilder verwenden
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen
Befehlszeilenbereitstellung
Verwaltung von mehreren Installationen


Administrator-Installationsabbilder verwenden

Ein Administrator-Installationsabbild gestattet die konfigurierbare Installation von SOLIDWORKS Produkten von einem einzigen Netzwerkbereich.

Administrator-Installationsabbilder lassen sich von jedem Netzwerkcomputer, einschließlich einem Client-Computer, aus installieren.
  • Das Administrator-Installationsabbild muss sich in einem freigegebenen Ordner befinden.
  • Wenn Sie alle Produkte mit einbeziehen, können 7 GB oder mehr auf der Festplatte für das Administrator-Installationsabbild erforderlich werden.
  • Wenn Sie den Freigabenamen bei der Aktualisierung des Administrator-Installationsabbilds aktualisieren, wird der Client automatisch beim nächsten Starten der Anwendung aktualisiert. Einzelheiten dazu finden Sie unter Aktualisierung von Clients von Administrator-Installationsabbildern.
  • Bei der Bereitstellung eines Administrator-Installationsabbilds muss der Pfad zum Abbild weniger als 58 Zeichen lang sein.
  • Clients benötigen Administratorrechte auf den jeweiligen Rechnern. Wenn ein Client nicht über ausreichende Berechtigungen verfügt, kann ein Client eine Installation unter einem anderen Benutzer durchführen. Diese Option ist nützlich, wenn ein einzelner Benutzer keine lokalen Administratorrechte auf dem Computer besitzt, die zur Installation der SOLIDWORKS Produkte erforderlich sind.

    Siehe Bereitstellung von Installationen über den Options-Editor. Dieser Abschnitt beschreibt auch eine alternative Methode zum Installieren von Installationsabbildern, wenn ein Client nicht über ausreichende Berechtigungen verfügt.

  • Wenn die Windows-Protokollierung aktiviert ist oder Sie die Statusfunktionen im Administrator-Installationsabbild-Options-Editor verwenden, müssen Sie über Lese-/Schreibberechtigungen für diesen Ordner verfügen: {Verzeichnis des Administrator-Installationsabbilds}\x64\Logs.

Nachdem Sie ein Administrator-Installationsabbild erstellt haben, können Sie im Administrator-Installationsabbild Options-Editor Installationsoptionseinstellungen für Benutzer und Gruppen, die Installationen mithilfe des Abbilds durchführen, vornehmen. Weitere Informationen finden Sie unter Options-Editor für das Administrator-Installationsabbild.

Inhaltsverzeichnis

  • Administrator-Installationsabbild vom SOLIDWORKS Installations-Manager aus erstellen

    Wenn Sie SOLIDWORKS auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.

Übergeordnetes Thema Mehrere Installationen
Bereitstellung für mehrere Clients
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen
Befehlszeilenbereitstellung
Verwaltung von mehreren Installationen
Aktualisierung von Clients von Administrator-Installationsabbildern


Administrator-Installationsabbild vom SOLIDWORKS Installations-Manager aus erstellen

Wenn Sie SOLIDWORKS auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.

  1. Starten Sie den SOLIDWORKS Installations-Manager. Siehe Initiieren der SOLIDWORKS Installation.
  2. Wählen Sie auf dem Bildschirm Willkommen die Option Administrator-Installationsabbild aus.
    Die Administrator-Installationsabbild-Optionen werden angezeigt.
    Option | Bezeichnung
    Neues Abbild mit Standardeinstellungen erstellen. | Erstellen Sie das Abbild unter Verwendung der Standardkonfigurationseinstellungen (d. h. nicht auf der Basis der aktuellen Einstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort erstellt wurden).
    Neues Abbild mit Einstellungen und Dateien von einem bestehenden Abbild erstellen. | Erstellen Sie das Abbild unter Verwendung der Konfigurationseinstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort festgelegt wurden. Klicken Sie auf Durchsuchen, um das Installationsverzeichnis für das vorhandene Administrator-Installationsabbild anzugeben.
  3. Befolgen Sie die Anweisungen auf dem Bildschirm.

Inhaltsverzeichnis

  • Administrator-Installationsabbild Options-Editor

    Mit dem Administrator-Installationsabbild Options-Editor können Sie Installationsparameter-Einstellungen in einem Administrator-Installationsabbild für Einzel-Computer und für Gruppen von Computern anpassen.

Übergeordnetes Thema Administrator-Installationsabbilder verwenden
SOLIDWORKS Installation wird initiiert


Administrator-Installationsabbild Options-Editor

Mit dem Administrator-Installationsabbild Options-Editor können Sie Installationsparameter-Einstellungen in einem Administrator-Installationsabbild für Einzel-Computer und für Gruppen von Computern anpassen.

Nach der Erstellung eines Administrator-Installationsabbilds werden Sie vom SOLIDWORKS Installations-Manager zum Starten des Options-Editors aufgefordert. Sie können den Options-Editor auch starten, indem Sie auf sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner doppelklicken.

Um verschiedene Installationskonfigurationen für Gruppen von Maschinen oder einzelne Maschinen festzulegen, wählen Sie im Options-Editor Maschinen aus, indem Sie eine der folgenden Optionen angeben:
  • Maschinenname
  • IP-Adresse
  • IP-Adressbereich
Geben Sie dann die Installationsoptionen für diese Maschinen an.
Alle Dialogfelder, in denen zur Eingabe eines Datei- oder Ordnerpfads aufgefordert wird, enthalten eine Option, in der einer Umgebungsvariable ein ausgewählter Ordner zugewiesen werden kann. Wenn Sie beispielsweise den Pfad „C:\Programme\SOLIDWORKS Corp“ auswählen, wird der Dateipfad mit „%ProgramFiles%\SOLIDWORKS Corp“ verknüpft. Die gängigsten Variablen sind %ProgramFiles% und %SystemDrive%. Sie können nicht alle Pfade in Umgebungsvariablen konvertieren. Zum Beispiel kann „Z:\SOLIDWORKS Data“ keiner Umgebungsvariable zugeordnet werden.

Inhaltsverzeichnis

  • Gruppen und Computer hinzufügen und löschen

    Mit dem Administrator-Installationsabbild Options-Editor können Sie verschiedene Installationskonfigurationen für Gruppen und Computer sowie für Einzelplatz-Computer festlegen.

  • Anzeigen und Bearbeiten von Optionseinstellungen

    Der SOLIDWORKS Options-Editor für das Administrator-Installationsabbild ermöglicht Ihnen, Optionseinstellungen für Gruppen und Computer, die für das Abbild festgelegt wurden, anzuzeigen und zu ändern.

  • Einstellungsadministrator-Werkzeug

  • Bereitstellung von Installationen über den Options-Editor

    Sie können Installationen direkt vom Options-Editor aus bereitstellen, indem Sie entweder die manuelle oder die Push-Methode verwenden.

  • Beenden des Options-Editors

    Sie können auf OK oder "Schließen" klicken, um den Options-Editor zu beenden.

  • Erstellen einer Desktop-Verknüpfung zum Options-Editor

    Sie können eine Windows-Desktop-Verknüpfung zum Options-Editor für ein bestimmtes Administrator-Installationsabbild erstellen, und von der Anwendung aus.

Übergeordnetes Thema Administrator-Installationsabbild vom SOLIDWORKS Installations-Manager aus erstellen


Gruppen und Computer hinzufügen und löschen

Mit dem Administrator-Installationsabbild Options-Editor können Sie verschiedene Installationskonfigurationen für Gruppen und Computer sowie für Einzelplatz-Computer festlegen.

Sie können z.B. u.U. etliche Computer so konfigurieren, dass sie einen bestimmten Teilsatz der Produktkomponenten verwenden, die im Abbild zur Verfügung stehen, während eine andere Gruppe u.U. einen anderen Teilsatz der Produktkomponenten verwendet. Obwohl Sie ein Administrator-Installationsabbild verwenden, ermöglichen es die Gruppeneinstellungen des Options-Editors, dass verschiedene Produkt-Teilsätze auf verschiedene Gruppen von Maschinen installiert werden können.

Hinzufügen einer Gruppe:
  1. Klicken Sie mit der rechten Maustaste auf Globale Einstellungen und dann auf Gruppe hinzufügen.
  2. Geben Sie den Gruppennamen ein.

Computer hinzufügen:
  1. Klicken Sie mit der rechten Maustaste auf eine bestehende Gruppe oder auf Globale Einstellungen und dann auf Computer hinzufügen.
    Wenn Sie auf eine bestehende Gruppe rechtsklicken, werden dieser Gruppe Computer hinzugefügt. Ansonsten werden sie auf der übergeordneten Ebene hinzugefügt.
  2. Wählen Sie eine der folgenden Optionen aus:
    • Wählen Sie Nach Computer-Name aus und geben Sie einen oder mehrere Computer-Namen ein. Mehrere Computer können durch einen Zeilenumbruch, einen Abstand, ein Tabstopp, Komma, einen Punkt, Doppelpunkt oder ein Semikolon getrennt sein. Sie können eine Liste von Computer-Namen aus einer externen Datei kopieren und einfügen. Computer-Namen dürfen keine Domain-Kennzeichner enthalten. pluto.solidworks.com ist z.B. ungültig.
    • Wählen Sie Nach IP-Adresse aus und geben Sie die IP-Adresse eines Computers ein.
    • Wählen Sie Nach IP-Adressbereich aus und geben Sie die erste und die letzte IP-Adresse des Bereichs ein.
    • Klicken Sie auf Mehrere Computer hinzufügen, um Computer aus dem Netzwerk auszuwählen.

Einen bestehenden Computer in eine Gruppe verschieben:

Ziehen Sie den Computer in die Gruppe.

Einen Computer aus einer Gruppe verschieben:

Ziehen Sie den Computer auf Globale Einstellungen oder in eine andere Gruppe.

Eine Gruppe oder Computer löschen:

Klicken Sie mit der rechten Maustaste auf die Gruppe oder den Computer und dann auf Gruppe löschen oder Computer löschen.

Wenn Sie eine Gruppe löschen, werden alle Computer in dieser Gruppe gelöscht.

All Gruppen und Computer löschen:

Klicken Sie mit der rechten Maustaste auf Globale Einstellungen und dann auf Alles löschen.

Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Anzeigen und Bearbeiten von Optionseinstellungen
Einstellungsadministrator-Werkzeug
Bereitstellung von Installationen über den Options-Editor
Beenden des Options-Editors
Erstellen einer Desktop-Verknüpfung zum Options-Editor


Anzeigen und Bearbeiten von Optionseinstellungen

Der SOLIDWORKS Options-Editor für das Administrator-Installationsabbild ermöglicht Ihnen, Optionseinstellungen für Gruppen und Computer, die für das Abbild festgelegt wurden, anzuzeigen und zu ändern.

  • Beim ersten Starten des Options-Editor werden die Optionseinstellungen schreibgeschützt angezeigt. Das Symbol „Bearbeiten“ ist nicht schattiert.

    Durch Klicken auf Globale Einstellungen wird eine Zusammenfassung der Optionseinstellungen für eine Gruppe oder einen Computer angezeigt:

    Bereich | Angezeigte Optionseinstellungen
    Globale Einstellungen | Alle Optionseinstellungen, die für das Administrator-Installationsabbild festgelegt wurden
    Gruppe | Änderungen bei den Gruppeneinstellungen bezüglich der globalen Einstellungen.
    Computer | Änderungen bei den Computereinstellungen bezüglich der Gruppe.
  • Um die Optionseinstellungen zu ändern, klicken Sie auf das Symbol "Bearbeiten". Das Symbol wird schattiert dargestellt und eine ausführlichere Optionseinstellungsliste wird angezeigt.

    Durch Klicken auf Globale Einstellungen können Sie Optionseinstellungen für eine Gruppe oder einen Computer ändern. Wenn Sie eine Optionseinstellung ändern, die sich von den übernommenen globalen oder Gruppeneinstellungen unterscheidet, wird diese Optionseinstellung hervorgehoben.

    Wenn Sie erneut auf das Symbol "Bearbeiten" klicken, wird die Anzeige wieder in den Schreibschutzmodus geschaltet.

    Beim Beenden des Options-Editors werden Sie aufgefordert, die Änderungen zu speichern oder zu verwerfen.

Inhaltsverzeichnis

  • Optionseinstellungen für Gruppen und Computer festlegen

    Sie können Optionseinstellungen für alle Computer (globale Einstellungen), Gruppen von Computern und Einzel-Computer festlegen.

  • Administrator-Installationsabbild-Optionseinstellungen

    Der Options-Editor ermöglicht die Definition der Einstellungen für einzelne Clients oder Gruppen, einschließlich Seriennummern, Client-Installationsoptionen, welche Software-Komponenten installiert werden sollen und die Toolbox Position.

  • Übernahme von globalen und Gruppenoptionseinstellungen

    Optionseinstellungen für Globale Einstellungen oder Gruppen werden von untergeordneten Elementen übernommen.

  • Anpassen der Einstellungen für einzelne Computer

    Sie können auch Einstellungen ändern, die Sie für bestimmte Computer festgelegt haben. Klicken Sie dazu mit der rechten Maustaste auf den Computer-Namen.

Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Einstellungsadministrator-Werkzeug
Bereitstellung von Installationen über den Options-Editor
Beenden des Options-Editors
Erstellen einer Desktop-Verknüpfung zum Options-Editor


Optionseinstellungen für Gruppen und Computer festlegen

Sie können Optionseinstellungen für alle Computer (globale Einstellungen), Gruppen von Computern und Einzel-Computer festlegen.

  1. Klicken Sie im Options-Editor auf das zu ändernde Objekt (z. B. Globale Einstellungen, eine Gruppe oder einen Computer).
  2. Klicken Sie im rechten Fensterbereich auf das Bearbeitungssymbol.
    Das Bearbeitungssymbol wird schattiert dargestellt und eine ausführlichere Optionseinstellungsliste wird angezeigt.
  3. Ändern Sie Optionseinstellungen, indem Sie rechts auf die Optionseinstellungen für das auf der linken Seite ausgewählte Element klicken.
    Änderungen an den Optionseinstellungen, die Globale Einstellungen oder Gruppeneinstellungen überschreiben, werden hervorgehoben.
  4. Klicken Sie auf OK oder Schließen, um die Änderungen zu speichern.
    Option | Bezeichnung
    OK | Die Änderungen werden gespeichert, und der Options-Editor wird geschlossen.
    Schließen | Der Options-Editor fragt, ob Sie die Änderungen speichern möchten, und wird dann geschlossen.
Übergeordnetes Thema Anzeigen und Bearbeiten von Optionseinstellungen
Administrator-Installationsabbild-Optionseinstellungen
Übernahme von globalen und Gruppenoptionseinstellungen
Anpassen der Einstellungen für einzelne Computer


Administrator-Installationsabbild-Optionseinstellungen

Der Options-Editor ermöglicht die Definition der Einstellungen für einzelne Clients oder Gruppen, einschließlich Seriennummern, Client-Installationsoptionen, welche Software-Komponenten installiert werden sollen und die Toolbox Position.

Seriennummern

Geben Sie die Seriennummern der Produkte ein, die auf den Clientcomputern installiert werden sollen.
Da es viele Möglichkeiten gibt, SOLIDWORKS Produkte zu erwerben, können einige Seriennummern zwei oder mehr Produkte abdecken. So kann eine SOLIDWORKS Seriennummer Ihnen beispielsweise gestatten, SOLIDWORKS Simulation zu installieren, ohne eine separate SOLIDWORKS Simulation Seriennummer eingeben zu müssen. Zudem benötigen einige Produkte keine Seriennummer. Wenn Sie Fragen zu Ihren Seriennummern haben, wenden Sie sich an Ihren Fachhändler.
Wenn Sie Lizenzen mit der SolidNetWork Lizenzierung verwalten:
  • Geben Sie die SolidNetWork Seriennummer in das erste Seriennummerfeld ein.
  • Geben Sie den Servernamen und Port des SolidNetWork License Manager in das Feld SNL Server Port@Server im Format nnnnn@Servername ein. Geben Sie mehrere Einträge durch Semikolon getrennt ein.

Nähere Informationen über die SolidNetWork Lizenzierung finden Sie unter Installation und Konfiguration von SolidNetWork Lizenzen.

Client-Installationsoptionen

Wie sollen Client-Installationen von Hauptversionen ausgeführt werden? Sie können festlegen, wie bei Clientinstallationen eine vorhandene Hauptversionsinstallation behandelt wird:
  • Auf bestehende Hauptversion (sofern vorhanden) aktualisieren.

    Aktivieren Sie diese Option, wenn die vorherige Hauptversioninstallation durch die neue Installation ersetzt werden soll.

  • Neue Hauptversion erstellen.

    Aktivieren Sie diese Option, wenn die vorherige Hauptversioninstallation erhalten bleiben soll und eine neue Installation für die neue Hauptversion erstellt werden soll. Um einen Speicherort für die Installation der neuen Version anzugeben, klicken Sie auf Durchsuchen.
Soll die letzte vorige Version deinstalliert werden, bevor eine neue Hauptversion installiert wird? Sie können festlegen, ob die bestehende Version vor der Hauptversion deinstalliert werden soll:
  • Nein, nicht zuerst deinstallieren.

    Aktivieren Sie diese Option, um die frühere Hauptversionsinstallation beizubehalten.

  • Ja, eine benutzerdefinierte Deinstallation ausführen.

    Wählen Sie diese Option, um die folgenden Elemente zu entfernen: Datendateien und -ordner, die bei einer früheren Installation erstellt wurden.

Wie sollen SOLIDWORKS Einstellungen angewendet werden? Sie können eine Einstellungsdatei festlegen, auf die Client-Installationen von SOLIDWORKS beim Start verweisen. Die Einstellungsdatei (*.sldsettings) muss sich unter einem freigegebenen UNC-Pfad befinden, der für alle Installationen sichtbar ist. Sie müssen einen *.sldsettings-Pfad vor der Installation von SOLIDWORKS angeben. Die Client-Installationen werden während der Installation über den *.sldsettings-Dateipfad informiert.
Schützen Sie die *.sldsettings-Datei, indem Sie in den Windows-Dateiberechtigungen den Schreibzugriff auf ganz bestimmte Benutzer einschränken.

Klicken Sie zum Erstellen oder Bearbeiten einer *.sldsettings-Datei auf Settings Administrator starten. Mit SOLIDWORKS Settings Administrator können Sie festlegen, welche SOLIDWORKS Systemoptionen angewendet und welche optional für Anwender in Ihrem Unternehmen gesperrt werden sollen. Sie können auch definieren, wie und wann die Einstellungen auf Einzelinstallationen angewendet werden, und Sie können die *.sldsettings-Datei jederzeit ändern, indem Sie Settings Administrator ausführen und die bestehende Datei überschreiben.

Sie können verschiedene *.sldsettings-Dateien für andere Computer oder Gruppen verwenden.

Der Pfad zu *.sldsettings wird bei der Installation festgelegt. Nach der Bereitstellung sollten Sie die *.sldsettings-Datei weder umbenennen noch verschieben.

Um das Einstellungsadministrator-Werkzeug auszuführen, benötigen Sie eine bestehende Installation von SOLIDWORKS 2019 [aktuelle Hauptversion].
Wie sollen Client-Installationen aktiviert werden? Sie können festlegen, ob Sie Produktaktivierung automatisch nach dem Ausführen der Installation ausführen möchten oder fordern, dass der Anwender die Produktaktivierung manuell nach der Installation ausführt.
Falls Sie eine automatische Produktaktivierung definieren, muss das Administrator-Installationsabbild durch eine freigegebene Netzwerkposition verfügbar sein, wenn die Clients SOLIDWORKS zum ersten Mal nach der Installation ausführen. Wenn das Administrator-Installationsabbild für Clients, die von diesem Abbild installiert haben, nicht verfügbar ist, können diese Clients die automatische Produktaktivierung nicht ausführen. Sie sind nicht in der Lage, SOLIDWORKS auszuführen, es sei denn, sie führen die SOLIDWORKS Produktaktivierung manuell aus.
  • Automatisch aktivieren, wenn alle Client-Installationen vollständig sind.

    Die Auswahl dieser Optionseinstellung definiert, dass das Produkt automatisch unter Verwendung einer SOLIDWORKS Produktaktivierungsdatei ausgeführt wird. (In der Regel hat die Datei die Bezeichnung AutoActivation.xml.) Klicken Sie auf Durchsuchen, um nach einer vorhandenen Aktivierungsdatei zu suchen, oder auf Neu, um die SOLIDWORKS Produktaktivierung zu starten und eine neue Aktivierungsdatei zu erstellen.

  • Nicht automatisch aktivieren.

    Die Auswahl dieser Optionseinstellung definiert, dass keine automatisierte Produktaktivierung erfolgt. Der Client-Anwender führt eine Produktaktivierung nach der Installation durch.

Verwaltungsoptionen

Während jeder Installation ein Diagnoseprotokoll erstellen. | Bei der Clientinstallation kann ein Diagnoseprotokoll erstellt werden, das bei der Beseitigung von Installationsproblemen helfen kann. Die Erstellung dieses Protokolls kann jedoch die Clientinstallation verlangsamen. Die Protokolldatei wird im Verzeichnis {Administrator-Installationsabbild -Verzeichnis}\x64\Logs\<Computername>\Status.xml gespeichert.
Installation als anderer Anwender ausführen.

Eine Clientinstallation kann als ein anderer Benutzer ausgeführt werden. Diese Option ist nützlich, wenn einzelne Benutzer keine lokalen Administratorrechte auf deren Computern besitzen ,welche zur Installation der SOLIDWORKS Produkte erforderlich sind.

Es steht eine alternative Vorgehensweise zur Bereitstellung und Installation zur Verfügung, wenn Clients nicht über Administratorrechte verfügen. Siehe Bereitstellung von Installationen über den Options-Editor.
Programm vor oder nach der Installation ausführen. | Sie können festlegen, dass ein benutzerdefiniertes Programm vor oder nach der Clientinstallation ausgeführt wird.
Sollen Clients am SOLIDWORKS Kunden-Feedback-Programm teilnehmen? | Außerdem können Sie festlegen, dass Clients am SOLIDWORKS Kunden-Feedback-Programm teilnehmen. Leistungsdaten werden zur Produktverbesserung an die SOLIDWORKS Corporation gesendet. Das Verfahren ist transparent und die gewonnenen Daten werden geschützt. Weitere Informationen dazu finden Sie unter Anwendererfahrungs-Optimierungsprogramm – Website.

Einschränkungen der Installationsoptionen "Programm vor/nach der Installation ausführen"

Mithilfe dieser Optionen können Sie auf den Client-Computern vor oder nach dem Bereitstellen von SOLIDWORKS andere Installationsprogramme oder Skripts ausführen, z. B. ein Skript zum Installieren von Microsoft Office.

Wenn Sie eine automatische Bereitstellung auf Windows 8-Client-Computern (und höher) durchführen, ist die Verwendung dieser Optionen eingeschränkt. Es tritt ein Fehler auf, wenn Sie eine der Optionen zum Bereitstellen eines Installationsprogramms oder Skripts verwenden, das eine Benutzeroberfläche anzeigt, z. B. ein Skript zum Anzeigen von Dialogfeldern. Wenn die automatische Bereitstellung von SOLIDWORKS ausgeführt wird, wird SOLIDWORKS nicht auf den Zielcomputern installiert. Diese Einschränkung tritt nicht bei Windows 7-Client-Computern auf.

Um die Optionen Programm vor der Installation ausführen und Programm nach der Installation ausführen zu verwenden, sollten Sie nur solche Programme auswählen, die im stillen Modus installiert werden können.

Zu installierende Software

Sie können festlegen, welche SOLIDWORKS Produktkomponenten installiert werden.
  • Durch Markieren des Kontrollkästchens neben der Produktkomponente wird die Komponente während der Clientinstallation installiert.
  • Wird die Markierung entfernt, wird die entsprechende Komponente nicht installiert.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.
Die Spezifikation Sprachen begrenzt nur die Sprachen, die für das SOLIDWORKS Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. Zum Beispiel werden für eDrawings® und SOLIDWORKS Explorer alle vorhandenen Sprachen installiert.

Toolbox Optionen

Sie können festlegen, welche Normen unterstützt werden sollen und das Toolbox Standardverzeichnis bei Client-Installationen festlegen.

In der Regel greifen mehrere Benutzer auf eine freigegebene Toolbox zu, die sich meistens in einem Netzwerkspeicherort befindet (z. B. UNC-Pfad, freigegebener Ordner oder ein gemeinsam verwendetes Netzwerklaufwerk).

Wenn am Speicherort bereits eine ältere Hauptversion der Toolbox vorhanden ist, wird bei der Clientinstallation ein Upgrade der Toolbox auf die neue Hauptversion ausgeführt. Die Dateien sind anschließend nicht mehr mit vorherigen Hauptversionen von SOLIDWORKS kompatibel.
Wenn die Toolbox für die ältere SOLIDWORKS Version erhalten bleiben soll (z. B. wenn auf einigen Clients weiterhin die ältere Version verwendet werden soll), müssen Sie einen anderen Toolbox-Netzwerkspeicherort für die Clients angeben, für die ein Upgrade auf die neue Version ausgeführt wird.

Weitere Informationen zur Verwaltung der SOLIDWORKS Toolbox finden Sie unter Toolbox in der SOLIDWORKS Hilfe.

SOLIDWORKS PDM Client Optionen

Sie können die folgenden Optionen für die Bereitstellung von SOLIDWORKS PDM Clients und Zusatzanwendungen auswählen:

  • PDM-Produkttyp
  • PDM Clienttyp
  • Features

Weitere Informationen zu diesen Clients und Zusatzanwendungen finden Sie im Abschnitt zu SOLIDWORKS PDM.

Optionen für Electrical

Sie können die folgenden Parameter für die administrativen Komponenten von SOLIDWORKS Electrical festlegen:
  • Datenpfad
  • Computername und Portnummer des Gemeinschaftsservers
  • SQL Server-Computername und -Passwort

Weitere Informationen zu diesen Komponenten finden Sie im Abschnitt zu SOLIDWORKS Electrical.

Übergeordnetes Thema Anzeigen und Bearbeiten von Optionseinstellungen
Optionseinstellungen für Gruppen und Computer festlegen
Übernahme von globalen und Gruppenoptionseinstellungen
Anpassen der Einstellungen für einzelne Computer
Installation und Konfiguration von SolidNetWork Lizenzen
Bereitstellung von Installationen über den Options-Editor
SOLIDWORKS Electrical


Übernahme von globalen und Gruppenoptionseinstellungen

Optionseinstellungen für Globale Einstellungen oder Gruppen werden von untergeordneten Elementen übernommen.

Beispiel:
  • Einstellungen, die für Globale Einstellungen definiert sind, gelten für alle Gruppen und Computer.
  • Einstellungen, die für eine Gruppe definiert sind, gelten für alle Computer in dieser Gruppe.

Sie können Optionseinstellung für einen Computer oder eine Gruppe ändern, um Standardeinstellungen oder übertragene Einstellungen außer Kraft zu setzen. Wenn Sie eine Optionseinstellung vom Standardwert oder übernommenen Wert ändern, wird diese Option hervorgehoben.

Klicken Sie, um Optionseinstellungen auf die ursprünglichen Einstellungen zurückzusetzen, mit der rechten Maustaste auf die Gruppe oder den Computer und klicken Sie dann auf Auf globale Einstellungen zurücksetzen (für eine Gruppe oder einen Computer, der nicht Teil der Gruppe ist) oder auf Gruppeneinstellungen zurücksetzen (für einen Computer, der Teil der Gruppe ist).
Übergeordnetes Thema Anzeigen und Bearbeiten von Optionseinstellungen
Optionseinstellungen für Gruppen und Computer festlegen
Administrator-Installationsabbild-Optionseinstellungen
Anpassen der Einstellungen für einzelne Computer


Anpassen der Einstellungen für einzelne Computer

Sie können auch Einstellungen ändern, die Sie für bestimmte Computer festgelegt haben. Klicken Sie dazu mit der rechten Maustaste auf den Computer-Namen.

Im Kontextmenü können Sie die folgenden Tasks für die einzelnen Computer ausführen:
  • Computer aus dem Editor löschen
  • Auf globale Einstellungen zurücksetzen
  • Hinweise hinzufügen oder bearbeiten
  • Optionen bearbeiten

Das Bearbeiten von Optionen ermöglicht Ihnen, alle Optionen für den Computer zu ändern, z. B. die Client-Installationsoptionen und die Verwaltungsoptionen.

Übergeordnetes Thema Anzeigen und Bearbeiten von Optionseinstellungen
Optionseinstellungen für Gruppen und Computer festlegen
Administrator-Installationsabbild-Optionseinstellungen
Übernahme von globalen und Gruppenoptionseinstellungen


Einstellungsadministrator-Werkzeug

Sie können mit dem Einstellungsadministrator-Werkzeug Systemoptionen festlegen, die bei der Bereitstellung oder Aktualisierung der SOLIDWORKS Software angewendet werden, und um zu verhindern, dass Benutzer diese Optionen ändern. Dieses Werkzeug ersetzt den Assistenten zum Kopieren der Einstellungen für die Bereitstellung von Einstellungen, obwohl der Assistent weiterhin für das Kopieren von Einstellungen verfügbar ist.

Die Verwendung des Einstellungsadministrator-Werkzeugs umfasst drei Schritte:
  1. Erstellen Sie ein Administrator-Installationsabbild, um auf das Werkzeug zuzugreifen.
  2. Den Einstellungsadministrator zum Erstellen einer *.sldSettings-Datei mit den ausgewählten SOLIDWORKS Optionen verwenden.
  3. Die *.sldSettings-Datei in SOLIDWORKS Installationen einschließen.

Inhaltsverzeichnis

  • Zugriff auf das Einstellungsadministrator-Werkzeug

    Erstellen Sie zunächst ein Administrator-Installationsabbild, um auf das Einstellungsadministrator-Werkzeug zuzugreifen.

  • Verwendung des Einstellungsadministrator-Werkzeugs

  • Anwenden und Speeren von Optionen

  • Fertigstellen der Optionseinstellungen

  • Einschließen einer .sldSettings-Datei in SOLIDWORKS Installationen

Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Anzeigen und Bearbeiten von Optionseinstellungen
Bereitstellung von Installationen über den Options-Editor
Beenden des Options-Editors
Erstellen einer Desktop-Verknüpfung zum Options-Editor


Zugriff auf das Einstellungsadministrator-Werkzeug

Erstellen Sie zunächst ein Administrator-Installationsabbild, um auf das Einstellungsadministrator-Werkzeug zuzugreifen.

Sie können das Einstellungsadministrator-Werkzeug über ein Administrator-Installationsabbild oder den folgenden Standardspeicherort starten: C:\SolidWorks Admin\SOLIDWORKS <Version>\64bit\SOLIDWORKS\Program Files 64\SOLIDWORKS\sldSettingsAdmin.exe.

So greifen Sie auf das Einstellungsadministrator-Werkzeug zu:

  1. Führen Sie sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner aus.
  2. Klicken Sie im Administrator-Installationsabbild-Options-Editor auf Einstellungen bearbeiten.
  3. Führen Sie im Abschnitt Client Installationsoptionen folgende Schritte aus:
    1. Klicken Sie auf Exportierte Einstellungsdatei aus SOLIDWORKS Settings Administrator verwenden.
    2. Klicken Sie auf Einstellungsadministrator starten.
Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Verwendung des Einstellungsadministrator-Werkzeugs

So verwenden Sie das Einstellungsadministrator-Werkzeug:

  1. Wählen Sie auf der Registerkarte Willkommen eine der folgenden Optionen aus:
    • Standardoptionen, um diese Version von SOLIDWORKS zu starten.
    • Optionen für SOLIDWORKS 2019 von diesem Computer importieren.
    • Gehen Sie zu einer bestehenden sldreg-Datei.
    • Gehen Sie zu einer bestehenden sldSettings-Datei.
    Die *.sldreg-Datei wird durch den Assistenten zum Kopieren der Einstellungen und die *.sldSettings-Datei durch das Einstellungsadministrator-Werkzeug generiert.
  2. Klicken Sie auf Weiter.
Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Anwenden und Speeren von Optionen

Auf der Registerkarte Systemoptionen können Sie über zwei Spalten mit Kontrollkästchen auswählen, welche dieser Optionen angewendet und welche der angewendeten Optionen gesperrt werden sollen, sodass sie von Benutzern nicht geändert werden können.

Wenn Benutzer auf das Dialogfeld Systemoptionen in der SOLIDWORKS Software zugreifen, werden die gesperrten Optionen mit einem Schlosssymbol [image] angezeigt. Sie können jedoch ein Passwort festlegen, das Benutzern das Entsperren von Optionen ermöglicht. Wenn Benutzer mit dem Cursor über eine gesperrte Option fahren, werden in einem Tooltip Ihr Name und Ihre E-Mail-Adresse angezeigt, damit die Benutzer Sie kontaktieren und um das Passwort bitten können.

So wenden Sie Optionen an und sperren sie:

  1. Gehen Sie auf der Registerkarte Systemoptionen wie folgt vor:
    1. Um eine Systemoption anzuwenden, wählen Sie die Option aus und aktivieren Sie das entsprechende Kontrollkästchen in der Spalte Anwenden.
    2. Um eine Systemoption zu sperren, wählen Sie die Option aus und aktivieren Sie die entsprechenden Kontrollkästchen in den Spalten Anwenden und Sperren.
      Wenn Benutzer auf die Registerkarte Systemoptionen zugreifen, werden diese Optionen mit einem Schloss [image] angezeigt.
  2. Je nach Option müssen Sie möglicherweise zusätzliche Parameter für die Option festlegen.
  3. Sie können Benutzer auch daran hindern, Meldungen zu verwerfen, indem Sie die Handhabung von Meldungen/Fehlern/Warnungen steuern.
    1. Klicken Sie auf Meldungen/Fehler/Warnungen.
    2. Wählen Sie Anwenden und aktivieren Sie optional Sperren für die zu verwaltenden Meldungen.
    3. Richten Sie die Meldung auf Einblenden oder Nicht mehr einblenden ein.

      Wenn Sie die Option Einblenden auswählen, wird die Meldung aus der Liste der verworfenen Meldungen eines Benutzers entfernt und dem Benutzer zu gegebener Zeit angezeigt. Wenn Sie Nicht mehr einblenden auswählen, wird die Meldung automatisch zur Liste der verworfenen Meldungen eines Benutzers hinzugefügt und nicht angezeigt, wenn der Benutzer an einem Modell arbeitet.

      In der nachfolgenden Tabelle wird das Verhalten in der Software beschrieben:
      Anwenden | Sperren | Einblenden | Nicht mehr einblenden | Verhalten
      X | X | Erzwingt das Anzeigen der Meldung.
      X | X | Verwirft die Meldung und fügt die Meldung der Liste verworfener Meldungen hinzu.
      X | X | X | Erzwingt das Anzeigen der Meldung und deaktiviert die Option Nicht mehr einblenden im Meldungsfeld.
      X | X | X | Verwirft die Meldung und hindert Benutzer daran, sie unter Extras > Optionen > Meldungen/Fehler/Warnungen zu aktivieren .
  4. Klicken Sie auf der Registerkarte Systemoptionen auf Weiter.
Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Fertigstellen der Optionseinstellungen

So stellen Sie die Einstellung von Optionen fertig:

  1. Legen Sie auf der Registerkarte Fertigstellen fest, wann Systemoptionen angewendet werden sollen:
    • Beim ersten Starten der Software
    • Bei jedem Starten der Software
    • und ob zur selben Zeit Anpassungen angewendet werden.
  2. Sie können entscheiden, ob Optionen angewendet werden, wenn der Benutzer vom Netzwerk getrennt wurde und das Außerkraftsetzen gesperrter Optionen durch API erlaubt ist.
  3. Für gesperrte Systemoptionen müssen Sie Ihren Namen und Ihre E-Mail-Adresse eingeben. Die SOLIDWORKS Software zeigt diese Informationen in einem Tooltip an, wenn Benutzer mit dem Cursor über eine gesperrte Option fahren.
  4. Sie können auch zulassen, dass Benutzer gesperrte Optionen außer Kraft setzen. Sie müssen dann ein Passwort angeben, dass Sie den Benutzern zur Verfügung stellen können.
  5. Klicken Sie auf Speichern, um eine .sldSettings-Datei für die Bereitstellung zu erstellen.
Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Einschließen einer .sldSettings-Datei in SOLIDWORKS Installationen

So schließen Sie eine *.sldSettings-Datei in Ihre Installation ein:

  1. Doppelklicken Sie auf sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner.
  2. Klicken Sie im Administrator-Installationsabbild-Options-Editor auf Einstellungen bearbeiten.
  3. Führen Sie im Abschnitt Client Installationsoptionen folgende Schritte aus:
    1. Klicken Sie auf Exportierte Einstellungsdatei aus SOLIDWORKS Settings Administrator verwenden.
    2. Klicken Sie auf Pfad bearbeiten und navigieren Sie zur Datei *.sldSettings.
    Sie können verschiedene *.sldSettings-Dateien für unterschiedliche Gruppen und Computer verwenden.
  4. Aktivieren und installieren Sie die SOLIDWORKS Software.

Nach der Bereitstellung können Sie Schritt 2 jederzeit zum Ändern einer bestehenden *.sldSettings-Datei wiederholen. Die SOLIDWORKS Software liest die geänderte *.sldSettings-Datei, wenn sie das nächste Mal gestartet wird.

Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Bereitstellung von Installationen über den Options-Editor

Sie können Installationen direkt vom Options-Editor aus bereitstellen, indem Sie entweder die manuelle oder die Push-Methode verwenden.

  • Verwenden Sie im Options-Editor die Seite zur manuellen Bereitstellung, um Benutzern per E-Mail Anweisungen zum Starten der Installation zu senden. Verwenden Sie diese Methode, wenn Benutzer über Administratorrechte für ihre Client-Computer verfügen.
  • Verwenden Sie im Options-Editor die Seite zur automatischen Bereitstellung, um Installationen mittels Push automatisch auf Zielcomputer zu übertragen. Es ist auch eine benutzerdefinierte Deinstallation möglich. Verwenden Sie diese Methode, wenn Benutzer keine Administratorrechte haben, um Software auf ihren Systemen zu installieren.

Um eine der beiden Methoden zu verwenden, müssen Sie das Installationsverzeichnis des Administrator-Installationsabbilds auf ein freigegebenes Windows-Verzeichnis ändern, sodass darauf über ein Netzwerkverzeichnis zugegriffen werden kann (zum Beispiel \\machine\shared_directory, oder das ganze Abbild auf jedem Computer in ein lokales Verzeichnis wie C:\SOLIDWORKS Admin\SOLIDWORKS 2019 SP0 kopieren).

Inhaltsverzeichnis

  • Verwenden eines zugeordneten Laufwerks, um ein Administrator-Installationsabbild bereitzustellen

    Zur Definition eines Netzwerkspeicherorts für das Administrator-Installationsabbildverzeichnis wird ein UNC-Pfad (\\Computername\Freigabename ) empfohlen. Sie können aber auch ein zugeordnetes Laufwerk als Speicherort für die Datei StartSWInstall.hta im Administrator-Installationsabbild verwenden (z. B. U:\StartSWInstall.hta). Voraussetzung ist, dass bei allen Benutzern, die Installationen ausführen, dem Administrator-Installationsabbildverzeichnis der gleiche Laufwerksbuchstabe zugeordnet ist.

  • Verwenden von StartSWInstall.exe zum Bereitstellen eines Administrator-Installationsabbilds

  • Manuelles Bereitstellen

    Verwenden Sie diese Methode, wenn Benutzer die Berechtigungen haben, die erforderlich sind, um auf ihren Systemen Installationen durchzuführen.

  • Voraussetzungen für die automatische Bereitstellung

    Bei der automatischen Bereitstellung werden die Installationsaufgaben per Push-Methode an Zielcomputer übertragen und ohne Benutzereingriff mit dem Microsoft-Taskplaner für jedes System ausgeführt. Verwenden Sie diese Methode, wenn Benutzer keine Administratorrechte haben, um Software auf ihren Systemen zu installieren.

  • Automatisches Bereitstellen

Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Anzeigen und Bearbeiten von Optionseinstellungen
Einstellungsadministrator-Werkzeug
Beenden des Options-Editors
Erstellen einer Desktop-Verknüpfung zum Options-Editor


Verwenden eines zugeordneten Laufwerks, um ein Administrator-Installationsabbild bereitzustellen

Zur Definition eines Netzwerkspeicherorts für das Administrator-Installationsabbildverzeichnis wird ein UNC-Pfad (\\Computername\Freigabename ) empfohlen. Sie können aber auch ein zugeordnetes Laufwerk als Speicherort für die Datei StartSWInstall.hta im Administrator-Installationsabbild verwenden (z. B. U:\StartSWInstall.hta). Voraussetzung ist, dass bei allen Benutzern, die Installationen ausführen, dem Administrator-Installationsabbildverzeichnis der gleiche Laufwerksbuchstabe zugeordnet ist.

Beispiel: Sie haben dem Administrator-Installationsabbildverzeichnis das Laufwerk U: zugeordnet. In diesem Fall wird die Benachrichtigungs-E-Mail die Benutzer anweisen, auf den Link zu file://U:\StartSWIOnstall.hta zu klicken. Die Installation kann nur dann erfolgreich ausgeführt werden, wenn das Laufwerk U: dem UNC-Speicherort für das Administrator-Installationsabbild (\\Computername\Freigabename ) zugeordnet ist.

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Verwenden von StartSWInstall.exe zum Bereitstellen eines Administrator-Installationsabbilds

Sie können ein Administrator-Installationsabbild auf Clients installieren bzw. deinstallieren. Führen Sie dazu den Befehl admin_image_install_dir\ StartSWInstall.exe aus. Diese Methode installiert SOLIDWORKS mit den im Options-Editor des Administrator-Installationsabbilds definierten Optionen, Computern und Gruppen.

Sie können die folgenden Schalter an den Befehl StartSWInstall.exe anfügen:
/install | Installiert das Administrator-Installationsabbild auf Client-Computern.
/uninstall Deinstalliert die Software von Client-Computern, mit zwei optionalen Schaltern:

/removedata

Nur für Deinstallation verfügbar. Entfernt SOLIDWORKS Datendateien und Ordner während der Deinstallation.

/removeregistry

Nur für Deinstallation verfügbar. Entfernt SOLIDWORKS Registrierungseinträge während der Deinstallation.
/showui | Zeigt ein Verlaufsfenster für den SOLIDWORKS Installations-Manager an. Andernfalls ist der SOLIDWORKS Installations-Manager für den Benutzer ausgeblendet.
/now | Startet die Installation oder Deinstallation sofort. Das 5-Minuten-Warndialogfeld wird nicht angezeigt.

StartSWInstall.exe sollte statt StartSWInstall.hta bevorzugt verwendet werden, wenn die Installation ohne Benutzereingriff durchgeführt werden soll, aber keine automatische Bereitstellung über den Options-Editor des Administrator-Installationsabbilds erwünscht ist.

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Manuelles Bereitstellen

Verwenden Sie diese Methode, wenn Benutzer die Berechtigungen haben, die erforderlich sind, um auf ihren Systemen Installationen durchzuführen.

Manuelles Bereitstellen von Installationen per E-Mail:

  1. Klicken Sie im Options-Editor auf Bereitstellen.
    Für jeden Computer werden die Verfügbarkeit und der Status bezüglich der Installation angezeigt.
  2. Klicken Sie auf E-Mail senden.
  3. Geben Sie den Netzwerkpfad zum Administrator-Installationsabbildverzeichnis an.
    In der Regel wird der Verzeichnispfad zum Administrator-Installationsabbildverzeichnis anfänglich als Windows-Dateipfad angezeigt (z. B. C:\SOLIDWORKS Admin\SOLIDWORKS 2019 SP0). Im Dialogfeld wird der Hinweis Dieser Pfad ist kein Netzwerkpfad angezeigt.
    1. Klicken Sie auf Durchsuchen, um den Netzwerkspeicherort für dieses Administrator-Installationsabbildverzeichnis anzugeben.
    2. Navigieren Sie zu dem Computer, auf dem das Administrator-Installationsabbild installiert ist, und wählen Sie das freigegebene Windows-Verzeichnis aus, das für das Administrator-Installationsabbild-Verzeichnis festgelegt ist.
      Navigieren Sie nicht in Unterverzeichnisse des Administrator-Installationsabbild-Verzeichnisses (z. B. in die Unterverzeichnisse 64bit).
    3. Klicken Sie auf OK.
      Im Dialogfeld wird nun der Hinweis Dieser Pfad ist ein Netzwerkpfad angezeigt.
    Es wird eine E-Mail erstellt, die den Eigentümer des Computers anleitet, wie aus dem Administrator-Installationsabbild installiert wird, und zwar unter Verwendung des Netzwerkspeicherorts für die Datei StartSWInstall.hta im Administrator-Installationsabbild.
  4. Senden Sie die E-Mail an die Benutzer, die für die SOLIDWORKS-Installation verantwortlich sind.

Benutzer können in der E-Mail auf den Link zum Netzwerkspeicherort für StartSWInstall.hta klicken, um SOLIDWORKS aus dem Administrator-Installationsabbild zu installieren.

Im Options-Editor zeigt Installationsstatus Folgendes an:
Noch nicht erledigt | Der Benutzer hat die Installation noch nicht auf dem betreffenden Computer durchgeführt.
Erfolgreich | Der Benutzer hat die Installation erfolgreich auf dem betreffenden Computer ausgeführt.
Fehlgeschlagen | Der Benutzer hat versucht, die Installation auf dem betreffenden Computer auszuführen, sie ist jedoch fehlgeschlagen.

Andere Statusmeldungen, die erscheinen könnten, sind: "Erfolgreich installiert", "Erfolgreich deinstalliert", "Installieren", "Deinstallieren", "Neustart erforderlich", "Installation fehlgeschlagen" und "Deinstallation fehlgeschlagen".

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Voraussetzungen für die automatische Bereitstellung

Bei der automatischen Bereitstellung werden die Installationsaufgaben per Push-Methode an Zielcomputer übertragen und ohne Benutzereingriff mit dem Microsoft-Taskplaner für jedes System ausgeführt. Verwenden Sie diese Methode, wenn Benutzer keine Administratorrechte haben, um Software auf ihren Systemen zu installieren.

Bei der Installation per Push-Methode startet der Taskplaner den SOLIDWORKS Installations-Manager mit den vom Administrator angegebenen Anmeldeinformationen. Der Taskplaner wird auf dem LocalSystem-Konto des Computers ausführt. Dieses Konto wird auf dem Netzwerk als Sicherheitsprinzip des Computers ausgeführt. Dieses Sicherheitsprinzip muss über Lesezugriff auf den freigegebenen Ordner verfügen, in dem sich das Administrator-Installationsabbild befindet.

Wählen Sie beim Hinzufügen eines Computers zu einer Gruppe eines freigegebenen Ordners in Active Directory die Option Objekttypen aus und stellen Sie sicher, dass Computer ausgewählt ist.

Der Computer mit dem Administrator-Installationsabbild und die Client-Zielcomputer müssen darüber hinaus Mitglieder derselben Microsoft Active Directory-Domäne sein.

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Automatisches Bereitstellen

Automatisches Bereitstellen durch Übertragung von Installationen mittels Push auf Benutzersysteme:

  1. Klicken Sie im Options-Editor auf die Registerkarte Automatisch bereitstellen.
    Für jeden Computer werden die Verfügbarkeit und der Status bezüglich der Installation angezeigt.
  2. Wählen Sie unter der Spalte Bereitstellen die Client-Zielcomputer und die Gruppen in der Spalte Bereitstellen aus.
    Wählen Sie eine(n) oder mehrere Computer oder Gruppen unter der Spalte Bereitstellen aus, bevor Sie den Bereitstellungsprozess starten.
  3. Wählen Sie unter Install Time (Installationszeitpunkt) die Option Jetzt aus, um sofort bereitzustellen, oder Später, um ein bestimmtes Datum und eine Uhrzeit für die Bereitstellung festzulegen.
  4. Wählen Sie unter Client-Optionen Folgendes aus:
    • SOLIDWORKS 2019 installieren oder aktualisieren
    • SOLIDWORKS 2019 deinstallieren
      Wenn Sie sich für eine Deinstallation entscheiden, können Sie angeben, ob Registrierungseinträge sowie Datendateien und -ordner zusammen mit den Programmdateien und -ordnern deinstalliert werden sollen.
  5. Wählen Sie Computer automatisch neu starten aus, wenn mindestens ein Zielrechner während oder nach der Bereitstellung bei Bedarf neu gestartet werden soll.
  6. Geben Sie die Clientanmeldeinformationen von mindestens einem Zielrechner ein.
  7. Klicken Sie auf Bereitstellen, um den Bereitstellungsprozess zu starten.
Im Options-Editor lautet der Installationsstatus wie folgt:
Noch nicht erledigt | Die Installation wurde noch nicht auf dem betreffenden Computer ausgeführt.
Erfolgreich | Die Installation wurde erfolgreich auf dem betreffenden Computer ausgeführt.
Fehlgeschlagen | Die Installation auf dem betreffenden Computer ist fehlgeschlagen.

Andere Statusmeldungen, die erscheinen könnten, sind: "Erfolgreich installiert", "Erfolgreich deinstalliert", "Planung", "Verbindung", "Installieren", "Deinstallieren", "Neustart erforderlich", "Installation geplant", "Deinstallation geplant", "Installation fehlgeschlagen", "Deinstallation fehlgeschlagen", "Verbindung fehlgeschlagen" und "Planung fehlgeschlagen".

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Beenden des Options-Editors

Sie können auf OK oder "Schließen" klicken, um den Options-Editor zu beenden.

Klicken Sie auf OK, Schließen, oder verwenden Sie die Schaltfläche "Schließen" der Windows-Anwendung, um Änderungen zu übernehmen, und beenden Sie den Options-Editor.
  • Klicken Sie auf OK, um die Optionseinstellungsänderungen zu übernehmen, und beenden Sie den Options-Editor.
  • Klicken Sie auf Schließen, um den Options-Editor zu schließen.

    Wenn Änderungen vorgenommen wurden, werden Sie gefragt, ob Sie diese Änderungen speichern möchten.

  • Klicken Sie auf die Schließ-Schaltfläche (X) der Windows-Anwendung. Wenn Änderungen vorgenommen wurden, werden Sie gefragt, ob Sie diese Änderungen speichern möchten.
Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Anzeigen und Bearbeiten von Optionseinstellungen
Einstellungsadministrator-Werkzeug
Bereitstellung von Installationen über den Options-Editor
Erstellen einer Desktop-Verknüpfung zum Options-Editor


Erstellen einer Desktop-Verknüpfung zum Options-Editor

Sie können eine Windows-Desktop-Verknüpfung zum Options-Editor für ein bestimmtes Administrator-Installationsabbild erstellen, und von der Anwendung aus.

  1. Starten Sie den Options-Editor.
    Beispiel: Im Windows Explorer navigieren Sie zum Administrator-Installationsabbildverzeichnis und doppelklicken auf sldAdminOptionEditor.exe.
  2. Klicken Sie auf Desktop-Verknüpfung zu diesem Options-Editor erstellen.
    Es wird dann eine Verknüpfung zum Options-Editor für das Administrator-Installationsabbild auf dem Windows-Desktop angezeigt.
Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Anzeigen und Bearbeiten von Optionseinstellungen
Einstellungsadministrator-Werkzeug
Bereitstellung von Installationen über den Options-Editor
Beenden des Options-Editors


Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen

Sobald Sie ein freigegebenes Administrator-Installationsabbild-Verzeichnis erstellt haben, können Sie Clients über E-Mail benachrichtigen.

Konfigurieren Sie das auf einem Computer freigegebene Administrator-Installationsabbild-Verzeichnis und auf den andere Computer zugreifen können auf einem Computer (z.B., über einen UNC-Pfad).

Sie können eine E-Mail mit einem Link auf admin_image_install_dir\StartSWInstall.hta an alle Clients schicken. Die Clients können dann auf diesen Link klicken und dann auf SOLIDWORKS Produkte jetzt installieren klicken, um die Installation vom Administrator-Installationsabbild aus zu starten.

Wenn Sie ein Administrator-Installationsabbild auf eine neue SOLIDWORKS Version aktualisieren, können Sie den Administrator-Installationsabbildbereich konfigurieren und Eigenschaften freigeben, sodass Clients, die früher mit diesem Abbild installiert haben, automatisch aktualisiert werden. Einzelheiten dazu finden Sie unter Aktualisierung von Clients von Administrator-Installationsabbildern.
Übergeordnetes Thema Mehrere Installationen
Bereitstellung für mehrere Clients
Administrator-Installationsabbilder verwenden
Befehlszeilenbereitstellung
Verwaltung von mehreren Installationen
Aktualisierung von Clients von Administrator-Installationsabbildern


Befehlszeilenbereitstellung

Sie können mittels einer Eingabeaufforderung oder Stapeldatei (stille Installation) ein Administrator-Installationsabbild automatisch aktivieren.

Zum Bereitstellen eines Administrator-Installationsabbilds mit der Befehlszeile für SOLIDWORKS PDM Clients, siehe die SOLIDWORKS PDM Installationsanleitung.

Inhaltsverzeichnis

  • Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus

    Nach der Erstellung des Administrator-Installationsabbildes und vor der Benachrichtung der Clients müssen Sie Microsoft Windows Komponenten installieren, die nicht mit dem Administrator-Installationsabbild über die Befehlzeile oder das Microsoft Active Directory installiert werden können.

  • Mit der Befehlszeile aus dem Administrator-Abbild installieren

    Sie können über die Befehlszeile Installationen von einem Administrator-Installationsabbild verwenden.

  • Befehlszeileneigenschaften

    Befehlszeileneigenschaften beschreiben hier die Feature-Eigenschaften, globalen Eigenschaften, produktspezifischen Eigenschaften und die Windows Konventionen in Bezug auf Standorte.

  • Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren

    Die Bereitstellung über Microsoft Active Directory wird für die Bereitstellung der SOLIDWORKS Kernprodukte an Clients unterstützt.

  • Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren

    Befolgen Sie diese Anleitungen, um ein bestehendes Administrator-Installationsabbild vorzubereiten, das SOLIDWORKS auf Client-Computern mittels Microsoft Windows Active Directory installiert.

Übergeordnetes Thema Mehrere Installationen
Bereitstellung für mehrere Clients
Administrator-Installationsabbilder verwenden
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen
Verwaltung von mehreren Installationen


Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus

Nach der Erstellung des Administrator-Installationsabbildes und vor der Benachrichtung der Clients müssen Sie Microsoft Windows Komponenten installieren, die nicht mit dem Administrator-Installationsabbild über die Befehlzeile oder das Microsoft Active Directory installiert werden können.

Die manuelle Installation dieser Windows-Komponenten ist nur dann erforderlich, wenn Sie von einem Administrator-Installationsabbild installieren, das über die Befehlszeile oder über Microsoft Active Directory erstellt wurde. Wenn Sie den SOLIDWORKS Installations-Manager für die Erstellung und Installation eines Administrator-Installationsabbilds verwenden, werden diese Windows-Komponenten automatisch installiert.
Hier ist eine Zusammenfassung der Dateien, die von SOLIDWORKS für die Windows-Komponenten erforderlich sind:
Windows Performance Toolkit: |
Visual C++ 2008, 2010, 2012, 2013 und 2015 Redistributable Package | Enthält die Laufzeit-Komponenten für Microsoft Visual C++. Die Versionen 2008, 2010, 2012, 2013 und 2015 müssen installiert sein.
Visual Basic for Applications 7.1 | Bietet Unterstützung für Visual Basic Makros.
Visual Studio Tools for Application 2005 | Umfasst ein Tool-Set zur Unterstützung von Visual Studio 2005-Anwendungen. Ab SOLIDWORKS 2013 ist das Installieren von Microsoft Visual Studio Tools for Applications (VSTA) optional. VSTA 2005 ist davon abhängig, dass Microsoft .NET Framework 3.5 auf Ihrem Computer installiert ist. Bei Windows 7 und höher ist .NET Framework eine Komponente des Betriebssystems. Wenn Sie .NET Framework 3.5 installieren müssen, steht es auf Ihren Windows Datenträgern und im Internet zur Verfügung. Wenn Sie Ihre Windows-Datenträger nicht finden können, keine Internetverbindung besitzen oder keine Berechtigung dazu haben, Microsoft .NET Framework 3.5 auf Ihrem Computer zu installieren, wenden Sie sich an Ihren Administrator.
Visual Studio Tools for Application 2015 | Optional. Umfasst ein Tool-Set zur Unterstützung von Visual Studio 2015-Anwendungen.
Visual Studio Remote Debugger | Bietet eine Debugging-Umgebung für 64-Bit-Betriebssysteme.
.NET Framework 4.6.2 | Enthält die gemeinsamen Sprach-Laufzeit- und .NET Framework-Komponenten, die für die Ausführung von .NET Framework 4.6.2-Anwendungen erforderlich sind.
Bonjour-Service für Windows | Bietet die Fähigkeit, Dienste in einem lokalen Netzwerk zu entdecken.
Visual C++ Redistributable Package und .NET Framework 4.6.2 sind nicht nur für die SOLIDWORKS Kernprodukte, sondern für alle SOLIDWORKS Produkte erforderlich.

Diese Komponenten müssen in die Unterverzeichnisse des Administrator-Installationsabbild-Verzeichnisses mit einbezogen sein.

Die folgenden Tabellen listen die spezifischen Dateien auf, die für die unterstützten Betriebssysteme erforderlich sind.
Betriebssystem: Windows Server 2016 64-Bit und Windows Server 2019 64-Bit
Betriebssystem: Windows Server 2012 R2 64-Bit
Die Installation unter Windows Server 2012 R2, 2016 und 2019 wird für SOLIDWORKS PDM Server und SOLIDWORKS SolidNetWork License Manager unterstützt.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2012 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2013 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2015 Redistributable Package: | vc_redist_x86.exe vc_redist_x64.exe Beide müssen installiert sein.
Visual Studio Tools for Applications 2005: (optional) | vsta_aide.msi
Wenn VSTA 2005 installiert wird, ist .NET 3.5 Framework (dotnetfx35.exe) erforderlich. Bei Windows 7 ist .NET Framework 3.5 eine Komponente des Betriebssystems.
Visual Studio Tools for Applications 2015 (optional): | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Mit optionalem Sprachpaket.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Bonjour-Service für Windows: | bonjour64.msi
Die Installation unter Windows Server 2012 R2 wird für SOLIDWORKS PDM Server und SOLIDWORKS SolidNetWork License Manager unterstützt.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2012 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2013 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2015 Redistributable Package: | vc_redist_x86.exe vc_redist_x64.exe Beide müssen installiert sein.
Visual Studio Tools for Applications 2005: (optional) | vsta_aide.msi
Wenn VSTA 2005 installiert wird, ist .NET 3.5 Framework (dotnetfx35.exe) erforderlich. Bei Windows 7 ist .NET Framework 3.5 eine Komponente des Betriebssystems.
Visual Studio Tools for Applications 2015 (optional): | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Mit optionalem Sprachpaket.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Bonjour-Service für Windows: | bonjour64.msi
Betriebssystem: Windows 7 64-Bit
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2012 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2013 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2015 Redistributable Package: | vc_redist_x86.exe vc_redist_x64.exe Beide müssen installiert sein.
Visual Studio Tools for Applications: (optional) | vsta_aide.msi
Wenn VSTA 2005 installiert wird, ist .NET 3.5 Framework (dotnetfx35.exe) erforderlich. Bei Windows 7 ist .NET Framework 3.5 eine Komponente des Betriebssystems.
Visual Studio Tools for Applications 2015: (optional) | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Mit optionalem Sprachpaket.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Bonjour-Service für Windows: | bonjour64.msi
Betriebssystem: Windows 10 64 Bit
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2008 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2010 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2012 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2013 Redistributable Package: | vcredist_x86.exe vcredist_x64.exe Beide müssen installiert sein.
Visual C++ 2015 Redistributable Package: | vc_redist_x86.exe vc_redist_x64.exe Beide müssen installiert sein.
Visual Studio Tools for Applications 2005: (optional) | vsta_aide.msi
Wenn VSTA 2005 installiert wird, ist .NET 3.5 Framework (dotnetfx35.exe) erforderlich. Bei Windows 7 ist .NET Framework 3.5 eine Komponente des Betriebssystems.
Visual Studio Tools for Applications 2015: (optional) | vsta_setup.exe
Visual Studio Remote Debugger: | rdbgexp.msi
Visual Basic 7.1: | vba71_1033.msi Mit optionalem Sprachpaket.
.NET Framework 4.6.2: | .NET 4.6.2 ist Teil des Betriebssystems, das diese Anforderung erfüllt.
Bonjour-Service für Windows: | bonjour64.msi

Inhaltsverzeichnis

  • Windows-Voraussetzungen von der Befehlszeile auf 64-Bit-Betriebssystemen installieren

    Befolgen Sie diese Anleitungen, um die Windows-Voraussetzungen für Administrator-Installationsabbilder mit der Befehlszeile unter 64-Bit-Versionen von Windows zu installieren.

Übergeordnetes Thema Befehlszeilenbereitstellung
Mit der Befehlszeile aus dem Administrator-Abbild installieren
Befehlszeileneigenschaften
Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren
Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren


Windows-Voraussetzungen von der Befehlszeile auf 64-Bit-Betriebssystemen installieren

Befolgen Sie diese Anleitungen, um die Windows-Voraussetzungen für Administrator-Installationsabbilder mit der Befehlszeile unter 64-Bit-Versionen von Windows zu installieren.

Um mehrere Komponenten in einer Installationsoperation zu installieren, erstellen Sie eine Stapeldatei mit den Befehlen, die in den folgenden Vorgehensweisen genannt werden und verwenden Sie sie, um die Komponenten den Client-Computern zuzuweisen.

  1. Stellen Sie sicher, dass der Ziel-Computer über mindestens 620 MB freien Speicherplatz und ein gültiges TEMP-Verzeichnis verfügt.
  2. Installieren Sie Visual C++ VERSION Redistributable Package.
    Installieren Sie das Paket für VERSION = 2008, 2010, 2012, 2013 und 2015.
    Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_VERSION_Redistributable_(x64)\vcredist_x64.exe /Q

    Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_VERSION_Redistributable\vcredist_x86.exe /Q

    Sie müssen sowohl die 32-Bit- als auch die 64-Bit-Version dieses Pakets installieren.

    Installieren Sie z. B. Visual C++ 2008 Redistributable Package wie folgt:

    • Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q
    • Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q
  3. Installieren Sie Microsoft .NET Framework 4.6.2:
    Administrator_Installationsabbild_Verzeichnis\.Net_Framework_4.6.2\NDP462-KB3151800-x86-x64-AllOS-ENU.exe
  4. Installieren Sie Visual Studio Tools for Applications 2015:
    Administrator_Installationsabbild_Verzeichnis\Microsoft_VSTA\vsta_setup.exe
  5. Visual Studio Remote Debugger installieren:
    Administrator_Installationsabbild_Verzeichnis\VSRemoteDebugger\install.exe /Q
  6. Installieren Sie Visual Basic 7.1:
    Administrator_Installationsabbild_VerzeichnisMicrosoft_VBA\vba71.msi und Administrator_Installationsabbild_Verzeichnis\Microsoft_VBA\vba71_1033.msi sind für alle Sprachen erforderlich.
    Nur die 64-Bit-Version dieses Pakets muss installiert werden.

    Installieren Sie außerdem das folgende Paket für die gewünschte Sprache:

    vba71_1028.msi | Chinesisch
    vba71_1031.msi | Deutsch
    vba71_1036.msi | Französisch
    vba71_1040.msi | Italienisch
    vba71_1041.msi | Japanisch
    vba71_1042.msi | Koreanisch
    vba71_1046.msi | Portugiesisch (Brasilianisch)
    vba71_2052.msi | Chinesisch - vereinfacht
    vba71_3082.msi | Spanisch
    Englisch, Tschechisch, Polnisch, Russisch und Türkisch erfordern keine zusätzlichen Sprachpakete.
    Ab SOLIDWORKS 2013 Service Pack 2.0 müssen Sie eine zusätzliche Grundanforderung installieren: Msiexec.exe /p vba71-kb27832-x64.msp
  7. Installieren Sie den Bonjour-Service für Windows:
    Administrator_Installationsabbild_Verzeichnis\Bonjour\Bonjour64.msi
Übergeordnetes Thema Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus


Mit der Befehlszeile aus dem Administrator-Abbild installieren

Sie können über die Befehlszeile Installationen von einem Administrator-Installationsabbild verwenden.

Still installieren:

  1. Öffnen Sie ein Eingabeaufforderungsfenster (klicken Sie in Windows auf Start > Ausführen.
  2. Geben Sie in das Fenster den Befehl msiexec.exe mit den Schaltern /i und /qb ein und legen Sie die Eigenschaften für alle Optionen, die keine Standardwerte sind, wie unten gezeigt fest.

    msiexec /i "64-bit_admin_image_path\SOLIDWORKS Explorer\SOLIDWORKS Explorer.msi" INSTALLDIR="C:\Programme\Ihr_Ordner /qb

Die einzelnen Installations-Komponenten-Befehlszeilen-Eigenschaften sind:
  • Befehlszeilen-Feature-Eigenschaften
  • Befehlszeile - Globale Eigenschaften
  • eDrawings Befehlszeileneigenschaften
  • SOLIDWORKS Flow Simulation Befehlszeileneigenschaften

Verwenden Sie die folgenden Beispiele als Vorlagen für eine stille Installation.

SOLIDWORKS Client

  • SOLIDWORKS-Kernprodukt (Englisch)
  • Zusatzanwendung Toolbox
  • Teilnahme am Feedback-Programm
  • Sprache Französisch

SOLIDWORKS:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

Die SOLIDWORKS-Installationskomponente für Französisch muss separat installiert werden:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS French\french.msi" /qb

Bei der Festlegung von SOLIDWORKS-Sprach-Komponenten-Installationsbefehlen dürfen keine Befehlszeilenargumente verwendet werden.

eDrawings Client

  • Leistungsprotokoll
  • Alle Features

msiexec /i "Administrator-Installationsabbild-Pfad\eDrawings\eDrawings.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Electrical

Aufgrund der technischen Komplexität der Installation von SOLIDWORKS Electrical mit Microsoft SQL Server sind in der Dokumentation keine Beispiel-Befehlszeilen für SOLIDWORKS Electrical enthalten.

SOLIDWORKS PCB

msiexec /i "admin_image_path\SOLIDWORKS PCB.msi" ACTIVSERIALNUMBER="1234123412341234ABCDEFGH" INSTALLDIR="C:\Programme\SOLIDWORKS Corp\SOLIDWORKS PCB" /qb

SOLIDWORKS Visualize und Visualize Boost

Für SOLIDWORKS Visualize:

msiexec. /i "admin_image_path\SOLIDWORKS Visualize.msi" ACTIVSERIALNUMBER="1234123412341234ABCDEFGH" INSTALLDIR="C:\Programme\SOLIDWORKS Corp\SOLIDWORKS Visualize" /qb

Für SOLIDWORKS Visualize:

msiexec /i "admin_image_path\SOLIDWORKS Visualize Boost.msi" ACTVISERIALNUMBER="1234123412341234ABCDEFGH" INSTALLDIR="C:\Programme\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost" /qb

Übergeordnetes Thema Befehlszeilenbereitstellung
Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus
Befehlszeileneigenschaften
Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren
Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren


Befehlszeileneigenschaften

Befehlszeileneigenschaften beschreiben hier die Feature-Eigenschaften, globalen Eigenschaften, produktspezifischen Eigenschaften und die Windows Konventionen in Bezug auf Standorte.

Inhaltsverzeichnis

  • Befehlszeilen-Feature-Eigenschaften

    Die SOLIDWORKS-Installation unterstützt diese ADDLOCAL-Eigenschaften für die Befehlszeilenanwendung.

  • Befehlszeile - Globale Eigenschaften

    Jede Eigenschaft gilt sowohl für eine Administrator- als auch eine Einzelinstallation, wenn nicht anders angegeben. Seriennummern können an Administrator-Installationen und an Einzelinstallationen unter Verwendung der globalen Eigenschaften übergeben werden.

  • eDrawings Befehlszeileneigenschaften

    Diese Befehlszeileneigenschaften sind spezifisch für eDrawings ®.

  • Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player

    Diese Befehlszeileneigenschaften gelten speziell für SOLIDWORKS Composer und SOLIDWORKS Composer Player.

  • SOLIDWORKS Flow Simulation Befehlszeileneigenschaften

    Diese Befehlszeileneigenschaften sind spezifisch für SOLIDWORKS Explorer Flow Simulation.

  • SOLIDWORKS Inspection Befehlszeileneigenschaften

    Diese Befehlszeileneigenschaften sind spezifisch für SOLIDWORKS Inspection.

  • SOLIDWORKS Visualize Befehlszeileneigenschaften

    Diese Befehlszeileneigenschaften sind für SOLIDWORKS Visualize spezifisch.

  • MSI Dateipositionen für Administrator-Installationsabbilder

    Um Administrator-Installationsabbilder von der Befehlszeile aus erstellen zu können, sind die .msi Dateien der Produktkomponente an folgenden Positionen auf dem SOLIDWORKS Medium abgelegt.

Übergeordnetes Thema Befehlszeilenbereitstellung
Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus
Mit der Befehlszeile aus dem Administrator-Abbild installieren
Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren
Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren


Befehlszeilen-Feature-Eigenschaften

Die SOLIDWORKS-Installation unterstützt diese ADDLOCAL-Eigenschaften für die Befehlszeilenanwendung.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorks Costing
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • VSTA
Wenn Eigenschaften für die Befehlszeilen-Installation angegeben werden:
  • SOLIDWORKS unterstützt nicht die Produktinstallation unter Verwendung der Option ADDSOURCE.
  • Bei den Eigenschaften muss die Groß- und Kleinschreibung beachtet werden. Die Befehle dürfen keine Leerzeichen oder Bindestriche enthalten und müssen durch Kommas getrennt sein.

    SolidWorks muss unter Verwendung der Kleinschreibung unter den ADDLOCAL-Eigenschaften angegeben werden, damit die Anwendung korrekt installiert wird.

Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


Befehlszeile - Globale Eigenschaften

Jede Eigenschaft gilt sowohl für eine Administrator- als auch eine Einzelinstallation, wenn nicht anders angegeben. Seriennummern können an Administrator-Installationen und an Einzelinstallationen unter Verwendung der globalen Eigenschaften übergeben werden.

Eigenschaft | Beschreibung
ENABLEPERFORMANCE Legt fest, ob die Anwendung Leistungsdaten automatisch an die SOLIDWORKS Corporation senden soll.

1

Leistungsdaten senden.

0

Keine Leistungsdaten senden.
INSTALLDIR Installationsordner für SOLIDWORKS.

Nur Einzelinstallationen.
MBDSERIALNUMBER | Seriennummer für das modellbasierte SOLIDWORKS Definitionsprodukt.
MOTIONSERIALNUMBER | Seriennummer für das SOLIDWORKS Motion Produkt.
OFFICEOPTION Festlegen des zu installierenden Produktpakets.
0 | SOLIDWORKS Client
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
REINSTALL Geben Sie ALL an, um alle derzeit installierten Funktionen zu aktualisieren.
Geben Sie diese Eigenschaft nur an, wenn auf eine Service Pack-Version innerhalb einer vorhandenen Hauptversion aktualisiert wird (z. B. Update einer vorhandenen SOLIDWORKS 2019 SP01-Installation auf SOLIDWORKS 2019 SP02).
REINSTALLMODE Microsoft Installationsprogramm-Neuinstallationsoptionen.

Beispiel: Wenn eine Installation von einer Service Pack-Version auf eine andere innerhalb derselben Hauptversion aktualisiert wird, müssen Sie REINSTALLMODE=vomus angeben.

Details zu den REINSTALLMODE-Einstellungen finden Sie in der Windows-Installationsprogramm-Dokumentation unter www.microsoft.com.

Geben Sie diese Eigenschaft nur an, wenn auf eine Service Pack-Version innerhalb einer vorhandenen Hauptversion aktualisiert wird (z. B. Update einer vorhandenen SOLIDWORKS 2019 SP01-Installation auf SOLIDWORKS 2019 SP02). Geben Sie diese Eigenschaft nicht an, wenn Sie zum ersten Mal eine neue Hauptversion von SOLIDWORKS installieren.
SERVERLIST SolidNetWork Server-Liste.
Die SolidNetWork Serverliste ist eine kommagetrennte Liste von Zeichenketten. Jeder String bezieht sich auf eine Portnummer auf einem Server im Format:
  • Triade (kommagetrennt) =xxxxx@Servername1,yyyyy@Servername2,zzzzz@Servername3
  • Nichttriade (durch Semikolons getrennt) = xxxxx@Servername1;yyyyy@Servername2;zzzzz@Servername3
S und Y sind Einzelziffern. Setzen Sie kein Trennzeichen nach dem letzten in der Liste aufgeführten Server.

Nur Einzelinstallationen.
SIMULATIONSERIALNUMBER | Seriennummer für das SOLIDWORKS Simulation Produkt
SOLIDWORKSSERIALNUMBER | Seriennummer für das SOLIDWORKS Produkt, das alle Zusatzanwendungen enthält.
SWMIGRATE Zu aktualisierende SOLIDWORKS Version, wie diese in der Liste im Dialogfeld SOLIDWORKS Installationsauswahl angezeigt wird. Beispiel:

SWMIGRATE="SOLIDWORKS 2019 x64 Edition SP01"

Geben Sie diese Eigenschaft nur an, wenn Sie eine neue Hauptversion installieren und schon eine ältere Hauptversion installiert ist. Geben Sie diese Eigenschaft nicht an, wenn Sie von einer Service Pack-Version auf eine andere Version innerhalb derselben Hauptversion aktualisieren.
TOOLBOXFOLDER Installationsordner für SOLIDWORKS Toolbox Dateien.

Nur Einzelinstallationen.

Beispiel: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"
TRANSFORMS Enthält sprachspezifische Elemente in der Form:
TRANSFORMS Zahl.mst
  • Chinese (1028)
  • Chinese-Simplified (2052)
  • Czech (1029)
  • English (1033)
  • French (1036)
  • German (1031)
  • Italian (1040)
  • Japanese (1041)
  • Korean (1042)
  • Polish (1045)
  • Portuguese-Brazilian (1046)
  • Russian (1049)
  • Spanish (1034)
  • Turkish (1055)
UPGRADESWINSTALL
Legt fest, ob eine bestehende SOLIDWORKS Version auf die aktuelle Version aufgerüstet werden soll.
0 | Neue Installation, nicht aktualisieren.
1 | Aktualisieren

Nur Einzelinstallationen.

Geben Sie diese Eigenschaft nur an, wenn Sie eine neue Hauptversion installieren und schon eine ältere Hauptversion installiert ist. Geben Sie diese Eigenschaft nicht an, wenn Sie innerhalb derselben Hauptversion von einer Service Pack-Version auf eine andere Version aktualisieren.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


eDrawings Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind spezifisch für eDrawings ®.

Eigenschaft | Beschreibung
ADDLOCAL Definiert die zu installierenden Komponenten der eDrawings Anwendung.
Alle ist die empfohlene Option.
Befehlszeilensyntax | Feature
Alle | Installiert alle Komponenten. Die eDrawings Anwendung sucht nach installierten SOLIDWORKS und AutoCAD Publisher Anwendungen, um die Installation zu bestätigen.
CALS | Öffnen von CAL-Dateien im eDrawings Viewer.
Inventor | Erstellen von eDrawings Dateien aus der Autodesk Inventor Anwendung.
eDrawingsViewer | Öffnen von eDrawings und anderer Dateien.
ProE | Öffnen von ProE-Dateien im eDrawings Viewer.
DXFDWGTranslator | Anzeige von DXF/DWG-Dateien im eDrawings Viewer.
Tastenkombinationen | Installation von Desktop-Verknüpfungen.
XML3D | Öffnen von 3DXML-Dateien im eDrawings-Viewer.
INSTALLDIR | Legt den Installationsordner für eDrawings fest.
LOGPERFORMANCE Legt fest, ob die Anwendung Leistungsdaten automatisch per E-Mail an die SOLIDWORKS Corporation senden soll.
1 | Leistungsdaten senden
0 | Anderes
SNLSERVER Geben Sie Anschluss@Servernamen für Ihren SolidNetWork License Server ein. Verwenden Sie Semikolons zum Trennen mehrerer Anschluss@Servernamen Kombinationen.

Ein Anschluss-Server-Name für SNLSERVER ist nur für die SOLIDWORKS SNL-Server-Konfiguration erforderlich. Liste_von_Anschluss@Server_Zeichenketten ist eine Liste von Zeichenketten, die durch Semikolons trennt sind. Jede Zeichenkette bezieht sich auf eine Anschlussnummer auf dem Server im Format:

xxxxx@Servername1; yyyyy@Servername2;

wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player

Diese Befehlszeileneigenschaften gelten speziell für SOLIDWORKS Composer und SOLIDWORKS Composer Player.

Für SOLIDWORKS Composer:

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER | SOLIDWORKS Composer Seriennummer.
ACTIVSERIALNUMBERPLAYERPRO | Optional. SOLIDWORKS Composer Player Pro Seriennummer.
ADDLOCAL Wenn Sie die vollständige Anwendung installieren, brauchen Sie die folgenden Elemente nicht anzugeben.
Erforderlich:
  • Lizenzierung
  • Eula
  • Interops
  • LicenseSupportFiles
  • Plugins
  • SWComposerCommon
  • SWPlayer
Optional:
  • Sync3Dvia
INSTALLDIR | Legt den Installationsordner für die SOLIDWORKS Composer Software fest.

Für SOLIDWORKS Composer Player:

Eigenschaft | Beschreibung
ACTIVSERIALNUMBERPLAYERPRO | Optional. SOLIDWORKS Composer Player Pro Seriennummer.
INSTALLDIR | Legt den Installationsordner für die SOLIDWORKS Composer Player Software fest.
Bei Rechnern, auf denen SOLIDWORKS nicht installiert ist, müssen Sie SOLIDWORKS Translator zum Importieren von SOLIDWORKS Dateien in SOLIDWORKS Composer verwenden. Für die Bereitstellung von SOLIDWORKS Translator müssen Sie den SOLIDWORKS Installations-Manager verwenden. Die Befehlszeile kann nicht verwendet werden.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


SOLIDWORKS Flow Simulation Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind spezifisch für SOLIDWORKS Explorer Flow Simulation.

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER Separate SOLIDWORKS Flow Simulation Seriennummer

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
CWUPGRADEINSTALL Aktualisiert eine bestehende Version einer bestimmten SOLIDWORKS Flow Simulation Anwendungs-Software.
1 | Aktualisieren
2 | Neue Installation; Installation in ein neues Verzeichnis

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
INSTALLDIR Legt die Installation für eine bestimmte SOLIDWORKS Flow Simulation Anwendungs-Software fest.

(Nur Einzelinstallationen)
SERVERLISTE | Liste von Strings (Zeichenketten), die durch Semikolons getrennt sind. Jeder String bezieht sich auf eine Anschlussnummer auf dem Server im Format: xxxxx@Server_Name1; yyyyy@Server_Name2;& wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
SOLIDWORKSPATH Gibt den Installationsordner der SOLIDWORKS Software an.

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


SOLIDWORKS Inspection Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind spezifisch für SOLIDWORKS Inspection.

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER | SOLIDWORKS Inspection Seriennummer. (Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
INSTALLDIR | Bestimmt die Installation der SOLIDWORKS Inspection Anwendungssoftware. (Nur Einzelinstallationen)
SERVERLISTE | Liste von Strings (Zeichenketten), die durch Semikolons getrennt sind. Jeder String bezieht sich auf eine Anschlussnummer auf dem Server im Format: xxxxx@Server_Name1; yyyyy@Server_Name2;& wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


SOLIDWORKS Visualize Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind für SOLIDWORKS Visualize spezifisch.

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER | SOLIDWORKS Visualize Seriennummer (Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
INSTALLDIR | Bestimmt die Installation der SOLIDWORKS Visualize Anwendungssoftware. (Nur Einzelinstallationen)
SERVERLISTE | Liste von Strings (Zeichenketten), die durch Semikolons getrennt sind. Jeder String bezieht sich auf eine Anschlussnummer auf dem Server im Format: xxxxx@Server_Name1; yyyyy@Server_Name2;& wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


MSI Dateipositionen für Administrator-Installationsabbilder

Um Administrator-Installationsabbilder von der Befehlszeile aus erstellen zu können, sind die .msi Dateien der Produktkomponente an folgenden Positionen auf dem SOLIDWORKS Medium abgelegt.

SOLIDWORKS (Kernprodukt, Englisch)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (Komponenten nicht auf Englisch)

Traditionelles Chinesisch | swwi\lang\chinese\chinese.msi
Vereinfachtes Chinesisch | swwi\lang\chinese-simplified\chinese-simplified.msi
Tschechisch | swwi\lang\czech\czech.msi
Französisch | swwi\lang\french\french.msi
Deutsch | swwi\lang\german\german.msi
Italienisch | swwi\lang\italian\italian.msi
Japanisch | swwi\lang\japanese\japanese.msi
Koreanisch | swwi\lang\korean\korean.msi
Polnisch | swwi\lang\polish\polish.msi
Portugiesisch (Brasilianisch) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
Russisch | swwi\lang\russian\russian.msi
Spanisch | swwi\lang\spanish\spanish.msi
Türkisch | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

eDrawings Shaders

eDrawingsShaders\eDrawings.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

PhotoView 360 Network Render

pvnetworkrender\pvnetrender.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS Aktivierungsassistent

swactwizard\Activation Wizard.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

SOLIDWORKS Explorer

swexplorer\SOLIDWORKS Explorer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PCB

PCB\SOLIDWORKS PCB.msi

SOLIDWORKS PDM

SOLIDWORKS PDM-Professional bietet eine API, aber sie ist nur für den Client und nicht in einer .msi- Datei verfügbar. Weitere Informationen finden Sie im API-Handbuch im SOLIDWORKS PDM-Client-Verzeichnis install\API.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften


Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren

Die Bereitstellung über Microsoft Active Directory wird für die Bereitstellung der SOLIDWORKS Kernprodukte an Clients unterstützt.

Microsoft Active Directory ist ein Verzeichnisdienst zur Verwaltung von Clients und Servers in Netzwerkumgebungen. Es vereinfacht die Verwaltung, Migration und Aktivierung.

Informationen zum Installieren von SOLIDWORKS über Microsoft Active Directory erhalten Sie von Ihrem Fachhändler.

Übergeordnetes Thema Befehlszeilenbereitstellung
Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus
Mit der Befehlszeile aus dem Administrator-Abbild installieren
Befehlszeileneigenschaften
Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren


Windows-Installationsvoraussetzungen mit Microsoft Active Directory installieren

Befolgen Sie diese Anleitungen, um ein bestehendes Administrator-Installationsabbild vorzubereiten, das SOLIDWORKS auf Client-Computern mittels Microsoft Windows Active Directory installiert.

  1. Extrahieren und installieren Sie alle Visual C++ Redistributable Package-Installationsdateien.
    1. Visual C++ 2008
      1. Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x: {Zielverzeichnis}
      2. Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2008_Redistributable_(64)\vcredist_x64.exe /x: {Zielverzeichnis}
      3. Erstellen Sie eine Richtlinie für die Installation der weiterverteilbaren Microsoft C++ 2008-Module.
    2. Visual C++ 2010
      1. Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{Zielverzeichnis}
      2. Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{Zielverzeichnis}
      3. Erstellen Sie eine Richtlinie für die Installation der weiterverteilbaren Microsoft C++ 2010-Module.
    3. Visual C++ 2012
      1. Installieren Sie Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2012_Redistributable\vcredist_x86.exe auf einem Testcomputer.
      2. Kopieren Sie diese Ordner in ein Netzverzeichnis (Zielverzeichnis):
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
    4. Visual C++ 2013
      1. Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2013_Redistributable\vcredist_x86.exe /x: {Zielverzeichnis}
      2. Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2013_Redistributable_(64)\vcredist_x64.exe /x: {Zielverzeichnis}
      3. Erstellen Sie eine Richtlinie für die Installation der weiterverteilbaren Microsoft C++ 2013-Module.
    5. Visual C++ 2015
      1. Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2015_Redistributable\vcredist_x86.exe /x: {Zielverzeichnis}
      2. Administrator_Installationsabbild_Verzeichnis\Microsoft_C++_2015_Redistributable_(64)\vcredist_x64.exe /x: {Zielverzeichnis}
      3. Erstellen Sie eine Richtlinie für die Installation der weiterverteilbaren Microsoft C++ 2015-Module.

      1. Erstellen Sie eine Richtlinie für die Installation der folgenden Dateien:
        Der Dateipfad darf keine Leerzeichen enthalten.

        Zielverzeichnis\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        Zielverzeichnis\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      2. Installieren Sie Administrator_Installationsabbild_Verzeichnis\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe auf einem Testcomputer.
      3. Kopieren Sie diese Ordner in ein Netzverzeichnis (Zielverzeichnis):
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      4. Erstellen Sie eine Richtlinie für die Installation der folgenden Dateien:
        Der Dateipfad darf keine Leerzeichen enthalten.

        Zielverzeichnis\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Zielverzeichnis\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Zielverzeichnis\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. Installieren Sie Microsoft .NET Framework 4.6.2:
    SOLIDWORKS empfiehlt, dass Sie unter Verwendung von Windows Updates Services (WSUS) oder eines ähnlichen Dienstes .NET Framework 4.6.2 installieren.
  3. Installieren Sie den Visual Studio Remote Debugger (64-Bit-Versionen nur, wenn .NET Framework 3.5 auf dem Computer installiert ist), indem Sie diese Richtlinie erstellen:
    {Microsoft_remote_debugger_Verzeichnis}\rdbgexp.MSI
    Für diese Installation ist keine Transformdatei erforderlich.
  4. Führen Sie die folgenden Tasks aus:
    1. Aktualisieren Sie Visual Basic 7.1 für Anwendungen mit Service Pack vba71-kb2783832-x64.
    2. Wenn Sie das Administrator-Installationsabbild erstellt haben, führen Sie diesen Befehl aus:
      Msiexec /a {SOLIDWORKS Administrator-Installationsabbild}/Microsoft_vba/vba71.msi /p {SOLIDWORKS Administrator-Installationsabbild}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp
    3. Installieren Sie Visual Basic 7.1 durch Erstellen dieser Richtlinie:
      {VBA-Verzeichnis}\vba71.MSI
      Für diese Installation ist keine Transformdatei erforderlich.
  5. Installieren Sie das Sprachpaket von Visual Basic 7.1 durch Erstellen dieser Richtlinie:
    {VBA-Verzeichnis}\vba71_nnnn.MSI
    Dabei definiert nnnn die erforderliche Sprache:
    • 1028 = Chinesisch
    • 1031 = Deutsch
    • 1033 = Englisch
    • 1036 = Französisch
    • 1040 = Italienisch
    • 1041 = Japanisch
    • 1042 = Koreanisch
    • 1046 = Portugiesisch
    • 2052 = Chinesisch – China
    • 3082 = Spanisch
  6. Installieren Sie den Bonjour-Service durch Erstellen dieser Richtlinie:
    {Bonjour-Verzeichnis}\Bonjour.MSI
    Für diese Installation ist keine Transformdatei erforderlich.
Übergeordnetes Thema Befehlszeilenbereitstellung
Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus
Mit der Befehlszeile aus dem Administrator-Abbild installieren
Befehlszeileneigenschaften
Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren


Verwaltung von mehreren Installationen

Für mehrere Installationen umfassen die Verwaltungsaufgaben die Aktualisierung der Administrator-Installationsabbilder auf die neuen Versionen, Anwendung der Service Pack Aktualisierungen und das Entfernen von Installationen.

Inhaltsverzeichnis

  • Administrator-Installationsabbilder auf neue Version aktualisieren

    Um Clients zu aktualisieren, die von einem Administrator-Installationsabbild aus installiert haben, muss zuerst das Administrator-Installationsabbild aktualisiert und dann müssen die Clients konfiguriert werden, damit sie sich auf die neue Kopie des Abbildes beziehen.

  • Administration von Service Pack-Produktaktualisierungen

    Service Pack-Produktaktualisierungen können Aktualisierungen für die Systemstabilität, Programmkompatibilität, Sicherheit etc. beinhalten.

  • Entfernen einer Installation

    Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.

Übergeordnetes Thema Mehrere Installationen
Bereitstellung für mehrere Clients
Administrator-Installationsabbilder verwenden
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen
Befehlszeilenbereitstellung


Administrator-Installationsabbilder auf neue Version aktualisieren

Um Clients zu aktualisieren, die von einem Administrator-Installationsabbild aus installiert haben, muss zuerst das Administrator-Installationsabbild aktualisiert und dann müssen die Clients konfiguriert werden, damit sie sich auf die neue Kopie des Abbildes beziehen.

Führen Sie den SOLIDWORKS Installations-Manager vom Internet aus, damit die korrekten Dateien referenziert werden. Der SOLIDWORKS Installations-Manager richtet sich selbst darauf aus oder Sie führen die Aktualisierung direkt von der SOLIDWORKS Download-Website (http://www.solidworks.com/sw/support/downloads.htm) aus.

Sobald Sie das Administrator-Installationsabbild aktualisiert haben (das eine neue Kopie des Abbilds erstellt), können Sie Clients aktualisieren, indem Sie eine Referenz auf die neue Kopie des Administrator-Installationsabbilds herstellen.

Wenn Clients eine Referenz auf die frühere Version des Administrator-Installationsabbilds über eine abgebildetes Laufwerk oder ein freigegebenes Verzeichnis hatten, könnten Sie das abgebildete Laufwerk oder das freigegebene Verzeichnis neu definieren, indem Sie den Ablageort der aktualisierten Kopie des Administrator-Installationsabbilds verwenden.

Inhaltsverzeichnis

  • Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen

    Der SOLIDWORKS Installations-Manager kann erkennen, wenn Sie aktualisierte Dateien für die Aktualisierung eines Administrator-Installationsabbilds benötigen.

  • Aktualisieren eines Administrator-Installationsabbildes

    Um ein Administrator-Installationsabbild zu aktualisieren erstellt der SOLIDWORKS Installations-Manager ein neues Abbildverzeichnis. Sie weisen dann direkte Clients an, das neue Administrator-Installationsabbild-Verzeichnis für die Aktualisierung zu dieser Produktversion zu verwenden.

  • Aktualisierung von Clients von Administrator-Installationsabbildern

    Der SOLIDWORKS Installations-Manager kann Client-Computer, die von einem Administrator-Installationsabbild installiert wurden, automatisch aktualisieren.

Übergeordnetes Thema Verwaltung von mehreren Installationen
Administration von Service Pack-Produktaktualisierungen
Entfernen einer Installation


Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen

Der SOLIDWORKS Installations-Manager kann erkennen, wenn Sie aktualisierte Dateien für die Aktualisierung eines Administrator-Installationsabbilds benötigen.

  1. Starten Sie den SOLIDWORKS Installations-Manager, indem Sie eine DVD in das entsprechende Laufwerk einlegen.
  2. Klicken Sie auf dem Bildschirm Willkommen auf Administrator-Installationsabbild.
  3. Verifizieren Sie auf dem Bildschirm Seriennummer die SOLIDWORKS Seriennummer.
    Der SOLIDWORKS Installations-Manager prüft die SOLIDWORKS Website auf Ihre lizenzierten Produkte und die verfügbaren Service Packs.
  4. Wenn der Bildschirm Neuere Version verfügbar erscheint, wählen Sie Ja, die neuere Version herunterladen und installieren: Version.
    Der SOLIDWORKS Installations-Manager startet eine neue Sitzung, um die neuere Version zu installieren.
  5. Sollte es ein Problem mit dem Download-Ordner geben, könnte Download-Optionen erscheinen. Nehmen Sie in diesem Fall das Standardverzeichnis für die neuen Installationsdateien an oder geben Sie einen neuen Verzeichnisnamen ein.
    Wenn eine Meldung eingeblendet wird, dass das Verzeichnis nicht existiert, klicken Sie auf Ja, um das Verzeichnis zu erstellen.
  6. Klicken Sie auf dem Bildschirm Download abgeschlossen auf Schließen, um das aktuelle Installationsprogramm zu schließen und das Installationsprogramm für die neue Version zu starten.
Übergeordnetes Thema Administrator-Installationsabbilder auf neue Version aktualisieren
Aktualisieren eines Administrator-Installationsabbildes
Aktualisierung von Clients von Administrator-Installationsabbildern


Aktualisieren eines Administrator-Installationsabbildes

Um ein Administrator-Installationsabbild zu aktualisieren erstellt der SOLIDWORKS Installations-Manager ein neues Abbildverzeichnis. Sie weisen dann direkte Clients an, das neue Administrator-Installationsabbild-Verzeichnis für die Aktualisierung zu dieser Produktversion zu verwenden.

Dieser Vorgang setzt voraus, dass Sie alle aktualisierten Installationsdateien für das Administrator-Installationsabbild heruntergeladen haben. Weitere Informationen finden Sie unter Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen.

  1. Starten Sie den SOLIDWORKS Installations-Manager. Weitere Informationen finden Sie unter Initiieren der SOLIDWORKS Installation.
  2. Wählen Sie im Bildschirm Willkommen die Option Administrator-Installationsabbild.
    Die Administrator-Installationsabbild-Optionen werden angezeigt.
    Option | Bezeichnung
    Neues Abbild mit Standardeinstellungen erstellen. | Erstellen Sie das Abbild unter Verwendung der Standardkonfigurationseinstellungen (d. h. nicht auf der Basis der aktuellen Einstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort erstellt wurden).
    Neues Abbild mit Einstellungen und Dateien von einem bestehenden Abbild erstellen. | Erstellen Sie das Abbild unter Verwendung der Konfigurationseinstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort festgelegt wurden. Klicken Sie auf Durchsuchen, um das Installationsverzeichnis für das vorhandene Administrator-Installationsabbild anzugeben.
  3. Verifizieren Sie auf dem Seriennummer-Bildschirm die Seriennummer.
  4. Stellen Sie auf dem Bildschirm Zusammenfassung (Bereit zur Erstellung des Abbilds) sicher, dass die Administrator-Installationsabbildoptionen korrekt sind.
    Details über individuelle Administrator-Installationsabbild- und Installationsoptionen erhalten Sie, wenn Sie auf ÄNDERN klicken, um zur Optionsseite zu gelangen, und dort auf Hilfe klicken.
  5. Um die neue Version des Administrator-Installationsabbilds zu erstellen, klicken Sie auf Jetzt erstellen.

Jetzt können Sie Clients auf diese neue Version des Administrator-Installationsabbilds aktualisieren. Einzelheiten dazu finden Sie unter Aktualisierung von Clients von Administrator-Installationsabbildern.

Übergeordnetes Thema Administrator-Installationsabbilder auf neue Version aktualisieren
Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen
Aktualisierung von Clients von Administrator-Installationsabbildern
SOLIDWORKS Installation wird initiiert


Aktualisierung von Clients von Administrator-Installationsabbildern

Der SOLIDWORKS Installations-Manager kann Client-Computer, die von einem Administrator-Installationsabbild installiert wurden, automatisch aktualisieren.

Normalerweise sind Administrator-Installationsabbilder in Ordnern auf einem Server organisiert. Um die automatische Aktualisierung von Clients zu unterstützen, muss sich das Administrator-Installationsabbild in einem freigegebenen Ordner befinden.

Nach der Aktualisierung des Administrator-Installationsabbilds wird sich die Original-Installation in einem Ordner befinden und die aktualisierte Installation in einem anderen Ordner. Um die aktualisierte Installation zu verwenden, entfernen Sie die Freigabeoption vom Originalordner des Administrator-Installationsabbilds und fügen Sie dann die Freigabeoption zum aktualisierten Administrator-Installationsabbild hinzu.

Wenn SOLIDWORKS auf einem Client-Computer, der vom Original-Administrator-Installationsabbild installiert ist, gestartet wird, „sieht“ die Anwendung die neue Version und aktualisiert den Client.
Zudem werden andere von einem Administrator-Installationsabbild installierte Produkte automatisch aktualisiert, wenn SOLIDWORKS eine Aktualisierung auslöst.
Übergeordnetes Thema Administrator-Installationsabbilder auf neue Version aktualisieren
Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen
Aktualisieren eines Administrator-Installationsabbildes

Freigabeoption vom Original-Administrator-Installationsabbildordner entfernen

Bei der Aktualisierung eines Administrator-Installationsabbildes, auf den von einem freigegebenen Ordner aus zugegriffen wird, müssen Sie zunächst die Freigabeoption vom Originalordner des Administrator-Installationsabbilds entfernen.

  1. Wählen Sie den Ordner aus, in dem sich die Dateien des Administrator-Installationsabbilds befinden.
  2. Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Eigenschaften aus.
  3. Wählen Sie auf dem Register Freigeben und wählen Sie dann Diesen Ordner nicht freigeben, klicken Sie dann auf OK.

Fügen Sie jetzt die Freigabeoption dem aktualisierten Ordner des Administrator-Installationsabbilds wie in Freigabeoption zu einem Original-Administrator-Installationsabbildordner hinzufügen beschrieben hinzu.

Freigabeoption zu einem Original-Administrator-Installationsabbildordner hinzufügen

Sobald Sie einen aktualisierten Administrator-Installationsabbildordner erstellt und die Freigabe für den Original-Administrator-Installationsabbildordner deaktiviert haben, müssen Sie dem neuen Ordner die Freigabeoption hinzufügen, um das Administrator-Installationsabbild wieder zu aktivieren.

  1. Wählen Sie den Ordner aus, in dem sich die Dateien des aktualisierten Administrator-Installationsabbilds befinden.
  2. Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Eigenschaften aus.
  3. Definieren Sie auf der Registerkarte Freigabe die Freigabeeigenschaften für Ihr Unternehmen oder Ihre Gruppe, und ändern Sie den Freigabenamen in den Namen, der für die Original-Administrator-Installationsabbild-Ordner verwendet wird.
Computer, die vom ursprünglichen Administrator-Installationsimage-Freigabepfad aus installiert wurden, werden automatisch beim nächsten Start von SOLIDWORKS auf die neue Version aktualisiert.


Administration von Service Pack-Produktaktualisierungen

Service Pack-Produktaktualisierungen können Aktualisierungen für die Systemstabilität, Programmkompatibilität, Sicherheit etc. beinhalten.

Sie können Produktaktualisierungen auf zwei verschiedene Arten erhalten:
  • Über die Verwendung des SOLIDWORKS Installations-Managers für die Suche nach, den Download und die Installation von Aktualisierungen.

    Sie können den SOLIDWORKS Installations-Manager manuell initiieren oder einen Zeitplan für eine periodische Überprüfung nach Aktualisierungen festlegen.

  • Durch manuelles Downloaden der Service Packs von der SOLIDWORKS Website.

    Service Packs werden als Patches auf die bestehende Software-Version angewendet. So ist SOLIDWORKS 2019 SP 1.0 ein Service Pack für SOLIDWORKS 2019 SP 0.0. Sie können diese Service Packs mit dem SOLIDWORKS 2019 Installations-Manager installieren, nicht jedoch mit dem SOLIDWORKS Installations-Manager in SOLIDWORKS 2018.

    Anleitungen zum Download und der Installation von Service Packs finden Sie in der Installationsdokumentation für die SOLIDWORKS Version, die Sie aktualisieren.

Inhaltsverzeichnis

  • Zurücksetzen von Service Packs in einem Administrator-Installationsabbild

    Sie können ein Administrator-Installationsabbild auf ein früher installiertes Service Pack zurücksetzen. Wenn Sie die SOLIDWORKS Software mit Datenträger installiert haben, benötigen Sie die Originaldatenträger, um auf ein Service Pack zurücksetzen zu können. Das frühere Administrator-Installationsabbild muss abgespeichert worden sein.

  • Anwenden von Service Packs auf Clients, die mit Microsoft Active Directory aktualisiert wurden

    Wenn Sie die SOLIDWORKS Software mit Microsoft Active Directory installiert haben, können Sie Service Packs auf Clients anwenden.

Übergeordnetes Thema Verwaltung von mehreren Installationen
Administrator-Installationsabbilder auf neue Version aktualisieren
Entfernen einer Installation


Zurücksetzen von Service Packs in einem Administrator-Installationsabbild

Sie können ein Administrator-Installationsabbild auf ein früher installiertes Service Pack zurücksetzen. Wenn Sie die SOLIDWORKS Software mit Datenträger installiert haben, benötigen Sie die Originaldatenträger, um auf ein Service Pack zurücksetzen zu können. Das frühere Administrator-Installationsabbild muss abgespeichert worden sein.

Administrator-Installationsabbilder, die aktualisiert wurden, können nicht auf ein früheres Service Pack zurückgesetzt werden. Administrator-Installationsabbilder, die mit einer anderen Methode als dem SOLIDWORKS Installations-Manager erstellt wurden, können nicht auf eine frühere Version zurückgesetzt werden. Clients, die von einem Administrator-Installationsabbild installiert wurden, müssen von einem Administrator-Installationsabbild einer früheren Version aus deinstalliert und wieder installiert werden.
  1. Löschen Sie den Ordner, der das aktuelle Administrator-Installationsabbild enthält. Öffnen Sie dazu das Fenster Eingabeaufforderung und geben Sie folgendes ein:
    rmdir /s/q Pfad_zu_aktuellem_Administrator_Installationsabbild
  2. Verschieben Sie die Sicherungskopie des Administrator-Installationsabbildes an den Ort, an dem Sie das aktuelle Administrator-Installationsabbild gelöscht haben. Öffnen Sie dazu das Fenster Eingabeaufforderung und geben Sie folgendes ein:
    move Pfad_zu_gesichertem_Administrator_Installationsabbild Pfad_zu_aktuellem_Administrator_Installationsabbild
    Nach der Zurücksetzung eines Administrator-Installationsabbildes werden Client-Computer automatisch beim nächsten Ausführen der SOLIDWORKS Software zurückgesetzt.
Übergeordnetes Thema Administration von Service Pack-Produktaktualisierungen
Anwenden von Service Packs auf Clients, die mit Microsoft Active Directory aktualisiert wurden


Anwenden von Service Packs auf Clients, die mit Microsoft Active Directory aktualisiert wurden

Wenn Sie die SOLIDWORKS Software mit Microsoft Active Directory installiert haben, können Sie Service Packs auf Clients anwenden.

  1. Kopieren Sie das Administrator-Installationsabbild in einen neuen Ordner, indem Sie die folgende Befehlszeile verwenden:
    xcopy Pfad_zu_aktuellem_Administrator_Installationsabbild Pfad_zu_gesichertem_Administator_Installationsabbild /s/i/v
  2. Aktualisieren Sie das Administrator-Installationsabbild mithilfe des SOLIDWORKS Installations-Managers.
  3. Erstellen Sie eine neue Transformationsdatei, um eine Upgrade-Installation für die SOLIDWORKS Software festzulegen:
    1. Öffnen Sie das Eingabeaufforderungsfenster.
    2. Ziehen Sie vom Ordner, in dem sich das Administrator-Installationsabbild befindet, die Datei SWCreateMST.exe in das Fenster „Eingabeaufforderung“.
      Das Befehlsformat ist:

      Pfad_zu_Administrator-Installationsabbild\SWCreateMST.exe Pfad_zur_MSI_Datei_eines_Administrator-Installationsabbilds Liste_der_Eigenschaften

      Die Befehlszeile muss alle Parameter enthalten, die für die Erstellung der ursprünglichen Transformationsdatei verwendet wurden, sowie die globalen Eigenschaften UPGRADESWINSTALL und SWMIGRATE.

      Wenn z. B. der ursprüngliche Befehl folgendermaßen lautete:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@Ihr_Server

      dann muss der Aktualisierungsbefehl folgendermaßen lauten:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Programme\Ihr_Ordner" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@Ihr_Server UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS Version Service_Pack"

      Die Transformationsdatei SOLIDWORKS.mst wird in dem Ordner erstellt, der das Administrator-Installationsabbild enthält.

  4. Bearbeiten Sie in Active Directory die Richtlinie Published Published Apps für die Gruppe oder Gruppen, die die SOLIDWORKS Software aktivieren sollen.
  5. Klappen Sie im Dialogfeld Gruppenrichtlinie die Optionen Computerkonfiguration und Softwareeinstellungen auf.
  6. Klicken Sie mit der rechten Maustaste auf Software-Installation und wählen Sie Neu > Paket aus.
  7. Wählen Sie das Administrator-Installationsabbild aus, und klicken Sie auf Öffnen.
  8. Wählen Sie im Dialogfeld Software bereitstellen die Option Erweiterte Methode von "Veröffentlicht" oder "Zugewiesen", und klicken Sie auf OK.
  9. Im Dialogfeld Eigenschaften von SOLIDWORKS auf der Registerkarte Änderungen:
    1. Klicken Sie auf Hinzufügen..
    2. Wählen Sie die .mst-Datei aus:
    3. Klicken Sie auf Öffnen.
  10. Klicken Sie auf OK.
Übergeordnetes Thema Administration von Service Pack-Produktaktualisierungen
Zurücksetzen von Service Packs in einem Administrator-Installationsabbild


SOLIDWORKS PDM und SOLIDWORKS Manage

SOLIDWORKS PDM ist ein Produkt zur Dokumentenverwaltung, das auf der Client-/Server-Architektur basiert, die früher SOLIDWORKS Enterprise PDM genannt wurde. Es sind zwei Typen von SOLIDWORKS PDM verfügbar:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM verwendet eine Microsoft SQL Server-Datenbank für die Verwaltung von Dateitresoren.

In dieser Tabelle sind die Datenbanksysteme, die Serverkomponenten und die für jeden Produkttyp verfügbaren Client-Optionen aufgeführt.
 | PDM Standard | PDM Professional
Vorgesehen für | Kleine und mittlere Büronetzwerke, im Allgemeinen mit weniger als 20 gleichzeitigen Benutzern. | Große Büronetzwerke, große Anzahl gleichzeitiger Benutzer
Grenzwerte | Weniger als 1 Socket oder 4 Kerne, 1 GB RAM und Datenbankgröße von 10 GB | Beschränkungen bei SQL Standard: Weniger als 4 Sockets oder 16 Kerne, 128 GB RAM und Datenbankgröße von 524 PB
Datenbankverwaltungssystem | Microsoft SQL Server Express 2014 (mit SOLIDWORKS geliefert und installiert) | Microsoft SQL Server 2014 (separat mit SOLIDWORKS geliefert) oder zuvor installierte Instanzen von Microsoft SQL Server 2014, 2012 oder 2008 R2
Erfordert SOLIDWORKS SolidNetWork License Manager? | Ja | Ja
Beinhaltet Archiv- und Datenbankserver? | Ja | Ja
Beinhaltet SOLIDWORKS PDM Webserver und Web2 Server? | Nein | Ja
Client-Typen | Nativ | Nativ, browser-basiert
Client-Zusatzanwendungen für CAD-Editoren | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration, Autodesk Inventor, AutoCAD
Client-Zusatzanwendungen für Beitragsleister | DraftSight | DraftSight, Microsoft Office-Integration
Client-Zusatzanwendungen für Viewer |  | Microsoft Office Integration

SOLIDWORKS Manage Professional bietet erweiterte Tools zur Datenverwaltung in SOLIDWORKS PDM Professional. Die Software umfasst Funktionen für die erweiterte Versionskontrolle und für die Verwaltung von Projekten, Prozessen und Elementen. Interaktive Dashboards und Berichte helfen Ihnen dabei, Elemente und Aktivitäten zu verfolgen und diese zum Abschluss von Projekten voranzubringen.

SOLIDWORKS Manage Professional hat eine ähnliche Architektur wie SOLIDWORKS PDM Professional. In der Software wird eine Client-Server-Architektur mit einer Microsoft SQL Server-Datenbank für die Verwaltung von Elementen und Projektdaten verwendet. Es gibt drei Services für Datenbank-, Dateiserver- und Webserver-Funktionen, die sowohl Thick Clients, als auch Browser-Clients unterstützen. Die drei Services können auf demselben oder auf unterschiedlichen Servern gehostet werden. Benutzer mit Lizenzen für SOLIDWORKS Manage Professional Editor können für den direkten Zugriff auf Daten in Manage von SOLIDWORKS aus eine SOLIDWORKS Zusatzanwendung verwenden.

Sie können den SOLIDWORKS Installation Manager verwenden, um den SOLIDWORKS Manage Professional Server und Client zu installieren.

Anweisungen zur Installation von SOLIDWORKS Manage Professional finden Sie in der SOLIDWORKS PDM/SOLIDWORKS Manage Installationsanleitung.

Inhaltsverzeichnis

  • Auflisten von PDM Serverkomponenten

  • Unterschiede zwischen PDM Clients

    Vor der Installation der Client-Software müssen Sie bestimmen, welche Clients je nach PDM-Umgebung erforderlich sind.

  • Vor der Installation von PDM Server

    Berücksichtigen Sie die folgenden Anforderungen vor der Installation von PDM Server Komponenten:

  • Installieren eines PDM Servers mit SLDIM

    Bei der Installation des PDM Servers für PDM Standard können Sie den Archivserver, den Datenbankserver und den PDM CAD Editor Client auf demselben Computer installieren. Sie brauchen die Client-Installation nicht separat auszuführen.

  • Installieren eines PDM Clients mit SLDIM


Auflisten von PDM Serverkomponenten

Diese Tabelle enthält eine Zusammenfassung der Serverkomponenten des SOLIDWORKS PDM Servers.

Server | Function | Installation
Microsoft SQL Server Express für PDM Standard | Verwaltet Daten in SOLIDWORKS PDM Datentresoren. | Kann mit PDM Standard installiert werden oder verwendet eine zuvor installierte und lizenzierte Version.
Microsoft SQL Server für PDM Professional | Verwaltet Daten in SOLIDWORKS PDM Datentresoren. | Wird separat mit PDM Professional geliefert. Sie können auch eine zuvor installierte und lizenzierte Version verwenden.
SolidNetWork License Manager | Verwaltet SOLIDWORKS PDM Lizenzen. | Muss installiert sein, damit neue Tresore erstellt werden können. Kann bei Verwendung von SLDIM mit SOLIDWORKS PDM Serverkomponenten installiert werden.
Archiv-Server | Verwaltet Übertragungen von Dateien zwischen Clients und dem Dateitresor-Archiv und verwaltet Benutzer und deren Anmeldeinformationen. | Erforderlich. Wird mit PDM Standard oder Professional installiert.
Datenbankserver | Fragt PDM Datenbanken nach Aktualisierungen ab, verwaltet Import- und Exportregeln für Daten, verwaltet das Nachrichtensystem und plant Replikation und Cold Storage. | Erforderlich. Wird mit PDM Standard oder Professional installiert.
Webserver und Web2-Server | Bietet Zugriff auf Dateitresore über das Internet von browserbasierten Clients. | Optional. Wird nur mit PDM Professional installiert.
Web-API-Server | EXALEAD OnePart-Benutzer können mit einem Web-API-Server SOLIDWORKS PDM Daten indizieren und abrufen. | Optional. Wird nur mit PDM Professional installiert.

Archivserver werden als Dienste auf dem Systemkonto der Computer ausgeführt, auf denen sie installiert sind. Ein Archivserver kann mehrere Dateitresore auf demselben Computer hosten.

In einer eigenständigen Installation können der Archivserver, Datenbankserver und Lizenzserver sowie die SQL Express- oder SQL Server-Datenbank alle auf demselben Computer installiert werden.

In einer verteilten Umgebung können sich die Serverkomponenten auf unterschiedlichen Computern befinden. Sie können auch mehrere Archivserver auf verschiedenen Computern einrichten, um replizierte Kopien desselben Dateitresorarchivs zu hosten. Siehe SOLIDWORKS Enterprise PDM Professional Replication Guide.

Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


Unterschiede zwischen PDM Clients

Vor der Installation der Client-Software müssen Sie bestimmen, welche Clients je nach PDM-Umgebung erforderlich sind.

Diese Tabelle enthält eine Zusammenfassung der Clients für SOLIDWORKS PDM Standard:
Standard Client-Typ | Beschreibung
CAD Editor | Unterstützt die Arbeit mit SOLIDWORKS-, DWG/DXF-Format-, Microsoft Word- und Microsoft Excel-Dateien. Alle Dateiformate, die von Microsoft Office Zusatzanwendungen unterstützt werden, verhalten sich auf die gleiche Weise in SOLIDWORKS PDM Standard, ausgenommen die Vorschau.
Beitragsleister | Unterstützt die Arbeit mit SOLIDWORKS-, DWG/DXF-Format-, Microsoft Word- und Microsoft Excel-Dateien.
Viewer | Ermöglicht den schreibgeschützten Zugriff auf Dateitresore. Benutzer können einen Übergang für Dateien durch einen Workflow durchführen. Die Benutzer können keine Dateien hinzufügen oder ändern (auschecken, einchecken, Werte aktualisieren).
Diese Tabelle enthält eine Zusammenfassung der Clients für SOLIDWORKS PDM Professional:
Professional Client-Typ | Beschreibung
CAD Editor & Web | Unterstützt die Arbeit mit allen Dateitypen, einschließlich der erweiterten Verwaltung und Vorschau von CAD-Formaten wie SOLIDWORKS. Mit CAD-Zusatzanwendungen können Benutzer über die CAD-Anwendung auf SOLIDWORKS PDM Professional zugreifen. Remote-Benutzer können mithilfe von Web- und Web2-Clients Tresore durchsuchen und grundlegende Funktionen über das Internet ausführen.
Contributor & Web | Unterstützt die Arbeit mit allen Dateitypen, einschließlich CAD-Dateien. Die CAD-Zusatzanwendungen werden auf diesem Client-Typ jedoch nicht unterstützt. Remote-Benutzer können mithilfe von Web- und Web2-Clients Tresore durchsuchen und grundlegende Funktionen über das Internet ausführen.
Viewer | Ermöglicht den schreibgeschützten Zugriff auf Dateitresore. Benutzer können einen Übergang für Dateien durch einen Workflow durchführen. Die Benutzer können keine Dateien hinzufügen oder ändern (auschecken, einchecken, Werte aktualisieren) und keine CAD-Zusatzanwendungen verwenden.
Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


Vor der Installation von PDM Server

Berücksichtigen Sie die folgenden Anforderungen vor der Installation von PDM Server Komponenten:

  • Besorgen Sie sich volle Administratorrechte für die Maschinen, auf denen Sie Server und Clients installieren wollen.
  • Stellen Sie sicher, dass der Datenbankserver über TCP-Port 3030 Zugriff auf den Archivserver und über TCP-Port 1433 Zugriff auf den SQL Server hat.
  • Wenn Sie eine bestehende SQL Server Express oder SQL Server Datenbank verwenden werden, besorgen Sie sich den Namen der SQL Server Datenbank und die Konto-ID und das Passwort eines SQL Server Administrators oder Datenbankbesitzers mit Lese-/Schreibzugriff auf die Datenbank. Der Benutzer TEW kann nicht verwendet werden.
  • Wenn auf dem System bereits ein PDM Client installiert ist, deinstallieren Sie ihn. Wenn Sie möchten, dass der PDM Server und der PDM Client auf demselben System installiert werden, können Sie beide von der Seite Server-Produkte im SOLIDWORKS Installations-Manager installieren.
Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


Installieren eines PDM Servers mit SLDIM

Bei der Installation des PDM Servers für PDM Standard können Sie den Archivserver, den Datenbankserver und den PDM CAD Editor Client auf demselben Computer installieren. Sie brauchen die Client-Installation nicht separat auszuführen.

Bei der Installation von PDM Server für PDM Professional können Sie diese Komponenten sowie den Webserver, Web2-Server und Web-API-Server einschließen.

So installieren Sie einen PDM Server und seine Komponenten:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Auf der Seite Willkommen wählen Sie Server-Produkte aus und prüfen Sie Folgendes:
    • SOLIDWORKS PDM Server Komponenten auf diesem Computer installieren.
    • SolidNetWork License Manager auf diesem Computer installieren.

      Wenn SolidNetWork License Manager installiert ist, wird diese Option nicht angezeigt.

  3. Wenn die Seite SolidNetwork License Manager-Optionen angezeigt wird, geben Sie eine Seriennummer ein, legen Sie einen Speicherort für das Verzeichnis fest und klicken Sie auf Weiter.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Klicken Sie auf der Seite Zusammenfassung für SOLIDWORKS PDM Server auf Ändern.
  6. Auf der Seite SOLIDWORKS PDM Server Optionen:
    1. Klicken Sie unter Serverprodukt auswählen auf SOLIDWORKS PDM Standard oder auf SOLIDWORKS PDM Professional.
    2. Klicken Sie bei Installationsort auf Durchsuchen, um einen Dateipfad anzugeben.
    3. In Features auswählen:
      1. Klicken Sie auf Archivserver, Datenbank-Server und Client, um diese Komponenten auf demselben Computer zu installieren. Wenn Sie sich in einer verteilten Umgebung befinden, können Sie den Archivserver und den Datenbankserver installieren, indem Sie den Installation Manager auf einem anderen Computer ausführen.
        Wenn auf dem Computer bereits ein PDM Client installiert ist, müssen Sie die Installation abbrechen und den Client deinstallieren. Anschließend können Sie SLDIM ausführen, um den PDM Server zusammen mit dem Client zu installieren.
      2. Wenn Sie PDM Professional installieren, können Sie auch auf Webserver, Web2-Server und Web-API-Server klicken.
        Wenn Sie den Web-API-Server installieren, können Sie für Http-Portnummer einen Wert zwischen 0 und 65535 angeben. Der Standardwert ist 65453.
    4. In SQL Server können Sie eine neue Instanz der Datenbankwerkzeuge installieren, die mit PDM Server geliefert werden (SQL Server Express für PDM Standard). Sie können auch den Datenbanknamen, den Benutzernamen und das Passwort einer vorhandenen Instanz angeben.
      Zusammen mit PDM Professional wird separat eine vollständige Edition von SQL Server geliefert.
    5. Klicken Sie auf Zurück zu Übersicht.
  7. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.

    Wenn die Installation im SOLIDWORKS Installation Manager abgeschlossen wurde, wird das Archivserver-Konfigurationswerkzeug gestartet. Folgen Sie den Anweisungen des Assistenten, um den Archivserver zu konfigurieren.

Informationen zum Einrichten und Konfigurieren des Archivservers, des Datenbankservers, der Web- und Web2-Server und der SQL Server-Datenbanken sowie zur Problembehebung finden Sie in den entsprechenden Themen in der SOLIDWORKS PDM 2019 Installationsanleitung.

Inhaltsverzeichnis

  • Ändern einer SOLIDWORKS PDM Server-Installation

Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


Ändern einer SOLIDWORKS PDM Server-Installation

Das Ändern der Installation von SOLIDWORKS PDM Server und seiner Komponenten ist nur über Programme und Funktionen in der Windows Systemsteuerung möglich. Sie können die Installation nicht mithilfe des SOLIDWORKS Installations-Managers (SLDIM) ändern, auch wenn Sie diesen zur Installation von SOLIDWORKS PDM Server verwendet haben.

Übergeordnetes Thema Installieren eines PDM Servers mit SLDIM


Installieren eines PDM Clients mit SLDIM

Die Hauptversion von SOLIDWORKS PDM Client muss mit der Hauptversion von SOLIDWORKS PDM Server übereinstimmen. Wenn Sie SOLIDWORKS PDM Client installieren oder aktualisieren, stellen Sie sicher, dass die Versionen übereinstimmen.

So installieren Sie einen Lizenz-Client:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Auf der Seite Willkommen wählen Sie Einzeln.
  3. Auf der Seite Seriennummer klicken Sie auf Weiter.
    SOLIDWORKS PDM Clients erfordern keine separate Seriennummer.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Auf der Seite Zusammenfassung unter „Produkte“ klicken Sie auf Ändern.
  6. Auf der Seite Produktauswahl klicken Sie auf Andere Pakete oder Produkte auswählen.
  7. Im Dialogfeld Das anzuzeigende Paket auswählen wählen Sie eine Edition von SOLIDWORKS aus. Klicken Sie auf OK.
  8. Auf der Seite Produktauswahl wählen Sie SOLIDWORKS PDM Client. Wählen Sie dann eDrawings aus, um die PDM Vorschaufunktion zu aktivieren. Wenn Sie SOLIDWORKS PDM Professional verwenden, können Sie auch den Artikel-Explorer auswählen.
  9. Erweitern Sie auf der Seite Zusammenfassung SOLIDWORKS PDM Optionen und klicken Sie auf Ändern.
  10. Wählen Sie auf der Seite SOLIDWORKS PDM Client Optionen Folgendes aus und klicken Sie auf Zurück zur Übersicht:
    • PDM Produkttyp
    • PDM Clienttyp
    • Zusatzanwendungen
  11. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.
Administratoren können auch den Options-Editor des Administrations-Abbilds verwenden, um Abbilder von PDM Clients zu erstellen und bereitzustellen. Weitere Informationen finden Sie unter Administrator-Installationsabbilder verwenden in der SOLIDWORKS Installations- und Administrationsanleitung.
Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS Electrical vereinfacht die Konstruktion elektrischer Systeme mit intelligenten Konstruktionswerkzeugen, einer umfassenden Teiledatenbank und Echtzeitintegration zwischen 2D-Abbildungen und 3D-Modellen.

Die Hauptkomponenten von SOLIDWORKS Electrical sind:
  • SOLIDWORKS Electrical Schematic - Werkzeuge für die dynamische Erstellung elektrischer Systeme in 2D.
  • SOLIDWORKS Electrical 3D - Werkzeuge zur Integration von 2D-Abbildungen in 3D-Modelle, sodass elektrische Systeme in 3D modelliert werden können, einschließlich von Kabeln und Drähten.
  • Daten – Eine Datenbank von Teilen, Symbolen, Bibliotheken und Katalogen, die von Benutzern freigegeben werden können.
  • Gemeinschaftsserver - Ein Dienstprogramm zum Öffnen und Aktualisieren von elektrischen Zeichnungen.
  • Eine Instanz der Microsoft SQL Server-Datenbank.

SOLIDWORKS Electrical erfordert eine Microsoft SQL Server-Datenbank. Es kann eine vorhandene Datenbank oder eine neue Instanz bei der Installation verwendet werden.

Sie können alle SOLIDWORKS Electrical Komponenten auf demselben Computer installieren. Diese Installation wird in der Regel als eigenständige Installation betrachtet. Alle Programmdaten, wie z. B. Projektzeichnungen und Berichte, sind auf einem einzelnen System gespeichert. Für die Installation von SOLIDWORKS Electrical sind volle Administratorrechte erforderlich.

Die SOLIDWORKS Electrical Komponenten können auch als Client-/Serveranwendung installiert werden. Diese Installation ist erforderlich, wenn Daten auf einem Netzwerkserver gespeichert werden müssen oder wenn eine SQL Server-Datenbank auf einem Netzwerkserver vorhanden ist, auf dem alle SOLIDWORKS Electrical Datenbanken gespeichert sind. In diesen Fällen sind sowohl für den Server als auch für die Client-Systeme volle Administratorrechte erforderlich. Weiterhin müssen Client-Systeme Netzwerkzugriff auf den Server und Schreib-/Leseberechtigungen zum Erstellen von Projekten, Bibliotheken und Symbolen haben.

Es kann nur eine Version von SOLIDWORKS Electrical auf einem Computer installiert werden. Wenn Sie eine neue Installation von SOLIDWORKS erstellen und SOLIDWORKS Electrical als eines der zu installierenden Produkte auswählen, wird die alte Version von SOLIDWORKS Electrical entfernt.

Sichern Sie immer Ihre bestehende SOLIDWORKS Electrical Umgebung, bevor Sie eine neue Version installieren. Wählen Sie in SOLIDWORKS Electrical Schematic Datei Anwendungsumgebung archivieren oder in SOLIDWORKS Electrical 3D SOLIDWORKS Electrical > Extras > Anwendungsumgebung archivieren aus.

Inhaltsverzeichnis

  • Verwalten von Daten in SOLIDWORKS Electrical

  • Anforderungen zum Installieren von SOLIDWORKS Electrical


Verwalten von Daten in SOLIDWORKS Electrical

Viele Programme verwenden eine einzelne Datenbank, die alle Programmdaten enthält. Dies ist bei SOLIDWORKS Electrical nicht der Fall. Jedem Projekt in SOLIDWORKS Electrical wird eine eindeutige ID-Nummer zugewiesen, und jedes Projekt hat eine verwandte Datenbank, die anhand der eindeutigen ID-Nummer identifiziert werden kann. Wenn beispielsweise im Projekt-Manager für SOLIDWORKS Electrical ein Projekt mit ID#112 vorliegt, lautet der Name der zugeordneten Datenbank “tew_project_data_112”.

Der Vorteil einer eindeutigen Datenbank für jedes Projekt liegt darin, dass die Verarbeitungszeit drastisch verringert wird. Darüber hinaus ist im Fall eines kritischen Datenbankfehlers nur ein Projekt betroffen, sodass die Integrität der meisten Programminformationen bewahrt wird.

Einige Unternehmen haben aber Richtlinien, die die Erstellung neuer Datenbanken einschränken. Bei der Ausführung von SOLIDWORKS Electrical darf es keine Einschränkungen für das Erstellen neuer Datenbanken durch Benutzer geben. Erkundigen Sie sich beim System- oder der Datenbankadministrator, ob Konfigurationseinstellungen vorhanden sind, durch die Benutzer am Erstellen neuer Datenbanken gehindert werden.
Übergeordnetes Thema SOLIDWORKS Electrical
Anforderungen zum Installieren von SOLIDWORKS Electrical


Anforderungen zum Installieren von SOLIDWORKS Electrical

Die aktuellen Systemanforderungen finden Sie unter http://solidworks.com/System_Requirements.

Inhaltsverzeichnis

  • Einzel- und Serveroptionen

    Sie können SOLIDWORKS Electrical entweder im Einzel- oder im Servermodus installieren.

  • Festlegen der Datenposition

  • Konfigurieren des Gemeinschaftsservers

  • Konfigurieren von Microsoft SQL Server

Übergeordnetes Thema SOLIDWORKS Electrical
Verwalten von Daten in SOLIDWORKS Electrical


Einzel- und Serveroptionen

Sie können SOLIDWORKS Electrical entweder im Einzel- oder im Servermodus installieren.

Es muss beachtet werden, dass SOLIDWORKS Electrical eine Verbindung mit einer Instanz von SQL Server herstellen muss, ganz gleich, ob es sich um eine vorhandene oder eine neue Instanz handelt.

Im Einzelmodus können Sie die folgenden Komponenten installieren:
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Gemeinschaftsserver
  • Daten
  • Eine neue Instanz der SQL Server-Datenbank
Im Servermodus können Sie die folgenden Komponenten installieren:
  • Eine neue Instanz der SQL Server-Datenbank
  • Gemeinschaftsserver
  • Daten

Sie können Komponenten des Einzel- und des Servermodus kombinieren, um eine Client-/Serverumgebung zu erstellen. Zum Beispiel können Sie SOLIDWORKS Electrical Schematic und SOLIDWORKS Electrical 3D auf Client-Systemen und alle Serverkomponenten auf einem Serversystem installieren.

Übergeordnetes Thema Anforderungen zum Installieren von SOLIDWORKS Electrical
Festlegen der Datenposition
Konfigurieren des Gemeinschaftsservers
Konfigurieren von Microsoft SQL Server


Festlegen der Datenposition

Wählen Sie für die Datenposition ein Verzeichnis zum Speichern von Programmdaten wie Teile, Vorlagen und 2D- bzw. 3D-Symbole aus. Diese Position sollte ein dediziertes Verzeichnis sein. Es darf sich nicht um ein Stammverzeichnis oder dasselbe Verzeichnis handeln, in dem die SOLIDWORKS Daten gespeichert werden.

Das Standardverzeichnis ist C:\ProgramData\SOLIDWORKS Electrical. Im selben Verzeichnis wird ein Ordner namens Aktualisierung erstellt, in dem alle verfügbaren Programmdaten gespeichert werden.

Wenn Sie SOLIDWORKS Electrical zum ersten Mal starten, wird der Assistent Datenaktualisierung angezeigt. In diesem Assistenten können Sie die Daten auswählen, die der Anwendung und der SQL Server-Datenbank hinzugefügt werden sollen.
Übergeordnetes Thema Anforderungen zum Installieren von SOLIDWORKS Electrical
Einzel- und Serveroptionen
Konfigurieren des Gemeinschaftsservers
Konfigurieren von Microsoft SQL Server


Konfigurieren des Gemeinschaftsservers

Um SOLIDWORKS Electrical auszuführen, müssen Sie den Gemeinschaftsserver auf demselben System installieren, auf dem die Microsoft SQL Server-Datenbank gehostet wird.

Der Gemeinschaftsserver muss fortwährend ausgeführt werden, und es muss eine konstante, ununterbrochene, bidirektionale Kommunikation mit Clients durch Firewalls und Virenscanner vorliegen.

Um den Gemeinschaftsserver entweder im Einzel- oder im Servermodus zu installieren, müssen Sie die folgenden Parameter festlegen:
  • Computer-Name, z. B. LOCALHOST
  • IP-Adresse des Computers, z. B. 127.0.0.1
  • Portnummer, z. B. 26666

Um eine ununterbrochene bidirektionale Kommunikation zu gewährleisten, überprüfen Sie, ob Port Nummer 26666 auf dem System verfügbar ist, auf dem der Gemeinschaftsserver installiert ist. Wenn Port 26666 nicht zugänglich ist, suchen Sie mithilfe des Systemadministrators einen anderen Port, auf den SOLIDWORKS Electrical zugreifen kann.

Übergeordnetes Thema Anforderungen zum Installieren von SOLIDWORKS Electrical
Einzel- und Serveroptionen
Festlegen der Datenposition
Konfigurieren von Microsoft SQL Server


Konfigurieren von Microsoft SQL Server

Sie müssen sicherstellen, dass für alle Installationen von SOLIDWORKS Electrical eine Instanz der SQL Server-Datenbank zur Verfügung steht. Es kann eine vorhandene, bereits auf dem System installierte SQL Server-Datenbank verwendet werden oder Sie können im Rahmen der Installation von SOLIDWORKS Electrical eine neue Instanz installieren.

Wenn Sie eine neue Instanz von SQL Servers installieren, bietet die SOLIDWORKS Installation eine kostenlose Version von Microsoft SQL Server Express. Diese Version ist auf 1 CPU, 1 GB Speicher und 10 GB Daten beschränkt. Speicher und die CPU-Begrenzungen sind für fünf gleichzeitige Benutzer ausreichend.

Wenn Sie SQL Server Express Edition installieren, überprüfen Sie, ob die Serversoftware und -hardware die hier aufgeführten Anforderungen erfüllen: http://solidworks.com/System_Requirements.

Wenn sechs oder mehr gleichzeitige Benutzer auf demselben Server vorliegen, sollten Sie eine Vollversion von SQL Server erwerben und installieren. Verwenden Sie dabei den Workflow zur Installation von SOLIDWORKS Electrical mit einer vorhandenen Instanz von SQL Server.

Informationen zur SQL Server Express Edition finden Sie in der Microsoft-Dokumentation zu SQL Server.

Übergeordnetes Thema Anforderungen zum Installieren von SOLIDWORKS Electrical
Einzel- und Serveroptionen
Festlegen der Datenposition
Konfigurieren des Gemeinschaftsservers

Neue Instanzen von SQL Server

Um eine neue Instanz von SQL Server zu installieren, benötigen Sie volle Administratorrechte für den Server und für alle Client-Systeme. Sie müssen auch sicherstellen, dass Clients Schreib-/Leseberechtigungen für die Datenbank haben, damit Projekte, Bibliotheken, Symbole und andere Projektdaten erstellt und geändert werden können.

Wenn Sie eine neue Instanz von SQL Server installieren, müssen Sie den Standardnamen ändern.

Vorhandene Instanzen von SQL Server

Sie benötigen ein Benutzerkonto mit vollen Administratorrechten für die SQL Server-Datenbank, um neue SOLIDWORKS Electrical Datenbanken zu installieren oder eine Verbindung zu einer SOLIDWORKS Electrical Installation auf einer vorhandenen Instanz von SQL Server herzustellen.

Sie müssen SQL Server für die Authentifizierung im gemischten Modus aktivieren, damit SOLIDWORKS Electrical richtig funktioniert. Die Authentifizierung im gemischten Modus ermöglicht die Verwendung von Windows- oder SQL Server-Anmeldeinformationen.

Um eine Verbindung zu einer vorhandenen SQL Server-Datenbank herzustellen, können Sie die Windows- oder die SQL Server-Authentifizierung verwenden. Geben Sie einen Benutzernamen und ein Passwort für eine Windows- oder SQL Server-Anmeldung ein, die über die vollen Administratorrechte für SQL Server verfügt.

Sie können bei der Installation für eine Verbindung zu SQL Server nicht den „TEW“-Benutzer verwenden. Kontaktieren Sie Ihren SQL Server-Administrator oder Systemadministrator, um die richtigen Anmeldeinformationen für SQL Server zu erhalten.

Nach der Installation von SQL Server

Nach der Installation von SOLIDWORKS Electrical erstellt die SQL Server-Instanz die folgenden Datenbanken in SOLIDWORKS Electrical:
  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION
  • TEW_SQLEXPRESS


SOLIDWORKS PCB

SOLIDWORKS® PCB (früher PCBWorks) ist ein PCB-Konstruktionswerkzeug (Printed Circuit Board, Leiterplatte), das in die SOLIDWORKS 3D-Konstruktionssoftware integriert ist. Es wird vom SOLIDWORKS Installations-Manager als Teil der Einzelinstallation installiert.

Ein Elektroingenieur kann mit SOLIDWORKS PCB Änderungen an einer Leiterplatte vornehmen und diese Änderungen an einen freigegebenen Speicherort weitergeben. Ein Maschinenbauingenieur, der mit der SOLIDWORKS Software arbeitet, kann die geänderte Leiterplatte aus dem Speicherort abrufen, die Änderungen analysieren, weitere Änderungen vornehmen und die Konstruktion wieder an den Speicherort zurückgeben, wo der Elektroingenieur dann erneut auf sie zugreifen kann.

Zum Aktivieren dieser Zusammenarbeit müssen Sie SOLIDWORKS PCB Services installieren. Damit wird der Speicherort auf einem freigegebenen Server verwaltet. Die Installation erfolgt durch den SOLIDWORKS Installations-Manager im Rahmen einer Server-Installation und erfordert keine separate Lizenz. Sie umfasst Microsoft Internet Information Services und eine Datenbank, in der die Daten, die zum Synchronisieren der Arbeit der Elektro- und Maschinenbauingenieure verwendet werden, gespeichert werden.

In Netzwerkumgebungen wird SOLIDWORKS PCB Services in der Regel auf einem Freigabeserver installiert, auf dem die SOLIDWORKS Software nicht ausgeführt wird. Es kann auch mit anderen SOLIDWORKS PCB-Komponenten auf einem einzelnen Computer installiert werden. SOLIDWORKS PCB Services muss fortwährend ausgeführt werden. Außerdem muss eine ununterbrochene, bidirektionale Kommunikation durch Firewalls und Virenscanner mit Clients vorliegen, auf denen SOLIDWORKS PCB und die SOLIDWORKS Software ausgeführt werden, sowie mit Clients, auf denen Altium Designer ausgeführt wird, die in die SOLIDWORKS Software integriert werden sollen.
Es wird empfohlen, dass Sie SOLIDWORKS PCB Services vor SOLIDWORKS PCB installieren.

Zusätzlich muss eine weitere Komponente, eine sogenannte SOLIDWORKS PCB Zusatzanwendung, auf Computern aktiviert sein, die die SOLIDWORKS Software ausführen. Sie können die Zusatzanwendung über Extras > Zusatzanwendungen aktivieren.

Elektroingenieure, die Altium Designer lizenziert haben, können auch über den Speicherort Konstruktionen mit Benutzern von SOLIDWORKS 3D-Konstruktionssoftware austauschen. Hierzu müssen diese Benutzer den SOLIDWORKS PCB Connector installieren. Diese Software wird vom Altium Designer-Client installiert.

Inhaltsverzeichnis

  • Voraussetzungen

  • Installieren von PCB Services mit SLDIM

  • Installieren von PCB mit SLDIM

  • Ändern der standardmäßigen Admin-Anmeldung

  • Installieren von PCB Connector für Altium Designer

  • Nach der Installation

  • Aktualisieren von PCB Services

  • Deinstallieren von PCB Services


Voraussetzungen

Vor dem Installieren müssen die folgenden Voraussetzungen vorhanden sein:
  • eine SOLIDWORKS PCB Seriennummer.
  • eine SOLIDWORKS PCB Connector Seriennummer für alle Altium Designer-Clients, die in die SOLIDWORKS Software integriert werden.

Die aktuellen Systemanforderungen finden Sie unter http://solidworks.com/System_Requirements.

Übergeordnetes Thema SOLIDWORKS PCB


Installieren von PCB Services mit SLDIM

So installieren Sie SOLIDWORKS PCB Services:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Auf der Seite Willkommen wählen Sie Server-Produkte aus.
  3. Wählen Sie dann SOLIDWORKS PCB Services auf diesem Computer installieren aus und klicken Sie auf Weiter.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Übernehmen Sie auf der Seite Zusammenfassung die Standardeinstellungen für SOLIDWORKS PCB Services oder klicken Sie auf Ändern, um die Einstellungen für folgende Optionen festzulegen:
    • Installationsort
    • Datenbankordner
    • Änderungsdateiordner
    • Anschlussnummer

    PCB Services umfasst Microsoft Internet Information Services und eine Datenbank, in der die Daten, die zum Synchronisieren der Arbeit der Elektro- und Maschinenbauingenieure verwendet werden, gespeichert werden.

    Die voreingestellte Portnummer lautet 9780.

  6. Akzeptieren Sie die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.
Übergeordnetes Thema SOLIDWORKS PCB


Installieren von PCB mit SLDIM

So installieren Sie SOLIDWORKS PCB:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Auf der Seite Willkommen wählen Sie Einzeln.
  3. Führen Sie die folgenden Schritte durch:
    1. Erweitern Sie Electrical Design.
    2. Wählen Sie SOLIDWORKS PCB aus und geben Sie die Seriennummer ein.
    3. Klicken Sie auf Weiter.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.
Übergeordnetes Thema SOLIDWORKS PCB


Ändern der standardmäßigen Admin-Anmeldung

SOLIDWORKS PCB Services bieten ein standardmäßiges Administrator-Konto mit den folgenden Anmeldeinformationen:
  • admin für Benutzername
  • admin für Passwort
Für mehr Sicherheit wird dringend empfohlen, die Anmeldeinformationen für dieses Konto zu ändern.

So ändern Sie die Standard-Anmeldeinformationen für das Admin-Konto:

  1. Öffnen Sie einen Webbrowser und geben Sie in das Adressfeld den Computernamen und die Portnummer im folgenden Format ein: http://Servername:Anschlussnummer.

    Die voreingestellte Portnummer lautet 9780.

  2. Geben Sie auf der Seite Bei SOLIDWORKS PCB Services anmelden den Benutzernamen admin und das Passwort admin ein und klicken Sie auf Anmelden.
  3. Klicken Sie im Menü SOLIDWORKS PCB Services auf Benutzer und dann auf die Registerkarte Benutzer.
  4. Klicken Sie auf den Link, der mit dem Admin-Konto verknüpft ist, oder klicken Sie auf das Symbol Benutzer bearbeiten [image].
  5. Ändern Sie die Benutzerinformationen wie den Benutzernamen und das Passwort.
  6. Klicken Sie auf Speichern.
Übergeordnetes Thema SOLIDWORKS PCB


Installieren von PCB Connector für Altium Designer

Altium Designer ist ein Werkzeug zum Konstruieren von PCBs (Leiterplatten). Benutzer, die Altium Designer installiert und lizenziert haben, können dieses Werkzeug durch die Installation von SOLIDWORKS PCB Connector in die SOLIDWORKS Software integrieren.

So installieren Sie SOLIDWORKS PCB Connector auf einem Computer mit Altium Designer:

  1. Melden Sie sich bei Ihrem Altium Konto an, wenn Sie nicht automatisch angemeldet werden.
  2. Starten Sie Altium Designer, öffnen Sie die Registerkarte DXP und klicken Sie auf Erweiterungen und Updates.
  3. Auf der Seite Erweiterungen und Updates klicken Sie auf die Registerkarte Erworben.
  4. Blättern Sie nach unten zum Abschnitt Software-Erweiterungen. Klicken Sie unter SOLIDWORKS PCB Connector auf den nach unten zeigenden Pfeil in der rechten oberen Ecke der Kachel, um den Download und die Installation zu starten.

  5. Klicken Sie im Dialogfeld Bestätigen auf Ja, um mit der Installation fortzufahren.
    Sie müssen Sie die Schritte 6 und 7 in der angegebenen Reihenfolge durchführen, um Aktivierungs- und Installationsprobleme zu vermeiden.
  6. Geben Sie auf der Seite PCB Connector Registration die Seriennummer von PCB Connector Registration ein und klicken Sie auf Registrieren.
  7. Klicken Sie im Dialogfeld Bestätigen, das von der Altium Designer-Anwendung angezeigt wird, auf Ja, um das System neu zu starten und die Installation abzuschließen, oder auf Nein, um die Installation später abzuschließen.

Um eine SOLIDWORKS PCB Connector Lizenz zu deaktivieren, klicken Sie im Menü Hilfe auf SOLIDWORKS PCB Connector Lizenzierung > Lizenzen deaktivieren.

Übergeordnetes Thema SOLIDWORKS PCB


Nach der Installation

Nach der Installation von SOLIDWORKS PCB und seiner Komponenten können Sie Benutzerkonten zu SOLIDWORKS PCB Services hinzufügen, damit Benutzer vom Speicherort aus auf Platinen zugreifen können.

Weitere Tasks schließen das Anmelden beim SOLIDWORKS PCB Add-in-Speicherort und das Deinstallieren der Software ein.

Inhaltsverzeichnis

  • Hinzufügen eines Benutzers zu PCB Services

  • Anmelden bei einem PCB-Speicherort

Übergeordnetes Thema SOLIDWORKS PCB


Hinzufügen eines Benutzers zu PCB Services

So fügen Sie einen Benutzer auf der SOLIDWORKS PCB Services Website hinzu:

  1. Öffnen Sie einen Webbrowser und geben Sie in das Adressfeld den Servernamen und die Anschlussnummer ein, die SOLIDWORKS PCB Services zugewiesen sind. Geben Sie diese in folgender Form ein: http://Servername:Anschlussnummer.
  2. Geben Sie auf der Seite Sign in to SOLIDWORKS PCB Services (Bei SOLIDWORKS PCB Services anmelden) Ihren Benutzernamen und Ihr Passwort ein und klicken Sie auf Anmelden.
  3. Klicken Sie im Menü SOLIDWORKS PCB Services auf Benutzer und dann auf die Registerkarte Benutzer.
  4. Klicken Sie auf die Schaltfläche Benutzer hinzufügen und geben Sie Folgendes ein:
    • Vorname
    • Nachname
    • Anwendername
    • Passwort
    • E-Mail-Adresse
    • Telefonnummer

    Sie müssen außerdem eine Benutzerrolle auswählen und das Kästchen Mitglied markieren, um den Benutzer mit einer Gruppe zu verknüpfen.

  5. Klicken Sie auf Speichern.
Sie können die Benutzerinformationen auf der Registerkarte Benutzer bearbeiten.
Übergeordnetes Thema Nach der Installation


Anmelden bei einem PCB-Speicherort

Wenn Sie in SOLIDWORKS eine neue Leiterplatte auswählen oder eine bestehende Leiterplatte aus dem Task-Fensterbereich PCB-Add-in abrufen, müssen Sie sich bei SOLIDWORKS PCB Services anmelden, um Zugriff auf den Speicherort zu erhalten.

So melden Sie sich beim SOLIDWORKS PCB Speicherort an:

  1. Klicken Sie im SOLIDWORKS Task-Fensterbereich auf die Schaltfläche SOLIDWORKS PCB Add-in [image].
  2. Klicken Sie auf Neue Leiterplatten-Baugruppe oder Leiterplatte aus Tresor abrufen.
  3. Melden Sie sich bei SOLIDWORKS PCB Services an:
    1. Geben Sie den Servernamen und die Anschlussnummer an, die SOLIDWORKS PCB Services zugewiesen wurden. Geben Sie diese in folgender Form ein: http://Servername:Anschlussnummer.
    2. Geben Sie Ihren Benutzernamen und ein Passwort ein und klicken Sie auf OK.
Übergeordnetes Thema Nach der Installation


Aktualisieren von PCB Services

Bei einem Upgrade auf SOLIDWORKS PCB Services auf 2019 aktualisiert der SOLIDWORKS Installations-Manager die Firebird-Datenbank von Version 2.0 auf 3.0 und migriert Ihre Daten automatisch. Vor dem Upgrade sollte Sie eine manuelle Sicherung der Datenbank erstellen.

So aktualisieren Sie SOLIDWORKS PCB Services:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Auf der Seite Willkommen wählen Sie Server-Produkte aus.
  3. Wählen Sie dann „SOLIDWORKS PCB Services auf diesem Computer aktualisieren“ aus und klicken Sie auf Weiter.

    Die folgende Meldung wird angezeigt: SOLIDWORKS PCB Services erfordert ein Upgrade Ihrer Firebird-Datenbank. Wenn Sie fortfahren, wird ein Upgrade der Firebird-Software und der Datenbank ausgeführt.

  4. Klicken Sie auf Weiter.
  5. Übernehmen Sie auf der Seite Zusammenfassung die Standardeinstellungen oder klicken Sie auf Ändern, um andere Einstellungen festzulegen.
  6. Akzeptieren Sie die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.
Übergeordnetes Thema SOLIDWORKS PCB


Deinstallieren von PCB Services

So deinstallieren Sie SOLIDWORKS PCB Services:

  1. Klicken Sie auf Start > Alle Programme > SOLIDWORKS Version > SOLIDWORKS PCB Services > SOLIDWORKS PCB Services deinstallieren.
  2. Wenn Sie aufgefordert werden, SOLIDWORKS PCB Services und seine Komponenten zu entfernen, klicken Sie auf Ja.
  3. Wenn Sie zum Löschen aller SOLIDWORKS PCB Services Daten aufgefordert werden, klicken Sie auf Nein.
    Sie müssen auf Nein klicken, um zu verhindern, dass alle Daten und Revisionsdateien unwiederbringlich gelöscht werden.
Übergeordnetes Thema SOLIDWORKS PCB


SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize (früher als Bunkspeed bekannt) bietet eine Suite aus eigenständigen Softwarewerkzeugen, die branchenführende Rendering-Kapazitäten mit designorientierten Funktionen und Workflows verbinden, damit Sie äußerst realistische Bilder von 3D-CAD-Modellen erstellen können.

SOLIDWORKS Visualize Produkte sind in zwei Paketen verfügbar:
  • Standard
  • Professional

Eine Liste der aktuellen Komponenten in jeder Version der SOLIDWORKS Visualize Software finden Sie unter solidworks.com. Suchen Sie dort nach dem SOLIDWORKS Visualize Datenblatt.

Eine kostenlose Lizenz von SOLIDWORKS Visualize Standard ist bei jedem aktiven Abonnement von SOLIDWORKS 2019 Professional und Premium enthalten. Um die kostenlose Version zu aktivieren, benötigen Sie eine zusätzliche Seriennummer, die Sie ermitteln können, indem Sie sich im SOLIDWORKS Kundenportal anmelden und auf Meine Produkte klicken. Sie können nicht mehr Ihre SOLIDWORKS Professional oder Premium Seriennummer zum Aktivieren der kostenlosen Version von SOLIDWORKS Visualize Standard verwenden.

SOLIDWORKS Visualize unterstützt auch SolidNetWork Licensing (SNL)-Lizenztypen wie Netzwerklizenzen sowie die Offline-Aktivierung.

Mit dem SOLIDWORKS Installation Manager (SLDIM) können Sie SOLIDWORKS Visualize im Rahmen der individuellen Installation installieren. Sie können es als eigenständige Anwendung installieren. Dies ist von Vorteil, wenn Sie separate Computer für Modellierung und Rendering nutzen möchten. Es verbraucht keine SOLIDWORKS Lizenz.

SOLIDWORKS Visualize Boost ist ein Dienst, mit dem Sie ein Rendering von einem Computer, auf dem SOLIDWORKS Visualize Professional ausgeführt wird, auf mehrere Computer im Netzwerk verteilen können. Sie können andere Aufgaben auf Ihrem Computer ausführen, während das Rendering durchgeführt wird, und das fertig gerenderte Bild wird schneller verfügbar gemacht. Bilder können auf einem einzelnen Computer oder in einem Cluster mit mehreren Computern, auf denen Visualize Boost ausgeführt wird, gerendert werden.

Eine kostenlose Lizenz von SOLIDWORKS Visualize Boost ist bei jedem aktiven Abonnement von SOLIDWORKS Visualize Professional 2019 enthalten.
Visualize Boost ist ein Produkt-Add-on nur für Visualize Professional. Mit Visualize Standard funktioniert Visualize Boost nicht.

Sie sollten Visualize Boost auf einem anderen Computer als dem installieren, auf dem SOLIDWORKS Visualize Professional ausgeführt wird. Sie können Visualize Boost auch als Teil der Einzelinstallation im SLDIM installieren.

Inhaltsverzeichnis

  • Voraussetzungen und Systemanforderungen

  • Installieren von SOLIDWORKS Visualize mit SLDIM

  • Installieren von Visualize Boost mit SLDIM


Voraussetzungen und Systemanforderungen

Vor der Installation von SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost ist für jede Maschine Folgendes erforderlich:
  • eine SOLIDWORKS Visualize Seriennummer
  • eine SOLIDWORKS Visualize Boost Seriennummer
Alle Computer, auf denen SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost ausgeführt werden, müssen die folgenden Anforderungen erfüllen:
  • Windows® 7 oder höher (64-Bit)
  • Dual Core-CPU; Quad Core empfohlen
  • 8 GB RAM; 16 GB empfohlen
  • 2 GB freier Speicherplatz; 5 GB empfohlen
  • 2 GB oder mehr GPU-RAM; 4 GB empfohlen
  • NVIDIA®-Grafikkarte: NVIDIA Quadro®/NVIDIA GeForce®/Tesla™ mit mindestens NVIDIA Kepler™-Chip; Dual-GPU-Setup mit mindestens NVIDIA Maxwell™-Karten für das beste Erlebnis
  • NVIDIA-Treiberversion 385.41 (oder höher) empfohlen
  • NVIDIA-Treiberunterstützung für CUDA® 9.0 oder höher erforderlich
  • HDR Light Studio-Verbindung: HDR Light Studio V5.3.3 oder höher, außer V5.4
  • 4 GB Videospeicher oder mehr für Denoiser-Funktion erforderlich
Wenn Nicht-NVIDIA-Grafikkarten installiert sind, nutzt SOLIDWORKS Visualize standardmäßig die CPU und verwendet diese Karten nicht zur GPU-Beschleunigung. Außerdem unterstützen auf Fermi™-Architektur basierende NVIDIA-Karten keine GPU-Beschleunigung mehr.
Übergeordnetes Thema SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost


Installieren von SOLIDWORKS Visualize mit SLDIM

So installieren Sie SOLIDWORKS Visualize:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Auf der Seite Willkommen wählen Sie Einzeln.
  3. Führen Sie die folgenden Schritte durch:
    1. Auf der Seite Seriennummer erweitern Sie Visualisierung.
    2. Wählen Sie SOLIDWORKS Visualize aus und geben Sie die Seriennummer ein.
    3. Klicken Sie auf Weiter.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.

Doppelklicken Sie auf das SOLIDWORKS Visualize Verknüpfungssymbol auf dem Desktop, um die Anwendung zu starten, oder klicken Sie im Windows-Menü Start auf Alle Programme > SOLIDWORKS Version > SOLIDWORKS Visualize Version.

Inhaltsverzeichnis

  • Aufgaben nach der Installation

Übergeordnetes Thema SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost


Aufgaben nach der Installation

Nach der Installation müssen einige Aufgaben zur Einrichtung von SOLIDWORKS Visualize ausgeführt werden.

Inhaltsverzeichnis

  • Erstellen des Inhaltsordners

  • Auswählen eines Rendering-Modus

  • Zugriff auf die Hilfe, Lehrbücher, Systeminformationen und Lizenzen

Übergeordnetes Thema Installieren von SOLIDWORKS Visualize mit SLDIM


Erstellen des Inhaltsordners

Wenn Sie die Software zum ersten Mal auszuführen, fragt SOLIDWORKS Visualize Sie nach einem Speicherort, um einen Ordner Inhalt zu erstellen.

Der Ordner Inhalt enthält folgende Unterordner, wo Sie Ressourcen für Ihre Projekte speichern können:
Unterordner | Speichert
Kameras | Standardmäßige Kameras und Kameras, die Sie gespeichert haben
Umgebungen | HDR-Bilder (High Dynamic Range)
Paletten | Exportierte Palettendateien
Bilder | Renderings und Schnappschüsse
Erscheinungsbilder | Materialien in Ihrer Erscheinungsbild-Bibliothek Der Inhalt wird aktualisiert, wenn Sie ein Erscheinungsbild zur Bibliothek hinzufügen.
Modelle | Modelldateien Standardmäßig sucht SOLIDWORKS Visualize diesen Ordner zuerst, wenn Sie Datei > Importieren für ein Modell verwenden.
Platten | Standardmäßige 2D-Bilder zur Verwendung in Hintergrundbildern
Projekte | Native Projektdateien im Format .SVP
Texturen | 2D-Texturen zur Verwendung in Erscheinungsbildern
Übergeordnetes Thema Aufgaben nach der Installation


Auswählen eines Rendering-Modus

Verschiedene Systeme können mit jedem Rendering-Modus unterschiedliche Ergebnisse erzeugen. Versuchen Sie jeden Rendering-Modus, bevor Sie den Modus festlegen, der sich am besten für Sie eignet.

So wählen Sie einen Rendering-Modus :

  1. Klicken Sie auf Extras > Optionen > 3D-Viewport.
  2. Unter Gerät rendern deaktivieren Sie Automatisch.
  3. Wählen Sie einen Rendering-Modus :
    • CPU, wenn die CPU wesentlich leistungsfähiger als die Grafikkarte ist.
    • GPU, wenn Sie über eine leistungsfähige Videokarte verfügen, wie z. B. eine nVidia CUDA-aktivierte GPU mit mehr als 1 GB VRAM.
    • Hybrid, wenn Sie über ein ausgeglichenes System mit einer guten nVidia-Karte und einer vergleichbaren CPU verfügen.

Weitere Informationen hierzu finden Sie unter Erste Schritte.

Übergeordnetes Thema Aufgaben nach der Installation


Zugriff auf die Hilfe, Lehrbücher, Systeminformationen und Lizenzen

Das Menü „Hilfe“ enthält Dokumentationen und Optionen zur Aktualisierung der Software sowie zur Fehlerbehebung in Ihrem System.

Visualize Hilfe | Öffnet die SOLIDWORKS Visualize Online-Hilfe.
Visualize Lehrbücher | Öffnet MySolidWorks für den Zugriff auf die SOLIDWORKS Visualize Lehrbücher.
Versionshinweise | Zeigt Online-Versionshinweise für die aktuelle Version an.
Neue Funktionen | Zeigt die neuen Funktionen für SOLIDWORKS Produkte an.
Hotkeys | Führt die Tastenkombinationen auf.
Systeminformationen | Führt eine Systemprüfung für die SOLIDWORKS Visualize Software mit Ihrer PC-Hardware durch und schlägt bei Bedarf Upgrades vor.
Lizenz aktivieren | (Arbeitsplatzgebundene Lizenzen) Verwendet den SOLIDWORKS Produktaktivierungsassistenten zur Aktivierung des Produkts.
Lizenz deaktivieren | (Arbeitsplatzgebundene Lizenzen) Verwendet den SOLIDWORKS Produktaktivierungsassistenten zur Deaktivierung des Produkts.
SolidNetWork License Manager | Verwendet den SOLIDWORKS Produktaktivierungsassistenten zur Deaktivierung des Produkts.
Info zu Visualize | Zeigt die Versionsnummer und Lizenzinformationen Ihres Exemplars von SOLIDWORKS Visualize.
Übergeordnetes Thema Aufgaben nach der Installation


Installieren von Visualize Boost mit SLDIM

Sie installieren Visualize Boost mit dem SOLIDWORKS Installations-Manager. Es erfordert eine separate Seriennummer.

Da der Zweck von Visualize Boost darin besteht, das Rendering auszulagern, sollten Sie Visualize Boost auf Computern installieren, auf denen SOLIDWORKS Visualize Professional nicht ausgeführt wird. Die Rendering-Leistung kann maximiert werden, indem Sie Visualize Boost auf Computern mit mehreren CPU-Kernen und Grafikprozessoren (GPUs) installieren.

So installieren Sie SOLIDWORKS Visualize Boost:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Auf der Seite Willkommen wählen Sie Einzeln.
  3. Führen Sie die folgenden Schritte durch:
    1. Auf der Seite Seriennummer erweitern Sie Visualisierung.
    2. Wählen Sie SOLIDWORKS Visualize Boost aus und geben Sie die Seriennummer ein.
    3. Klicken Sie auf Weiter.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.

Doppelklicken Sie auf das SOLIDWORKS Visualize Boost Verknüpfungssymbol auf dem Desktop, um die Oberfläche zu öffnen.

Inhaltsverzeichnis

  • Aktivieren der Visualize Boost Lizenz

    Sie müssen SOLIDWORKS Visualize Boost über eine Internetschnittstelle aktivieren und konfigurieren, bevor Sie das Produkt zum Rendern verwenden können. Die Browser Chrome, Firefox und Internet Explorer werden unterstützt.

  • Konfigurieren von Visualize Boost

Übergeordnetes Thema SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost


Aktivieren der Visualize Boost Lizenz

Sie müssen SOLIDWORKS Visualize Boost über eine Internetschnittstelle aktivieren und konfigurieren, bevor Sie das Produkt zum Rendern verwenden können. Die Browser Chrome, Firefox und Internet Explorer werden unterstützt.

Nach dem Aktivieren und Konfigurieren von Visualize Boost wird es automatisch beim Systemstart gestartet und im Hintergrund ausgeführt. Keine weiteren Schritte erforderlich.

So aktivieren Sie die SOLIDWORKS Visualize Boost Lizenz:

  1. Wählen Sie eine der folgenden Optionen aus:
    1. Doppelklicken Sie von Ihrem Desktop aus auf das Verknüpfungssymbol Visualize Boost.
    2. Öffnen Sie ein Browserfenster und geben Sie folgende URL ein: http://localhost:8993/config.html.
  2. Geben Sie eine E-Mail-Adresse ein und klicken Sie auf Lizenz aktivieren.
Übergeordnetes Thema Installieren von Visualize Boost mit SLDIM


Konfigurieren von Visualize Boost

Für die meisten Netzwerke sind die Standardeinstellungen ausreichend, um einen Computer für Visualize Boost zu konfigurieren, aber wenn Ihre Netzwerkumgebung andere Einstellungen erfordert, führen Sie die folgenden Schritte aus, um den Computer manuell zu konfigurieren.

So konfigurieren Sie einen Computer als Teil eines Rendering-Clusters in Visualize Boost:

  1. Wählen Sie eine der folgenden Optionen aus:
    1. Wenn auf Ihrem System SOLIDWORKS Visualize Boost ausgeführt wird, doppelklicken Sie auf das Visualize Boost Verknüpfungssymbol auf dem Desktop oder öffnen Sie ein Browserfenster und geben folgende URL ein: http://localhost:8993/config.html.
    2. Wenn Sie auf einem anderen System arbeiten, öffnen Sie einen Browser und geben Sie folgende URL ein: http://<IP Address>:8993/config.html oder http://<DNS name>:8993/config.html.
  2. Wählen Sie Ihre Sprache in der Dropdown-Liste in der rechten oberen Ecke der Anzeige aus.
  3. Klicken Sie auf die Registerkarte Setup zum Konfigurieren des Visualize Boost-Knotens.
  4. Geben Sie im Feld Cluster-Name einen Computernamen wie Superschnelles Rendering, Präsentations-Cluster oder Computer 4. Stock ein.

    Der Cluster-Name wird in SOLIDWORKS Visualize Professional als Cluster-Profil angezeigt. Um ein Bild zu rendern, wählen Benutzer, die SOLIDWORKS Visualize Professional ausführen, ein Cluster-Profil aus einer Liste der verfügbaren Boost Cluster aus.

    Es wird empfohlen, dass Sie den Cluster-Namen auf dem Visualize Boost Computer angeben und nicht lokal auf dem Visualize Professional Computer, damit alle Visualize Benutzer in ihrer Liste der Visualize Boost Profile Zugriff auf dieselben Cluster-Namen haben.
  5. Geben Sie den Cluster-Client-Zugriffsanschluss ein.
    Dies ist der Port, den Computer, auf denen SOLIDWORKS Visualize ausgeführt wird, zum Verbinden mit dem Boost Cluster verwenden. Der standardmäßige Cluster-Client-Zugriffsanschluss ist 8998.
  6. Wählen Sie im Bereich Netzwerkmodus eine Option basierend auf Ihrer Netzwerkumgebung aus:
    • Wählen Sie Kein Netzwerkbetrieb aus, um zu verhindern, dass dieser Computer zu einem anderen Cluster gehört. Dieser Modus ist nützlich zum Beheben von Fehlern mit Visualize Boost.
    • Wählen Sie UDP Multicast-Modus aus, wenn Ihr Netzwerk UDP Multicast unterstützt. Visualize Boost durchsucht das Netzwerk und bildet einen Cluster mit allen Computern, die den UDP Multicast-Modus an demselben Port verwenden. Dieser Modus wird empfohlen, wenn er von Ihrem Netzwerk unterstützt wird.
    • Wählen Sie TCP-Modus mit Discovery (Standard) aus, wenn Sie den UDP Multicast-Modus nicht verwenden können. Visualize Boost durchsucht das Netzwerk und bildet einen Cluster mit allen Computern, die den TCP-Modus mit Discovery an demselben Port verwenden.
    • Wählen Sie den TCP-Modus aus, wenn Sie eine explizite Liste der Computer im Cluster erstellen müssen, da die anderen Modi bei der Ermittlung der Computer, die Sie einschließen möchten, nicht erfolgreich sind. Dieser Modus erfordert einen zusätzlichen Konfigurationsaufwand und wird nicht empfohlen, wenn der UDP Multicast- oder der TCP-Modus mit Discovery verfügbar ist.
  7. Wenn Sie UDP Multicast-Modus oder TCP-Modus mit Discovery auswählen, geben Sie die Cluster-Discovery-Adresse ein.
    Diese Einstellungen müssen eine IP-Adresse und ein Port über 1024 sein. Der voreingestellte Port variiert je nach Netzwerkmodus:
    • 8994 für UDP Multicast
    • 8995 für den TCP-Modus mit Discovery
    • 8996 für TCP

    Diese Ports werden verwendet, damit Visualize Boost Computer miteinander verbunden werden können. Alle Computer, die mit derselben Cluster-Discovery-Adresse konfiguriert sind und die sich in demselben lokalen Netzwerk befinden, bilden einen Cluster.

  8. Gehen Sie bei Auswahl von TCP-Modus folgendermaßen vor:
    • Geben Sie einen Cluster-Zugriffsanschluss ein. Dies ist der Anschluss, den Visualize Boost Knoten im Cluster verwenden, um miteinander zu kommunizieren. Der Standardanschluss für den TCP-Modus lautet 8996.
    • Wenn diese Maschine der „Kopf-Knoten“ des Clusters ist (der Computer, der die Arbeit des Clusters koordiniert), verwenden Sie das Feld Cluster-Adressenliste, um die IP-Adressen anderer Knoten im Cluster aufzulisten. Jede IP-Adresse (z. B. 192.168.0.100 :8996) muss den Cluster-Zugriffsanschluss enthalten, der für alle Knoten im Cluster konfiguriert ist. Lassen Sie das Feld leer, wenn dieser Computer nicht der Kopfknoten des Clusters ist.
  9. Klicken Sie auf Konfiguration speichern. Visualize Boost speichert die neue Konfiguration, hält den Dienst dann an und startet ihn erneut.
  10. Klicken Sie auf die Registerkarte Status. Wenn der Status Bereit lautet, werden auf dem Bildschirm die mit dem Cluster verbundenen Computer und die dem Cluster zugewiesenen Sitzungen (Jobs) angezeigt.
Übergeordnetes Thema Installieren von Visualize Boost mit SLDIM


SOLIDWORKS Admin Portal und Online-Lizenzierung

Das SOLIDWORKS Admin Portal ist ein Cloud-basiertes Ressourcen- und Servicemanagement-System, mit dem Sie Online-Lizenzen zuweisen und verwalten können.

Das Admin Portal erleichtert Ihnen, SOLIDWORKS Online-Lizenzen zu überwachen, Mitglieder zu einem Konto einzuladen, Mitgliedern Produkte und Services zuzuweisen und neue Administratoren zu erstellen. Sie können auch Benutzer aus Lizenzen entfernen, selbst wenn sich diese Benutzer an entfernten Standorten befinden.

SOLIDWORKS Benutzer können mit der Online-Lizenzierung eine SOLIDWORKS Lizenz flexibel auf allen Geräten und an allen Standorten verwenden, ohne die Lizenzen auf jedem Computer manuell aktivieren und deaktivieren zu müssen. Zur Anmeldung und Verwendung von Online-Lizenzen müssen Sie über einen Internetzugang verfügen. Nach der Anmeldung können Sie aber den Offline-Modus auswählen und arbeiten, während das Gerät nicht mit einem Netzwerk verbunden ist.

Inhaltsverzeichnis

  • Zugriff auf das Admin Portal

    Sie müssen über eine SOLIDWORKS ID und ein MySolidWorks Gast-, Standard- oder Professional-Konto verfügen, um auf das Admin Portal zuzugreifen.

  • Administratoraufgaben

    Administratoren sind in der Regel für die Verwaltung von Benutzerkonten und Online-Lizenzen verantwortlich.

  • SOLIDWORKS Produkte mit Online-Lizenzierung verwenden

  • Zugriff auf das CAD Admin Dashboard

    Wenn Sie über einen SOLIDWORKS Subskriptionsvertrag verfügen, können Sie über das Admin Portal auf das SOLIDWORKS CAD Admin Dashboard zugreifen, ohne sich erneut anzumelden.


Zugriff auf das Admin Portal

Sie müssen über eine SOLIDWORKS ID und ein MySolidWorks Gast-, Standard- oder Professional-Konto verfügen, um auf das Admin Portal zuzugreifen.

Jeder kommerzielle Kunde mit einer gültigen SOLIDWORKS ID kann sich unabhängig vom Abonnementstatus bei MySolidWorks.com anmelden und mit einer entsprechenden Berechtigung auf das Admin Portal zugreifen.

Zugreifen auf das Admin Portal:

  1. Melden Sie sich bei MySolidWorks.com an.
  2. Erweitern Sie die Liste unter Ihrem Profilnamen und klicken Sie auf Admin Portal.
Übergeordnetes Thema SOLIDWORKS Admin Portal und Online-Lizenzierung
Administratoraufgaben
SOLIDWORKS Produkte mit Online-Lizenzierung verwenden
Zugriff auf das CAD Admin Dashboard


Administratoraufgaben

Administratoren sind in der Regel für die Verwaltung von Benutzerkonten und Online-Lizenzen verantwortlich.

Standardmäßig ist die SOLIDWORKS Software so eingerichtet, dass die Computeraktivierung verwendet wird. Die grundlegenden Schritte zur Aktivierung der Online-Lizenzierung mit dem Admin Portal sind:
  1. Wenn die SOLIDWORKS Software bereits auf einem Computer installiert ist, deaktivieren Sie die Lizenz manuell.
  2. Ändern Sie den Aktivierungstyp eines Produkts von der Computeraktivierung auf die Online-Lizenzierung.
  3. Weisen Sie dann den Mitgliedern (Benutzern) Produkte und Services zu.

Inhaltsverzeichnis

  • Erstes Administratorkonto erstellen

    Wenn Sie als erste Person auf ein Konto im Admin Portal zugreifen, können Sie sich als erster Administrator einrichten, wenn Folgendes gegeben ist:

  • Produkte und Services verwalten

  • Mitglieder und Lizenzen verwalten

  • Produkte zur Nutzung der Online-Lizenzierung festlegen

    Standardmäßig ist die SOLIDWORKS Software so eingerichtet, dass die Computeraktivierung verwendet wird. Wenn die SOLIDWORKS Software auf einem Computer installiert ist, müssen Sie die Lizenz manuell deaktivieren und dann den Aktivierungstyp ändern, um die Online-Lizenzierung zu verwenden.

  • Benutzer zum Administrator hochstufen

    Wenn ein Konto über Administratoren verfügt, zeigt das Admin Portal Kontaktinformationen für die Administratoren an. Sie können sie kontaktieren und beantragen, Administrator für das Konto zu werden.

  • SOLIDWORKS Kundenportal – Registrierung meiner Produkte

    Sobald für Ihr Unternehmen ein Administrator ernannt wurde, können Produkte des Unternehmens nicht mehr im SOLIDWORKS Kundenportal registriert werden.

Übergeordnetes Thema SOLIDWORKS Admin Portal und Online-Lizenzierung
Zugriff auf das Admin Portal
SOLIDWORKS Produkte mit Online-Lizenzierung verwenden
Zugriff auf das CAD Admin Dashboard


Erstes Administratorkonto erstellen

Wenn Sie als erste Person auf ein Konto im Admin Portal zugreifen, können Sie sich als erster Administrator einrichten, wenn Folgendes gegeben ist:

  • Das Konto ist Ihr Hauptkonto.
  • Das Konto enthält Ressourcen.
  • Sie haben ein Produkt für das Konto registriert.

Wenn Sie nicht mit dem Konto verknüpft sind oder wenn das Konto keine Ressourcen hat, wenden Sie sich an das SOLIDWORKS Kundenzentrum.

So weisen Sie sich als ersten Administrator eines Kontos zu:

  1. Melden Sie sich bei MySolidWorks.com an, erweitern Sie die Liste unter ihrem Profilnamen und wählen Sie Admin Portal aus.

    Auf der Willkommensseite werden Sie informiert, dass aktuell keine Administratoren verfügbar sind.

  2. Prüfen und akzeptieren Sie die Bedingungen und Verantwortlichkeiten für die Verwaltung der SOLIDWORKS Produktlizenzzuweisungen.
  3. Klicken Sie auf Mich zum Administrator hochstufen.
Übergeordnetes Thema Administratoraufgaben
Produkte und Services verwalten
Mitglieder und Lizenzen verwalten
Produkte zur Nutzung der Online-Lizenzierung festlegen
Benutzer zum Administrator hochstufen
SOLIDWORKS Kundenportal – Registrierung meiner Produkte


Produkte und Services verwalten

Das Admin Portal enthält eine Registerkarte Produkte und eine Registerkarte Services. Auf der Registerkarte Produkte können Sie Produkte zuweisen und aktivieren. Auf der Registerkarte Services können Sie Mitgliedern Services wie E-Learning-Kurse und MySolidWorks Pro zuweisen.

Im Gegensatz zu Produkten können Services nicht übertragen werden. Sobald Sie einem Mitglied einen Service zugewiesen haben, können Sie den Service diesem Mitglied nicht mehr entziehen.

Die Verwaltung von Produkten ist für Produkte mit Computeraktivierung, z. B. Netzwerklizenzprodukte, optional.

Sie können Mitglieder benennen und ihnen Produkte zuweisen, um die folgenden Vorteile zu erzielen:
  • Mitglieder können die ihnen zugewiesenen Seriennummern über die Anmeldefunktion im Installationsmanager installieren.
  • Wenn Sie Mitgliedern Abonnementprodukte zuweisen, erhalten sie Online-Zugang auf Abonnementinhalte.

Für Produkte mit Computeraktivierung müssen Sie jedoch keine Mitglieder benennen und ihnen Produkte zuweisen. Der Zugriff auf Computeraktivierungsprodukte erfolgt unabhängig von der Zuweisung im Admin Portal über einen Lizenzserver oder Aktivierungsereignisse. In größeren Unternehmen werden Sie wahrscheinlich nicht alle Mitglieder und deren Produkte verwalten.

Die Verwaltung von Produkten ist für die Online-Lizenzierung erforderlich. Ebenso müssen Services benannten Mitgliedern zugewiesen werden.

Übergeordnetes Thema Administratoraufgaben
Erstes Administratorkonto erstellen
Mitglieder und Lizenzen verwalten
Produkte zur Nutzung der Online-Lizenzierung festlegen
Benutzer zum Administrator hochstufen
SOLIDWORKS Kundenportal – Registrierung meiner Produkte


Mitglieder und Lizenzen verwalten

Inhaltsverzeichnis

  • Neue Mitglieder zu einem Konto einladen

    Administratoren können neue Mitglieder zu einem Konto einladen.

  • Mitglieder aus Konten entfernen

    Vor dem Entfernen eines Mitglieds müssen Administratoren zunächst alle dem Konto des Mitglieds zugewiesenen Produkte entfernen.

  • Produkte zu Mitgliedern zuweisen

    Administratoren können ein Mitglied nur einem Produkt pro Produkttyp zuweisen. Einem Mitglied kann beispielsweise nur ein CAD-Produkt und nur ein Simulation-Produkt zugewiesen werden.

  • Zuweisen von Mitgliedern zu Produkten

  • Services zu Mitgliedern zuweisen

  • Lizenzen von Mitgliedern entfernen

    Sie können Produkte von einem Mitglied entfernen.

  • Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen

    Das Admin Portal bietet verschiedene Möglichkeiten, um einen Benutzer zu finden und dessen Benutzerrechte und die jeweils zugewiesenen Produkte zu überwachen.

  • Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen

    Das Admin Portal bietet verschiedene Möglichkeiten, um Produkte zu finden und zu überwachen, welche Benutzer ihnen jeweils zugewiesen sind.

  • Entfernen der Produkte von externen Mitgliedern

    Externe Mitglieder sind Personen außerhalb Ihrer Organisation, die eines Ihrer Produkte registriert haben. Über das Admin Portal können Sie sie identifizieren und von Ihrem Produkt entfernen.

  • Zahnradmenü für Abfragen verwenden

    Das Zahnradmenü enthält Befehle zum Erstellen und Optimieren von Abfragen.

Übergeordnetes Thema Administratoraufgaben
Erstes Administratorkonto erstellen
Produkte und Services verwalten
Produkte zur Nutzung der Online-Lizenzierung festlegen
Benutzer zum Administrator hochstufen
SOLIDWORKS Kundenportal – Registrierung meiner Produkte


Neue Mitglieder zu einem Konto einladen

Administratoren können neue Mitglieder zu einem Konto einladen.

So laden Sie neue Mitglieder ein:

  1. Klicken Sie auf die Registerkarte Mitglieder.
  2. Klicken Sie auf Mitglied einladen.
  3. Geben Sie die E-Mail-Adressen der einzuladenden Mitglieder ein.
    Sie können mehrere Benutzer mit einer E-Mail einladen, indem Sie ihre E-Mail-Adressen, getrennt durch Semikolons (;) in das Adressfeld eingeben.
  4. Wählen Sie Mitglied oder Admin für die Ebene der Benutzerrechte aus.
  5. Bearbeiten Sie den Text in der Einladung, falls erforderlich, und klicken Sie auf Einladung senden.
Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Mitglieder aus Konten entfernen
Produkte zu Mitgliedern zuweisen
Zuweisen von Mitgliedern zu Produkten
Services zu Mitgliedern zuweisen
Lizenzen von Mitgliedern entfernen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Entfernen der Produkte von externen Mitgliedern
Zahnradmenü für Abfragen verwenden


Mitglieder aus Konten entfernen

Vor dem Entfernen eines Mitglieds müssen Administratoren zunächst alle dem Konto des Mitglieds zugewiesenen Produkte entfernen.

So entfernen Sie ein Mitglied aus einem Konto:

  1. Klicken Sie auf die Registerkarte Mitglieder.
  2. Wählen Sie durch Klicken auf eine Zeile in der Liste Mitglieder einen Namen aus.

    Mit den Navigationssteuerelementen unten können Sie im Datensatzset vorwärts oder rückwärts navigieren. Sie können auch im Fenster Mitglieder suchen nach einem Mitglied suchen.

  3. Entfernen Sie auf der Seite Mitgliedsdetails alle Produkte in der Liste Zugewiesene Produkte, indem Sie auf Produkt entfernen klicken.
  4. Klicken Sie unter Mitgliedsdetails auf Mitglied entfernen und klicken Sie dann zum Bestätigen auf OK.
Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Produkte zu Mitgliedern zuweisen
Zuweisen von Mitgliedern zu Produkten
Services zu Mitgliedern zuweisen
Lizenzen von Mitgliedern entfernen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Entfernen der Produkte von externen Mitgliedern
Zahnradmenü für Abfragen verwenden


Produkte zu Mitgliedern zuweisen

Administratoren können ein Mitglied nur einem Produkt pro Produkttyp zuweisen. Einem Mitglied kann beispielsweise nur ein CAD-Produkt und nur ein Simulation-Produkt zugewiesen werden.

Ausstehenden Mitgliedern können keine Produkte zugewiesen werden.

So weisen Sie einem Mitglied ein Produkt zu:

  1. Klicken Sie auf die Registerkarte Mitglieder.
  2. Wählen Sie durch Klicken auf eine Zeile in der Liste Mitglieder einen Namen aus.

    Mit den Navigationssteuerelementen unten in der Liste können Sie im Datensatzset vorwärts oder rückwärts navigieren. Sie können auch im Fenster Mitglieder suchen nach einem Mitglied suchen.

    Auf der Seite „Mitgliedsdetails“ sind die zugewiesenen Produkte und die verfügbaren Produkte aufgeführt, die nicht zugewiesen sind.

  3. Markieren Sie ein Produkt unter Verfügbare Produkte.

    Sie können einem Mitglied jeweils nur ein Produkt zuweisen. Das erste Element in der Liste ist standardmäßig ausgewählt. Wenn das Produkt, das Sie zuweisen möchten, nicht das erste in der Liste ist, löschen Sie dieses Element und wählen Sie das richtige Element aus.

    Sie können basierend auf mehreren Faktoren filtern, um nur folgende Produkte anzuzeigen:
    • Produkte mit einem aktuellen oder abgelaufenen Abonnement
    • Zugewiesen oder nicht zugewiesene Produkte
    • Aktivierte oder nicht aktivierte oder für die Online-Lizenzierung aktivierte Produkte
    • Zu einem oder mehreren Produkttypen gehörende Produkte
    Sie können auch Filter auf Basis eines Produktnamens oder einer Seriennummer anwenden.

    Wenn Sie einen Produktnamen auswählen, wird die Seite „Produktdetails“ angezeigt. Klicken Sie im Browser auf Zurück, um zur Seite „Mitgliedsdetails“ zurückzukehren.

  4. Klicken Sie auf Produkt zuweisen.

    Das Produkt wird im Admin Portal zur Liste der zugewiesenen Produkte des Mitglieds hinzugefügt.

    Sie können den Produkten auch auf der Seite „Produktdetails“ Mitglieder zuweisen.
Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Mitglieder aus Konten entfernen
Zuweisen von Mitgliedern zu Produkten
Services zu Mitgliedern zuweisen
Lizenzen von Mitgliedern entfernen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Entfernen der Produkte von externen Mitgliedern
Zahnradmenü für Abfragen verwenden


Zuweisen von Mitgliedern zu Produkten

So ordnen Sie ein Mitglied einem Produkt zu:

  1. Klicken Sie auf die Registerkarte Produkte.

    Auf der Seite „Produktdetails“ werden die verfügbaren Mitglieder aufgeführt, die dem Produkt nicht zugewiesen sind.

  2. Markieren Sie ein Produkt unter Verfügbare Produkte.
  3. Um ein Mitglied zu finden, können Sie verfügbare Mitglieder basierend auf Vorname, Nachname, E-Mail und Produkttyp filtern.
  4. Klicken Sie auf Mitglied zuweisen.

Im Abschnitt Zugewiesene Produkte der Registerkarte Mitglieder können Mitgliedern auch Produkte zugeordnet werden.

Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Mitglieder aus Konten entfernen
Produkte zu Mitgliedern zuweisen
Services zu Mitgliedern zuweisen
Lizenzen von Mitgliedern entfernen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Entfernen der Produkte von externen Mitgliedern
Zahnradmenü für Abfragen verwenden


Services zu Mitgliedern zuweisen

Administratoren können den Mitgliedern Services zuweisen. Beispiele für Services sind MySolidWorks Professional- und E-Learning-Kurse. Im Gegensatz zu Produkten können Services nicht übertragen werden. Wenn Sie einem Mitglied einen Service zugewiesen haben, können Sie den Service nicht von diesem Mitglied entfernen.

So weisen Sie Mitgliedern Services zu:

  1. Klicken Sie auf die Registerkarte Mitglieder.
  2. Suchen Sie im Bereich Mitglieder suchen nach einem Mitglied oder klicken Sie in der Liste auf einen Benutzernamen.
  3. Klicken Sie auf der Seite Mitglieder unter „Mitgliedsdetails“ auf Services.

    Auf der Registerkarte Services sind die dem Mitglied zugewiesenen Services sowie die verfügbaren Services aufgeführt, die nicht zugewiesen sind.

  4. Markieren Sie einen Service unter Verfügbare Services.

    Sie können einem Mitglied jeweils nur ein Service zuweisen. Das erste Element in der Liste ist standardmäßig ausgewählt. Wenn der Service, den Sie zuweisen möchten, nicht der erste in der Liste ist, löschen Sie dieses Element und wählen Sie das richtige Element aus.

    Sie können basierend auf mehreren Faktoren filtern, um nur folgende Services anzuzeigen:
    • Produkte mit einem aktuellen oder abgelaufenen Abonnement.
    • Zugewiesene oder nicht zugewiesene Produkte.
    Sie können auch Filter auf Basis eines Servicenamens oder einer Seriennummer anwenden.

    Wenn Sie einen Servicenamen auswählen, wird die Seite Servicedetails angezeigt. Klicken Sie im Browser auf Zurück, um zur Seite Mitgliedsdetails zurückzukehren.

  5. Klicken Sie auf Service zuweisen.

Das Produkt wird im Admin Portal zur Liste der Services des Mitglieds hinzugefügt.

Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Mitglieder aus Konten entfernen
Produkte zu Mitgliedern zuweisen
Zuweisen von Mitgliedern zu Produkten
Lizenzen von Mitgliedern entfernen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Entfernen der Produkte von externen Mitgliedern
Zahnradmenü für Abfragen verwenden


Lizenzen von Mitgliedern entfernen

Sie können Produkte von einem Mitglied entfernen.

So entfernen Sie ein Produkt von einem Mitglied:

  1. Klicken Sie auf die Registerkarte Mitglieder.
  2. Suchen Sie im Bereich Mitglieder suchen nach einem Mitglied oder klicken Sie auf einen Namen in der Liste.

    Auf der Mitgliedsseite sind unter Zugewiesene Produkte alle dem Mitglied zugewiesenen Produkte aufgeführt. Unter Verfügbare Produkte werden die nicht zugewiesenen Produkte angezeigt.

  3. Wählen Sie das Produkt unter Zugewiesene Produkte aus und klicken Sie auf Produkt entfernen.
  4. Klicken Sie zur Bestätigung auf OK.

    Das Produkt wird im Admin Portal zur Liste der verfügbaren Produkte des Mitglieds hinzugefügt.

Wenn ein Mitglied Produkte im Offlinemodus verwendet, können Sie dessen Lizenz erst dann wiederherstellen und neu zuweisen, wenn das Mitglied den Offline-Modus ausgeschaltet hat oder der Offlinezeitraum von 30 Tagen abläuft.
Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Mitglieder aus Konten entfernen
Produkte zu Mitgliedern zuweisen
Zuweisen von Mitgliedern zu Produkten
Services zu Mitgliedern zuweisen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Entfernen der Produkte von externen Mitgliedern
Zahnradmenü für Abfragen verwenden


Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen

Das Admin Portal bietet verschiedene Möglichkeiten, um einen Benutzer zu finden und dessen Benutzerrechte und die jeweils zugewiesenen Produkte zu überwachen.

Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen:

  1. Klicken Sie auf die Registerkarte Mitglieder.
  2. Im Bereich Mitglieder suchen können Sie basierend auf Benutzerrechten und zugewiesenen Produkten filtern:
    • Wählen Sie Admin, Mitglied oder Ausstehend aus, um die Suche auf Benutzer mit diesem Status einzuschränken.
    • Wählen Sie eine oder mehrere Produktarten aus, um die Suche auf Benutzer zu beschränken, die den ausgewählten Produkten zugewiesen sind.
  3. Um die Rechte und zugewiesenen Produkte für einen bestimmten Anwender zu überprüfen, wählen Sie unter Mitglieder einen Namen aus.

    Sie können die Zugriffsrechte für einen bestimmten Benutzer unter Mitgliedsdetails anzeigen. Auf derselben Seite sind die dem Benutzer zugewiesenen Produkte und die zur Zuweisung verfügbaren Produkte aufgeführt.

Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Mitglieder aus Konten entfernen
Produkte zu Mitgliedern zuweisen
Zuweisen von Mitgliedern zu Produkten
Services zu Mitgliedern zuweisen
Lizenzen von Mitgliedern entfernen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Entfernen der Produkte von externen Mitgliedern
Zahnradmenü für Abfragen verwenden


Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen

Das Admin Portal bietet verschiedene Möglichkeiten, um Produkte zu finden und zu überwachen, welche Benutzer ihnen jeweils zugewiesen sind.

So suchen Sie ein Produkt:

  1. Klicken Sie auf die Registerkarte Produkte.
  2. Geben Sie im Bereich „Produkte suchen“ den Produktnamen ein.
  3. Sie können basierend auf mehreren Faktoren filtern, um nur folgende Produkte anzuzeigen:
    • Produkte mit einem aktuellen oder abgelaufenen Abonnement
    • Zugewiesen oder nicht zugewiesene Produkte
    • Für die Online-Lizenzierung aktivierte bzw. nicht aktivierte Produkte
    • Zu einem oder mehreren Produkttypen gehörende Produkte
    Sie können auch basierend auf einer Seriennummer filtern.
  4. Klicken Sie auf Suchen.
  5. Um die einem Produkt zugeordneten Anwender zu überprüfen, wählen Sie unter Produkte einen Produktnamen aus.
    Auf der Seite „Produktdetails“ sind alle Mitglieder aufgeführt, die diesem Produkt zugewiesen sind.
Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Mitglieder aus Konten entfernen
Produkte zu Mitgliedern zuweisen
Zuweisen von Mitgliedern zu Produkten
Services zu Mitgliedern zuweisen
Lizenzen von Mitgliedern entfernen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Entfernen der Produkte von externen Mitgliedern
Zahnradmenü für Abfragen verwenden


Entfernen der Produkte von externen Mitgliedern

Externe Mitglieder sind Personen außerhalb Ihrer Organisation, die eines Ihrer Produkte registriert haben. Über das Admin Portal können Sie sie identifizieren und von Ihrem Produkt entfernen.

So entfernen Sie Produkte von externen Mitgliedern:

  1. Klicken Sie auf die Registerkarte Produkte.
  2. Geben Sie im Bereich Produkte suchen den Produktnamen oder Suchkriterien ein.
  3. Klicken Sie auf Suchen.
  4. Wählen Sie den Produktnamen aus.
    Auf der Seite „Produktdetails“ sind alle Mitglieder aufgeführt, die diesem Produkt zugewiesen sind.
  5. Wählen Sie in der Liste Zugeordnete externe Mitglieder das externe Mitglied aus und klicken Sie auf Mitglied entfernen.
Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Mitglieder aus Konten entfernen
Produkte zu Mitgliedern zuweisen
Zuweisen von Mitgliedern zu Produkten
Services zu Mitgliedern zuweisen
Lizenzen von Mitgliedern entfernen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Zahnradmenü für Abfragen verwenden


Zahnradmenü für Abfragen verwenden

Das Zahnradmenü enthält Befehle zum Erstellen und Optimieren von Abfragen.

Befehl | Tastenkombination | Beschreibung
Neue Abfrage | Alt + Q | Erstellt eine Abfrage durch Eingabe von Text in einem oder mehreren Feldern auf der Seite „Mitglieder“, z. B. Vorname, Nachname, Benutzerrechte, E-Mail und zugewiesene Produkte, sowie auf den Produktseiten, z. B. Produktname, Produkttyp, Seriennummer, Aktiviert, Zugewiesen und Abgelaufen.
Abfrage ausführen | Alt + Eingabetaste | Zum Ausführen der Abfrage.
Abfrage verfeinern | Alt + G | Zum Ändern von Text in den Abfragefeldern und Hinzufügen von Text.
Angezeigte Spalten | Strg + Umschalttaste + K | Zum Auswählen der Spalten, die auf den Seiten „Mitglieder“ und „Produkte“ angezeigt werden sollen.
Exportieren |  | Zum Exportieren der Abfrageergebnisse. Sie können alle Zeilen oder nur die aktuelle Zeile in der Spalte exportieren, sowie alle Spalten oder nur die sichtbaren Spalten. Sie können die Ergebnisse als tabulatorgetrennte Textdatei, durch Komma getrennte Textdatei, HTML-Datei oder Textdatei mit einem von Ihnen festgelegten Trennzeichen exportieren.
Erweitertes Sortieren |  | Sortiert die Abfrageergebnisse in bis zu drei Spalten.
Übergeordnetes Thema Mitglieder und Lizenzen verwalten
Neue Mitglieder zu einem Konto einladen
Mitglieder aus Konten entfernen
Produkte zu Mitgliedern zuweisen
Zuweisen von Mitgliedern zu Produkten
Services zu Mitgliedern zuweisen
Lizenzen von Mitgliedern entfernen
Nach Mitgliedern suchen und Benutzerrechte und zugewiesene Produkte überprüfen
Nach Produkten suchen und die ihnen zugewiesenen Benutzer überprüfen
Entfernen der Produkte von externen Mitgliedern


Produkte zur Nutzung der Online-Lizenzierung festlegen

Standardmäßig ist die SOLIDWORKS Software so eingerichtet, dass die Computeraktivierung verwendet wird. Wenn die SOLIDWORKS Software auf einem Computer installiert ist, müssen Sie die Lizenz manuell deaktivieren und dann den Aktivierungstyp ändern, um die Online-Lizenzierung zu verwenden.

Übergeordnetes Thema Administratoraufgaben
Erstes Administratorkonto erstellen
Produkte und Services verwalten
Mitglieder und Lizenzen verwalten
Benutzer zum Administrator hochstufen
SOLIDWORKS Kundenportal – Registrierung meiner Produkte

Installierte Lizenzen in SOLIDWORKS deaktivieren

Bevor Sie eine Online-Lizenz verwenden, müssen Sie sicherstellen, dass das gleiche Produkt noch nicht auf dem Computer installiert ist. Wenn es bereits installiert ist, müssen Sie die Lizenz für das installierte Produkt deaktivieren, bevor Sie die Online-Lizenzierung mit dem Admin Portal konfigurieren.

So deaktivieren Sie eine Lizenz:

  • Klicken Sie in der SOLIDWORKS Software auf Hilfe > Lizenzen deaktivierenund befolgen Sie die Anweisungen.
Sie können eine Mischung aus Online-Lizenzen und SolidNetWork Lizenzen auf demselben Computer verwenden. Beispiel: Auf demselben Computer können SOLIDWORKS Premium 2018 mit einer Online-Lizenz und SOLIDWORKS Simulation Premium 2018 mit einer SolidNetWork Lizenz ausgeführt werden.

Aktivierungstyp auf Online-Lizenzierung ändern

Bevor Sie die Online-Lizenzierung mit einem Produkt verwenden können, müssen Sie den Aktivierungstyp von der Computeraktivierung auf die Online-Lizenzierung ändern.

Sie können den Aktivierungstyp einer Lizenz vor oder nach der Zuweisung zu einem Mitglied ändern. Sie können den Aktivierungstyp einer Lizenz nicht ändern, wenn die Lizenz aktiviert ist oder wenn das Produkt mehr als einem Mitglied zugewiesen ist. Wenn eine Lizenz durch die Computeraktivierung aktiviert wird, ist eine Deaktivierung per Fernzugriff nicht möglich. Die Lizenz muss durch einen Benutzer auf dem Computer deaktiviert werden.

So ändern Sie den Aktivierungstyp auf die Online-Lizenzierung:

  1. Wenn das Produkt einem Mitglied zugewiesen ist:
    1. Klicken Sie auf die Registerkarte Mitglieder und wählen Sie ein Element aus der Liste aus.
    2. Klicken Sie unter Zugewiesene Produkte auf das Produkt, das Sie ändern möchten.
    3. Klicken Sie in „Produktdetails“ unter Aktivierungstyp auf Auf Online-Lizenzierung ändern.
    4. Klicken Sie zum Bestätigen auf Ändern oder alternativ auf Abbrechen.
  2. Wenn das Produkt keinem Mitglied zugewiesen ist:
    1. Klicken Sie auf die Registerkarte Produkte und wählen Sie in der Liste ein Produkt aus.

      Sie können auch im Fenster Produkte suchen nach einem Produkt suchen.

  3. Klicken Sie in „Produktdetails“ unter Aktivierungstyp auf Auf Online-Lizenzierung ändern.
  4. Klicken Sie zum Bestätigen auf Ändern oder alternativ auf Abbrechen.
  5. Weisen Sie einem Mitglied ein Produkt zu.
Wenn Sie eine Onlinelizenz zuweisen, kann dieses Produkt nur von diesem Mitglied verwendet werden. Das Zuweisen eines Produkts mit Computeraktivierung zu einem Mitglied dient aber nur zu Nachverfolgungszwecken. Jede Person, die an dem jeweiligen Computer sitzt, kann das Produkt verwenden. In diesem Fall müssen Sie möglicherweise überprüfen, ob die Person, die den Computer verwendet, das Mitglied mit der Lizenz ist.


Benutzer zum Administrator hochstufen

Wenn ein Konto über Administratoren verfügt, zeigt das Admin Portal Kontaktinformationen für die Administratoren an. Sie können sie kontaktieren und beantragen, Administrator für das Konto zu werden.

Wenn Sie Administrator sind, können Sie andere Benutzer des Kontos als Administrator hochstufen.

So stufen Sie einen Benutzer zum Administrator hoch:

  1. Klicken Sie auf die Registerkarte Mitglieder.
  2. Wählen Sie in der Liste der Namen einen Anwender aus.

    Wenn Sie Probleme bei der Suche nach einem Benutzer haben, können Sie das Admin Portal abfragen, indem Sie Suchkriterien im Bereich Mitglieder suchen eingeben.

  3. Klicken Sie im Bereich „Mitgliedsdetails“ unter Benutzerrechte auf Zu Admin ändern.
  4. Klicken Sie dann zum Bestätigen auf Ändern oder alternativ auf Abbrechen.
  5. Es wird eine E-Mail angezeigt, in der der Benutzer aufgefordert wird, Administrator zu werden. Klicken Sie auf Senden.

Die Benutzerrechte werden als Ausstehend angezeigt, wenn die Einladung gesendet wird. Nach Annahme der Einladung werden die Benutzerrechte auf Admin geändert.

Durch Auswahl von Zu Mitglied ändern können Sie einen Administrator zum Benutzer herunterstufen.
Übergeordnetes Thema Administratoraufgaben
Erstes Administratorkonto erstellen
Produkte und Services verwalten
Mitglieder und Lizenzen verwalten
Produkte zur Nutzung der Online-Lizenzierung festlegen
SOLIDWORKS Kundenportal – Registrierung meiner Produkte


SOLIDWORKS Kundenportal – Registrierung meiner Produkte

Sobald für Ihr Unternehmen ein Administrator ernannt wurde, können Produkte des Unternehmens nicht mehr im SOLIDWORKS Kundenportal registriert werden.

Dem Benutzer wird die Registrierung verweigert und eine E-Mail mit den Kontaktinformationen der beantragenden Person und der angeforderten Seriennummer wird an die ernannten Administratoren für das Unternehmen gesendet. Als Administrator können Sie entscheiden, ob die Produkte der beantragenden Person zugewiesen werden sollen.
Das Zuweisen eines Produkts führt zum gleichen Status wie das Registrieren eines Produkts.

Wenn die beantragende Person bereits Mitglied Ihres Kontos ist, können Sie ihr das angeforderte Produkt oder ein gleichwertiges Produkt zuweisen.

Wenn die beantragende Person noch kein Mitglied des Kontos ist, kann der Administrator sie als Mitglied einladen und anschließend die Zuweisung abschließen.

Übergeordnetes Thema Administratoraufgaben
Erstes Administratorkonto erstellen
Produkte und Services verwalten
Mitglieder und Lizenzen verwalten
Produkte zur Nutzung der Online-Lizenzierung festlegen
Benutzer zum Administrator hochstufen


SOLIDWORKS Produkte mit Online-Lizenzierung verwenden

Die SOLIDWORKS Online-Lizenzierung ermöglicht Benutzern, eine Lizenz flexibel auf allen Geräten und an allen Standorten zu verwenden, ohne die Lizenzen auf jedem Computer manuell aktivieren und deaktivieren zu müssen.

So können Sie beispielsweise tagsüber im Büro an einem Computer arbeiten, dann nach Hause gehen und sich auf Ihrem Heimcomputer bei demselben Produkt anmelden. Sie benötigen keine zweite Lizenz für das Produkt. Sie müssen die Lizenz nicht manuell auf dem Bürocomputer deaktivieren und dann auf dem Heimcomputer aktivieren.

Zur Verwendung von Online-Lizenzen müssen Sie über einen Internetzugang verfügen. Nach der Anmeldung können Sie den Offline-Modus auswählen und arbeiten, während das Gerät nicht mit einem Netzwerk verbunden ist.

Außerdem können Sie SOLIDWORKS Optionen über verschiedene Computer hinweg synchronisieren und auf SOLIDWORKS Websites wie MySolidWorks.com und das SOLIDWORKS Kundenportal zugreifen, ohne sich erneut anzumelden.

Inhaltsverzeichnis

  • Anmeldung bei einem SOLIDWORKS Produkt mit einer Online-Lizenz

    Nachdem Sie ein SOLIDWORKS Produkt mit einer Online-Lizenz installiert haben, können Sie sich auf einem beliebigen Computer anmelden. Sie müssen das Produkt nicht erneut installieren, um es auf einem anderen Computer zu verwenden.

  • Ein SOLIDWORKS Produkt im Offline-Modus verwenden

    Wenn Sie ein SOLIDWORKS Produkt mit einer Online-Lizenz verwenden, können Sie den Offline-Modus festlegen, wenn Sie keine Internetverbindung haben.

  • Wechseln des Computers bei Verwendung von Online-Lizenzen

    Mit der Online-Lizenzierung können Sie eine Lizenz flexibel auf allen Ihren Computern verwenden. Die Lizenz kann jedoch nur auf einem Computer gleichzeitig genutzt werden.

  • Synchronisieren der Einstellungen und Optionen für mehrere Computer

    Wenn Sie die SOLIDWORKS Software auf mehreren Computern verwenden, können Sie Ihre Einstellungen auf jedem der Computer aktualisieren und diese Einstellungen auf allen Computern mit SOLIDWORKS 2018 und höher synchronisieren.

  • SOLIDWORKS Produkt für die Verwendung von Online-Lizenzen benachrichtigen

Übergeordnetes Thema SOLIDWORKS Admin Portal und Online-Lizenzierung
Zugriff auf das Admin Portal
Administratoraufgaben
Zugriff auf das CAD Admin Dashboard


Anmeldung bei einem SOLIDWORKS Produkt mit einer Online-Lizenz

Nachdem Sie ein SOLIDWORKS Produkt mit einer Online-Lizenz installiert haben, können Sie sich auf einem beliebigen Computer anmelden. Sie müssen das Produkt nicht erneut installieren, um es auf einem anderen Computer zu verwenden.

So melden Sie sich bei einem SOLIDWORKS Produkt mit einer Online-Lizenz an:

  1. Klicken Sie auf Ihrem Desktop auf SOLIDWORKS [image].
  2. Geben Sie Ihre SOLIDWORKS ID und Ihr Kennwort ein und klicken Sie auf Anmelden.
    Die SOLIDWORKS ID kann Ihre E-Mail-Adresse sein.

Das SOLIDWORKS Produkt wird gestartet, wenn Sie eine gültige SOLIDWORKS ID und ein gültiges Kennwort eingeben und Ihnen von Ihrem SOLIDWORKS Administrator eine Lizenz für dieses Produkt zugewiesen wurde.

Bis Sie sich abmelden, können Sie das SOLIDWORKS Produkt auf demselben Computer schließen und neu starten, ohne dass Sie die Anmeldedaten erneut eingeben müssen.

Übergeordnetes Thema SOLIDWORKS Produkte mit Online-Lizenzierung verwenden
Ein SOLIDWORKS Produkt im Offline-Modus verwenden
Wechseln des Computers bei Verwendung von Online-Lizenzen
Synchronisieren der Einstellungen und Optionen für mehrere Computer
SOLIDWORKS Produkt für die Verwendung von Online-Lizenzen benachrichtigen


Ein SOLIDWORKS Produkt im Offline-Modus verwenden

Wenn Sie ein SOLIDWORKS Produkt mit einer Online-Lizenz verwenden, können Sie den Offline-Modus festlegen, wenn Sie keine Internetverbindung haben.

So arbeiten Sie im Offline-Modus:

  • Klicken Sie in der SOLIDWORKS Titelleiste mit der rechten Maustaste auf Anmelden [image] und wählen Sie dann Lizenz offline schalten aus.

Sie können das SOLIDWORKS Produkt 30 Tage lang verwenden, ohne die Verbindung zu einer SOLIDWORKS Website wiederherzustellen. Nach 30 Tagen müssen Sie erneut auf Lizenz offline schalten klicken, um mit der Arbeit im Offline-Modus fortzufahren.

Wenn Sie eine Online-Lizenz auf einem Computer im Offline-Modus verwenden, können Sie diese Lizenz nicht auf anderen Computern verwenden.
Übergeordnetes Thema SOLIDWORKS Produkte mit Online-Lizenzierung verwenden
Anmeldung bei einem SOLIDWORKS Produkt mit einer Online-Lizenz
Wechseln des Computers bei Verwendung von Online-Lizenzen
Synchronisieren der Einstellungen und Optionen für mehrere Computer
SOLIDWORKS Produkt für die Verwendung von Online-Lizenzen benachrichtigen


Wechseln des Computers bei Verwendung von Online-Lizenzen

Mit der Online-Lizenzierung können Sie eine Lizenz flexibel auf allen Ihren Computern verwenden. Die Lizenz kann jedoch nur auf einem Computer gleichzeitig genutzt werden.

Sie führen SOLIDWORKS Software auf Ihrem primären Computer aus und melden sich nicht ab. Wenn Sie versuchen, sich bei einem zweiten Computer anzumelden (z. B. einem Computer zu Hause), wird Ihnen von der Software angeboten, die Lizenz vom primären Computer zu übernehmen.

So starten Sie die SOLIDWORKS Software auf einem zweiten Computer:

  1. Wenn Sie sich beim zweiten Computer anmelden, werden Sie von der SOLIDWORKS Software darüber informiert, dass ein online lizenziertes Produkt auf einem anderen Computer verwendet wird. Klicken Sie auf Ja, um fortzufahren.

    Das SOLIDWORKS Produkt wird auf dem zweiten Computer ausgeführt.

  2. Wenn Sie zu Ihrem primären Computer zurückkehren, werden Sie aufgefordert, Ihre Arbeit vor dem Schließen der SOLIDWORKS Software zu speichern. Klicken Sie auf OK, um die Änderungen am Modell zu speichern.
Übergeordnetes Thema SOLIDWORKS Produkte mit Online-Lizenzierung verwenden
Anmeldung bei einem SOLIDWORKS Produkt mit einer Online-Lizenz
Ein SOLIDWORKS Produkt im Offline-Modus verwenden
Synchronisieren der Einstellungen und Optionen für mehrere Computer
SOLIDWORKS Produkt für die Verwendung von Online-Lizenzen benachrichtigen


Synchronisieren der Einstellungen und Optionen für mehrere Computer

Wenn Sie die SOLIDWORKS Software auf mehreren Computern verwenden, können Sie Ihre Einstellungen auf jedem der Computer aktualisieren und diese Einstellungen auf allen Computern mit SOLIDWORKS 2018 und höher synchronisieren.

Die Synchronisierung der Einstellungen ist ein Dienst und wird möglicherweise durch bestimmte Netzwerkkonfigurationen blockiert. Stellen Sie für den Zugriff auf den Cloud-Speicherdienst sicher, dass die Firewall bzw. die Proxyserver die Kommunikation mit *.solidworks.com zulassen.

So synchronisieren Sie die Einstellungen und Optionen für mehrere Computer:

  1. Melden Sie sich bei der SOLIDWORKS Software an.
  2. Klicken Sie unter Extras > Optionen auf Einstellungen synchronisieren.
  3. Wählen Sie eine manuelle oder automatische Methode:
    • Jetzt synchronisieren.

      Einstellungen hochladen. Sendet Ihre Einstellungen vom aktuellen Computer an den Cloud-Speicherdienst. Aktualisieren Sie Ihre Einstellungen in der Cloud jederzeit, indem Sie sie erneut hochladen.

      Einstellungen herunterladen. Lädt Ihre Einstellungen vom Cloud-Speicherdienst auf den aktuellen Computer herunter und wendet sie an.

    • Automatische Synchronisation.

      Synchronisiert die aktuellen Computer mit dem Cloud-Speicherdienst. Ihre ausgewählten Einstellungen und Anpassungen werden automatisch in die Cloud-Speicherdienste hochgeladen, sobald sie aktualisiert werden, und dann beim Start oder bei der Anmeldung heruntergeladen und angewendet.

    Die Synchronisierungseinstellungen können auf den verschiedenen Computern variieren. Beispielsweise können Sie festlegen, dass ein Computer automatisch die Systemoptionen und Speicherorte synchronisiert, aber nicht die Anpassungen. Auf einem anderen Computer können Sie festlegen, dass alle Arten von Einstellungen manuell herunter- und hochgeladen werden.

    Bei der Synchronisierung können die angewendeten oder gesperrten Administratoreinstellungen nicht überschrieben werden.
  4. Klicken Sie auf OK.
Übergeordnetes Thema SOLIDWORKS Produkte mit Online-Lizenzierung verwenden
Anmeldung bei einem SOLIDWORKS Produkt mit einer Online-Lizenz
Ein SOLIDWORKS Produkt im Offline-Modus verwenden
Wechseln des Computers bei Verwendung von Online-Lizenzen
SOLIDWORKS Produkt für die Verwendung von Online-Lizenzen benachrichtigen


SOLIDWORKS Produkt für die Verwendung von Online-Lizenzen benachrichtigen

Es gibt zwei Möglichkeiten, das SOLIDWORKS Produkt über die Umstellung auf eine Online-Lizenz zu benachrichtigen:
  • Wenn Sie sich bei einem SOLIDWORKS Produkt anmelden, wird eine Nachricht angezeigt, dass die eingegebene Seriennummer auf eine Online-Lizenz zurückgesetzt wird. Starten Sie das Produkt neu und melden Sie sich an.
  • Ihr Administrator kann über den Options-Editor des Administrator-Installationsabbilds festlegen, dass für das Produkt die Online-Lizenzierung anstelle einer Seriennummer verwendet wird. Auf diese Weise werden Sie bei jedem installierten Produkt aufgefordert, sich anzumelden, wenn Sie die Software ausführen.
Übergeordnetes Thema SOLIDWORKS Produkte mit Online-Lizenzierung verwenden
Anmeldung bei einem SOLIDWORKS Produkt mit einer Online-Lizenz
Ein SOLIDWORKS Produkt im Offline-Modus verwenden
Wechseln des Computers bei Verwendung von Online-Lizenzen
Synchronisieren der Einstellungen und Optionen für mehrere Computer


Zugriff auf das CAD Admin Dashboard

Wenn Sie über einen SOLIDWORKS Subskriptionsvertrag verfügen, können Sie über das Admin Portal auf das SOLIDWORKS CAD Admin Dashboard zugreifen, ohne sich erneut anzumelden.

Auf dem CAD Admin Dashboard können Sie Aufgaben wie das Überwachen der Leistung und der Sitzungsstatistiken durchführen und die Details von Computern in Ihrem Netzwerk anzeigen, auf denen die SOLIDWORKS Software ausgeführt wird.

Weitere Informationen finden Sie in der Hilfe im CAD Admin Dashboard.

Übergeordnetes Thema SOLIDWORKS Admin Portal und Online-Lizenzierung
Zugriff auf das Admin Portal
Administratoraufgaben
SOLIDWORKS Produkte mit Online-Lizenzierung verwenden


Lizenzadministration

Nach der Installation können Sie die SOLIDWORKS Lizenzen aktivieren, indem Sie entweder einzelne Computer aktivieren (Rechneraktivierung), variable Netzwerklizenzen auf einem Server installieren und aktivieren (SolidNetWork Lizenzierung) oder sich bei Ihren SOLIDWORKS Anwendungen anmelden (Online-Lizenzierung).

In der Regel Typischerweise wird für Installationen auf Einzel-Computern eine Lizenzaktivierung verwendet; Sie können aber die Software einzeln installieren und die Lizenzen über den SolidNetWork License Manager steuern. Ebenso können Sie, obwohl an größeren Standorten normalerweise variable Netzwerklizenzen verwendet werden, die Installationen von einem Administrator-Installationsabbild verwenden, und dann die Seriennummern von den Einzel-Computern aus aktivieren.

Inhaltsverzeichnis

  • Verwalten von Einzellizenzen

    Eine Einzellizenz kann mittels Rechneraktivierung oder Online-Lizenzierung aktiviert werden. Dieser Abschnitt behandelt die Rechneraktivierung. Weitere Informationen zur Online-Lizenzierung finden Sie im Admin-Portal.

  • Lizenzen mit einem SolidNetWork License Manager verwalten

    Der SolidNetWork License Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.


Verwalten von Einzellizenzen

Eine Einzellizenz kann mittels Rechneraktivierung oder Online-Lizenzierung aktiviert werden. Dieser Abschnitt behandelt die Rechneraktivierung. Weitere Informationen zur Online-Lizenzierung finden Sie im Admin-Portal.

In der Regel besteht die Verwaltung von Einzellizenzen aus der Aktivierung und Deaktivierung von Lizenzen direkt aus SOLIDWORKS.

Die Aktivierung ist ein Vorgang der Produktlizenzierung und -registrierung für SOLIDWORKS Einzelplatzlizenzen (nicht für SolidNetWork Lizenzen). Wenn Ihre Produktlizenz noch nicht aktiviert wurde, versucht SOLIDWORKS in der Regel, sie zu aktivieren, wenn Sie das Produkt starten.

Sie können auch Einzellizenzen deaktivieren, indem Sie in SOLIDWORKS auf Hilfe > Lizenzen deaktivieren klicken.

Übergeordnetes Thema Lizenzadministration
Lizenzen mit einem SolidNetWork License Manager verwalten

Aktivierung einer Lizenz

Sie müssen die Lizenz für einen einzelnen Computer aktivieren, bevor Sie SOLIDWORKS Produkte auf ihm laufen lassen können.

Die Aktivierung erfordert einen Internetanschluss oder eine E-Mail-Adresse. Nach der Aktivierung müssen Sie nicht Online sein, um das Produkt zu nutzen. Wenn Sie keinen E-Mail-Zugriff auf dem Rechner haben, auf dem Sie dieses Produkt nutzen, können Sie die Aktivierungsdatei speichern und von einem anderen Rechner senden.

Dieser Vorgang:
  • Aktiviert alle Software-Lizenzen der gesamten SOLIDWORKS Produktlinie.
  • Ermöglicht Ihnen, Lizenzen von einem Rechner auf einen anderen zu übertragen.
  • Kann sofort (empfohlen) oder innerhalb von 30 Tagen nach der Installation durchgeführt werden.
  • Macht Dongles überflüssig. Wenn Sie jedoch frühere Versionen von SOLIDWORKS nutzen, die keine Aktivierung erfordern, benötigen Sie weiterhin Dongles.

Systemadministratoren, die mehrere Seriennummern zu verwalten haben, können den Administrator-Installationsabbild-Options-Editor verwenden. Weitere Informationen finden Sie unter Options-Editor für das Administrator-Installationsabbild.

Aktivieren einer Lizenz:

  1. Starten Sie die SOLIDWORKS Anwendung.
  2. Starten Sie die SOLIDWORKS Produktaktivierung mittels einer der folgenden Methoden:
    • Wenn Sie die Lizenz für diesen Rechner noch nicht aktiviert haben, dann erscheint das Fenster SOLIDWORKS Produktaktivierung automatisch, wenn Sie SOLIDWORKS starten.
    • Sollte das Fenster SOLIDWORKS Produktaktivierung nicht automatisch angezeigt werden, starten Sie die Aktivierung, indem Sie auf Hilfe > Lizenzen aktivieren klicken.
  3. Klicken Sie auf die Produkt-Liste, um das Produkt zu spezifizieren, dessen Lizenz Sie aktivieren möchten.
  4. Spezifizieren Sie automatische Aktivierung über das Internet oder manuelle Aktivierung mittels E-Mail.
  5. Geben Sie ihre Kontaktinformationen bekannt.
  6. Klicken Sie auf Weiter, um fortzufahren.
    • Internet: Die Aktivierung findet automatisch statt.
    • E-Mail: Betätigen Sie Speichern, um eine Anforderungsdatei zu erstellen, und schicken Sie die Datei dann an activation@solidworks.com. Wenn Sie die E-Mail mit der Antwortdatei erhalten, extrahieren Sie die Datei aus der E-Mail und klicken Sie danach auf Öffnen, um sie zu laden.
      Falls notwendig, können Sie die Anwendung beenden und den Aktivierungsvorgang nochmals ausführen, um die Antwortdatei zu öffnen.
  7. Klicken Sie auf Fertig stellen.

Übertragen einer Lizenz

Um die Lizenz auf einen neuen oder aktualisierten Computer zu übertragen,deaktivieren Sie sie zunächst auf dem Lizenzschlüssel-Server der Dassault Systèmes SOLIDWORKS Corporation, und reaktivieren Sie sie anschließend auf dem anderen Computer.

Wenn Sie die Lizenz nicht an Dassault Systèmes SOLIDWORKS Corporation zurückgeben konnten (z. B. aufgrund eines Festplattenfehlers), ist die Reaktivierung in den meisten Fällen dennoch erfolgreich. Falls nicht, wenden Sie sich bitte an Ihren Fachhändler.

Lizenz an den Server zurückgeben:

  1. Klicken Sie in SOLIDWORKS auf Hilfe > Lizenzen deaktivieren, und befolgen Sie die Anweisungen.
  2. Gehen Sie zur Reaktivierung zum neuen oder aktualisierten Computer, und aktivieren Sie die Lizenz wie bei der ursprünglichen Aktivierung. Weitere Informationen finden Sie unter Aktivierung einer Lizenz.


Lizenzen mit einem SolidNetWork License Manager verwalten

Der SolidNetWork License Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.

Dieses Bild zeigt eine typische SolidNetWorks Lizensierungs-Installation:

Diese Abbildung zeigt:
  • SolidNetWork License Manager ist nur auf dem License Manager Computer installiert und aktiviert.
  • Auf Lizenz-Client-Computern ist keine zusätzliche SolidNetWork spezifische Software installiert.

    Wenn Sie bei der Installation eine SolidNetWork Lizenzseriennummer spezifizieren, identifiziert der SOLIDWORKS Installations-Manager diesen Computer als einen SolidNetWork Lizenz-Client. Der SOLIDWORKS Installations-Manager fragt Sie nach dem Namen des SolidNetWork License Manager Computers und der Portnummer, um den Client mit dem License Manager zu verbinden.

  • Beim License Manager und allen Lizenz-Clients muss TCP/IP (Transmission Control Protocol/Internet Protocol)-Verbindung zur Verfügung stehen.

Inhaltsverzeichnis

  • Aktivierung einer SolidNetWork Lizenz

    Bevor Anwender SOLIDWORKS Produkt auf ihren einzelnen Computern ausführen können, muss eine SolidNetWork Lizenz auf dem SolidNetWork License Manager-Computer aktiviert werden.

  • Verschieben einer SolidNetWork Lizenz

    Um die Lizenz auf einen neuen oder aktualisierten Computer zu verschieben, geben Sie sie zunächst durch Deaktivieren an den Lizenzschlüssel-Server der Dassault Systèmes SOLIDWORKS Corporation zurück, und reaktivieren Sie sie auf dem anderen Computer.

  • Installation und Konfiguration von SolidNetWork Lizenzen

    Eine SolidNetWork Lizenz zu konfigurieren, besteht daraus, den SolidNetWork License Manager auf dem License Manager-Computer zu installieren und dann SOLIDWORKS auf den Cient-Computern mittels der SolidNetWork Lizenzseriennummer zu installieren.

  • SolidNetWork Lizenzverwaltung

    Zu den Tasks gehören Start, Aktualisierung und Deinstallation des Lizenz-Managers sowie Ausleihen und Zurückgabe von Lizenzen.

Übergeordnetes Thema Lizenzadministration
Verwalten von Einzellizenzen


Aktivierung einer SolidNetWork Lizenz

Bevor Anwender SOLIDWORKS Produkt auf ihren einzelnen Computern ausführen können, muss eine SolidNetWork Lizenz auf dem SolidNetWork License Manager-Computer aktiviert werden.

Die Aktivierung erfordert einen Internetanschluss oder eine E-Mail-Adresse. Nach der Aktivierung müssen Sie nicht Online sein, um das Produkt zu nutzen. Wenn Sie keinen E-Mail-Zugriff auf dem Rechner haben, auf dem Sie dieses Produkt nutzen, können Sie die Aktivierungsdatei speichern und von einem anderen Rechner senden.

Dieser Vorgang:
  • Aktiviert den SOLIDWORKS SolidNetWork License Manager mit SolidNetWork Lizenzen über SOLIDWORKS Produkte hinweg.
  • Erlaubt es Ihnen, SolidNetWork Lizenzrechte von einem SolidNetWork License Manager Computer auf einen anderen zu verschieben.
  • Damit können Sie SolidNetWork Lizenzrechte auf einen SolidNetWork License Manager Computer installieren und aktivieren.
  • Dies muss durchgeführt werden, bevor Sie die SolidNetWork Lizenzen verwenden können.
  • Macht Dongles überflüssig. Wenn Sie eine SolidNetWork Lizenz für diese Version von SOLIDWORKS aktivieren, werden SolidNetWork Lizenzen für vorherige Versionen von SOLIDWORKS aktiviert. (Sie müssen den Dongle nicht weiterhin behalten.)

Aktivieren einer SolidNetWork Lizenz:

  1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Sollten Sie die SolidNetWork Lizenz noch nicht aktiviert haben, werden Sie gefragt, ob Sie sie jetzt aktivieren möchten. Klicken Sie auf Ja, um sie zu aktivieren.
  3. Wählen Sie unter Wie möchten Sie aktivieren? die Option Automatisch über das Internet (empfohlen).
  4. Spezifizieren Sie unter Kontaktinformationen eine E-Mailkontaktadresse.
Das Dialogfeld Aktivierung/Reaktivierung erfolgreich zeigt die Produkte an, die aktiviert wurden.
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Verschieben einer SolidNetWork Lizenz
Installation und Konfiguration von SolidNetWork Lizenzen
SolidNetWork Lizenzverwaltung


Verschieben einer SolidNetWork Lizenz

Um die Lizenz auf einen neuen oder aktualisierten Computer zu verschieben, geben Sie sie zunächst durch Deaktivieren an den Lizenzschlüssel-Server der Dassault Systèmes SOLIDWORKS Corporation zurück, und reaktivieren Sie sie auf dem anderen Computer.

Wenn Sie die Lizenz nicht an Dassault Systèmes SOLIDWORKS Corporation zurückgeben konnten (z. B. aufgrund eines Festplattenfehlers), ist die Reaktivierung in den meisten Fällen dennoch erfolgreich. Falls nicht, wenden Sie sich bitte an Ihren Fachhändler.

Eine SolidNetWork Lizenz zurück auf den Server verschieben:

  1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Klicken Sie unter Lizenzinformation auf Modifizieren. Der SOLIDWORKS Produktaktivierungsassistent wird gestartet.
  3. Wählen Sie unter Was möchten Sie ausführen? die Aussage Software-Lizenz deaktivieren und klicken Sie dann auf Weiter.
  4. Wählen Sie unter Wie möchten Sie sie deaktivieren? die Aussage Automatisch über das Internet (empfohlen).
  5. Spezifizieren Sie unter Kontaktinformationen eine E-Mailkontaktadresse.
  6. Klicken Sie auf Weiter. Die Deaktivierung der Produktlizenz wird abgeschlossen.
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Aktivierung einer SolidNetWork Lizenz
Installation und Konfiguration von SolidNetWork Lizenzen
SolidNetWork Lizenzverwaltung


Installation und Konfiguration von SolidNetWork Lizenzen

Eine SolidNetWork Lizenz zu konfigurieren, besteht daraus, den SolidNetWork License Manager auf dem License Manager-Computer zu installieren und dann SOLIDWORKS auf den Cient-Computern mittels der SolidNetWork Lizenzseriennummer zu installieren.

Inhaltsverzeichnis

  • Einen License Manager installieren und aktivieren

    Der SolidNetWork License Manager unterstützt mehrere Lizenz-Clients. Er verteilt die Lizenzen an die Clients auf dem Netzwerk.

  • Einen Lizenz-Client installieren

    Bei der Installation von SOLIDWORKS auf SolidNetWork Lizenz-Client-Computern identifiziert die Seriennummer diesen Computer als SolidNetWork Lizenz-Client.

  • SolidNetWork License Manager vor dem Installieren von Lizenz-Clients installieren

    Sie müssen den SolidNetWork License Manager auf mindestens einem Computer installieren und konfigurieren, bevor Sie SolidNetWork Lizenz-Client-Computer installieren.

  • Verwalten des Zugriffs auf SOLIDWORKS Versionen

    Sie können den Zugriff der Benutzer auf bestimmte Versionen von SOLIDWORKS in einer SolidNetWork Umgebung unterbinden. Diese Funktion ermöglicht Ihnen, die Versionen von SOLIDWORKS zu verwalten, die von verschiedenen Personen, Projekten und Unternehmenseinheiten genutzt werden.

  • Triaden-Lizenz-Manager-Installation

    Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Wenn der Computer, der die Lizenzdatei verwaltet, nicht verfügbar ist, übernimmt einer der beiden anderen Computer.

  • SolidNetWork Lizenzen mit Firewalls verwenden

    Wenn Ihr Computer mit einer Firewall arbeitet, müssen Sie die Ports so konfigurieren, dass sie SolidNetWork Lizenzen unterstützen.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Aktivierung einer SolidNetWork Lizenz
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzverwaltung


Einen License Manager installieren und aktivieren

Der SolidNetWork License Manager unterstützt mehrere Lizenz-Clients. Er verteilt die Lizenzen an die Clients auf dem Netzwerk.

Wenn Sie von einer früheren Version des SolidNetWork License Manager aktualisieren, der Hardware-Dongles zur Lizenzaktivierung verwendete, entfernen Sie den Hardware-Dongle, bevor Sie die neue Version des SolidNetWork License Managers installieren.

  1. Starten Sie den SOLIDWORKS Installations-Manager (wie oben unter Initiieren der SOLIDWORKS Installation beschrieben).
    1. Wählen Sie für Installationsart eine der folgenden Optionen aus:
      • Server-Produkte
      • Installieren Sie SolidNetWork License Manager (verteilte Lizenzierung) auf diesem Computer.
    2. Geben Sie auf der Seite SolidNetWork License Manager-Optionen die SolidNetWork Lizenz-Seriennummer und den SolidNetWork License Manager-Installationsort an.
    3. Klicken Sie auf der Seite Zusammenfassung auf Jetzt installieren, um den SOLIDWORKS Installations-Manager-Vorgang abzuschließen.
  2. So aktivieren Sie die SolidNetWork Lizenzierung:
    1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Klicken Sie auf Ja, wenn Sie zur Aktivierung aufgefordert werden.
    3. Auf dem Bildschirm SolidNetWork License Serverinformationen:
      • Wenn Ihr Unternehmen eine Firewall verwendet, wählen Sie Eine Firewall ist auf diesem Server aktiviert.

        Weitere Informationen finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.

      • Verwenden Sie den Standardwert für die Portnummer (und Portnummer der Händlerdomäne, wenn Sie eine Firewall haben) oder geben Sie die Portnummern ein, die Ihr Unternehmen verwendet.
        Die Portnummer ist eine TCP/IP-Portnummer im Bereich von 1024-60000, die nur von diesem Prozess verwendet werden kann. Die Standardeinstellung (25734) eignet sich in der Regel und ist meistens mit der des FLEXnet Server-Prozesses auf Ihrem Lizenz-Server nicht identisch.
    4. Auf dem Bildschirm Aktivieren Sie Ihr SOLIDWORKS Produkt:
      • Wählen Sie eine Vorgehensweise über Internet oder E-Mail.
      • Geben Sie Ihre Kontaktinformationen an.
      • Klicken Sie auf Weiter, um fortzufahren.
        • Internet: Die Aktivierung findet automatisch statt.
        • E-Mail: Betätigen Sie Speichern, um eine Anforderungsdatei zu erstellen, und schicken Sie die Datei dann an activation@solidworks.com. Wenn Sie die E-Mail mit der Antwortdatei erhalten, extrahieren Sie die Datei aus der E-Mail und klicken Sie danach auf Öffnen, um sie zu laden.
          Falls notwendig, können Sie die Anwendung beenden und den Aktivierungsvorgang nochmals ausführen, um die Antwortdatei zu öffnen.
  3. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema Installation und Konfiguration von SolidNetWork Lizenzen
Einen Lizenz-Client installieren
SolidNetWork License Manager vor dem Installieren von Lizenz-Clients installieren
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Triaden-Lizenz-Manager-Installation
SolidNetWork Lizenzen mit Firewalls verwenden
SOLIDWORKS Installation wird initiiert


Einen Lizenz-Client installieren

Bei der Installation von SOLIDWORKS auf SolidNetWork Lizenz-Client-Computern identifiziert die Seriennummer diesen Computer als SolidNetWork Lizenz-Client.

  1. Starten Sie den SOLIDWORKS Installations-Manager (wie oben unter Initiieren der SOLIDWORKS Installation beschrieben).
  2. Klicken Sie auf dem Willkommen-Bildschirm auf Einzelinstallation (auf diesem Computer), wenn dies für diese Hauptversion die erste SOLIDWORKS Installation auf diesem Computer ist.
    Wenn Sie von einer aktuellen Version aktualisieren und von einer Einzellizenz auf SolidNetWork Lizenzierung wechseln, klicken Sie auf Einzelinstallation (auf diesem Computer) ändern. Einzelheiten finden Sie unter Aktualisieren von einer Einzellizenz auf SolidNetWork Lizenzierung.
  3. Geben Sie, wenn Sie aufgefordert werden, eine Seriennummer einzugeben, die SolidNetWork Lizenzseriennummer ein.
  4. Geben Sie im Dialogfeld Server hinzufügen die Adresse des SolidNetWork License Manager in folgender Form ein:

    port@ComputerName

    Die Portnummer muss dieselbe sein, die für den License Manager verwendet wird. Der Standard lautet 25734 (wie in Einen License Manager installieren und aktivieren) beschrieben.

    Der SOLIDWORKS Installations-Manager wird versuchen zu validieren, ob auf diesen SolidNetWork License Manager zugegriffen werden kann. Wenn Sie noch keinen License Manager installiert haben, wird diese Validierung fehlschlagen. Sie können jedoch mit der Installation des Lizenz-Clients fortfahren.
  5. Schließen Sie die SOLIDWORKS Installation ab, indem Sie die Anleitungen des SOLIDWORKS Installations-Managers befolgen.
Übergeordnetes Thema Installation und Konfiguration von SolidNetWork Lizenzen
Einen License Manager installieren und aktivieren
SolidNetWork License Manager vor dem Installieren von Lizenz-Clients installieren
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Triaden-Lizenz-Manager-Installation
SolidNetWork Lizenzen mit Firewalls verwenden
SOLIDWORKS Installation wird initiiert
Von Einzellizenzen auf SolidNetWork-Lizenzen aktualisieren


SolidNetWork License Manager vor dem Installieren von Lizenz-Clients installieren

Sie müssen den SolidNetWork License Manager auf mindestens einem Computer installieren und konfigurieren, bevor Sie SolidNetWork Lizenz-Client-Computer installieren.

Bei der Installation mittels einer SolidNetWork Lizenzseriennummer fordert der SOLIDWORKS Installations-Manager Sie auf, den Namen und die Portnummer des Computers mit dem SolidNetWork License Manager einzugeben, und versucht dann, diese Informationen zu validieren.

Diese Validierung kann nicht erfolgreich verlaufen, wenn Sie den SolidNetWork License Manager noch nicht auf dem von Ihnen spezifizierten Computer installiert haben. In diesem Falle zeigt eine fehlgeschlagene Validierung jedoch nicht an, ob Sie die richtige Daten für den License Manager angegeben haben. Wenn der License Manager bereits installiert ist, zeigt ein Fehlschlagen der Validierungen an, dass Sie falsche Daten für den License Manager angegeben haben.

Übergeordnetes Thema Installation und Konfiguration von SolidNetWork Lizenzen
Einen License Manager installieren und aktivieren
Einen Lizenz-Client installieren
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Triaden-Lizenz-Manager-Installation
SolidNetWork Lizenzen mit Firewalls verwenden


Verwalten des Zugriffs auf SOLIDWORKS Versionen

Sie können den Zugriff der Benutzer auf bestimmte Versionen von SOLIDWORKS in einer SolidNetWork Umgebung unterbinden. Diese Funktion ermöglicht Ihnen, die Versionen von SOLIDWORKS zu verwalten, die von verschiedenen Personen, Projekten und Unternehmenseinheiten genutzt werden.

So verwalten Sie die Zugriffsberechtigung für SOLIDWORKS Versionen mithilfe einer FLEXnet Optionsdatei:

  1. Erstellen Sie im Installationsverzeichnis des SolidNetWork License Manager eine Textdatei:
    SolidNetWork_License_Manager_Installationsverzeichnis\Licenses\sw_d.opt
  2. Zum Verwalten der Zugriffsberechtigung für eine bestimmte Version von SOLIDWORKS fügen Sie in der Lizenzdatei die folgende Syntax neben SOLIDWORKS hinzu:
    :SWVERSION=xx wobei xx die Version des SOLIDWORKS Produkts ist, das Sie verwalten möchten.
  3. Zum Verwalten mehrerer Versionen von SOLIDWORKS fügen Sie für jede Version, die Sie verwalten möchten, eine Zeile hinzu.

    Nicht alle FLEXnet Optionen werden unterstützt. Die unterstützten Optionen der Versionsfilter sind:

    INCLUDE | Nur dem Benutzer oder der Gruppe die Möglichkeit zum Starten der spezifischen Version gewähren. Allen anderen Anwender ist es nicht gestattet, die Version zu starten.
    INCLUDE_BORROW | Nur dem Benutzer oder der Gruppe die Möglichkeit zum Ausleihen der spezifischen Version gewähren. Allen anderen Anwender ist es nicht gestattet, die Version auszuleihen.
    EXCLUDE | Den aufgelisteten Benutzer oder die Gruppe daran hindern, die spezifische Version von SOLIDWORKS zu starten. EXCLUDE ersetzt INCLUDE.
    EXCLUDE_BORROW | Den aufgelisteten Benutzer oder die Gruppe daran hindern, die spezifische Version von SOLIDWORKS auszuleihen. EXCLUDE ersetzt INCLUDE.
    Beispiele:
    1 | SWVERSION=26.0 bezieht sich auf SOLIDWORKS 2019
    SWVERSION=25.0 bezieht sich auf SOLIDWORKS 2018
    2 | INCLUDE solidworks:SWVERSION=26.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=26.0 USER jane
    Diese Zeilen in der Optionsdatei würden nur jane erlauben, SOLIDWORKS 2019 auszuführen. Alle anderen Anwender können SOLIDWORKS 2019 weder starten noch ausleihen, aber sie können andere Versionen von SOLIDWORKS ausführen und ausleihen. jane kann ebenfalls andere Versionen von SOLIDWORKS ausführen und ausleihen.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=26.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=25.0 GROUP chicago
    EXCLUDE solidworks USER don
    Diese Zeilen definieren eine GROUP von Benutzern namens chicago, wobei diesen Benutzern der Zugriff auf SOLIDWORKS 2019 und SOLIDWORKS 2018 verweigert wird. Sie können aber jede andere Version von SOLIDWORKS ausführen. Der Benutzer don kann keine Version von SOLIDWORKS ausführen.
    4 | EXCLUDE swinspection_std:SWVERSION=26.0 HOST machine1
    Diese Zeile hindert alle Benutzer auf machine1 daran, SOLIDWORKS Inspection 2019 zu starten.

    Weitere Informationen zu FLEXnet finden Sie in der FLEXnet Publisher Lizenz-Administrationsanleitung im Installationsverzeichnis des SolidNetWork License Managers, (\Docs\flexuser\licensingenduserguide.pdf).

Übergeordnetes Thema Installation und Konfiguration von SolidNetWork Lizenzen
Einen License Manager installieren und aktivieren
Einen Lizenz-Client installieren
SolidNetWork License Manager vor dem Installieren von Lizenz-Clients installieren
Triaden-Lizenz-Manager-Installation
SolidNetWork Lizenzen mit Firewalls verwenden


Triaden-Lizenz-Manager-Installation

Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Wenn der Computer, der die Lizenzdatei verwaltet, nicht verfügbar ist, übernimmt einer der beiden anderen Computer.

Voraussetzungen für die Verwendung von Triaden-Lizenz-Managern:
  • Installieren Sie Triaden-Lizenz-Manager auf stabilen Computern, die nicht oft heruntergefahren werden.
  • Die drei Lizenz-Manager sollten sich im selben Subnetz befinden. Sie sollten Triaden-Lizenz-Manager niemals mit langsamen Verbindungen oder Wählverbindungen konfigurieren.
  • In einer Triaden-Lizenz-Manager-Umgebung sollte der Systemadministrator sofort feststellen können, wenn ein Lizenz-Manager-Computer abstürzt und diesen so schnell wie möglich wieder starten.
    Wenn nur zwei Lizenz-Manager-Computer betrieben werden, ist dies ungünstiger als wenn nur ein einzelner Lizenz-Manager-Computer betrieben wird, da dann zwei Schwachpunkte für einen Ausfall vorliegen.

Inhaltsverzeichnis

  • Installation des Initial Triad License Manager

    Dieses Verfahren beschreibt die Installation von SolidNetWork License Manager auf dem ersten Computer in der Triade.

  • Den Triad License Manager auf weiteren Computern installieren

    Befolgen Sie diese Anweisungen für die Installation der SolidNetWork License Manager-Software auf dem zweiten und dritten Computer in der Triade. Dieses Verfahren entspricht fast der Installation der Software auf dem ersten Computer, mit Ausnahme der Schritte 2(f) und 2(i).

Übergeordnetes Thema Installation und Konfiguration von SolidNetWork Lizenzen
Einen License Manager installieren und aktivieren
Einen Lizenz-Client installieren
SolidNetWork License Manager vor dem Installieren von Lizenz-Clients installieren
Verwalten des Zugriffs auf SOLIDWORKS Versionen
SolidNetWork Lizenzen mit Firewalls verwenden


Installation des Initial Triad License Manager

Dieses Verfahren beschreibt die Installation von SolidNetWork License Manager auf dem ersten Computer in der Triade.

  1. Installieren Sie mit dem SOLIDWORKS Installations-Manager auf dem ersten Triaden-License Manager-Computer den SolidNetWork License Manager:
    1. Starten Sie den SOLIDWORKS Installations-Manager (wie oben unter Initiieren der SOLIDWORKS Installation beschrieben).
    2. Wählen Sie für Installationsart eine der folgenden Optionen aus:
      • Server-Produkte
      • Installieren Sie SolidNetWork License Manager (verteilte Lizenzierung) auf diesem Computer.
    3. Geben Sie auf der Seite SolidNetWork License Manager-Optionen die SolidNetWork Lizenz-Seriennummer und den SolidNetWork License Manager-Installationsort an.
    4. Klicken Sie auf der Seite Zusammenfassung auf Jetzt installieren, um den SOLIDWORKS Installations-Manager-Vorgang abzuschließen.
  2. Konfigurieren Sie den Initial Triad License Manager Computer mit dem SolidNetWork License Manager:
    1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Klicken Sie auf Nein.
      Es erscheint die Registerkarte "Server-Administration" des SOLIDWORKS SolidNetWork License Managers.
    3. Klicken Sie in Erweiterte Optionen auf Optionen.
      Das Dialogfeld Erweiterte Optionen wird geöffnet.
    4. Klicken Sie im SolidNetWork Server-Lizenzmodus auf Eine Lizenzdatei verwenden und dann auf OK.
      Das Dialogfeld Erweiterte Optionen wird geschlossen.
    5. Klicken Sie unter Lizenzinformation auf Modifizieren.
      Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.
    6. Wählen Sie unter Server-Typ die Option Triade aus, und klicken Sie auf Weiter.
    7. Verifizieren Sie im Bereich „Server-Information“, dass der Computername und die Portnummer des Initial Triad License Manager Computers korrekt sind, und klicken Sie dann auf Weiter.

      Prüfen Sie, ob die Adresse der Netzwerkschnittstellenkarte (NIC) den Informationen in der Lizenzdatei von SOLIDWORKS entspricht und ob die Portnummer für den Triad License Manager Computer korrekt ist. Die NIC-Adresse wird auch als MAC-Adresse (Media Access Control Address) bezeichnet. Klicken Sie dann auf Weiter.

      Um die NIC-Adresse zu ermitteln, öffnen Sie ein Eingabeaufforderungsfenster und geben Sie folgende Zeichenfolge ein:

      ipconfig /all

      Wenn Ihr Computer eine Firewall verwendet, müssen Sie darüber hinaus u. U. Angaben auf diesem Bildschirm machen. Informationen finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.

    8. Geben Sie unter Triaden-Partner Server-Information den Computernamen und die Host-ID-Werte für die beiden anderen Triad License Manager Computer ein.
      Dadurch wird sichergestellt, dass ein Client-Computer eine Lizenz von den beiden anderen Servern erhalten kann, wenn ein License Manager nicht verfügbar ist.
    9. Klicken Sie auf dem Bildschirm Lizenzen auf Lesen, um zur SolidNetWork Lizenzdatei zu gelangen und sie zu öffnen.
      Die Lizenzen werden im Dialogfeld SolidNetWork Lizenzdatei-Assistent aufgeführt. Für diesen Computer verwenden Sie eine Lizenzdatei, die Sie von einem Fachhändler oder Kundenzentrum erhalten haben.
    10. Klicken Sie auf Fertig stellen.
    11. Klicken Sie auf OK, um den SolidNetWork Lizenzdatei-Assistenten zu schließen, und dann auf Fertig stellen, um den SolidNetWork License Manager abzuschließen.
Übergeordnetes Thema Triaden-Lizenz-Manager-Installation
Den Triad License Manager auf weiteren Computern installieren
SOLIDWORKS Installation wird initiiert
SolidNetWork Lizenzen mit Firewalls verwenden


Den Triad License Manager auf weiteren Computern installieren

Befolgen Sie diese Anweisungen für die Installation der SolidNetWork License Manager-Software auf dem zweiten und dritten Computer in der Triade. Dieses Verfahren entspricht fast der Installation der Software auf dem ersten Computer, mit Ausnahme der Schritte 2(f) und 2(i).

Es wird angenommen, dass Sie bereits mindestens einen Triad License Manager auf einem anderen Computer installiert haben.

  1. Installieren Sie mit dem SOLIDWORKS Installations-Manager auf dem Triaden-License Manager-Computer den SolidNetWork License Manager:
    1. Starten Sie den SOLIDWORKS Installations-Manager (wie unter SOLIDWORKS Installation wird initiiert beschrieben).
    2. Wählen Sie für Installationsart eine der folgenden Optionen aus:
      • Server-Produkte
      • Installieren Sie SolidNetWork License Manager (verteilte Lizenzierung) auf diesem Computer.
    3. Geben Sie auf der Seite SolidNetWork License Manager-Optionen die SolidNetWork Lizenz-Seriennummer und den SolidNetWork License Manager-Installationsort an.
    4. Klicken Sie auf der Seite Zusammenfassung auf Jetzt installieren, um den SOLIDWORKS Installations-Manager zu installieren.
  2. Konfigurieren Sie den Triad License Manager Computer mithilfe des SolidNetWork License Manager.
    1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
      Da dies das erste Mal ist, dass Sie den SolidNetWork License Manager auf diesem Computer ausführen, werden Sie gefragt, ob Sie ihn jetzt aktivieren möchten.
    2. Klicken Sie auf Nein.
      Es erscheint die Registerkarte "Server-Administration" des SOLIDWORKS SolidNetWork License Managers.
    3. Klicken Sie in Erweiterte Optionen auf Optionen.
      Das Dialogfeld Erweiterte Optionen wird geöffnet.
    4. Klicken Sie im SolidNetWork Server-Lizenzmodus auf Eine Lizenzdatei verwenden und dann auf OK.
      Das Dialogfeld Erweiterte Optionen wird geschlossen.
    5. Klicken Sie unter Lizenzinformation auf Modifizieren.
      Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.
    6. Wählen Sie unter Server-Typ die Optionen Triade und Server-/Lizenzinformation abstimmen aus, und klicken Sie anschließend auf Weiter.
    7. Verifizieren Sie im Bereich „Server-Information“, dass der Computername und die Portnummer für diesen Triad License Manager Computer korrekt sind, und klicken Sie dann auf Weiter.

      Prüfen Sie, ob die Adresse der Netzwerkschnittstellenkarte (NIC) den Informationen in der Lizenzdatei von SOLIDWORKS entspricht und ob die Portnummer für den Triad License Manager Computer korrekt ist. Die NIC-Adresse wird auch als MAC-Adresse (Media Access Control Address) bezeichnet. Klicken Sie dann auf Weiter.

      Um die NIC-Adresse zu ermitteln, öffnen Sie ein Eingabeaufforderungsfenster und geben Sie folgende Zeichenfolge ein:

      ipconfig /all

      Wenn Ihr Computer eine Firewall verwendet, müssen Sie darüber hinaus u. U. Angaben auf diesem Bildschirm machen. Weitere Informationen hierzu finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.

    8. Geben Sie unter Triaden-Partner Server-Information den Computernamen und die Host-ID-Werte ein.
      Dadurch wird sichergestellt, dass ein Client-Computer eine Lizenz von den beiden anderen Servern erhalten kann, wenn ein License Manager nicht verfügbar ist.
    9. Klicken Sie auf dem Bildschirm Lizenzen auf Lesen, um zur SolidNetWork Lizenzdatei zu gelangen und sie zu öffnen.
      Die Lizenzen werden im Dialogfeld SolidNetWork Lizenzdatei-Assistent aufgeführt.
    Diese Lizenzdatei wird durch den ersten Triaden-Lizenz-Computer generiert, den Sie konfiguriert haben. Die Lizenzdatei ist in der Regel unter \licenses\sw_d.lic gespeichert. Beispiel: C:\Programme\SOLIDWORKS Corp\SolidNetWork License Manager\licenses\sw_d.lic.
    1. Klicken Sie auf Fertig stellen.
      Eine Warnung im Dialogfeld SolidNetWork Lizenzdatei-Assistent wird eingeblendet.
    2. Klicken Sie auf OK, um den SolidNetWork Lizenzdatei-Assistenten zu schließen, und dann auf Fertig stellen, um den SolidNetWork License Manager abzuschließen.

Wiederholen Sie diesen Vorgang für den dritten Triaden-Lizenz-Computer.

Übergeordnetes Thema Triaden-Lizenz-Manager-Installation
Installation des Initial Triad License Manager


SolidNetWork Lizenzen mit Firewalls verwenden

Wenn Ihr Computer mit einer Firewall arbeitet, müssen Sie die Ports so konfigurieren, dass sie SolidNetWork Lizenzen unterstützen.

Sie müssen der Firewall zwei SolidNetWork Lizenzports zur Firewall-Ausnahmenliste hinzufügen (z. B. SNL-in-port und SNL-out-port). Wenden Sie sich bei Fragen zu Einzelheiten der Konfiguration dieser Ports an Ihren Systemadministrator.

Wenn Sie Windows-Firewall auf einem unterstützten Windows-Betriebssystem verwenden, müssen Sie die Ports auf dem SolidNetWork License Manager-Computer sowie die SolidNetWork Lizenzdatei modifizieren, um die Lizenzen auf die Lizenz-Client-Computer zu verteilen.

Inhaltsverzeichnis

  • License Manager Computerports für eine Windows Firewall modifizieren

    Wenn Sie eine Windows Firewall verwenden, müssen Sie die Firewall-Anschlusseinstellungen auf dem SolidNetWork License Manager-Computer modifizieren.

  • SolidNetWork License Manager-Einstellungen für eine Windows Firewall modifizieren

    Wenn Sie eine Windows Firewall verwenden, müssen Sie die SolidNetWork Lizenzdatei anpassen, um die Firewallports für das Verteilen von Lizenzen an Client-Computer verwenden zu können.

Übergeordnetes Thema Installation und Konfiguration von SolidNetWork Lizenzen
Einen License Manager installieren und aktivieren
Einen Lizenz-Client installieren
SolidNetWork License Manager vor dem Installieren von Lizenz-Clients installieren
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Triaden-Lizenz-Manager-Installation


License Manager Computerports für eine Windows Firewall modifizieren

Wenn Sie eine Windows Firewall verwenden, müssen Sie die Firewall-Anschlusseinstellungen auf dem SolidNetWork License Manager-Computer modifizieren.

  1. Öffnen Sie in Windows die Systemsteuerung und doppelklicken Sie auf Sicherheitscenter.
  2. Klicken Sie auf Windows Firewall.
  3. Klicken Sie auf der Registerkarte Ausnahmen auf Port hinzufügen.
  4. Geben Sie einen Namen ein (z.B. SNL-in-port) und eine Portnummer (z. B. 25734) und klicken Sie dann auf OK.
  5. Klicken Sie für die zweite Portnummer wieder auf der Registerkarte Ausnahmen auf Port hinzufügen, geben Sie den Namen und die Nummer des anderen Ports an (z. B. SNL-out-port und 25735) und klicken Sie dann auf OK. Notieren Sie sich die Portnummer, da Sie sie später benötigen, wenn Sie die SolidNetWork Lizenzdatei modifizieren.
  6. Schießen Sie das Windows Sicherheitscenter und die Systemsteuerung.
Übergeordnetes Thema SolidNetWork Lizenzen mit Firewalls verwenden
SolidNetWork License Manager-Einstellungen für eine Windows Firewall modifizieren


SolidNetWork License Manager-Einstellungen für eine Windows Firewall modifizieren

Wenn Sie eine Windows Firewall verwenden, müssen Sie die SolidNetWork Lizenzdatei anpassen, um die Firewallports für das Verteilen von Lizenzen an Client-Computer verwenden zu können.

  1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Klicken Sie auf der Registerkarte Server-Administration unter License Server auf Stop. (Klicken Sie auf Ja, wenn Sie um eine Bestätigung gebeten werden, und auf OK, um den License Server vollkommen zu stoppen.)
  3. Klicken Sie unter Lizenzinformation auf Modifizieren.
  4. Wählen Sie unter Server-Typ das Server-Arrangement für Ihr Netzwerk aus (Einzel oder Triade) und klicken Sie dann auf Weiter.
  5. Unter Server-Information:
    1. Wählen Sie Eine Firewall ist auf diesem Server aktiviert.
    2. Die Portnummer und die Portnummer der Händlerdomäne sollten die Portnummern enthalten, die für die Windows-Firewall angegeben sind (Weitere Informationen finden Sie unter License Manager Computerports für eine Windows Firewall modifizieren).
    3. Wählen Sie Optionsdatei aus und klicken Sie auf Durchsuchen, um die Datei zu suchen. Klicken Sie auf Bearbeiten, um Parameter der Datei zu ändern.
      Die Optionsdatei ermöglicht dem Lizenzadministrator, verschiedene Bedienungsparameter der FLEXnet Lizenzierung zu steuern.

      Der empfohlene Speicherort für die Optionsdatei ist im SolidNetWork License Manager-Installationsverzeichnis (SolidNetwork_License_Manager_install_dirLicenses sw_d.opt). Dieses Datei muss sich im selben Verzeichnis wie die Datei SW_D. lic befinden.

      Weitere Informationen zur Optionsdatei finden Sie in der FLEXnet Publisher Lizenz-Administrationsanleitung im Installationsverzeichnis des SolidNetwork License Managers, (\Docs\flexuser\licensingenduserguide.pdf).

    4. Klicken Sie auf Weiter und dann auf Fertig stellen.
  6. Klicken Sie auf der Registerkarte Server-Administration unter License Server auf Start.
  7. Klicken Sie auf OK, um den SolidNetWork License Manager zu schließen.
Übergeordnetes Thema SolidNetWork Lizenzen mit Firewalls verwenden
License Manager Computerports für eine Windows Firewall modifizieren


SolidNetWork Lizenzverwaltung

Zu den Tasks gehören Start, Aktualisierung und Deinstallation des Lizenz-Managers sowie Ausleihen und Zurückgabe von Lizenzen.

Bevor Sie den Lizenz-Manager starten oder aktualisieren, müssen Sie alle ausgeliehenen Lizenzen zurückgeben.

Inhaltsverzeichnis

  • SolidNetWork License Manager starten

    Sie können den SolidNetWork License Manager vom Windows Start-Menü aus starten.

  • SolidNetWork License Manager aktualisieren

    Für SOLIDWORKS Hauptversionen besteht die Aktualisierung des License Managers darin, den alten License Manager zu deinstallieren, einen neuen zu installieren und die SolidNetWork Lizenz zu aktivieren.

  • SolidNetWork Lizenzdateien löschen

    Löschen Sie alte und abgelaufene SolidNetWork Dateien, bevor Sie eine Aktualisierung auf neue vornehmen.

  • Leihen und Rückgabe von SolidNetWork-Lizenzen

    Sie können sich eine SolidWorks Lizenz leihen, um die Software von einem externen Standort aus zu verwenden. Da die Lizenz von dem Pool der verfügbaren Lizenzen entfernt wurde, muss eine geborgte Lizenz zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

  • Leerlaufzeit der Lizenz überwachen

    SOLIDWORKS kann die Leerlaufzeit des SolidNetWork License Managers erkennen, sodass Lizenzen, die eine bestimmte Zeit lang nicht verwendet wurden, der Gruppe der verfügbaren Lizenzen hinzugefügt werden.

  • Temporäre Lizenzen installieren

    Die temporäre "ANY"-Lizenz kann vorübergehend benutzt werden, wenn die SolidNetWork Originallizenz nicht zur Verfügung steht.

  • Von Einzellizenzen auf SolidNetWork-Lizenzen aktualisieren

    Sie können einen Computer von einer SOLIDWORKS Einzellizenz auf eine SolidNetWork Lizenz aktualisieren, indem Sie die SolidNetWork Lizenzseriennummer in den SOLIDWORKS Installations-Manager eingeben.

  • SolidNetWork-Lizenzen mit Zusatzanwendungen

    Sie können den SolidNetWork License Manager verwenden, um Lizenzen für die wichtigsten SOLIDWORKS Zusatzanwendungen zu verteilen.

  • Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden

    Sie können einen Computer in einem Netzwerk so konfigurieren, dass er sowohl als Lizenzmanager bei der Verteilung von SolidNetWork Lizenzen und als Administrator-Installationsabbild-Ablageort fungiert, von dem aus Anwender SOLIDWORKS Software installieren können.

  • FLEXnet Publisher-Lizenzverwaltung

    Die Lizensierung von SolidNetWork basiert auf der Lizenzverwaltung von FLEXnet Publisher®.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Aktivierung einer SolidNetWork Lizenz
Verschieben einer SolidNetWork Lizenz
Installation und Konfiguration von SolidNetWork Lizenzen


SolidNetWork License Manager starten

Sie können den SolidNetWork License Manager vom Windows Start-Menü aus starten.

Führen Sie in Windows diesen Befehl aus: Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager.
Übergeordnetes Thema SolidNetWork Lizenzverwaltung


SolidNetWork License Manager aktualisieren

Für SOLIDWORKS Hauptversionen besteht die Aktualisierung des License Managers darin, den alten License Manager zu deinstallieren, einen neuen zu installieren und die SolidNetWork Lizenz zu aktivieren.

Ein License Manager für eine neuere Version kann Lizenzen für Client Computer verteilen, die auch die frühere Version beibehalten.

  1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Stellen Sie auf der Registerkarte Lizenzverwendung sicher, dass keine Client-Computer im Netzwerk SOLIDWORKS ausführen.
  3. Den alten License Manager deinstallieren. Weitere Informationen finden Sie unter SolidNetWork License Manager deinstallieren.
  4. Installieren Sie den neuen License Manager r und reaktivieren Sie die SolidNetWork Lizenz auf dem License Manager Computer. Einzelheiten finden Sie unter Einen License Manager installieren und aktivieren.

Wenn Sie den SolidNetWork License Manager auf einem Computer aktualisieren, der auch die SOLIDWORKS Anwendung ausführt, müssen Sie die SolidNetWork License Manager und Clients aktualisieren, bevor Sie neue SOLIDWORKS Anwendungs-Service-Packs auf diesem Computer installieren.

Wenn Sie den License Manager auf einem Computer aktualisieren, der Administrator-Installationsabbilder hostet, müssen Sie den License Manager aktualisieren, bevor Sie die Administrator-Installationsabbilder aktualisieren. Weitere Informationen finden Sie unter Denselben Computer für den License Manager und Administrator-Installationsabbilder verwenden.

Inhaltsverzeichnis

  • SolidNetWork License Manager deinstallieren

    Vor der Aktualisierung des SolidNetWork License Manager müssen Sie den alten License Manager deinstallieren, bevor Sie den neuen installieren.

Übergeordnetes Thema SolidNetWork Lizenzverwaltung


SolidNetWork License Manager deinstallieren

Vor der Aktualisierung des SolidNetWork License Manager müssen Sie den alten License Manager deinstallieren, bevor Sie den neuen installieren.

  1. Starten Sie den SolidNetwork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetwork License Manager > SolidNetwork License Manager ).
  2. Verifizieren Sie, dass in diesem Netzwerk kein Client-Computer SOLIDWORKS ausführt.
    Auf der Registerkarte Lizenzverwendung sind alle Clients aufgeführt, die SOLIDWORKS ausführen.
  3. Wenn Sie die SolidNetWork Lizenz auf einen anderen Computer verschieben möchten, geben Sie die Lizenz durch Deaktivieren an diesem Computer, bevor Sie den SolidNetWork License Manager entfernen.
    Informationen über das Verschieben von SolidNetWork Lizenzen finden Sie unter Eine SolidNetWork Lizenz verschieben.
  4. Klicken Sie auf der Registerkarte Server-Administration unter License Server auf Stop.
  5. Klicken Sie auf OK, um den License Manager zu beenden.
  6. Öffnen Sie in Windows Systemsteuerung > Software.
  7. Wählen Sie SOLIDWORKS SolidNetWork License Manager, klicken Sie auf Entfernen und bestätigen Sie diesen Vorgang.
  8. Löschen Sie unter Verwendung von Windows Explorer den Ordner SOLIDWORKS SolidNetWork License Manager.
    (In der Regel befindet sich dieser Ordner unter Programme im SOLIDWORKS Installationsverzeichnis.)

Sie können jetzt eine neue Version des License Managers installieren. Weitere Informationen finden Sie unter Einen License Manager installieren und aktivieren.

Wenn sich auf dem SolidNetWork License Manager-Computer ein Hardware-Dongle befindet, entfernen Sie den Hardware-Dongle, bevor Sie die neue Version des SolidNetWork License Managers installieren.
Übergeordnetes Thema SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
Einen License Manager installieren und aktivieren


SolidNetWork Lizenzdateien löschen

Löschen Sie alte und abgelaufene SolidNetWork Dateien, bevor Sie eine Aktualisierung auf neue vornehmen.

  1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Klicken Sie auf der Registerkarte Server-Administration unter Lizenzdatei auf Modifizieren und dann auf Weiter, bis Sie den Bildschirm Lizenzen erreichen.
  3. Wählen Sie auf dem Bildschirm Lizenzen die alte oder abgelaufene SolidNetWork Lizenzdatei aus, und klicken Sie auf Entfernen.
  4. Klicken Sie auf Fertig stellen und dann auf OK.
Übergeordnetes Thema SolidNetWork Lizenzverwaltung


Leihen und Rückgabe von SolidNetWork-Lizenzen

Sie können sich eine SolidWorks Lizenz leihen, um die Software von einem externen Standort aus zu verwenden. Da die Lizenz von dem Pool der verfügbaren Lizenzen entfernt wurde, muss eine geborgte Lizenz zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

Geliehene Lizenzen sind nur für den aktuellen Benutzer und auf dem Rechner, für den sie ausgeliehen wurden, gültig. Eine Verschiebung auf andere Computer ist nicht möglich.

Die Lizenz wird auf bestimmte Zeit bis maximal 30 Tage verliehen (oder laut Definition durch den Systemadministrator), und die Lizenz wird aus einem Pool verfügbarer Lizenzen entnommen.

Das Ausleihen und Zurückgeben einer Lizenz funktioniert nicht, wenn die SOLIDWORKS Lizenz verwendet wird.

Der Systemadministrator kann das Entleihen anpassen:
  • Er kann Anwender oder Gruppen definieren, die Lizenzen ausleihen dürfen
  • Er kann die Anzahl der Lizenzen festlegen, die ausgeliehen werden können

Weitere Details finden Sie unter SolidNetWork_Lizenz_Manager_Installationsverzeichnis\Docs\flexuser\licensingenduserguide.pdf.

Inhaltsverzeichnis

  • SolidNetWork Lizenzen ausleihen

  • Rückgabe einer SolidNetWork Leihlizenz

    Da eine Leihlizenz aus dem Pool der verfügbaren Lizenzen entfernt wurde, muss diese Leihlizenz zunächst zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

Übergeordnetes Thema SolidNetWork Lizenzverwaltung


SolidNetWork Lizenzen ausleihen

Starten Sie den SolidNetWork License Manager immer vom Windows Start-Menü aus. Sie müssen mit dem SolidNetWork License Manager verbunden sein, um die Lizenz zu beziehen.

Diese Schritte können je nach Systemkonfiguration unterschiedlich ausfallen. Weitere Anweisungen und Optionen finden Sie in der Microsoft Windows-Dokumentation.
  1. Starten Sie den SolidNetWork License Manager auf dem Client-Computer (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Führen Sie auf der Registerkarte Ausleihen einer Lizenz folgende Schritte aus:
    1. Wählen Sie unter Ausleihen bis ein Datum aus.
    2. Wählen Sie die auszuleihenden Produkte aus, und klicken Sie auf Ausleihen und danach zur Bestätigung auf Ja.
    3. Klicken Sie auf Aktualisieren. In der Spalte Ablaufdatum wird angezeigt, wann die Lizenzen wieder zurückgegeben werden müssen.
  3. Klicken Sie auf OK.
Übergeordnetes Thema Leihen und Rückgabe von SolidNetWork-Lizenzen
Rückgabe einer SolidNetWork Leihlizenz


Rückgabe einer SolidNetWork Leihlizenz

Da eine Leihlizenz aus dem Pool der verfügbaren Lizenzen entfernt wurde, muss diese Leihlizenz zunächst zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

  1. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Führen Sie auf der Registerkarte Ausleihen einer Lizenz folgende Schritte aus:
    1. Wählen Sie die zurückzugebenden Produkte aus, und klicken Sie auf Zurückgeben und danach zur Bestätigung auf Ja.
    2. Klicken Sie auf Aktualisieren. Die Spalte Ablaufdatum ist leer, was darauf hinweist, dass die Lizenzen zurückgegeben wurden.
  3. Klicken Sie auf OK.
Es ist nicht erforderlich, Lizenzen nach dem Ablaufdatum zurückzugeben. Die Lizenz wird um Mitternacht des Ablaufdatums in die Gruppe der zurückgegebenen Lizenzen im SolidNetWork License Manager zurückgegeben und die Anwendungen auf dem Remote-System können nicht mehr ausgeführt werden.
Übergeordnetes Thema Leihen und Rückgabe von SolidNetWork-Lizenzen
SolidNetWork Lizenzen ausleihen


Leerlaufzeit der Lizenz überwachen

SOLIDWORKS kann die Leerlaufzeit des SolidNetWork License Managers erkennen, sodass Lizenzen, die eine bestimmte Zeit lang nicht verwendet wurden, der Gruppe der verfügbaren Lizenzen hinzugefügt werden.

  1. Erstellen Sie im Installationsverzeichnis des SolidNetWork License Manager eine Textdatei:
    SolidNetWork_License_Manager_Installationsverzeichnis\Licenses\sw_d.opt
  2. Fügen Sie die folgende Zeile zur Datei hinzu:
    TIMEOUTALL Sekunden

    wobei Sekunden einer Zahl größer oder gleich 900 (15 Minuten) entspricht (zulässige Mindestdauer).

Übergeordnetes Thema SolidNetWork Lizenzverwaltung


Temporäre Lizenzen installieren

Die temporäre "ANY"-Lizenz kann vorübergehend benutzt werden, wenn die SolidNetWork Originallizenz nicht zur Verfügung steht.

Mit der Installation der "ANY"-Lizenzdatei erklären Sie sich bereit, die herkömmliche Lizenz nach Erhalt einer SolidNetWork Lizenz von der Dassault Systèmes SOLIDWORKS Corporation zu implementieren. Die Einhaltung der Lizenzbeschränkungen ist weiterhin erforderlich.

Eine „ANY“-Lizenz installieren:

  1. Wenn Sie ein aktueller Anwender von SolidNetWork sind, deinstallieren Sie den SolidNetWork License Manager und löschen Sie den Installationsordner. Einzelheiten finden Sie unter SolidNetWork License Manager deinstallieren.
  2. Starten Sie den SOLIDWORKS Installations-Manager (wie unter SOLIDWORKS Installation wird initiiert beschrieben).
    1. Wählen Sie für Installationsart eine der folgenden Optionen aus:
      • Server-Produkte
      • Installieren Sie SolidNetWork License Manager (verteilte Lizenzierung) auf diesem Computer.
    2. Geben Sie auf der Seite SolidNetWork License Manager-Optionen die SolidNetWork Lizenz-Seriennummer und den SolidNetWork License Manager-Installationsort an.
    3. Klicken Sie auf der Seite Zusammenfassung auf Jetzt installieren, um den SOLIDWORKS Installations-Manager-Vorgang abzuschließen.
  3. Starten Sie den SolidNetWork License Manager (Start > Programme > SOLIDWORKS Version > SolidNetWork License Manager > SolidNetWork License Manager).
  4. Wenn Sie zur Aktivierung aufgefordert werden, klicken Sie auf Nein.
    Es erscheint die Registerkarte "Server-Administration" des SOLIDWORKS SolidNetWork License Managers.
  5. Klicken Sie in Erweiterte Optionen auf Optionen.
    Das Dialogfeld Erweiterte Optionen wird geöffnet.
  6. Klicken Sie im SolidNetWork Server-Lizenzmodus auf Eine Lizenzdatei verwenden und dann auf OK.
    Das Dialogfeld Erweiterte Optionen wird geschlossen.
  7. Klicken Sie unter Lizenzinformation auf Modifizieren.
    Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.
  8. Wählen Sie unter Server-Typ die Option Einzel aus und klicken Sie auf Weiter.
  9. Wenn Sie folgende Meldung sehen:
    Konnte die Dongle-ID-Nummer nicht lesen. Klicken Sie auf Abbrechen.
    Die ID „ANY“ wird automatisch eingeblendet.
    Wenn Ihr Computer mit einer Firewall arbeitet werden Sie u.U. einige zusätzliche Spezifizierungen auf diesem Bildschirm vornehmen müssen. Weitere Informationen hierzu finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.
  10. Setzen Sie die Installation fort.
Übergeordnetes Thema SolidNetWork Lizenzverwaltung


Von Einzellizenzen auf SolidNetWork-Lizenzen aktualisieren

Sie können einen Computer von einer SOLIDWORKS Einzellizenz auf eine SolidNetWork Lizenz aktualisieren, indem Sie die SolidNetWork Lizenzseriennummer in den SOLIDWORKS Installations-Manager eingeben.

Wenn auf einem Computer SOLIDWORKS nicht installiert ist, können Sie SolidNetWork Lizenzierung spezifizieren, indem Sie die SolidNetWork Seriennummer eingeben, wenn Sie eine Installation mittels dem SOLIDWORKS Installations-Manager vornehmen.

Wenn auf einem Computer SOLIDWORKS bereits installiert ist und Sie von einer Einzellizenz auf SolidNetWork Lizenzierung umsteigen, können Sie für den Client-Computer die Installation modifizieren und die SolidNetWork Lizenzseriennummer statt der Einzellizenzseriennummer angeben, wenn Sie den SOLIDWORKS Installations-Manager ausführen. Weitere Informationen finden Sie unter Modifizieren einer Installation.
Wenn Sie SOLIDWORKS von einem Administrator-Installationsabbild installiert haben, ist die Option zum Modifizieren nicht verfügbar. Sie müssen mit dem Administrator-Options-Editor Änderungen am Administrator-Installationsabbild vornehmen, den Client deinstallieren und die Installation wiederholen.
Übergeordnetes Thema SolidNetWork Lizenzverwaltung
Modifizieren einer Installation


SolidNetWork-Lizenzen mit Zusatzanwendungen

Sie können den SolidNetWork License Manager verwenden, um Lizenzen für die wichtigsten SOLIDWORKS Zusatzanwendungen zu verteilen.

  • Eine gleiche Anzahl von SOLIDWORKS Software-Lizenzen und SOLIDWORKS Zusatzanwendungslizenzen ist nicht erforderlich.
  • Um eine Lizenz für eine Zusatzanwendung auszuchecken, müssen Sie zuerst eine Lizenz für SOLIDWORKS auschecken.
  • Um eine Lizenz für eine Zusatzanwendung auszuleihen, müssen Sie sowohl die SOLIDWORKS Software-Lizenz als auch die SOLIDWORKS Produktlizenz, die die Zusatzanwendung beinhaltet, ausleihen. Eine SOLIDWORKS Standardlizenz wird standardmäßig ausgeliehen. Jedoch müssen Sie sich eine SOLIDWORKS Professional oder SOLIDWORKS Premium Produktlizenz ausleihen, um eine Zusatzanwendung zu aktivieren.
  • Eine Zusatzanwendungslizenz freigeben:
    • Klicken Sie in SOLIDWORKS auf Extras > Zusatzanwendungen, und beenden Sie die Zusatzanwendung.
    • Beenden Sie SOLIDWORKS.
Übergeordnetes Thema SolidNetWork Lizenzverwaltung


Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden

Sie können einen Computer in einem Netzwerk so konfigurieren, dass er sowohl als Lizenzmanager bei der Verteilung von SolidNetWork Lizenzen und als Administrator-Installationsabbild-Ablageort fungiert, von dem aus Anwender SOLIDWORKS Software installieren können.

Die Client-Computer können eine Lizenz vom License Manager erhalten und dann die SOLIDWORKS Anwendung vom selben Computer aus installieren.

Für diese Konfiguration müssen der Lizenz-Manager und das Administrator-Installationsabbild auf demselben Computer installiert sein. Den Lizenz-Manager zuerst installieren und dann das Administrator-Installationsabbilderstellen und verwenden.
Details finden Sie unter:
  • Einen License Manager installieren und aktivieren
  • Bereitstellung für mehrere Clients
Übergeordnetes Thema SolidNetWork Lizenzverwaltung


FLEXnet Publisher-Lizenzverwaltung

Die Lizensierung von SolidNetWork basiert auf der Lizenzverwaltung von FLEXnet Publisher®.

Weitere Informationen zur Lizenzverwaltung von FLEXnet Publisher finden Sie in der FLEXnet Publisher Lizenz-Administrationsanleitung im Installationsverzeichnis des SolidNetwork License Manager (\Docs\flexuser\licensingenduserguide.pdf).

Die jeweils neuesten Informationen zur Lizenzverwaltung von FLEXnet Publisher erhalten Sie über Acresso® Software.

Übergeordnetes Thema SolidNetWork Lizenzverwaltung


Problembehebung

Schlagen Sie unter diesen Themen nach, wenn Sie Hilfe bei der Problembehebung bei Installationsproblemen benötigen.

Inhaltsverzeichnis

  • Netzwerk-Lizenz-Benutzung

  • SOLIDWORKS Installations-Manager-Protokolldateien

    Die Protokolldateien des SOLIDWORKS Installations-Managers stehen Ihnen zur Problembehebung bei Installationsproblemen zur Verfügung.

  • SOLIDWORKS Installations-Manager Download-Ordner

    Der SOLIDWORKS Installations-Manager kann die benötigten Installationsdateien in einen von Ihnen festgelegten Ordner herunterladen. Diese Hilfe gibt Antworten auf häufig gestellte Fragen zum Download-Ordner.

  • Problembehebung bei Netzwerklizenzen

    Wenn die Installation des SolidNetWork Lizenz-Managers fehlschlägt, überprüfen Sie diese möglichen Erklärungen.

  • Problembehebung bei Aktualisierungen

    Wenn Sie während der Aktualisierung auf eine neue SOLIDWORKS Version Probleme haben, überprüfen Sie diese möglichen Erklärungen.

  • Überprüfen der Grafikkarte beim Installieren oder Aktualisieren

    Nach dem Installieren oder Aktualisieren von SOLIDWORKS auf Ihrem Computer sollten Sie SOLIDWORKS Rx ausführen, um sicherzustellen, dass Ihr Computer eine unterstützte Grafikkarte und einen unterstützten Grafikkartetreiber verwendet.


Netzwerk-Lizenz-Benutzung

Dieses Dialogfeld wird geöffnet, wenn für ein Produkt auf dem Server keine Lizenz mehr zur Verfügung steht.

Klicken Sie auf den Pfeil im Feld Produkt, um die Produktauswahl einzublenden. Zur Auswahl stehen unter anderem SOLIDWORKS und alle erwerbbaren Zusatzanwendungen.

Gesamtanzahl an Lizenzen ist die Gesamtzahl der Lizenzen, die Sie erworben haben.

Verfügbare Lizenzen ist die Anzahl an Lizenzen, die gegenwärtig nicht verwendet werden.

Das Feld Lizenzen verwendet von enthält Informationen zu den Personen, die derzeit über eine Lizenz verfügen.

Übergeordnetes Thema Problembehebung
SOLIDWORKS Installations-Manager-Protokolldateien
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Netzwerklizenzen
Problembehebung bei Aktualisierungen
Überprüfen der Grafikkarte beim Installieren oder Aktualisieren


SOLIDWORKS Installations-Manager-Protokolldateien

Die Protokolldateien des SOLIDWORKS Installations-Managers stehen Ihnen zur Problembehebung bei Installationsproblemen zur Verfügung.

Diese Protokolldateien befinden sich im gleichen Ordner wie die anderen SOLIDWORKS Anwendungsprotokolldateien.
  • Für Windows 7 oder höher:

    C:\Benutzer\Benutzername\AppData\Roaming\SOLIDWORKS\Installation Logs\Installierte_Version

Um die Protokolldateienverzeichnisse sehen zu können, müssen Sie u.U. die Windows-Ordner-Option konfigurieren, sodass sie Alle Dateien und Ordner anzeigen.

Wenn die Anwendungsdaten auf einem anderen Laufwerk als C: liegen, dann muss der Verzeichnispfad dementsprechend angepasst werden.

Dieses Verzeichnis enthält die Datei SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, ein allgemeines Protokoll des Fortschritts des SOLIDWORKS Installation-Managers.

Das Unterverzeichnis Andere Protokolldateien enthält weitere detaillierte Protokolldatei-Informationen.

Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Netzwerklizenzen
Problembehebung bei Aktualisierungen
Überprüfen der Grafikkarte beim Installieren oder Aktualisieren


SOLIDWORKS Installations-Manager Download-Ordner

Der SOLIDWORKS Installations-Manager kann die benötigten Installationsdateien in einen von Ihnen festgelegten Ordner herunterladen. Diese Hilfe gibt Antworten auf häufig gestellte Fragen zum Download-Ordner.

Frage Antwort
Wie werden die Dateien in diesen Ordner installiert?

Führen Sie setup.exe aus. Eventuell müssen Sie noch einige Dateien herunterladen, wenn Sie Elemente zur Installation auswählen, die noch nicht heruntergeladen wurden.

Installieren Sie nicht msiexec (siehe unten).
Kann ich MSI-Dateien manuell von diesem Ordner mit msiexec oder einer anderen Anwendung installieren?

Nein. Der Installations-Manager lädt einige Dateien nicht herunter, die für die Ausführung von msiexec benötigt würden.
Kann ich denselben Download-Ordner für alle Versionen auswählen?

Heruntergeladenen Ordner sind versionsspezifisch. Seit SOLIDWORKS 2010 erstellt der SOLIDWORKS Installation-Manager automatische einen versionsspezifischen Unterordner im spezifizierten Ordner.

Ich habe einige Produkte manuell von der Dassault Systèmes SOLIDWORKS Corporation Website heruntergeladen. Kann der Installations-Manager auch diese installieren?
Seit SW2009 können manuell heruntergeladene Dateien vom SOLIDWORKS Installations-Manager verwendet werden. Es ist jedoch besser, den SOLIDWORKS Installations-Manager auszuführen, wobei die Option zum Dateien-Download ausgewählt wird. Der SOLIDWORKS Installations-Manager zeigt, welche Dateien Sie basierend auf Ihrer Installation benötigen und umfasst Links für den Download der einzelnen benötigten Dateien. Diese Option kann verwendet werden, wenn die integrierte Download-Seite nicht funktioniert (meist aufgrund von Download-Beschränkungen durch einen Proxy-Server).
Wenn der Microsoft Internet Explorer fragt, ob Sie während eines Downloads oder einer Installation die Dateien speichern oder ausführen möchten, wählen Sie stets die Option zum Speichern.
Können die heruntergeladenen Dateien von mehreren Anwendern gemeinsam verwendet werden?

Ja. Laden Sie dazu die Dateien auf ein freigegebenes Netzwerk. Jeder Client kann dann den SOLIDWORKS Installations-Manager vom freigegebenen Netzwerk ausführen.

Keine weiteren Downloads sind erforderlich, es sei denn, ein Anwender wählt einige Elemente zur Installation aus, die während des ersten Downloads nicht ausgewählt waren oder wenn der Computer, der diesen Download zur Installation verwendet, einen anderen Satz von Voraussetzungen hat als der Computer, auf den Sie die Dateien heruntergeladen haben.

Wenn Sie im Namen anderer einen Download ausführen, aber nicht installieren, wählen Sie bei der Installation die Option Nur Download. Diese Option ermöglicht es Ihnen, Produkte unabhängig davon auszuwählen, was auf Ihrem System installiert ist. Diese Option kann jedoch nicht für den Download von Patches oder die Erstellung von Administrator-Installationsabbildern verwendet werden.
Wie weiß ich, dass eine neue Version von SOLIDWORKS Produkten verfügbar ist?
Sie werden in den folgenden Fällen benachrichtigt, wenn eine neue Version verfügbar ist:
  • Wenn Sie "Nach Aktualisierungen suchen" ausführen (Start > Alle Programme > SOLIDWORKS Installations-Manager > Nach Aktualisierungen suchen)
  • Wenn Sie den SOLIDWORKS Hintergrund-Downloader aktiviert haben
  • Wenn Sie eine installierte Version von SOLIDWORKS unter Windows Software auswählen und auf Ändern klicken
  • Wenn Sie eine ältere Version des Installations-Managers (sldIM.exe) von einem Download-Ordner aus ausführen.
In diesen Fällen haben Sie die Möglichkeit, eine neuere Version herunterzuladen. Der SOLIDWORKS Installations-Manager wird die neuere Version von sich selbst und keine Installationsdateien herunterladen und ausführen. Sobald die neuere Version des SOLIDWORKS Installations-Managers ausgeführt wird, können Sie einen Satz von Installationsoperationen auswählen. Der SOLIDWORKS Installations-Manager wird dann feststellen, welche Installationsdateien benötigt werden (und früher noch nicht heruntergeladen wurden) und anbieten, diese Dateien herunterzuladen.
Warum lässt mich der SOLIDWORKS Installations-Manager kein anderes Service Pack eines Produkts zur Installation auswählen?

Jede Version des SOLIDWORKS Installations-Managers ist nur für die Installation einer bestimmten Version von SOLIDWORKS Produkten entwickelt. Wenn Sie ein anderes Service Pack installieren möchten, müssen Sie den SOLIDWORKS Installations-Manager dieser Version ausführen. Im vorhergehenden Element erfahren Sie, wie Sie die neueste verfügbare Version finden.
Warum darf der SOLIDWORKS Installations-Manager diese Dateien nicht herunterladen?

Wenn Proxy-Server-Beschränkungen Anwendungen am Download von Dateien hindern, kann der SOLIDWORKS Installations-Manager Dateien nicht automatisch herunterladen.

Sie können Dateien manuell herunterladen und sie anschließend mit dem SOLIDWORKS Installations-Manager installieren. Wählen Sie, um einzelne Dateien herunterzuladen, die Option im SOLIDWORKS Installations-Manager aus (z. B. Manuellen Download durchführen auf der Seite Download-Optionen). Basierend auf Ihrer Produktauswahl und den Systemanforderungen, wird eine Webseite in einem separaten Fenster mit Links für den manuellen Download der erforderlichen Dateien angezeigt. Diese Links sind identisch mit jenen im SOLIDWORKS Kundenportal, Sie brauchen aber nicht nach den Dateien zu suchen.
Nicht alle meine SOLIDWORKS Produkte werden auf das neueste Service Pack aktualisiert. Warum habe ich laut Option „Nach Aktualisierungen suchen“ die neueste Version?

Die Option "Nach Aktualisierungen suchen" informiert Sie darüber, ob Sie die letzte Version des SOLIDWORKS Installations-Managers installiert haben (oder ausführen).

Wenn Sie alle Produkte auf die letzte Version, die installiert ist, aktualisieren möchten, wählen Sie in Software die zuletzt installierte Version von SOLIDWORKS aus und klicken Sie auf Ändern.

Kann ich eine DVD in einen Download-Ordner kopieren?

Ja, aber Installationen können fehlschlagen, wenn Sie nicht den gesamten Inhalt aller DVDs kopieren, die für ein bestimmtes Betriebssystem freigegeben wurden. Der SOLIDWORKS Installations-Manager sucht nach den Dateien swdata*.id, um die Version festzustellen. Wenn diese Dateien fehlen, können die Installationsdateien, die Sie kopiert haben, nicht erkannt werden. Ein Download wird gefordert.
Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager-Protokolldateien
Problembehebung bei Netzwerklizenzen
Problembehebung bei Aktualisierungen
Überprüfen der Grafikkarte beim Installieren oder Aktualisieren


Problembehebung bei Netzwerklizenzen

Wenn die Installation des SolidNetWork Lizenz-Managers fehlschlägt, überprüfen Sie diese möglichen Erklärungen.

Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager-Protokolldateien
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Aktualisierungen
Überprüfen der Grafikkarte beim Installieren oder Aktualisieren

Zugriff auf SolidNetWork Lizenz-Protokolldateien

Wenn ein Lizenzfehler auftritt, kann die Antwort oft in der Datei SNL_Manager_Installationsverzeichnis\lmgrd.log gefunden werden.

Konnte keine Lizenz für SOLIDWORKS erhalten. Kann nicht zum License Server verbinden.

In der Regel wird dieses Problem durch die Porteinstellungen verursacht.

  • Porteinstellungen zwischen dem SolidNetWork License Manager und dem Lizenz-Client stimmen u.U. nicht überein.
  • Weitere Anschlusseinstellungen für mehrere Versionen des SolidNetWork License Manager wurden möglicherweise nicht festgelegt.
  • Überprüfen Sie anhand des Servernamens, ob der Client-Computer den Server richtig auflösen kann und das Routing zum Server korrekt erfolgt. Überprüfen Sie außerdem anhand des Client-Computernamens, ob der Server den Client richtig auflösen kann und das Routing korrekt erfolgt.
Details zu den Porteinstellungen für die SolidNetWork License Manager und Clients finden Sie in SolidNetWork Lizenzen mit Firewalls verwenden.
SolidNetWork Lizenzen mit Firewalls verwenden


Problembehebung bei Aktualisierungen

Wenn Sie während der Aktualisierung auf eine neue SOLIDWORKS Version Probleme haben, überprüfen Sie diese möglichen Erklärungen.

Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager-Protokolldateien
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Netzwerklizenzen
Überprüfen der Grafikkarte beim Installieren oder Aktualisieren

Aktualisieren von einer Quelle, die an einen anderen Ort verschoben wurde

Wenn SOLIDWORKS installiert ist, merkt sich der SOLIDWORKS Installations-Manager den Ort der Installationsquellen (Diskettenmedium, Diskettenabbildung auf einem Netz usw.). Beim Update erwartet der Manager, dass sich die Quelle an derselben Stelle befindet.

Wenn die Quelle an einen anderen Ort verlagert oder gelöscht wurde oder sich das Quellmedium geändert hat, produziert der SOLIDWORKS Installations-Manager eine Fehlermeldung. Sie können aber die Aktualisierung fortsetzen, indem Sie einen anderen Speicherort auswählen, vorausgesetzt, die Datei- und Ordnerstruktur ist da dieselbe.


Überprüfen der Grafikkarte beim Installieren oder Aktualisieren

Nach dem Installieren oder Aktualisieren von SOLIDWORKS auf Ihrem Computer sollten Sie SOLIDWORKS Rx ausführen, um sicherzustellen, dass Ihr Computer eine unterstützte Grafikkarte und einen unterstützten Grafikkartetreiber verwendet.

So überprüfen Sie die Grafikkarte und den Treiber:

  1. Wenn der Installations-Manager die Installation abgeschlossen hat und die Seite Fertig stellen anzeigt, klicken Sie unter System überprüfen auf Systemdiagnose ausführen.

    SOLIDWORKS Rx wird gestartet und führt die Diagnose aus.

  2. SOLIDWORKS Rx prüft, ob die Grafikkarte und der Grafikkartentreiber unterstützt werden. Wenn zwar die Grafikkarte, aber nicht der Treiber unterstützt wird, wird möglicherweise in einer Statusmeldung ein Link zu einem unterstützten Treiber bereitgestellt.

Bei jedem zehnten Start von SOLIDWORKS wir die Meldung System überprüfen eingeblendet, die empfiehlt, wieder die Systemdiagnose auszuführen. Zum Unterdrücken dieser Benachrichtigungen klicken Sie im Windows-Benachrichtigungsbereich mit der rechten Maustaste auf SOLIDWORKS Resource Monitor [image] und dann auf Grafische Benachrichtigungen deaktivieren.

Sie können die Grafikkarte und den Treiber jederzeit überprüfen, indem Sie im Windows-Benachrichtigungsbereich mit der rechten Maustaste auf „SOLIDWORKS Resource Monitor“ klicken. Das Kontextmenü ermöglicht Ihnen auch Folgendes auszuführen:
  • Anzeigen der Hilfe für den SOLIDWORKS Resource Monitor
  • Systemdiagnose ausführen
  • Subskriptionsbenachrichtigungen deaktivieren
  • Grafiktreiber aktualisieren
Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager-Protokolldateien
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Netzwerklizenzen
Problembehebung bei Aktualisierungen


SOLIDWORKS Installations-Manager-Anwendungshilfe

Der SOLIDWORKS Installations-Manager ist eine eigenständige Anwendung, die Ihre SOLIDWORKS Produkte installiert und aktualisiert.

Der SOLIDWORKS Installations-Manager ist das primäre Werkzeug zum Herunterladen, Installieren, Modifizieren, Aktualisieren, Reparieren und Entfernen der SOLIDWORKS Software.

Sie können den SOLIDWORKS Installations-Manager von folgenden Orten aus ausführen:
  • Von einer SOLIDWORKS DVD oder einem freigegebenen Quell- oder Download-Ordner (für die Installation einer neuen Version)
  • Von der Seite Systemsteuerung, Software (zum Modifizieren oder Entfernen einer bestehenden Version)
  • Über eine geplante oder manuelle Aktualisierungsüberprüfung (für das Ermitteln, den Download und die Installation neuer Versionen.

Jede SOLIDWORKS Version verfügt über eine zugehörige SOLIDWORKS Installations-Manager-Version.

Inhaltsverzeichnis

  • SOLIDWORKS Hintergrund-Downloader

    SOLIDWORKS Hintergrund-Downloader führt Datei-Downloads in Hintergrundprozessen (z. B. wenn eine neue Service Pack-Version gefunden wurde) aus, was es Ihnen ermöglicht, weiter zu arbeiten, während Sie downloaden. Wenn der Download abgeschlossen ist, können Sie entscheiden, ob Sie die Installation nun durchführen möchten, den Download auf einen anderen Zeitpunkt verschieben oder ihn entfernen möchten.

  • Nach Aktualisierungsergebnissen suchen

    Die Option Nach Updates suchen sucht nach neueren Versionen von SOLIDWORKS.

  • Administrator-Installationsabbild-Position

    Geben Sie den Installationsspeicherort des Administrator-Installationsabbilds an.

  • Download-Optionen

    Geben Sie Einzelheiten zum Durchführen des Download-Vorgangs an, z. B. den Speicherort der heruntergeladenen Dateien, die Download-Methode und ob die heruntergeladenen Dateien installiert werden sollen.

  • Download-Optionen für SOLIDWORKS Installations-Manager-Dateien

    Sie haben beschlossen, eine spätere Version des SOLIDWORKS Installations-Managers herunterzuladen. Verwenden Sie diesen Bildschirm, um zu definieren, wo und wie er heruntergeladen werden soll.

  • Produkt-Installationsdateien herunterladen

    Definieren Sie, wo und wie fehlende Dateien für das betreffende Produkt heruntergeladen werden sollen.

  • Download-Verlauf

    Der SOLIDWORKS Installations-Manager lädt während dieses Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.

  • Download-Ergebnisse

    Gibt an, ob der Download erfolgreich durchgeführt wurde, während des Vorgangs fehlgeschlagen ist oder abgebrochen wurde.

  • Installationsfehler / Installation abgebrochen

    Bei der Installation ist ein Fehler aufgetreten oder sie wurde abgebrochen.

  • Installation vollständig

    Der SOLIDWORKS Installations-Manager hat die Verarbeitung abgeschlossen.

  • Installationsort

    Geben Sie an, wo SOLIDWORKS installiert werden soll.

  • Aktualisierungsoptionen

    Auf diesem Computer sind eine oder mehrere SOLIDWORKS Hauptversionen installiert. Sie können eine neue Installation erstellen, die parallel zu der älteren Version existiert, oder Sie können ein Upgrade durchführen, das die ältere Version entfernt.

  • Installationsfortschritt

    Dieser Bildschirm zeigt den Verlauf der Installation.

  • Installationstyp

    Geben Sie den Installationsvorgang an, den Sie ausführen möchten, z. B. Erstellen einer neuen Installation, Modifizieren oder Reparieren einer vorhandenen Installation, Erstellen eines Administrator-Installationsabbilds, Installieren von Administrator-Serverprodukten oder Herunterladen von Dateien ohne Installation.

  • Installieren und Verwalten mehrerer Computer

    Der SOLIDWORKS Installations-Manager bietet die folgenden Werkzeuge zum Installieren auf mehreren SOLIDWORKS Computern und deren Verwaltung.

  • Manueller Download

    Sie haben sich für das manuelle Herunterladen von Dateien entschieden (oder Sie haben diese Entscheidung möglicherweise getroffen, als Sie den SOLIDWORKS Installations-Manager zum letzten Mal ausgeführt haben).

  • Neuere Version verfügbar

    Der Installations-Manager hat eine neuere Version von SOLIDWORKS Produkten gefunden. Sie können die Version von der ursprünglichen Installations-DVD oder dem ursprünglichen Download installieren oder die neuere Version herunterladen und installieren.

  • Keine neuen Versionen verfügbar

    Es stehen keine neueren Versionen zum Download bereit. Fahren Sie mit der Installation der angegebenen Version fort.

  • Festgestellte Prozesse

    Der SOLIDWORKS Installations-Manager hat auf diesem Computer laufende Prozesse festgestellt, die eine erfolgreiche Installation verhindern könnten.

  • Produktauswahl

    Geben Sie die Produktkomponenten an, die installiert, modifiziert, heruntergeladen oder entfernt werden sollen.

  • Produkte zum Herunterladen

    Wählen Sie SOLIDWORKS Produkte zum Herunterladen an einen bestimmten Ablageort aus.

  • Zu reparierende Produkte

    Wenn Sie Diese Installation reparieren auswählen, zeigt dieser Bildschirm die SOLIDWORKS Produkte mit den Versionsnummern an, die von dieser Version des SOLIDWORKS Installations-Managers repariert werden können.

  • Seriennummern

    Seriennummern, die im Verteilungspool gefunden werden, assoziieren Ihren Computer mit den SOLIDWORKS Produkten, die Sie erworben haben.

  • Server-Installation

    Die Server-Produkte, die Sie zu installieren versuchen, sind mit den Ergebnissen der Installation aufgeführt.

  • SolidNetWork License Manager

    Legen Sie Installationsoptionen für das Server-Produkt des SolidNetWork License Manager fest.

  • Zusammenfassung

    Der SOLIDWORKS Installations-Manager verfügt über alle für die Durchführung der Installation erforderlichen Informationen.

  • Warnungen bei der Systemprüfung

    Die Systemprüfung hat Probleme gemeldet, die sich auf die weitere Installation auswirken könnten. In den meisten Fällen sollten Sie mit dem SOLIDWORKS Installations-Manager fortfahren können.

  • Bohrungsassistent/Toolbox-Optionen

    Wenn SOLIDWORKS Toolbox installiert ist, beinhaltet SOLIDWORKS eine Standardbibliothek von Bohrungstypen und Maschinenteilen.

  • Produkte deinstallieren

    Wenn Sie die Option zum Entfernen oder Deinstallieren von Programmen in der Systemsteuerung auswählen, zeigt dieser Bildschirm die SOLIDWORKS Produkte (mit Versionsnummern) an, die von dieser Version des SOLIDWORKS Installations-Managers deinstalliert werden können. Sie können zwischen einer Standard-, benutzerdefinierten oder vollständige Deinstallation wählen.


SOLIDWORKS Hintergrund-Downloader

SOLIDWORKS Hintergrund-Downloader führt Datei-Downloads in Hintergrundprozessen (z. B. wenn eine neue Service Pack-Version gefunden wurde) aus, was es Ihnen ermöglicht, weiter zu arbeiten, während Sie downloaden. Wenn der Download abgeschlossen ist, können Sie entscheiden, ob Sie die Installation nun durchführen möchten, den Download auf einen anderen Zeitpunkt verschieben oder ihn entfernen möchten.

Hintergrund-Downloader wird standardmäßig aktiviert, wenn Sie SOLIDWORKS installieren.

Wenn der Installations-Manager ausgeführt wurde, um eine Installation oder einen Download auszuführen, wird der Hintergrund-Downloader angehalten. Der Downloader hält jeden Download an und lässt nicht zu, dass neue Downloads gestartet werden und dass der Download-Zielordner geändert wird.

Sie können den Hintergrund-Downloader während der Installation deaktivieren. Deaktivieren Sie auf der Seite „Zusammenfassung“ unter „Download-Optionen“ die Option Hintergrund-Downloader für zukünftige Service Packs verwenden.

Wenn die Option aktiviert ist, erscheint dieses Symbol in der Windows-Taskleiste:

Durch Klicken auf dieses Symbol kann auf folgende Optionen zugegriffen werden:
  • Hilfe für Hintergrund-Downloader
  • Download anhalten
  • Download wieder aufnehmen
  • Download abbrechen
  • Installationsoptionen
  • Download-Position ändern
  • Nach Aktualisierungen suchen
  • Automatisch nach Aktualisierungen suchen
  • Aktualisierungen automatisch herunterladen
  • Hintergrund-Downloader deaktivieren

Hilfe für Hintergrund-Downloader

Öffnen Sie dieses Hilfethema für den Hintergrund-Downloader in der SOLIDWORKS Installationsanleitung.

Download anhalten/wieder aufnehmen

Wenn ein Download im Hintergrund ausgeführt wird, klicken Sie auf Download anhalten, um den Download anzuhalten. Wenn Sie den Download später fortsetzen wollen, klicken Sie auf Download wieder aufnehmen.

Download abbrechen

Wenn ein Download ausgeführt wird, brechen Sie den Download ab und löschen Sie alle bereits heruntergeladene Dateien.
Ein abgebrochener Download kann nicht wieder aufgenommen werden.

Installationsoptionen

Wenn ein Download abgeschlossen ist, können Sie aus den folgenden Optionen auswählen:
  • Jetzt installieren: Heruntergeladene Dateien installieren.
  • Erinnere mich später: Heruntergeladene Dateien nicht installieren, aber eine Erinnerungsmeldung einrichten.
  • Diesen Download löschen: Heruntergeladene Dateien nicht installieren und löschen. (Diese Option sollte gewählt werden, wenn Sie sich entschieden haben, die heruntergeladenen Dateien nicht zu installieren.)

Download-Position ändern

Speicherort für die vom Hintergrund-Downloader heruntergeladenen Dateien ändern.

Diese Option ist nicht verfügbar, wenn ein Download läuft oder angehalten wurde.

Nach Aktualisierungen suchen

Die Funktion Nach Aktualisierungen suchen des SOLIDWORKS Installations-Managers wird ausgeführt.

Automatisch nach Aktualisierungen suchen

Die Funktion Nach Aktualisierungen suchen wird regelmäßig ausgeführt und Sie werden benachrichtigt, wenn Aktualisierungen zum Download bereit stehen.

Aktualisierungen automatisch herunterladen

Die Funktion Nach Aktualisierungen suchen wird regelmäßig ausgeführt und bereitgestellte Aktualisierungen werden heruntergeladen.

Deaktivieren und Reaktivieren von SOLIDWORKS Hintergrund-Downloader

Sie können den Hintergrund-Downloader deaktivieren, indem Sie auf das Symbol klicken und Hintergrund-Downloader deaktivieren wählen.

Um den Hintergrund-Downloader wieder zu aktivieren, klicken Sie auf Start > Alle Programme > SOLIDWORKS Installations-Manager > SOLIDWORKS Hintergrund-Downloader.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Nach Aktualisierungsergebnissen suchen

Die Option Nach Updates suchen sucht nach neueren Versionen von SOLIDWORKS.

Wenn Sie über Administratorrechte für den Computer verfügen, können Sie Nach Updates suchen manuell ausführen:
  • Klicken Sie in Windows auf Start > Programme > SOLIDWORKS Installations-Manager > Nach Updates suchen.
  • Klicken Sie in SOLIDWORKS auf Hilfe > Nach Updates suchen.
Die Funktion Nach Updates suchen ist bei Clients, die von Administrator-Installationsabbildern installiert wurden, nicht verfügbar.

Neuere Version verfügbar

Der SOLIDWORKS Installations-Manager hat eine neuere Version von SOLIDWORKS Produkten gefunden. Sie können auf eine neuere Version aktualisieren, indem Sie den SOLIDWORKS Installations-Manager für diese Version auswählen.

Die neuere Version kann Installationsdateien auf der Basis der Produkte herunterladen, die Sie bei der Installation ausgewählt haben. Sie können die heruntergeladenen Dateien mit anderen Anwendern, die auch den SOLIDWORKS Installations-Manager für die Installationen verwenden, gemeinsam verwenden.

Diese Downloads sind nur für die Verwendung durch den SOLIDWORKS Installations-Manager geeignet.
Folgende Optionen stehen zur Verfügung:
  • Falls mehrere Versionen verfügbar sind, können Sie eine Version aus der Liste auswählen.
  • Für Details zu dieser Version klicken Sie auf Inhalt der Aktualisierung prüfen.
Durch Klicken auf Weiter wird die ausgewählte Version des SOLIDWORKS Installations-Managers abgerufen und ausgeführt.

Keine neuen Downloads verfügbar/Es kann nicht nach neuen Versionen gesucht werden

Der SOLIDWORKS Installations-Manager hat keine neuere Version von SOLIDWORKS Produkten gefunden, entweder weil Sie bereits die aktuellste zur Verfügung stehende Version installieren oder weil die zur Überprüfung erforderliche Verbindung zur SOLIDWORKS Website nicht hergestellt werden konnte.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Administrator-Installationsabbild-Position

Geben Sie den Installationsspeicherort des Administrator-Installationsabbilds an.

Beim Erstellen eines Administrator-Installationsabbilds sind die folgenden Optionen verfügbar:
Neue Installationsabbild-Position | Dies ist der Verzeichnisort, an dem der SOLIDWORKS Installations-Manager das neue Installationsabbild erstellt. | Dieses Verzeichnis kann kein bestehendes Administrator-Installationsabbild enthalten. Das Administratorabbild muss sich in einem freigegebenen Ordner befinden, damit es den Clients bereitgestellt werden kann.
Geschätzter erforderlicher Speicher für Abbilderstellung | Dies ist der für das Administrator-Installationsabbild erforderliche zusätzliche Speicher. | Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Anforderungen bzgl. des Installationsabbilds zu erfüllen.
Installationsabbild erstellen von | Die ist der Verzeichnisort, von dem aus Sie SOLIDWORKS Produkte installieren. Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Einzelheiten finden Sie unter Download-Optionen.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Download-Optionen

Geben Sie Einzelheiten zum Durchführen des Download-Vorgangs an, z. B. den Speicherort der heruntergeladenen Dateien, die Download-Methode und ob die heruntergeladenen Dateien installiert werden sollen.

Der SOLIDWORKS Installations-Manager unterstützt die elektronische Software-Bereitstellung (ESD). Wenn Sie nicht von einer SOLIDWORKS DVD installieren, werden Sie aufgefordert, die Quelle für die SOLIDWORKS Produkte, die Sie installieren, anzugeben.

Für Antworten zu Fragen über den Download-Ordner siehe SOLIDWORKS Installations-Manager Download-Ordner.

Was möchten Sie tun?

Wählen Sie eine der folgenden Optionen aus:

Herunterladen und installieren/Download und Abbild erstellen

Nach erfolgtem Download führt der SOLIDWORKS Installations-Manager eine Installation mit den heruntergeladenen Dateien aus.

Nur Download. Sie können einmal herunterladen und dann heruntergeladene Dateien auf mehreren Computern verwenden.

Der SOLIDWORKS Installations-Manager führt nach Abschluss des Downloads keine Installation aus.

Normalerweise würden Sie diese Option dann auswählen, wenn Sie die Dateien zum Konfigurieren einer Installationsdatei herunterladen, die auf mehreren Computern verwendet werden soll.

Wenn Sie diese Option auswählen, werden Sie aufgefordert, einen von zwei Dateisätzen auszuwählen, der heruntergeladen werden soll:
  • Dateien für DIESEN Computer: Der Download umfasst nur die Dateien, die in dem aktuell auf diesem Computer befindlichen Installationsdateisatz fehlen.
    Dies sollte ein kleineres Download sein, weil es nur Folgendes enthält:
    • Nur Dateien für die auf der Seite „Produktauswahl“ ausgewählte Produkte
    • Nur die für Ihren Computer erforderlichen, aber noch nicht installierten Dateien

    Wenn Sie jedoch versuchen, diesen heruntergeladenen Dateisatz auf einem anderen Computer zu verwenden, um eine Installation vorzunehmen, könnten einige Dateien fehlen (da sich der Installationsdateisatz auf dem anderen Computer von diesem unterscheiden könnte). Mit diesen Download-Dateien können Sie die Installation auf einem anderen Computer durchführen, aber wenn die Installation ausgeführt wird, müssen Sie möglicherweise zusätzliche Dateien herunterladen, um den Installationsdateisatz auf diesem Computer zu vervollständigen.

  • Dateien für die Verwendung auf JEDEM Computer: Der Download umfasst den vollständigen Installationsdateisatz, mit dessen Hilfe diese Version auf jedem beliebigen Computer installiert werden kann.

    Dieser Download ist umfangreicher, weil es den vollständigen Dateisatz umfasst, den Sie zum Installieren dieser Version eines beliebigen Produkts auf jedem Computer verwenden können.

    Wenn Sie einen begrenzten Satz herunterzuladender Produkte angegeben haben, ignoriert diese Option diese Festlegung und lädt alle in der Produktversion enthaltenen Produkte herunter.

    Der Download enthält alle zum Erstellen eines Administrator-Installationsabbilds benötigten Dateien, also nicht nur diejenigen, die zur Durchführung einer individuellen Installation erforderlich sind.

Nur installieren/Nur Abbild erstellen. Ich habe bereits alle erforderlichen Installationsdateien.

Der SOLIDWORKS Installations-Manager lädt keine Dateien herunter, sondern verwendet die im ausgewählten Verzeichnis befindlichen Dateien.

Klicken Sie auf Durchsuchen, um zu einem anderen Speicherort zu navigieren. So können Sie z. B. zu einer Installations-DVD oder einem Download-Ordner navigieren, solange sich an diesem Speicherort alle benötigten Dateien befinden.

Wenn Sie eine Fehlermeldung erhalten, dass der Ordner nicht vollständig ist, Sie aber davon ausgegangen sind, dass alle Installationsdateien vorhanden sind, sind mögliche Erklärungen folgende:
  • Sie habe eine Komponente zur Installation ausgewählt, die früher noch nicht heruntergeladen wurde, oder sie wurde standardmäßig ausgewählt.
  • Die Dateien wurden auf einem anderen Computer mit anderen Systemanforderungen heruntergeladen.
  • Sie haben früher eine Client-Installation ausgeführt und erstellen nun ein Administrator-Installationsabbild, für das ein größerer Dateisatz erforderlich ist.

Sie können entweder zu einem Ordner navigieren, der alle Dateien enthält (z. B. zu einer DVD), oder eine der Download-Optionen auswählen.

Wohin sollen die erforderlichen Dateien heruntergeladen werden?

Dies ist der Download-Ordner.

In manchen Fällen ist diese Option zwar sichtbar, aber deaktiviert. Wenn z. B. Nur installieren angegeben wird, installiert der SOLIDWORKS Installations-Manager alle heruntergeladenen Dateien aus dem für diese Option ausgewählten Verzeichnis, anstatt einen eigenen Download-Ordner zu verwenden.

Ob Sie diese Dateien nun herunterladen oder auf sie von lokaler Stelle zugreifen – alle Dateien müssen in denselben Download-Ordner heruntergeladen werden.

Geschätzte Download-Größe

Der geschätzte Festplattenspeicherbedarf für den Download basiert auf der vollständigen ausgewählten Liste, ungeachtet dessen, ob es sich um einen neuen Download handelt oder ob Sie einen Download von einer früheren Sitzung weiterführen.

Wenn Sie z. B. einen früheren Download wieder aufnehmen, verarbeitet der SOLIDWORKS Installations-Manager nur diejenigen Dateien, die noch nicht heruntergeladen wurden. Die Download-Zeit könnte unter der Schätzung liegen.

Wenn eine Datei im Rahmen des vorherigen Downloads vollständig heruntergeladen wurde, ist ihre Größe in dieser Schätzung nicht enthalten. Daher ist die Schätzung möglicherweise größer als der tatsächliche Umfang des Downloads

Wie möchten Sie die Dateien herunterladen?

Dafür gibt es zwei Optionen:

Manueller Download

In manchen Fällen verhindert ein Proxy-Server vom SOLIDWORKS Installations-Manager initiierte automatische Downloads.

Wenn Sie diese Option auswählen, können Sie die Dateien manuell über eine Webseite herunterladen und die Installationsvorgänge dann innerhalb des SOLIDWORKS Installations-Managers abschließen. Diese Webseite wird vom SOLIDWORKS Installations-Manager so angepasst, dass nur diejenigen Dateien heruntergeladen werden, die zum Abschließen der Installation erforderlich sind.

Beschleunigen Sie die Downloads, indem Sie eine höhere Netzwerk-Bandbreite verwenden

Der Downloader verwendet einen Algorithmus zur Erhöhung der Download-Geschwindigkeit, indem die Netzwerkbandbreite während des Downloads erhöht wird.

In einigen Fällen kann das die Netzwerkleistung stören. Wenn Sie Probleme beim Download haben, wird diese Option vom Proxy-Server u. U. nicht unterstützt. Versuchen Sie, diese Option zu deaktivieren, und den Download zu wiederholen. Einzelheiten erfahren Sie von Ihrem Netzwerk-Administrator.

Diese Option trifft nur auf automatische Downloads zu. Sie hat keinerlei Auswirkung auf manuelle Downloads.

Verwenden des SOLIDWORKS Hintergrund-Downloader

Sie können diesen Downloadvorgang mit dem SOLIDWORKS Hintergrund-Downloader abschließen. Auch können Sie mit dem Downloader SOLIDWORKS Service Pack-Versionen herunterladen, sobald sie zur Verfügung gestellt werden.

Der SOLIDWORKS Hintergrund-Downloader kann neue Service Pack-Aktualisierungen automatisch im Hintergrund erkennen und herunterladen und benachrichtigt Sie, wenn der Download abgeschlossen ist und die Dateien installiert werden können. Einzelheiten finden Sie unter SOLIDWORKS Hintergrund-Downloader.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Download-Optionen für SOLIDWORKS Installations-Manager-Dateien

Sie haben beschlossen, eine spätere Version des SOLIDWORKS Installations-Managers herunterzuladen. Verwenden Sie diesen Bildschirm, um zu definieren, wo und wie er heruntergeladen werden soll.

Für Antworten zu Fragen über den Download-Ordner siehe SOLIDWORKS Installations-Manager Download-Ordner.

Dieser Bildschirm erscheint nur, wenn ein Problem mit den Download-Standardordner vorliegt (wenn z. B. kein Schreib- oder Netzwerkzugriff verfügbar ist). Normalerweise können Sie einfach ein alternatives Download-Verzeichnis angeben, um weitermachen zu können.

Download-Verzeichnis

Wählen Sie den Zielordner für die SOLIDWORKS Installations-Manager Dateien aus.

Es werden der Umfang des Downloads sowie der benötigte Speicherplatz angezeigt. Die Menge des erforderlichen Speicherplatzes beinhaltet extra Speicherplatz für das Entpacken bestimmter Downloads und ist größer als die tatsächliche Größe des Downloads.

Download-Beschleuniger verwenden

Wenn Sie diese Option auswählen, verwendet der Downloader einen Algorithmus zur Erhöhung der Download-Geschwindigkeit.

Die Download-Beschleunigung erhöht die Bandbreite und kann die Netzwerkleistung stören. Kontaktieren Sie Ihren Netzwerk-Administrator, bevor Sie die Download-Beschleunigung aktivieren.

Wenn Download-Beschleunigung vom Proxy-Server nicht unterstützt wird, wird diese Option automatisch deaktiviert.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Produkt-Installationsdateien herunterladen

Definieren Sie, wo und wie fehlende Dateien für das betreffende Produkt heruntergeladen werden sollen.

Der SOLIDWORKS Installations-Manager lädt während des Download-Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.

Das Abbrechen dieses Bildschirm führt zum Abbruch der restlichen Installationssequenz.

Bezüglich der Konsequenzen eines Abbruchs und Anleitungen zum Abschließen von unterbrochenen Installationen siehe Installationsfehler.

Download-Verzeichnis

Wählen Sie den Zielordner für die heruntergeladenen Dateien aus.

Der Umfang des Downloads und der benötigte Speicherplatz auf der Festplatte werden angezeigt. Der erforderliche Speicherplatz beinhaltet extra Speicherplatz für das Entpacken bestimmter Downloads und ist größer als der tatsächliche Umfang des Downloads.

Antworten auf Fragen zum Download-Ordner finden Sie unter SOLIDWORKS Installations-Manager Download-Ordner.

Download-Optionen

Beschleunigen Sie die Downloads, indem Sie eine höhere Netzwerk-Bandbreite verwenden

Der Downloader verwendet einen Algorithmus zur Erhöhung der Download-Geschwindigkeit, indem die Netzwerkbandbreite während des Downloads erhöht wird.

In einigen Fällen kann das die Netzwerkleistung stören. Wenn Sie Probleme beim Download haben, wird diese Option vom Proxy-Server u. U. nicht unterstützt. Versuchen Sie, diese Option zu deaktivieren, und den Download zu wiederholen. Einzelheiten erfahren Sie von Ihrem Netzwerk-Administrator.
Die Download-Beschleunigung erhöht die Bandbreite und kann die Netzwerkleistung stören. Kontaktieren Sie Ihren Netzwerk-Administrator, bevor Sie die Download-Beschleunigung aktivieren.

Wenn Download-Beschleunigung vom Proxy-Server nicht unterstützt wird, wird diese Option möglicherweise automatisch deaktiviert.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Installationsfehler / Installation abgebrochen
SOLIDWORKS Installations-Manager Download-Ordner


Download-Verlauf

Der SOLIDWORKS Installations-Manager lädt während dieses Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.

Um den Download nach dem Start abzubrechen, klicken Sie auf Abbrechen.

Wenn Sie den Download abbrechen oder der Download fehlschlägt, informiert Sie der Bildschirm Download abgebrochen oder Download-Problem darüber, welche Downloads nicht abgeschlossen wurden, und ermöglicht die Fortsetzung des Downloads oder das Schließen der Anwendung.

Für Antworten zu Fragen über den Download-Ordner siehe SOLIDWORKS Installations-Manager Download-Ordner.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Download-Ergebnisse

Gibt an, ob der Download erfolgreich durchgeführt wurde, während des Vorgangs fehlgeschlagen ist oder abgebrochen wurde.

Download-Problem/Download abgebrochen

Wenn Download-Problem angezeigt wird, ist der SOLIDWORKS Installations-Manager auf Probleme gestoßen, die die Durchführung des Downloads verhinderten.

Wenn Download abgebrochen wird, haben Sie den Herunterladevorgang vor seinem Abschluss abgebrochen.

Fahren Sie wie folgt fort:

Download wiederholen/Automatische Downloads wiederholen | Um den automatischen Download an der Stelle fortzusetzen, an der Sie ihn abgebrochen hatten, wählen Sie diese Option aus und klicken Sie auf Download wiederholen oder Download fortsetzen.
Dateien einzeln in einem Webbrowser downloaden | In manchen Fällen verhindert ein Proxy-Server vom SOLIDWORKS Installations-Manager initiierte automatische Downloads. | Wenn Sie diese Option auswählen, können Sie die Dateien manuell über eine Webseite herunterladen und die Installationsvorgänge dann innerhalb des SOLIDWORKS Installations-Managers abschließen. Diese Webseite wird vom SOLIDWORKS Installations-Manager so angepasst, dass nur diejenigen Dateien heruntergeladen werden, die zum Abschließen der Installation erforderlich sind.

Download abgeschlossen

Der Bildschirm „Download abgeschlossen“ erscheint, wenn der Download abgeschlossen ist und Sie die Option Nur Download ausgewählt haben.

Klicken Sie auf Fertigstellen, um den SOLIDWORKS Installations-Manager zu beenden.

Versuchen Sie nicht, diese Produkte manuell zu installieren. Verwenden Sie zum Installieren der heruntergeladenen Dateien den SOLIDWORKS Installations-Manager.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Installationsfehler / Installation abgebrochen

Bei der Installation ist ein Fehler aufgetreten oder sie wurde abgebrochen.

Wenn ein Fehler oder ein Abbruch eintritt:
  • Produkte, die vor dem Fehler oder Abbruch installiert wurden, bleiben auf dem Computer.
  • Das Produkt, das während des Abbruchs installiert wurde, wird, wenn möglich, zurückgesetzt, sodass keine teilweisen Installationen vorliegen.
  • Die übrigen Produkte werden weder installiert noch deinstalliert. Unter Noch nicht versucht wird eine Liste bereitgestellt.

    Um das Installieren oder Deinstallieren dieser Produkte fortzusetzen, klicken Sie auf den bereitgestellten Link.

Der SOLIDWORKS Installations-Manager installiert zunächst erforderliche Dateien, die auf dem Computer noch nicht installiert sind, wie etwa .NET Framework.

Inhaltsverzeichnis

  • Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation

    Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation erneut ausführen, wodurch sie vom Punkt des Eintretens des Problems an fortgesetzt wird.

  • Reparieren einer Installation

    Wenn Sie Probleme mit einem installierten SOLIDWORKS Produkt haben, können Sie den SOLIDWORKS Installations-Manager für die Reparatur der Installation verwenden.

  • Kontaktaufnahme mit dem SOLIDWORKS Fachhändler

    Wenn das Ändern oder Reparieren der Installation fehlschlägt, wenden Sie sich an Ihren SOLIDWORKS Fachhändler vor Ort mit den Informationen, die auf dem Bildschirm angezeigt werden. Möglicherweise müssen Sie auch eine Zip-Datei der Protokolldateien des SOLIDWORKS Installations-Managers bereitstellen.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation

Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation erneut ausführen, wodurch sie vom Punkt des Eintretens des Problems an fortgesetzt wird.

  1. Notieren Sie sich die Fehlermeldung und den Produktcode für die fehlgeschlagene Installation, so wie sie im Fenster Installationsfehler oder Installation abgebrochen angezeigt werden.
    Wenn Sie nach einer Quelldatei gefragt werden und Sie keine vorhandene SOLIDWORKS Installation modifizieren, ist u. U. die Installation oder der Computer defekt. Wenden Sie sich an Ihren SOLIDWORKS Fachhändler.
  2. Starten Sie den Computer neu.
  3. Um sicherzustellen, dass keine SOLIDWORKS Produkte ausgeführt werden, drücken Sie in Windows Strg+Alt+Entf, um den Task Manager zu öffnen.
  4. Wenn auf der Registerkarte Prozesse einige der folgenden Prozesse unter Name angezeigt werden, wählen Sie sie aus, und klicken Sie auf Prozess beenden.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Wenn die Anwendung bereits installiert ist und Sie versuchen, sie zu ändern oder zu entfernen, versuchen Sie, die Installation zu reparieren. Weitere Informationen hierzu finden Sie unter Reparieren einer Installation.
  6. Klicken Sie in Windows 7 oder höher auf Start > Systemsteuerung > Programme und Funktionen.
  7. Wählen Sie die SOLIDWORKS Version aus, die fehlgeschlagen ist.
    Wenn kein Eintrag für die SOLIDWORKS Version vorliegt, die Sie zu installieren versuchen, wiederholen Sie den Installationsvorgang.
  8. Führen Sie einen der folgenden Schritte aus:
    • Um den Vorgang zu wiederholen, klicken Sie auf Ändern, und wählen Sie alle Produkte aus, die nicht installiert oder während der Installation übersprungen wurden.

    • Um die fehlgeschlagene Installation zu überspringen, klicken Sie auf Ändern, und wählen Sie alle Produkte aus, die während der Installation übersprungen wurden. Deaktivieren Sie das Produkt, das nicht installiert wurde.

    • Um die Installation abzubrechen, klicken Sie auf Entfernen, und wählen Sie alle Produkte aus, die installiert wurden.
    Dadurch wird eine frühere Version von Produkten, die aktualisiert werden, nicht wieder hergestellt.
Übergeordnetes Thema Installationsfehler / Installation abgebrochen
Reparieren einer Installation
Kontaktaufnahme mit dem SOLIDWORKS Fachhändler


Kontaktaufnahme mit dem SOLIDWORKS Fachhändler

Wenn das Ändern oder Reparieren der Installation fehlschlägt, wenden Sie sich an Ihren SOLIDWORKS Fachhändler vor Ort mit den Informationen, die auf dem Bildschirm angezeigt werden. Möglicherweise müssen Sie auch eine Zip-Datei der Protokolldateien des SOLIDWORKS Installations-Managers bereitstellen.

  1. Suchen Sie die Protokolldateien:
    • Für Windows 7 oder höher:

      C:\Benutzer\Benutzername\AppData\Roaming\SOLIDWORKS\Installation Logs\installierte_Version\

    Wenn Sie den Ordner nicht finden können, ist er u. U. ausgeblendet. Klicken Sie in Windows Explorer auf Extras > Ordneroptionen. Wählen Sie auf der Registerkarte Ansicht unter Erweiterte Einstellungen für Versteckte Dateien und Ordner die Option Versteckte Dateien und Ordner anzeigen aus.
  2. Komprimieren Sie den vollständigen Inhalt des Ordners, einschließlich aller Unterordner.
Übergeordnetes Thema Installationsfehler / Installation abgebrochen
Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation
Reparieren einer Installation


Installation vollständig

Der SOLIDWORKS Installations-Manager hat die Verarbeitung abgeschlossen.

Möglicherweise wird eine oder mehrere der folgenden Optionen angezeigt.

Neue Funktionen

Bei Einzelinstallationen wird bei Beenden des Installationsvorgangs ein Dokument angezeigt, das die neuen Funktionen in SOLIDWORKS und den Zusatzanwendungen beschreibt.

Bei Installationen mit Administrator-Installationsabbild wird das Dokument auf den Client-Computern angezeigt, wenn diese die Installation abschließen.

Umfrage

Teilen Sie uns Ihre Meinung über den Installationsvorgang mit, indem Sie die Fragen in einer kurzen Umfrage beantworten.

Nehmen Sie am SOLIDWORKS Anwendererfahrungs-Verbesserungsprogramm teil

Leistungsdaten werden zur Produktverbesserung an die SOLIDWORKS Corporation gesendet. Das Verfahren ist transparent und die gewonnenen Daten werden geschützt. Wählen Sie eine der folgenden Optionen aus:
  • Ja, ich möchte teilnehmen
  • Nein danke
  • Erinnere mich später
Weitere Informationen finden Sie im Anwendererfahrungs-Optimierungsprogramm – Website.

Erstellung des Administrator-Installationsabbilds ist abgeschlossen

Nach Abschluss der Erstellung des Administrator-Installationsabbilds können Sie auf Customize Image (Abbild anpassen) klicken, um den Administrator-Installationsabbild Options-Editor auszuführen und das Abbild anzupassen.

Klicken Sie auf Anleitung für die Installation dieses Abbilds auf einem Client., um eine Anleitung zur Verwendung des Options-Editors anzuzeigen.

Details zur Konfiguration eines Administrator-Installationsabbilds mit dem Options-Editor finden Sie unter Administrator-Installationsabbild Options-Editor.

Klicken Sie auf Customize Image, um den Administrator-Installationsabbild Options-Editor zu starten und die Optionseinstellungen für dieses Administrator-Installationsabbild anzupassen.
Sie können den Options-Editor auch starten, indem Sie auf sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner doppelklicken.

Inhaltsverzeichnis

  • Suchen nach SOLIDWORKS Aktualisierungen

    Wenn Sie über Administratorrechte auf dem Computer verfügen, können Sie mithilfe des SOLIDWORKS Installations-Managers manuell nach Aktualisierungen suchen oder regelmäßige, automatische Überprüfungen auf Aktualisierungen konfigurieren.

  • SOLIDWORKS Anwendererfahrungs-Optimierungsprogramm

    Während der Installation von SOLIDWORKS können Sie festlegen, dass Leistungsdaten an die SOLIDWORKS Corporation gesendet werden, was zur Produktverbesserung beiträgt.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Suchen nach SOLIDWORKS Aktualisierungen

Wenn Sie über Administratorrechte auf dem Computer verfügen, können Sie mithilfe des SOLIDWORKS Installations-Managers manuell nach Aktualisierungen suchen oder regelmäßige, automatische Überprüfungen auf Aktualisierungen konfigurieren.

  1. Starten Sie den SOLIDWORKS Installations-Manager, indem Sie einen der folgenden Vorgänge ausführen:

    • Klicken Sie in der SOLIDWORKS Anwendung auf Hilfe > Nach Aktualisierungen suchen.

    • Klicken Sie in Windows auf Start > Programme > SOLIDWORKS Installations-Manager > Nach Aktualisierungen suchen.

    Der SOLIDWORKS Installations-Manager gibt an, ob Aktualisierungen verfügbar sind.
  2. Wenn Aktualisierungen verfügbar sind, haben Sie die Wahl, ob sie heruntergeladen und installiert werden sollen.
  3. Um regelmäßige, automatische Überprüfungen auf das Vorhandensein von Aktualisierungen zu aktivieren, wählen Sie, nachdem der SOLIDWORKS Installations-Manager die Bearbeitung abgeschlossen hat, die Option Nach Aktualisierungen alle __ Tage suchen aus, und geben Sie die Häufigkeit dieser Überprüfungen an.
Übergeordnetes Thema Installation vollständig
SOLIDWORKS Anwendererfahrungs-Optimierungsprogramm


SOLIDWORKS Anwendererfahrungs-Optimierungsprogramm

Während der Installation von SOLIDWORKS können Sie festlegen, dass Leistungsdaten an die SOLIDWORKS Corporation gesendet werden, was zur Produktverbesserung beiträgt.

SOLIDWORKS verwendet diese Informationen, um Tendenzen bei der Produktnutzung und der Qualität festzustellen. Unser Ziel ist es, die höchstmögliche Produktqualität zu liefern, und die Leistungsprotokolle spielen eine wichtige Rolle in diesem Prozess.

Der Vorgang ist transparent. Alle Informationen in den Protokolldateien werden vertraulich behandelt. Sie werden für keine anderen Zwecke genutzt, und niemand wird Sie kontaktieren.

Nähere Informationen dazu finden Sie auf der Website des Anwendererfahrungs-Optimierungsprogramms.

Übergeordnetes Thema Installation vollständig
Suchen nach SOLIDWORKS Aktualisierungen


Installationsort

Geben Sie an, wo SOLIDWORKS installiert werden soll.

Für Installationen mit Ausnahme der Administrator-Installationsabbilderstellung gelten die folgenden Optionen:
Ausgewählte Produkte installieren in | Die ist der Verzeichnisort, an dem Sie SOLIDWORKS installieren. Beim Aktualisieren oder Ändern einer Installation müssen alle Dateien in das bestehende Installationsverzeichnis installiert werden. In diesem Fall können Sie das Verzeichnis, in dem sich die vorhandene SOLIDWORKS Installation befindet, nicht ändern.
Geschätzter erforderlicher Speicher für Installation | Dies ist der Speicherbedarf, der für die zur Installation oder Änderung der ausgewählten Produkte zusätzlich benötigt wird. | Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Installationsanforderungen zu erfüllen.
Installieren von | Die ist der Verzeichnisort, von dem aus Sie SOLIDWORKS installieren. Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Weitere Informationen finden Sie unter Download-Optionen.
Fragen Sie bei Ihrem Systemadministrator nach, bevor Sie eines der SOLIDWORKS Installationsverzeichnisse ändern.

Administrator-Installationsabbild-Positionen

Beim Erstellen eines Administrator-Installationsabbilds sind die folgenden Optionen verfügbar:
Neue Installationsabbild-Position | Dies ist der Verzeichnisort, an dem der SOLIDWORKS Installations-Manager das neue Installationsabbild erstellt. | Dieses Verzeichnis kann kein bestehendes Administrator-Installationsabbild enthalten.
Geschätzter erforderlicher Speicher für Abbilderstellung | Dies ist der für das Administrator-Installationsabbild erforderliche zusätzliche Speicher. | Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Anforderungen bzgl. des Installationsabbilds zu erfüllen.
Installationsabbild erstellen von | Die ist der Verzeichnisort, von dem aus Sie SOLIDWORKS Produkte installieren. Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Weitere Informationen finden Sie unter Download-Optionen.
Bestehende Installationsabbild-Position | Wenn ein vorhandenes Administrator-Installationsabbild aktualisiert wird, erstellt der SOLIDWORKS Installations-Manager ein neues Installationsbild auf der Grundlage der Einstellungen für dieses bestehende Installationsabbild. Das bereits vorhandene Installationsabbild wird nicht geändert. Hier wird das Verzeichnis des ursprünglichen Installationsabbilds angezeigt, das Sie auf dem Bildschirm Willkommen angegeben haben.

Versionsspezifische Verzeichnispfade vermeiden

Falls Sie eine Versionsnummer in einem Installationsverzeichnis angeben (z. B. C:\Programme\SOLIDWORKS Corp\SOLIDWORKS 2018\) und diese Installation dann auf SOLIDWORKS 2019 aktualisieren, erhält das SOLIDWORKS 2019 Installationsverzeichnis die Bezeichnung SOLIDWORKS 2018.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Download-Optionen


Aktualisierungsoptionen

Auf diesem Computer sind eine oder mehrere SOLIDWORKS Hauptversionen installiert. Sie können eine neue Installation erstellen, die parallel zu der älteren Version existiert, oder Sie können ein Upgrade durchführen, das die ältere Version entfernt.

Erstellen Sie eine neue Installation von SOLIDWORKS version.

Wenn Sie eine neue Installation erstellen, können Sie auswählen, welche SOLIDWORKS Produkte installiert werden sollen.

Für jedes der ausgewählten Produkte wird eine neue Installation dieser Hauptversion erstellt. Die älteren Hauptversionen verbleiben auf dem Rechner, mit Ausnahme von SOLIDWORKS Electrical und SOLIDWORKS PDM Client.

Wenn Sie die Auswahl eines Produkts aufheben, wird die neue Version nicht installiert.

Die Erstellung einer neuen Installation ist sinnvoll, wenn Sie auf die ältere Version von SOLIDWORKS zugreifen möchten, nachdem die neuere Version installiert wurde. Wen Sie z. B. Dateien gemeinsam mit anderen Anwendern nutzen, die noch die ältere Version ausführen, können Sie mit Dateien, die in der neueren Version gespeichert wurden, Kompatibilitätsprobleme zwischen den beiden Versionen vermeiden.

Upgrade von SOLIDWORKS previous_major_version auf SOLIDWORKS 2019 current_major_version.

Wenn Sie ein Upgrade durchführen, können Sie auswählen, welche SOLIDWORKS Produkte aktualisiert werden sollen. Für jedes der ausgewählten Produkte wird eine neue Installation erstellt und werden die älteren Versionen entfernt.

Wenn Sie die Auswahl eines Produkts aufheben, wird die neue Version nicht installiert und verbleibt die ältere Version auf dem Rechner.

Überlegungen zu SOLIDWORKS Electrical und SOLIDWORKS PDM Client

Es kann nur eine Version von SOLIDWORKS Electrical auf einem Computer installiert werden. Wenn Sie eine neue Installation von SOLIDWORKS erstellen und SOLIDWORKS Electrical als eines der zu installierenden Produkte auswählen, wird die alte Version von SOLIDWORKS Electrical entfernt.

Sie sollten Ihre bestehende SOLIDWORKS Electrical Umgebung immer sichern, bevor Sie eine neue Version installieren. Wählen Sie in SOLIDWORKS Electrical Schematic Datei Anwendungsumgebung archivieren oder in SOLIDWORKS Electrical 3D SOLIDWORKS Electrical > Extras > Anwendungsumgebung archivieren aus.

Die Hauptversion von SOLIDWORKS PDM Client muss mit der Hauptversion von SOLIDWORKS PDM Server übereinstimmen. Wenn Sie SOLIDWORKS PDM Server nicht aktualisieren möchten, wählen Sie SOLIDWORKS PDM Client nicht für das Upgrade aus.

Verwenden Sie zum Entfernen eines Produkts in Windows die Funktion Software. Weitere Informationen finden Sie unter Entfernen einer Installation.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Entfernen einer Installation


Installationsfortschritt

Dieser Bildschirm zeigt den Verlauf der Installation.

Um die Installation nach dem Start abzubrechen, klicken Sie auf Abbrechen.

Informationen zu den Konsequenzen eines Abbruchs und Anweisungen zum Abschließen unterbrochener Installationen finden Sie unter Installationsfehler.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Installationstyp

Geben Sie den Installationsvorgang an, den Sie ausführen möchten, z. B. Erstellen einer neuen Installation, Modifizieren oder Reparieren einer vorhandenen Installation, Erstellen eines Administrator-Installationsabbilds, Installieren von Administrator-Serverprodukten oder Herunterladen von Dateien ohne Installation.

Einzelinstallation

Installieren Sie SOLIDWORKS Produkte auf diesem Computer.

Diese Option erscheint nur, wenn diese Version aktuell nicht auf diesem Computer installiert ist.

Einzelinstallation modifizieren

Modifizieren Sie die bestehende SOLIDWORKS Installation auf diesem Computer.

Diese Option erscheint nur, wenn diese Version aktuell auf diesem Computer installiert ist.
Die folgenden Modifizierungen sind möglich:
  • Hinzufügen oder Entfernen von SOLIDWORKS Produktkomponenten
  • Umstieg auf ein anderes SOLIDWORKS Paket (z. B. SOLIDWORKS Professional, SOLIDWORKS Premium usw.)
  • Ändern der SOLIDWORKS Seriennummerneinstellung
    Wenn Sie bei einer früheren Installation bereits eine SOLIDWORKS Seriennummer angegeben haben, werden Sie vom SOLIDWORKS Installations-Manager möglicherweise nicht zu deren Eingabe aufgefordert. Sie müssen diese Option auswählen, um die vom SOLIDWORKS Installations-Manager angenommene Seriennummer zu ändern.

Einzelinstallation reparieren

Reparieren Sie die bestehende SOLIDWORKS Installation auf diesem Computer.

Diese Option erscheint nur, wenn diese Version aktuell auf diesem Computer installiert ist.
Die Reparatur überprüft, ob alle Dateien vorhanden und ordnungsgemäß registriert sind, und repariert Probleme, die gefunden werden. Daten, die Sie erstellt haben, sind davon nicht betroffen.
  • Stellen Sie sicher, dass ein Produkt, das repariert werden soll, ausgewählt ist.
  • Deaktivieren Sie Kontrollkästchen für Produkte, die nicht repariert werden sollen.
Eine Einzelinstallation kann repariert werden. Eine Administrator-Installationsabbild-Installation kann nicht repariert werden; Sie müssen mithilfe des Administrator-Installationsabbilds eine Deinstallation vornehmen.

Administrator-Installationsabbild

Administrator-Installationsabbild auf diesem Computer erstellen oder aktualisieren.

Sie können ein Administrator-Installationsabbild zur Installation auf mehreren Computern verwenden. Für Einzelheiten zum Installieren von SOLIDWORKS auf mehreren Clients mithilfe von Administrator-Installationsabbildern siehe Administrator-Installationsabbilder.

Beim Erstellen oder Aktualisieren von Administrator-Installationsabbildern:
  • Sie können zum Konfigurieren des neuen oder aktualisierten Installationsabbilds die Installationseinstellungen eines bestehenden Installationsabbilds oder die standardmäßigen SOLIDWORKS Installationseinstellungen verwenden.
  • Wenn Sie ein bestehendes Installationsabbild aktualisieren:
    • Der SOLIDWORKS Installations-Manager erstellt eine neue Kopie des Installationsabbilds, auch wenn Sie eine Aktualisierung vornehmen. Das ursprüngliche Installationsabbild wird nicht modifiziert.
    • Sie können das aktualisierte Installationsabbild mit Dateien aus dem bestehenden, von Ihnen aktualisierten Installationsabbild erstellen. Dies hat einen kleineren Download zur Folge.
    Wenn Sie kein Installationsabbild angeben, für das ein Service Pack zum Aktualisieren des älteren Installationsabbilds verfügbar ist, können Sie die Vorteile des kleineren Downloads nicht nutzen.

Server-Produkte

SOLIDWORKS Administrator-Server-Produkte sind SOLIDWORKS Electrical, SOLIDWORKS PDM und SolidNetWork License Manager.

Bei SOLIDWORKS Electrical und SOLIDWORKS PDM können Sie die Client- und Serverwerkzeuge auf demselben Computer oder auf unterschiedlichen Computern installieren.

Einzelheiten zum Installieren dieser Server finden Sie unter den entsprechenden Themen in der Hilfe.

Nur Download

Laden Sie die Installationsdateien für ausgewählte SOLIDWORKS Produkte herunter, ohne die Produkte zu installieren.

Diese Option wird nicht angezeigt, wenn Sie die Installation von einer DVD durchführen.

Der Inhalt der heruntergeladenen Dateien ist mit dem Inhalt der Dateien identisch, die auf den SOLIDWORKS Installations-DVDs verfügbar sind. Bei Auswahl dieser Option wird der vollständige Installationsdateisatz heruntergeladen, ungeachtet dessen, welche Dateien bereits auf dem Computer installiert sind.

Sie können diese Methode verwenden, um einen Server einzurichten, von dem Anwender Installationen ausführen können. Das unterscheidet sich von der Erstellung eines Administrator-Installationsabbilds.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Administrator-Installationsabbilder verwenden
Lizenzen mit einem SolidNetWork License Manager verwalten
SOLIDWORKS Electrical


Installieren und Verwalten mehrerer Computer

Der SOLIDWORKS Installations-Manager bietet die folgenden Werkzeuge zum Installieren auf mehreren SOLIDWORKS Computern und deren Verwaltung.

SOLIDWORKS Administrator-Installationsabbilder

Wenn Sie SOLIDWORKS auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.

SOLIDWORKS PDM

SOLIDWORKS PDM ist ein Produkt zur Dokumentenverwaltung, das auf derselben Client-/Server-Architektur basiert wie SOLIDWORKS Enterprise PDM. Es ist in zwei Versionen verfügbar: Standard und Professional. SOLIDWORKS PDM verwendet eine Microsoft SQL Server-Datenbank für die Verwaltung von Dateitresoren.

SolidNetWork Lizenz-Manager

Der SolidNetWork License Manager ermöglicht durch den variablen Einsatz von Lizenzen, dass die Anzahl der Anwender über die Anzahl der Lizenzen hinausgeht. Wenn eine Client-Lizenz nicht in Verwendung ist, ist sie für einen anderen SOLIDWORKS Anwender verfügbar.

Sie können den SolidNetWork License Manager auch dafür verwenden, Lizenzen für die wichtigsten SOLIDWORKS Zusatzanwendungen (z. B. FeatureWorks) zu verteilen.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Manueller Download

Sie haben sich für das manuelle Herunterladen von Dateien entschieden (oder Sie haben diese Entscheidung möglicherweise getroffen, als Sie den SOLIDWORKS Installations-Manager zum letzten Mal ausgeführt haben).

Klicken Sie auf den Link, um eine automatisch erzeugte Webseite zu öffnen, die eine vollständige Liste der Dateien enthält, die Sie zum Abschließen des Downloads benötigen.

Sie müssen die Dateien in einen auf der Seite „Zusammenfassung“ angegebenen Ordner herunterladen. Die Installation kann erst beginnen, wenn alle Dateien in diesen Ordner heruntergeladen wurden.

Nachdem Sie die Dateien manuell heruntergeladen haben, klicken Sie auf Weiter, um fortzufahren.

Wenn Sie einen automatischen Download wünschen, können Sie diese Option anders einstellen, indem Sie zur Seite „Zusammenfassung“ zurückkehren und unter „Download-Optionen“ die entsprechende Änderung vornehmen.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Neuere Version verfügbar

Der Installations-Manager hat eine neuere Version von SOLIDWORKS Produkten gefunden. Sie können die Version von der ursprünglichen Installations-DVD oder dem ursprünglichen Download installieren oder die neuere Version herunterladen und installieren.

Wenn Sie von einem Download installieren

Wählen Sie eine der folgenden Optionen aus:
  • Installation von Version fortsetzen.

    Wählen Sie diese Option aus, um die Version des ersten Downloads zu installieren.

  • Eine neue Version herunterladen und installieren: Version.

    Wählen Sie diese Option zum Herunterladen und Installieren der neuen Version aus. Wenn mehrere neue Versionen verfügbar sind, können Sie die Version für den Download und die Installation auswählen.

Wenn Sie von einer DVD installieren

Wählen Sie unter Möchten Sie die neuere Version verwenden? eine der folgenden Optionen:
  • Nein, Version weiter von dieser DVD installieren. Sie können danach aktualisieren.

    Wählen Sie diese Option aus, um mit der Installation mittels des aktuellen Installations-Managers fortzufahren.

    Nach der Installation können Sie mit dem Installations-Manager prüfen, ob Aktualisierungen vorhanden sind, und diese installieren. Klicken Sie auf Start > SOLIDWORKS Installations-Manager > Nach Updates suchen, um zu prüfen, ob Aktualisierungen zum Herunterladen verfügbar sind.
    Nach Updates suchen ist nur verfügbar, wenn Sie über Administratorrechte auf dem Computer verfügen.

    Dies hat einen kleineren Download zur Folge. Andererseits handelt es sich hierbei um einen Zwei-Schritt-Vorgang und sind die heruntergeladenen Dateien versionsspezifisch (und können von anderen Anwendern, die andere Versionen verwenden, nicht genutzt werden).

  • Ja, Installation mit dieser DVD ausführen; dann herunterladen und auf version aktualisieren.

    Wählen Sie diese Option, um eine spätere Version des Installations-Managers herunterzuladen und auszuführen, um SOLIDWORKS Produkte für diese Version zu installieren.

    Wenn zur Aktualisierung der DVD-Version eine kleine Service Pack-Version verfügbar ist, installiert der Installations-Manager die Originalversion von der DVD und aktualisiert das Programm dann mit dem Service Pack. Dies hat einen kleineren Download zur Folge.

    Sie können das gleiche Ergebnis erzielen, wenn Sie die Option zur Fortsetzung der Installation von der DVD auswählen und die Aktualisierung später durchführen.

    Diese Option hat den Vorteil, dass sie nur einen einzigen Verfahrensschritt erfordert.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Keine neuen Versionen verfügbar

Es stehen keine neueren Versionen zum Download bereit. Fahren Sie mit der Installation der angegebenen Version fort.

Um mit der Installation fortzufahren, klicken Sie auf Weiter.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Festgestellte Prozesse

Der SOLIDWORKS Installations-Manager hat auf diesem Computer laufende Prozesse festgestellt, die eine erfolgreiche Installation verhindern könnten.

  • Um die Installation fortzusetzen, führen Sie einen der folgenden Schritte aus:
    • Schließen Sie die betroffenen Prozesse (z. B. den Microsoft Windows Task-Manager) und klicken Sie auf Wiederholen.
    • Klicken Sie auf Ignorieren, um ohne Schließen der Prozesse fortzufahren.
  • Zum Beenden der Installation klicken Sie auf Abbrechen.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Produktauswahl

Geben Sie die Produktkomponenten an, die installiert, modifiziert, heruntergeladen oder entfernt werden sollen.

Auf der Produktliste:
  • Die Produktliste ist die Liste aller Produkte, die in dem über der Produktliste angegebenen Paket verfügbar sind.
  • Klicken Sie, um die projizierte Aktion für eine bestimmte Komponente zu sehen, auf den Namen der Komponente (aber nicht auf das Kontrollkästchen). Die gewünschte Installationsaktion erscheint im Informationsfeld unter der Produktauflistung.
  • Sie können auf das Kontrollkästchen neben der Produktkomponente klicken, um die Installationsaktion für diese Komponente zu ändern. (Beispiel: Wenn Sie Komponenten installieren oder entfernen, legt die Aktivierung des Kontrollkästchens fest, dass die Komponente zu installieren oder zu entfernen ist, und die Deaktivierung des Kontrollkästchens legt fest, dass die Komponente nicht zu installieren oder zu entfernen ist.)
  • Wenn Sie eine Modifizierungsinstallation durchführen, erscheint links von den einzelnen Komponenten ein Sternchen (*), wenn Sie eine Änderung an der Produktauswahl vornehmen.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.

Wenn Sie ein Service Pack anwenden, können SOLIDWORKS Features (wie z. B. FeatureWorks), die unter SOLIDWORKS angezeigt werden, nicht ausgewählt werden. Der Grund dafür ist, dass Sie ein Feature weder hinzufügen oder entfernen können, wenn Sie diese Art von Aktualisierung auswählen.

Die Operationen, die vom SOLIDWORKS Installations-Manager ausgeführt werden, werden von einer Reihe von Produkt-Koexistenzregeln gesteuert. Weitere Informationen hierzu finden Sie unter Produkt-Koexistenzregeln.

Der SOLIDWORKS Installations-Manager wählt standardmäßig die folgenden Produktkomponenten aus:
  • Wenn Sie eine Aktualisierung oder eine Service Pack-Aktualisierung durchführen, wählt der SOLIDWORKS Installations-Manager die aktuell installierten Produkte aus.
  • Andernfalls wählt der SOLIDWORKS Installations-Manager alle Produkte aus, für die Sie eine Berechtigung besitzen.
Um die Installations- oder Download-Zeit zu verkürzen und den Festplatten-Speicherbedarf zu verringern, blenden Sie die Produktkomponenten ein und entfernen Sie für die nicht benötigten Komponenten die Markierung aus dem Kontrollkästchen.

Wenn der SOLIDWORKS Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie auf Andere Pakete oder Produkte auswählen klicken, um ein anderes aufgeführtes Produktpaket (z. B. SOLIDWORKS Professional oder SOLIDWORKS Premium) für die Installation oder Modifikation zu bestimmen. Der SOLIDWORKS Installations-Manager führt alle SOLIDWORKS Produkte auf Ihrem Installationsmedium auf, die mit dem ausgewählten Paket kompatibel sind. Sie können alle Produkte auswählen, die Sie erworben haben oder zu deren Evaluierung Sie berechtigt sind.

SOLIDWORKS Suche

SOLIDWORKS Suche bietet eine leistungsstarke Volltextsuche in SOLIDWORKS Dokumenten und in 3D ContentCentral. Die Suche zeigt eine Vorschau und die Dateiposition und den -namen an.

Nach der Installation indiziert SOLIDWORKS Suche SOLIDWORKS Dokumente, um schnellere Suchvorgänge zu gewährleisten. Nur SOLIDWORKS Dateien werden standardmäßig indiziert.

Mit der Installation von SOLIDWORKS Suche wird automatisch die Windows-Desktopsuche installiert, wenn diese Funktion nicht bereits auf Ihrem Computer installiert ist.

Sprachunterstützung

Blenden Sie das SOLIDWORKS Produkt und die Komponente Sprachen ein, um die installierbaren Sprachen anzuzeigen.

Die Spezifikation Sprachen limitiert nur die Sprachen, die für das SOLIDWORKS Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. eDrawings®, SOLIDWORKS Explorer und SOLIDWORKS PDM installieren beispielsweise alle Sprachen.

Benötigter Speicherplatz

Der SOLIDWORKS Installations-Manager gibt entweder die Gesamtinstallationsgröße oder die Gesamt-Download-Größe unten auf der Seite an.

  • Wenn Sie die Option Nur Download ausgewählt haben, wird die Größe des Downloads angezeigt. Download-Größe ist die Gesamtmenge des Festplattenspeicherbedarfs für alle heruntergeladenen Dateien (Extrabedarf für das Entpacken der Dateien nach dem Download nicht eingerechnet). Es handelt sich dabei um einen Schätzwert.
    Alle Dateien, die für die Installation erforderlich sind, sind in der Gesamt-Download-Größe erfasst. Wenn einige Dateien bereits in den aktuellen Download-Ordner heruntergeladen wurden, werden sie nicht erneut heruntergeladen. Folglich kann die aktuelle Download-Größe kleiner sein als die angezeigte Gesamt-Download-Größe oder es kann auch sein, dass Sie keine Dateien herunterladen müssen.
  • Ansonsten wird Installationsgröße angezeigt. Installationsgröße ist die Änderung des Festplattenspeicherbedarfs, die auftritt, wenn diese Installation abgeschlossen ist. Aufgrund der Dateikomprimierung sind diese Zahlen stets lediglich Schätzwerte.

    Wenn Sie eine bestehende Installation aktualisieren oder entfernen, kann die Installationsgröße Null sein.

    Die angezeigte Zahl beinhaltet nicht den Speicherplatz, der für den Download oder das Extrahieren der Installationsdateien erforderlich ist.

    Wenn Downloads erforderlich sind und Sie auf dasselbe Laufwerk herunterladen, könnte der tatsächliche Speicherbedarf bedeutend größer sein als die angezeigte Installationsgröße.

    Um die Download- oder Installationszeit für zukünftige Modifizierungen zu reduzieren, löschen Sie die heruntergeladenen Dateien nach der Installation nicht. Folgeaktualisierungen und Patches benötigen normalerweise Zugriff auf den letzten vollständigen Installationsdateisatz.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Produkt-Koexistenzregeln


Produkte zum Herunterladen

Wählen Sie SOLIDWORKS Produkte zum Herunterladen an einen bestimmten Ablageort aus.

Die Produkte, die heruntergeladen werden können, werden durch die Seriennummer, die Sie bereitgestellt haben, bestimmt:

  • Die Aktion, die für die einzelnen Komponenten ausgeführt werden soll, wird rechts von einem jeden Element angezeigt.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.
  • Klicken Sie auf das Kontrollkästchen links von jeder Komponente, um auszuwählen, wie es vom SOLIDWORKS Installations-Manager gehandhabt werden soll.
Der SOLIDWORKS Installation-Manager lädt alle Produktkomponenten herunter, für die Sie eine Berechtigung haben, sofern Sie nichts anderes festlegen. Um die Download-Zeit zu verkürzen und den Festplatten-Speicherbedarf zu verringern, klappen Sie die Produktkomponenten auf und wählen Sie die Komponenten, die Sie nicht benötigen.

Wenn der SOLIDWORKS Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie ein SOLIDWORKS Paket zum Herunterladen auswählen. Der SOLIDWORKS Installations-Manager führt alle SOLIDWORKS Produkte auf, die mit dem ausgewählten Paket kompatibel sind.

Wenn der SOLIDWORKS Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie auf Andere Pakete oder Produkte auswählen klicken, um ein anderes aufgeführtes Produktpaket (z. B. SOLIDWORKS Professional oder SOLIDWORKS Premium) für die Installation oder Modifikation zu bestimmen. Der SOLIDWORKS Installations-Manager führt alle SOLIDWORKS Produkte auf Ihrem Installationsmedium auf, die mit dem ausgewählten Paket kompatibel sind. Sie können alle Produkte auswählen, die Sie käuflich erworben haben oder zu deren Evaluierung Sie berechtigt sind.

Sprachunterstützung

Die Spezifikation "Sprachen" limitiert nur die Sprachen, die für das SOLIDWORKS Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. Zum Beispiel werden für eDrawings® und SOLIDWORKS Explorer alle vorhandenen Sprachen installiert.

Benötigter Speicherplatz

Basierend auf den ausgewählten Produkten wird der Speicherplatz angezeigt, der für die Durchführung des Downloads benötigt wird. Download-Größe ist die Gesamtmenge des Festplattenspeicherbedarfs für alle heruntergeladenen Dateien (Extrabedarf für das Entpacken der Dateien nach dem Download nicht eingerechnet). Es handelt sich dabei um einen Schätzwert.

Um die Download- oder Installationszeit für zukünftige Aktualisierungen und Patches zu reduzieren, löschen Sie die heruntergeladenen Dateien nach der Installation nicht. Folgeaktualisierungen und Patches benötigen normalerweise Zugriff auf den letzten vollständigen Installationsdateisatz.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Zu reparierende Produkte

Wenn Sie Diese Installation reparieren auswählen, zeigt dieser Bildschirm die SOLIDWORKS Produkte mit den Versionsnummern an, die von dieser Version des SOLIDWORKS Installations-Managers repariert werden können.

Die Reparatur überprüft, ob alle Dateien vorhanden und ordnungsgemäß registriert sind, und repariert Probleme, die gefunden werden. Daten, die Sie erstellt haben, sind davon nicht betroffen.
  • Stellen Sie sicher, dass ein Produkt, das repariert werden soll, ausgewählt ist.
  • Deaktivieren Sie Kontrollkästchen für Produkte, die nicht repariert werden sollen.

Klicken Sie auf Reparieren, um mit dem Reparieren der ausgewählten Produkte zu beginnen.

Eine Einzelinstallation kann repariert werden. Eine Administrator-Installationsabbild-Installation kann nicht repariert werden; Sie müssen das Administrator-Installationsabbild erneut installieren.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Seriennummern

Seriennummern, die im Verteilungspool gefunden werden, assoziieren Ihren Computer mit den SOLIDWORKS Produkten, die Sie erworben haben.

Wenn auf Ihrem Computer bereits SOLIDWORKS Produkte installiert sind, werden standardmäßig ihre Seriennummern angezeigt:
  • Geben Sie Ihre SOLIDWORKS Seriennummer ein, wenn Sie nicht bereits angezeigt wird.
  • Wenn Sie Seriennummern für Produkte haben, die nicht in Ihrer SOLIDWORKS Lizenz enthalten sind, geben Sie sie in die entsprechenden Felder ein.
  • Wenn Ihr SOLIDWORKS Administrator Ihnen Produkte im SOLIDWORKS Admin-Portal zugewiesen hat, verwenden Sie die Anmeldefunktion oben auf der Seite, um die zugewiesenen Seriennummern automatisch zu laden.

Wenn Sie eine Internetverbindung haben, bestimmen die von Ihnen angegebenen Seriennummern, zu welchen Produkten Sie berechtigt sind, während Sie den Installationsprozess fortsetzen.

Da es viele Möglichkeiten gibt, SOLIDWORKS Produkte zu erwerben, können einige Seriennummern zwei oder mehr Produkte abdecken. So kann eine SOLIDWORKS Seriennummer Ihnen beispielsweise gestatten, SOLIDWORKS Simulation zu installieren, ohne eine separate SOLIDWORKS Simulation Seriennummer eingeben zu müssen. Zudem benötigen einige Produkte keine Seriennummer. Wenn Sie Fragen zu Ihren Seriennummern haben, wenden Sie sich an Ihren Fachhändler.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Server-Installation

Die Server-Produkte, die Sie zu installieren versuchen, sind mit den Ergebnissen der Installation aufgeführt.

Server-Installationsstatus

Installationen von Server-Produkten werden über eine externe Installationsanwendung durchgeführt. Wenn diese Anwendung aktuell nicht geöffnet ist, müssen Sie zu ihr wechseln, um die Installation abzuschließen.

Klicken Sie auf Abbrechen, um die Server-Produkt-Installationen zu beenden.

Server-Installation abgeschlossen

Die externe Installationsanwendung wurde erfolgreich abgeschlossen.

Klicken Sie auf Fertig stellen oder Weiter.
  • Wenn Sie auch andere Administrator-Produkte (z. B. ein SOLIDWORKS Administrator-Installationsabbild) installieren, wird diese Installation fortgesetzt.
  • Falls es sich bei den Server-Produkt-Installationen um den einzigen Installationsvorgang handelt, wird der SOLIDWORKS Installations-Manager geschlossen.

Server-Installation abgebrochen oder fehlgeschlagen

Wenn die Installation eines Server-Produkts fehlschlug oder abgebrochen wurde, während sie bereits lief, werden die Server, die nicht installiert wurden, aufgeführt.

Klicken Sie auf Schließen oder Weiter.
  • Wen Sie Installationen weiterer Administrator-Produkte ausgewählt haben, wird der SOLIDWORKS Installations-Manager fortgesetzt.
  • Falls es sich bei den Server-Produkt-Installationen um den einzigen Installationsvorgang handelt, wird der SOLIDWORKS Installations-Manager geschlossen.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


SolidNetWork License Manager

Legen Sie Installationsoptionen für das Server-Produkt des SolidNetWork License Manager fest.

Seriennummern

Geben Sie SolidNetWork Lizenz-Seriennummern an. Sie können mehrere Seriennummern eingeben, indem Sie sie mit Kommas trennen.
SolidNetWork Seriennummern unterscheiden sich von SOLIDWORKS Seriennummern.

Installationsort

Geben Sie den Installationsort für den SolidNetWork License Manager an.

Wenn Sie einen vorhandenen SolidNetWork License Manager aktualisieren, müssen Sie dafür den vorhandenen Installationsort verwenden.

Weitere Informationen

Details über die Installation, Konfiguration und Verwendung des SolidNetWork License Managers finden Sie unter Lizenzen mit einem SolidNetWork License Manager verwalten.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Lizenzen mit einem SolidNetWork License Manager verwalten


Zusammenfassung

Der SOLIDWORKS Installations-Manager verfügt über alle für die Durchführung der Installation erforderlichen Informationen.

Fahren Sie wie folgt fort: | Klicken Sie auf die Schaltfläche Jetzt Aktion, um den Installationsvorgang zu starten (z. B. Jetzt installieren, Jetzt erstellen, Jetzt herunterladen, Jetzt modifizieren).
Ändern der Installationseinstellungen: | Klicken Sie für den Abschnitt, an dem Sie Änderungen vornehmen möchten, auf ÄNDERN [image] (z. B. Produkte, Installationsort, Toolbox Optionen).
Abbrechen:. | Klicken Sie auf Abbrechen, um den SOLIDWORKS Installations-Manager zu beenden, ohne Installationskomponenten zu ändern.
Zurückkehren zu einer vorherigen Seite: | Klicken Sie auf Zurück, um zu einer vorherigen Seite im SOLIDWORKS Installations-Manager zurückzukehren.
Anzeigen von Informationen über eine bestimmte Gruppe von Installationsoptionen (z. B. Produkte, Installationsort, Toolbox Optionen usw.):
  1. Klicken Sie neben dem Abschnitt, für den Sie Informationen einsehen möchten, auf ÄNDERN [image].
  2. Klicken Sie auf der daraufhin angezeigten Detailseite auf Hilfe, um Informationen über die Einstellungen dieser Installationsoption anzuzeigen.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Warnungen bei der Systemprüfung

Die Systemprüfung hat Probleme gemeldet, die sich auf die weitere Installation auswirken könnten. In den meisten Fällen sollten Sie mit dem SOLIDWORKS Installations-Manager fortfahren können.

Es folgen Warnungen, die in diesem Stadium ausgegeben werden können, und entsprechende empfohlene Maßnahmen.

Probleme bei der Seriennummervalidierung

Der Installations-Manager konnte nicht nach neuen Versionen suchen, da Ihre Seriennummer nicht validiert werden konnte. Wenn Sie eine aktive Verbindung zum Server haben und eine gültige Seriennummer eingegeben haben, könnte dies auf ein temporäres Problem auf unserem Server hinweisen. Versuchen Sie es später noch einmal.

Seriennummervalidierung: Der Installations-Manager konnte Ihre Seriennummer nicht validieren, um die Produkte zu ermitteln, zu deren Installation Sie berechtigt sind. Sie werden weiterhin die Produkte, die Sie installieren möchten, auswählen aber keine Installationsdateien herunterladen können. Sie müssen einen vollständigen Satz an Download-Quelldateien oder eine DVD für die Installation bereit stellen.

Auflösung:
  • Prüfen Sie die Internetverbindung. Für die Seriennummervalidierung ist eine funktionierende Internetverbindung erforderlich.
  • Überprüfen Sie, ob die eingegebene Seriennummer für die Produkte gilt, die Sie installieren möchten.
  • Bei bestimmten Installationen ist es erforderlich, dass zum Zeitpunkt der Freigabe der Version ein gültiger Subskriptionsvertrag besteht. Nähere Informationen dazu erhalten Sie von Ihrem SOLIDWORKS Fachhändler.
  • In den meisten Fällen können Sie die Installation fortsetzen, vorausgesetzt, Sie installieren von einer DVD oder einem zuvor heruntergeladenen Dateisatz.

Neuere Version verfügbar

Neuere Version verfügbar

Neue Versionen verfügbar

Eine neuere Version dieses Produkts steht zum Download bereit.

Auflösung: Beim Ausführen der Funktion "Nach Aktualisierungen suchen" werden Sie möglicherweise aufgefordert, eine neuere Version zu installieren, die zum Download auf der SOLIDWORKS Website bereit steht. Sie können den Vorgang mit der ursprünglich angegebenen Version fortsetzen oder die neuere Version herunterladen und den Vorgang mit der neueren Version fortsetzen.

Neueste verfügbare Version

Dies ist die neueste verfügbare Version. Klicken Sie zum Fortfahren auf "Weiter".

Keine neuen Downloads verfügbar

Lösung: Diese Meldung kann erscheinen, wenn während einer Installation oder Modifizierung nach Aktualisierungen gesucht wird. Die Meldung weist darauf hin, dass Sie die neuste verfügbare Version installieren bzw. installiert haben.

Probleme mit der Internetverbindung

Internetverbindung: Der Installations-Manager konnte keine Verbindung zum SOLIDWORKS Server herstellen, um die Produkte zu ermitteln, zu deren Installation Sie berechtigt sind. Sie werden weiterhin die Produkte, die Sie installieren möchten, auswählen aber keine Installationsdateien herunterladen können. Sie müssen Quelldateien auf DVD oder einen zuvor heruntergeladenen Dateisatz bereitstellen.

Es kann nicht nach neuen Versionen gesucht werden

Der Installations-Manager konnte nicht nach neuen Versionen suchen, da eine Verbindung zum Server nicht hergestellt werden konnte.

Lösung:
  • Prüfen Sie die Internetverbindung.
  • Sie können die Installation fortsetzen, vorausgesetzt, Sie installieren von einer DVD oder einem zuvor heruntergeladenen Dateisatz.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Bohrungsassistent/Toolbox-Optionen

Wenn SOLIDWORKS Toolbox installiert ist, beinhaltet SOLIDWORKS eine Standardbibliothek von Bohrungstypen und Maschinenteilen.

Wenn Sie nähere Einzelheiten zu Konfiguration, Erweiterung und Gebrauch von SOLIDWORKS Toolbox wünschen, klicken Sie in SOLIDWORKS auf Hilfe > Toolbox Hilfe.
Um diese Hilfe anzuzeigen, müssen Sie über Extras > Zusatzanwendungen möglicherweise die Toolbox Zusatzanwendung starten.

Bevor Sie SOLIDWORKS Toolbox verwenden, sollten Sie überprüfen, ob die Anwendung gemäß den Firmen- oder Gruppenbestimmungen konfiguriert ist. In vielen Fällen konfiguriert und unterhält eine Gruppe eine zentrale Toolbox. Lassen Sie sich vom SOLIDWORKS Administrator über die Auswahl einer Toolbox während der SOLIDWORKS Installation beraten.

Sie können die ausgewählte SOLIDWORKS Toolbox nach der Installation wieder ändern. Klicken Sie in SOLIDWORKS auf Extras > Optionen. Klicken Sie auf der Registerkarte Systemoptionen auf Bohrungsassistent/Toolbox.

In den folgenden Abschnitten sind alle Optionen beschrieben, die auf diesem Bildschirm für alle Konfigurationen möglich sind. Die tatsächlich angezeigten Toolbox Optionen hängen von den bereits vorhandenen SOLIDWORKS und Toolbox Konfigurationen auf diesem Computer und den bisher ausgewählten SOLIDWORKS Installations-Manager-Optionen ab.

Erstellen einer neuen new-version Toolbox

Erstellen Sie eine neue Version von SOLIDWORKS Toolbox auf diesem Computer.

Wenn Sie eine neue Version erstellen, erweitern Sie im Bildschirm für die Produktauswahl SOLIDWORKS > SOLIDWORKS Toolbox und wählen Sie die Normen aus, die für die Toolbox unterstützt werden sollen. Alle Normen sind standardmäßig ausgewählt.

Keine der auf diesem Computer bereits vorhandenen Toolboxes werden modifiziert.

Referenzieren oder Aktualisieren einer vorhandenen Toolbox

Verwenden Sie eine bestehende Toolbox. Klicken Sie auf Durchsuchen, um den Ablageort der Toolbox festzulegen, die zusammen mit dieser Installation verwendet werden soll.

  • Wenn die Toolbox für eine ältere SOLIDWORKS Hauptversion konfiguriert ist, wird sie auf diese Version aktualisiert. Alle an dieser Toolbox vorgenommenen Anpassungen bleiben in der aufgerüsteten Toolbox erhalten.
    Durch die Aktualisierung einer Toolbox auf eine neue SOLIDWORKS Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SOLIDWORKS Hauptversionen ausgeführt werden.
  • Wenn die Toolbox für diese SOLIDWORKS Version konfiguriert ist (was der Fall sein könnte, wenn Sie eine bereits aktualisierte Toolbox auf einem freigegebenen Netz festlegen), findet keine Aktualisierung dieser Toolbox statt.
  • Wenn Sie eine Toolbox in einer SOLIDWORKS PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Hinweise zur Konfiguration von SOLIDWORKS Toolbox.

Diese Option erscheint in allen Installationsszenarien mit Ausnahme des Szenarios für die Erstellung eines Administrator-Installationsabbilds.

Aktualisieren einer previous-version Toolbox

Kopieren Sie eine für eine ältere Hauptversion konfigurierte Toolbox an einen neuen Speicherort und aktualisieren Sie diese Kopie auf diese Version.

Diese Option erscheint, wenn auf diesem Computer eine ältere SOLIDWORKS Hauptversion installiert ist, Sie aber entschieden haben, diese Installation dieser Version nicht zu aktualisieren.
Der Zweck dieser Option besteht in der Aktualisierung einer Toolbox für eine ältere installierte SOLIDWORKS Hauptversion, ohne dass Anwender, die die ältere Toolbox Version verwenden, in ihrer Arbeit beeinträchtigt werden.

Wenn Sie eine Toolbox in einer SOLIDWORKS PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Hinweise zur Konfiguration von SOLIDWORKS Toolbox.

Aktualisieren dieser installierten previous-version Toolbox

Aktualisieren Sie diese Toolbox auf die neuere Version.
Durch die Aktualisierung einer Toolbox auf eine neue SOLIDWORKS Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SOLIDWORKS Hauptversionen ausgeführt werden.

Diese Option wird angezeigt, wenn Sie eine ältere SOLIDWORKS Hauptversion auf diese Version aktualisieren und auf diesem Computer eine für diese ältere Version konfigurierte Toolbox vorgefunden wird.

Wenn Sie eine Toolbox in einer SOLIDWORKS PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Hinweise zur Konfiguration von SOLIDWORKS Toolbox.

Gebrauch der installierten current-version Toolbox

Der SOLIDWORKS Installations-Manager hat auf diesem Computer eine Toolbox festgestellt, die für diese SOLIDWORKS Hauptversion konfiguriert ist.

Wenn Sie diese Option auswählen, verwendet SOLIDWORKS diese Toolbox. Es findet keine Aktualisierung statt.

Diese Option erscheint, wenn auf diesem Computer eine ältere SOLIDWORKS Hauptversion installiert ist, aber eine Toolbox für diese Version konfiguriert ist. Diese Situation kann eintreten, wenn auf einem Computer, auf dem noch eine ältere SOLIDWORKS Version läuft, eine freigegebene Toolbox erstellt wird.

Toolbox Ablageort für den Client-Computer festlegen

Legen Sie einen Netzwerk- oder Verzeichnisort als Toolbox Standardablageort fest, wenn Clients eine Installation von einem Administrator-Installationsabbild aus durchführen.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SOLIDWORKS Hauptversion konfiguriert ist, aktualisiert der SOLIDWORKS Installations-Manager diese Toolbox.

Diese Option erscheint, wenn Sie ein neues Administrator-Installationsabbild erstellen.

Toolbox, auf die im bestehenden Installationsabbild für den Client-Computer Bezug genommen wird, aktualisieren oder verwenden

Verwenden Sie den Toolbox-Speicherort, der in einem bestehenden Administrator-Installationsabbild angegeben ist, das Sie aktualisieren.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SOLIDWORKS Hauptversion konfiguriert ist, aktualisiert der SOLIDWORKS Installations-Manager diese Toolbox.

Anderen Toolbox Ablageort für den Client-Computer festlegen

Geben Sie einen anderen Toolbox-Speicherort als denjenigen an, der in einem bestehenden Administrator-Installationsabbild angegeben ist, das Sie aktualisieren.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SOLIDWORKS Hauptversion konfiguriert ist, aktualisiert der SOLIDWORKS Installations-Manager diese Toolbox.

Inhaltsverzeichnis

  • Hinweise zur Konfiguration von SOLIDWORKS Toolbox

    SOLIDWORKS Toolbox bietet leistungsfähige und komplexe Funktionen. In diesem Thema sind einige Konzepte zusammengefasst, die vor der Konfiguration einer Toolbox mit dem SOLIDWORKS Installations-Manager in Betracht zu ziehen sind.

  • UNC-Format

    Die Uniform (bzw. Universal) Naming Convention ist ein Format, das zur Beschreibung eines freigegebenen Dateispeicherorts eine bestimmte Dateinamensyntax vorschreibt.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Hinweise zur Konfiguration von SOLIDWORKS Toolbox


Hinweise zur Konfiguration von SOLIDWORKS Toolbox

SOLIDWORKS Toolbox bietet leistungsfähige und komplexe Funktionen. In diesem Thema sind einige Konzepte zusammengefasst, die vor der Konfiguration einer Toolbox mit dem SOLIDWORKS Installations-Manager in Betracht zu ziehen sind.

Weitere Informationen über SOLIDWORKS Toolbox

Wenn Sie nähere Einzelheiten zu Konfiguration, Erweiterung und Gebrauch von SOLIDWORKS Toolbox wünschen, klicken Sie auf Hilfe > Toolbox Hilfe in SOLIDWORKS.
Um diese Hilfe anzuzeigen, müssen Sie über Extras > Zusatzanwendungen möglicherweise die Toolbox Zusatzanwendung starten.

Gebrauch einer freigegebenen Toolbox

Bei der Installation von Toolbox können Toolbox Daten auf dem lokalen Computer oder in einem freigegebenen Verzeichnis gespeichert werden. Empfohlen wird die Speicherung der Toolbox Daten in einem freigegebenen Netzwerkverzeichnis. Durch die Verwendung eines gemeinsamen Verzeichnisses ist sichergestellt, dass alle SOLIDWORKS Anwender dieselben Verbindungselementdaten verwenden.

Wenn dies eine Erstinstallation ist, gehen Sie zum neuen freigegebenen Verzeichnis, in dem Toolbox installiert werden soll.

Aktualisierung einer bestehenden Toolbox Anwendung

Durch die Aktualisierung einer Toolbox auf eine neue SOLIDWORKS Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SOLIDWORKS Hauptversionen ausgeführt werden.

Wenn andere Computer diese ältere Hauptversion weiterhin verwenden und auch weiterhin eine für diese Version konfigurierte Toolbox benötigen, sollten Sie eine Kopie dieser Toolbox anfertigen und diese Kopie dann aktualisieren. Die neue SOLIDWORKS Installation aktualisiert dann die Kopie der Toolbox und die früheren SOLIDWORKS Installationen verwenden weiterhin die alte Toolbox.

Toolbox Zugriff konfigurieren

Nach der Installation, wenn Sie auf Toolbox Komponenten zugreifen, prüft SOLIDWORKS, wie Toolbox konfiguriert ist und macht Vorschläge für einen verbesserten Zugriff und eine erhöhte Leistung.

Verwenden Sie für den Zugriff auf Toolbox auf einem freigegebenen Netz (empfohlen), einen UNC-Pfad zum Server, auf dem die freigegebene Toolbox installiert wurde. Weitere Weitere Informationen finden Sie unter UNC-Format.

Der Administrator kann ein Passwort für Toolbox erstellen sowie Zugriffsrechte und Anwendereinstellungen für die Arbeitsgruppe festlegen. Durch die Beschränkung des Zugriffs auf die Konfiguration und die Einrichtung gemeinsamer Anwendereinstellungen wird sichergestellt, dass konsistente Toolbox Daten verwendet werden.

Aktualisieren von Toolbox in einer SOLIDWORKS PDM Umgebung

Wenn Sie die SOLIDWORKS Software aktualisieren, wird auch Toolbox aktualisiert, sofern Teile hinzugefügt wurden. Wenn sich das Toolbox Stammverzeichnis in einem Tresor von SOLIDWORKS PDM befindet, müssen Sie vor der SOLIDWORKS Aktualisierung den Toolbox Ordner vorbereiten.

Auf dem ersten System, auf dem die Aktualisierung durchgeführt werden soll, müssen Sie die Toolbox Datenbank auschecken und mit dem Befehl Neueste Version holen die Toolbox Dateien in den lokalen Cache herunterladen. Bei anderen zu aktualisierenden Systemen müssen nur die Toolbox Dateien heruntergeladen werden.

Vor der Aktualisierung:
  • Stellen Sie sicher, dass eine vollständige aktuelle Sicherung der Tresordatenbank und des Archivs vorhanden ist.
  • Stellen Sie sicher, dass die Toolbox Teile nicht ausgecheckt sind oder von momentan ausgecheckten Baugruppen verwendet werden.

Aktualisierung von Toolbox:

  1. Melden Sie sich in Windows Explorer beim Tresor als Benutzer mit vollständigen Berechtigungen an (Auschecken, Einchecken, Hinzufügen, Löschen).
  2. Klicken Sie mit der rechten Maustaste auf den Toolbox Ordner und wählen Sie Neueste Version holen, um alle Toolbox Dateien und die Toolbox Datenbank in den lokalen Cache zu kopieren.
    Bei einem dezentralen Archivserver kann dies mehrere Minuten dauern.
  3. Checken Sie die Toolbox Datenbankdatei (SWBrowser.mdb) aus Toolbox_Ordnername\lang\Ihre_Sprache aus.
  4. Führen Sie zur Aktualisierung den SOLIDWORKS Installations-Manager aus.
  5. Stellen Sie auf dem Bildschirm Zusammenfassung sicher, dass der Installationsort für Toolbox Optionen der Ablageort im Tresor ist.

    Wenn dies nicht der Fall ist, klicken Sie auf Ändern, wählen Sie Bestehende Toolbox referenzieren oder aktualisieren und wählen Sie den Toolbox Speicherort im Tresor aus.

  6. Checken Sie nach Abschluss der Aktualisierung den Toolbox Ordner im Windows Explorer ein, um dem Tresor neue oder aktualisierte Dateien hinzuzufügen, damit andere Anwender mit Toolbox arbeiten können.
  7. Navigieren Sie bei Aktualisierungen auf SOLIDWORKS 2012 oder später zum Toolbox Ordner im Tresor, und stellen Sie sicher, dass folgende Dateien und Ordner vorhanden sind:
    • \Toolbox_Ordnername\Updates
    • \Toolbox_Ordnername\ToolboxStandards.xml
    • \Toolbox_Ordnername\Browser\ToolboxFiles.index

      Ist dies nicht der Fall, wenden Sie sich an Ihren Fachhändler.

  8. Aktualisieren Sie den Rest der Computer, die SOLIDWORKS PDM Integration mit Toolbox verwenden:
    1. Melden Sie sich im Windows Explorer im Tresor als Benutzer mit mindestens Leseberechtigung für den Toolbox Ordner an.
    2. Klicken Sie mit der rechten Maustaste auf den Toolbox Ordner und wählen Sie Neueste Version holen, um die Toolbox Dateien in den lokalen Cache-Speicher zu kopieren.
    3. Führen Sie zur Aktualisierung den SOLIDWORKS Installations-Manager aus.

      Das Installationsprogramm erkennt, dass Toolbox bereits aktualisiert wurde.

Bezüglich Details zur Toolbox Konfiguration in SOLIDWORKS PDM siehe Toolbox konfigurieren in der SOLIDWORKS PDM Administrationswerkzeug-Hilfe.

Übergeordnetes Thema Bohrungsassistent/Toolbox-Optionen
UNC-Format


UNC-Format

Die Uniform (bzw. Universal) Naming Convention ist ein Format, das zur Beschreibung eines freigegebenen Dateispeicherorts eine bestimmte Dateinamensyntax vorschreibt.

\\Server\Datenträger\Pfad

Beispiel:

\\Disk_Server\SOLIDWORKS\AdminImage

Übergeordnetes Thema Bohrungsassistent/Toolbox-Optionen
Hinweise zur Konfiguration von SOLIDWORKS Toolbox


Produkte deinstallieren

Wenn Sie die Option zum Entfernen oder Deinstallieren von Programmen in der Systemsteuerung auswählen, zeigt dieser Bildschirm die SOLIDWORKS Produkte (mit Versionsnummern) an, die von dieser Version des SOLIDWORKS Installations-Managers deinstalliert werden können. Sie können zwischen einer Standard-, benutzerdefinierten oder vollständige Deinstallation wählen.

Die Standarddeinstallation entfernt Programmdateien und Ordner eines SOLIDWORKS Produkts. Standardmäßig werden alle SOLIDWORKS Produkte für die ausgewählte Version für eine Standarddeinstallation festgelegt.

In einer benutzerdefinierten Deinstallation werden eines oder mehrere der folgenden Elemente entfernt: Programmdateien und Ordner, Registrierungsschlüssel und Datenordner, wie SOLIDWORKS Toolbox, sowie Dateien und Ordner aus dem ursprünglichen Download-Verzeichnis.

In einer vollständigen Deinstallation werden die Installationsverzeichnisse, Registrierungsschlüssel und Datenordner entfernt.

Ein Produkt deinstallieren:
  1. Wählen Sie auf dem Bildschirm Deinstallieren das Produkt aus.

    Wenn Sie alle Produkte deinstallieren, wird auch der Solidworks Installations-Manager deinstalliert.

  2. Deaktivieren Sie die Produkte, die nicht entfernt werden sollen.

    Wenn Sie ein Produkt behalten, wird der SOLIDWORKS Installations-Manager nicht deinstalliert.

  3. Wählen Sie, ob eine benuterzdefinierte oder vollständige Deinstallation durchgeführt werden soll.
    1. Klicken Sie auf Ändern in Erweiterte Optionen.

      Der Bildschirm Erweiterte Optionen wird eingeblendet. Die Option Programmdateien und Ordner ist aktiviert.

    2. Wählen Sie eine oder mehrere Optionen aus, um eine benutzerdefinierte Deinstallation auszuführen, oder wählen Sie alle Optionen, um eine vollständige Deinstallation durchzuführen.
    3. Klicken Sie auf Zurück zu Übersicht.
    4. Klappen Sie auf dem Bildschirm Übersicht Erweiterte Optionen auf, um die Deinstallationsmethode und die Einträge anzuzeigen.
  4. Klicken Sie auf Elemente entfernen.
Wenn Sie auf Elemente entfernen klicken, beginnt der SOLIDWORKS Installations-Manager unverzüglich mit dem Entfernen von Produkten.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Rechtliche Hinweise

© 1995-2018, Dassault Systèmes SolidWorks Corporation, ein Unternehmen der Dassault Systèmes SE-Gruppe, 175 Wyman Street, Waltham, Mass., USA 02451 USA. Alle Rechte vorbehalten.

Die Informationen in diesem Dokument sowie die behandelte Software können ohne Ankündigung geändert werden und stellen keine Verpflichtungen seitens Dassault Systemes SolidWorks Corporation (DS SolidWorks) dar.

Es ist untersagt, Material ohne ausdrückliche schriftliche Genehmigung von DS SolidWorks in irgendeiner Form oder auf irgendeine Weise, elektronisch oder manuell, für welchen Zweck auch immer, zu vervielfältigen oder zu übertragen.

Die in diesem Dokument behandelte Software wird unter einer Lizenz ausgeliefert und darf nur in Übereinstimmung mit den Lizenzbedingungen verwendet und kopiert werden. Alle Gewährleistungen, die von DS SolidWorks in Bezug auf die Software und Dokumentation übernommen werden, sind im vorliegenden Lizenzvertrag festgelegt, und nichts, was in diesem Dokument aufgeführt oder durch dieses Dokument impliziert ist, darf als Modifizierung oder Änderung dieser Gewährleistungen betrachtet werden.

Patenthinweise

SOLIDWORKS® 3D-CAD-Software für die Mechanikkonstruktion und/oder Simulation ist durch die US-amerikanischen Patente 6.611.725; 6.844.877; 6.898.560; 6.906.712; 7.079.990; 7.477.262; 7.558.705; 7.571.079; 7.590.497; 7.643.027; 7.672.822; 7.688.318; 7.694.238; 7.853.940; 8.305.376; 8.581.902; 8.817.028; 8.910.078; 9.129.083; 9.153.072; 9.262.863; 9.465.894; 9.646.412, 9.870.436, 10.055.083, 10.073.600 und Patente anderer Länder (z. B. EP 1.116.190 B1 und JP 3.517.643) geschützt.

Die eDrawings®® Software ist durch die US-amerikanischen Patente 7.184.044 und 7.502.027 sowie das kanadische Patent 2.318.706 geschützt.

Weitere US-amerikanische Patente und Patente anderer Länder angemeldet.

Warenzeichen und Produktnamen für SOLIDWORKS Produkte und Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings und das eDrawings Logo sind eingetragene Marken und FeatureManager ist eine eingetragene Gemeinschaftsmarke von DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360 und TolAnalyst sind Marken von DS SolidWorks.

FeatureWorks ist eine eingetragene Marke von HCL Technologies Ltd.

SOLIDWORKS 2019, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, SOLIDWORKS Simulation Premium, SOLIDWORKS Flow Simulation, SOLIDWORKS CAM, SOLIDWORKS Manage, eDrawings Viewer, eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical Schematic Standard, SOLIDWORKS Electrical Schematic Professional, SOLIDWORKS Electrical 3D, SOLIDWORKS Electrical Professional, CircuitWorks, SOLIDWORKS Composer, SOLIDWORKS Inspection, SOLIDWORKS MBD, SOLIDWORKS PCB powered by Altium, SOLIDWORKS PCB Connector powered by Altium und SOLIDWORKS Visualize sind Produktnamen von DS SolidWorks.

Andere Marken- oder Produktbezeichnungen sind Marken oder eingetragene Marken der jeweiligen Eigentümer.

KOMMERZIELLE COMPUTER-SOFTWARE – EIGENTUMSRECHTE

Bei der Software handelt es sich um ein „Handelsgut“ laut Begriffsdefinition unter 48 C.F.R. 2.101 (OCT 1995), bestehend aus „kommerzieller Computer-Software“ und „kommerzieller Software-Dokumentation“ laut Begriffsdefinition in 48 C.F.R. 12.212 (SEPT 1995). Sie wird der US-Regierung (a) zum Erwerb von oder im Namen von Zivilbehörden, laut der Bestimmung in 48 C.F.R. 12.212; oder (b) zum Erwerb von oder im Namen von Abteilungen des Verteidigungsministeriums, laut den Bestimmungen in 48 C.F.R. 227.7202-1 (JUN 1995) und 227.7202-4 (JUN 1995), bereitgestellt.

Falls Sie eine Anfrage einer der Behörden der US-Regierung zur Bereitstellung der Software mit Rechten erhalten, die die obengenannten überschreiten, setzen Sie DS SolidWorks über das Ausmaß der Anfrage in Kenntnis und DS SolidWorks verfügt über fünf (5) Werktage, um nach eigenem Ermessen eine solche Anfrage zu akzeptieren oder abzulehnen. Lieferant/Hersteller: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright-Vermerke für die Produkte SOLIDWORKS Standard, Premium, Professional und Education

Teile dieser Software sind urheberrechtlich geschützt durch Siemens Product Lifecycle Management Software Inc., © 1986-2018. Alle Rechte vorbehalten.

Dieses Werk enthält die folgende Software, die Siemens Industry Software Limited gehört:

D-Cubed® 2D DCM © 2018. Siemens Industry Software Limited. Alle Rechte vorbehalten.

D-Cubed® 3D DCM © 2018. Siemens Industry Software Limited. Alle Rechte vorbehalten.

D-Cubed® PGM © 2018. Siemens Industry Software Limited. Alle Rechte vorbehalten.

D-Cubed® CDM © 2018. Siemens Industry Software Limited. Alle Rechte vorbehalten.

D-Cubed® AEM © 2018. Siemens Industry Software Limited. Alle Rechte vorbehalten.

Teile dieser Software sind urheberrechtlich geschützt durch HCL Technologies Ltd., © 1998-2018.

Teile dieser Software beinhalten PhysX™ von NVIDIA, 2006-2010.

Teile dieser Software sind urheberrechtlich geschützt von Luxology, LLC, © 2001-2018. Alle Rechte vorbehalten, Patente angemeldet.

Teile dieser Software sind urheberrechtlich geschützt durch DriveWorks Ltd., © 2007-2018.

© 2011, Microsoft Corporation. Alle Rechte vorbehalten.

Umfasst Adobe® PDF-Bibliothekstechnologie.

Urheberrechtlich geschützt von Adobe Systems Inc. und Lizenzgebern, © 1984-2016. Alle Rechte vorbehalten. Geschützt durch die US-amerikanischen Patente 5.929.866; 5.943.063; 6.289.364; 6.563.502; 6.639.593; 6.754.382; Patente angemeldet.

Adobe, das Adobe Logo, Acrobat, das Adobe PDF Logo, Distiller und Reader sind eingetragene Marken oder Marken von Adobe Systems Inc. in den USA und anderen Ländern.

Weitere DS SolidWorks Copyright-Informationen finden Sie unter Hilfe > SOLIDWORKS Info.

Copyright-Vermerke für SOLIDWORKS Simulation Produkte

Teile dieser Software sind urheberrechtlich geschützt durch die Solversoft Corporation, © 2008.

PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. Alle Rechte vorbehalten.

Copyright-Vermerke für das SOLIDWORKS PDM Professional Produkt

Outside In® Viewer Technology, © 1992-2012 Oracle

© 2011, Microsoft Corporation. Alle Rechte vorbehalten.

Copyright-Vermerke für eDrawings Produkte

Teile dieser Software sind urheberrechtlich geschützt durch Tech Soft 3D, © 2000-2014.

Teile dieser Software sind urheberrechtlich geschützt durch Jean-Loup Gailly und Mark Adler, © 1995-1998.

Teile dieser Software sind urheberrechtlich geschützt durch 3Dconnexion, © 1998-2001.

Teile dieser Software sind urheberrechtlich geschützt durch Open Design Alliance, © 1998-2017. Alle Rechte vorbehalten.

Die eDrawings® für Windows®-Software basiert zum Teil auf der Arbeit der Independent JPEG Group.

Teile von eDrawings® für iPad® sind urheberrechtlich geschützt von Silicon Graphics Systems, Inc., © 1996-1999.

Teile von eDrawings® für iPad® sind urheberrechtlich geschützt von Apple Computer Inc., © 2003-2005.

Copyright-Hinweise für SOLIDWORKS PCB Produkte

Teile dieser Software sind urheberrechtlich geschützt von Altium Limited, © 2017-2018.

Copyright-Hinweise für SOLIDWORKS Visualize Produkte

NVIDIA GameWorks™ Technologie wird unter der Lizenz von NVIDIA Corporation bereitgestellt. Copyright © 2002-2015 NVIDIA Corporation. Alle Rechte vorbehalten.